Глава1(часть1).htm

Иллюстрированный самоучитель по Windows XP

Содержание

I. Основы работы с Windows XP

    • 1.Знакомство с Windows
    • 2. Работа с помощью проводника Windows
    • 3. Печать из Windows
    • 4. Использование справочной системы.

II. Работа с программами в составе Windows XP

    • 5. Создание текстовых документов.
    • 6. Работа с изображениями
    • 7. Работа в сети Интернет
    • 8. Работа с аудио и видео
    • 9. Вспомогательные программы.
    • 10. Игры, поставляемые в составе Windows.

III. Дополнительные возможности Windows XP

    • 11. Основы совместной работы.
    • 12. Основы работы с блокнотными компьютерами.
    • 13. Восстановление системы и защита важных файлов.
    • 14. Прочие полезные возможности

IV. Установка и настройка системы.

    • 15. Установка системы и ее компонентов
    • 16. Настройка системы.


  • I. Основы работы с Windows XP
    • История Windows
    • Особенности Windows XP
    • Файловая система и структура.
    • Основные принципы работы с системой
    • Работа с мышью
    • Начало и завершение работы, главное меню
    • Запуски завершение программ
    • Окна и диалоги, панель задач
    • Работа с несколькими программами
    • .Использование клавиатуры
    • Пример 1.1. Одновременное использование


I. Основы работы с Windows XP

1. Знакомство с Windows

Буквы ХР в названии новой версии популярной операционной системы Windows являются частью английского слова eXPerience, которое переводится как жизненный опыт, знания. При создании операционной системы Windows XP использован многолетний опыт разработчиков самых популярных компьютерных программ и систем, а также знания, накопленные в результате общения с многочисленными пользователями. Без сомнения, новая версия Windows является значительным шагом вперед, по сравнению с предыдущими версиями.

Операционная система является необходимой компонентой любого компьютера и представляет собой набор программ, предназначенных для управления компьютером, хранения информации и организации работы всех подключенных к нему устройств. В настоящее время Windows - самая распространенная операционная система для персональных компьютеров. Среди достоинств, определяющих популярность Windows, можно выделить удобный, интуитивно понятный, графический интерфейс, параллельную работу множества программ и автоматическую настройку нового оборудования.

Под общим названием Windows объединяются несколько операционных систем, которые хотя и похожи друг на друга, но обладают различными возможностями и предназначены для разных целей. Все системы семейства Windows построены на одних и тех же принципах, и программы, написанные для Windows, работают во всех этих системах.


1.1. История Windows

История Windows берет свое начало в 1986 году, когда появилась первая версия системы. Она представляла собой набор программ, расширяющих возможности существующих операционных систем для большего удобства в работе. Через несколько лет вышла вторая версия, но особой популярности система Windows не завоевала. Однако в 1990 году вышла новая версия - Windows 3.0, которая стала использоваться на многих персональных компьютерах. Популярность новой версии Windows объяснялась несколькими причинами. Графический интерфейс позволяет работать с объектами вашего компьютера не с помощью команд, а с помощью наглядных и понятных действий над значками, обозначающими эти объекты. Возможность одновременной работы с несколькими программами значительно повысила удобство и эффективность работы. Кроме того, удобство и легкость написания программ для Windows привели к появлению все больше разнообразных программ, работающих под управлением Windows. Наконец, лучше была организована работа с разнообразным компьютерным оборудованием, что также определило популярность системы. Последующие версии Windows были направлены на повышение надежности, а также поддержку средств мультимедиа (версия 3.1) и работу в компьютерных сетях (версия 3.11).

Параллельно с разработкой Windows компания Microsoft в 1988 году начала работу над новой операционной системой, названной Windows NT. Перед новой системой были поставлены задачи существенного повышения надежности и эффективной поддержки сетевой работы. При этом интерфейс системы не должен был отличаться от интерфейса Windows 3.0. Интересно, что самой распространенной версией Windows NT также стала третья версия. В 1992 году появилась версия Windows NT 3.0, а в 1994 году - Windows NT 3.5.

Процесс развития операционных систем не стоит на месте, и в 1995 появилась система Windows 95, ставшая новым этапом в истории Windows. По сравнению с Windows 3.1 значительно изменился интерфейс, выросла скорость работы программ. Одной из новых возможностей Windows 95 была возможность автоматической настройки дополнительного оборудования компьютера для работы без конфликтов друг с другом. Другой важной особенностью системы стала возможность работы с Интернетом без использования дополнительных программ.

Интерфейс Windows 95 стал основным для всего семейства Windows, и в 1996 появляется переработанная версия Windows NT 4.0, имеющая такой же интерфейс, как и Windows 95. Продолжением развития Windows 95 стала операционная система, появившаяся в 1998 году. При сохранившемся интерфейсе внутренняя структура была значительно переработана. Много внимания было уделено работе с Интернетом, а также поддержке современных протоколов передачи информации - стандартов, обеспечивающих обмен информацией между различными устройствами. Кроме того, особенностью Windows 98 является возможность работы с несколькими мониторами.

Следующим этапом в развитии Windows стало появление Windows 2000 и Windows Me (Millennium Edition - редакция тысячелетия). Система Windows 2000 разработана на основе Windows NT и унаследовала от нее высокую надежность и защищенность информации от постороннего вмешательства. Операционная система Windows Me стала наследницей Windows 98, но приобрела многие новые возможности. Прежде всего, это улучшенная работа со средствами мультимедиа, возможность записывать не только аудио, но и видеоинформацию, мощные средства восстановления информации после сбоев и многое другое. Постепенно разница между разными системами Windows стирается, и новая операционная система Windows XP предназначена для замены как Windows 2000, так и Windows Me.


1.2. Особенности Windows XP

Операционная система Microsoft Windows XP, создана на основе технологии NT и является прямой наследницей системы Windows 2000. Вместе с тем, все лучшие нововведения, включенные в Windows Me, можно обнаружить и в Windows XP. При сохранении высоких показателей надежности, безопасности и быстродействия, система стала более простой в освоении, в ней появилось множество средств, предназначенных для индивидуальных домашних пользователей.

Система поставляется в нескольких вариантах, ориентированных на разные особенности применения. Версия Microsoft Windows XP Home Edition предназначена для индивидуальных пользователей, чаще всего работающих на домашнем компьютере. В этой версии особый упор сделан на работу с рисунками, аудио и видео. Версия Microsoft Windows XP Professional предназначена, как ясно из названия, для профессионалов. Эта версия наиболее часто используется в организациях. Если же вы дома выполняете сложные работы по созданию и редактированию изображений, моделированию и конструированию, или любые другие сложные работы, то эта версия подойдет и для вашего домашнего компьютера. Версия Microsoft Windows XP Server предназначена для установки на сервере - мощном компьютере, обеспечивающем работу множества пользователей в компьютерной сети. Работа в локальных сетях выходит за рамки данной книги, так что версия для сервера рассматриваться нами не будет. В книге описана основная версия операционной системы - Windows XP Professional. Практически не отличается от нее версия Windows XP Home Edition. Об имеющихся незначительных отличиях будет особо указано.

Следует отметить, что для эффективной работы с операционной системой Windows XP требуется достаточно мощный современный компьютер. Прежде всего, в компьютере должно быть установлено не менее 128 мегабайт памяти. Лучше установить 256 мегабайт, чтобы система работала быстрее. Процессор может использоваться любой, но не слишком старый. Если тактовая частота процессора не менее 300 мегагерц, то он подойдет. Хотя лучше, конечно, использовать процессор с частотой более одного гигагерца. Жесткий диск должен вмещать не только файлы операционной системы и временные файлы, но и иметь достаточно свободного места, например, для создания образа компакт-диска перед его записью. Реально требуется диск размером не менее двух-трех гигабайт. А если учесть, что на диске надо установить другие программы и оставить место для разных документов, то диск объемом 10 гигабайт нельзя назвать слишком большим.

В версии Windows XP сильно изменился внешний вид системы. Кнопки, значки, панели теперь выглядят немного иначе. Даже главное меню Windows изменилось. Изменения интерфейса самые значительные после перехода с Windows 3.1 на Windows 95. Вместе с тем имеется возможность использовать и старый интерфейс, если вы к нему привыкли. Особо следует отметить работу программ в режиме совместимости с предыдущими версиями Windows. Вы можете работать с программой, которая написана для Windows 95, и не работает в Windows 2000. Все версии Windows XP имеют множество нововведений. Поддерживается значительно больше разнообразных устройств. Система позволяет легко и удобно обрабатывать видеофильмы, фотографии, рисунки, музыку и песни. Теперь с помощью Windows XP любой сможет построить домашнюю сеть на основе двух-трех компьютеров, обеспечив совместное использование файлов, папок, принтера, факса и доступа в Интернет.

При работе с Windows XP для записи информации на записываемые и перезаписываемые компакт-диски вам не потребуется устанавливать дополнительные программы. Записать компакт-диск можно прямо из проводника Windows. Кстати, проводник сильно изменился. Кроме поддержки сжатых папок, особых папок для хранения рисунков, музыки и видео, добавлена панель с командами, состав которых меняется в зависимости от выполняемых вами действий.

Полезным компонентом системы является редактор видеофильмов. Теперь вы сможете выполнить профессиональный нелинейный монтаж своих любительских фильмов. Существенно легче стало работать с цифровыми фотокамерами и сканерами. Вам не потребуется никакой дополнительной программы, чтобы ввести фотографию в компьютер, незначительно преобразовать ее и распечатать на принтере. Универсальный проигрыватель аудио и видео теперь поддерживает больше форматов и позволяет сменить свой внешний вид. Вы можете сами создавать звуковые файлы в популярном формате МРЗ. Универсальный проигрыватель поддерживает также воспроизведение цифровых видеодисков (DVD-дисков), что позволит вам насладиться высочайшим качеством изображения и звука при просмотре современных фильмов. Для развлечений в Windows XP включено несколько новых игр, часть из которых позволяют вам играть в Интернете.

Существенно улучшена и защита системы. Теперь при случайном удалении важных системных файлов, они будут автоматически восстановлены. Имеется возможность восстановления системы к более раннему состоянию, после установки новых программ и оборудования. Улучшенная поддержка технологии Plug & Play позволяет подключить к компьютеру многие современные бытовые приборы.

Дальнейшее развитие получили и средства для работы с Интернетом. Существенно переработана справочная система, улучшена система безопасности. Многочисленные изменения коснулись средств администрирования и управления работой множества пользователей в локальной вычислительной сети.

В системе имеется и множество других нововведений, о которых вы узнаете по мере прочтения книги и знакомства с Windows XP. Однако перед началом работы с системой мы рекомендуем вам познакомиться с основными понятиями, используемыми в Windows XP. Если вы знакомы с предыдущими версиями Windows, большинство понятий для вас окажутся знакомыми.


1.3. Файловая система и структура

Информация в компьютере хранится в памяти или на различных носителях, таких как: гибкие и жесткие диски, или компакт-диски. При выключении питания компьютера информация, хранящаяся в памяти компьютера, теряется, а хранящаяся на дисках - нет. Для уверенной работы за компьютером следует знать основные принципы хранения информации на компьютерных дисках.

Вся информация, предназначенная для долговременного использования, хранится в файлах. Файл представляет собой последовательность байт, объединенных по какому-то признаку и имеющих имя. Система хранения и работы с файлами в компьютере называется файловой системой. Для удобства файлы хранятся в различных папках, которые расположены на дисках. В компьютере может быть установлено несколько дисков. Любой гибкий диск, жесткий диск, компакт-диск, цифровой видеодиск или сетевой диск мы будем называть просто диском, так как принципы организации хранения файлов на них идентичны. Каждому диску присваивается буква латинского алфавита от А до Z, причем существуют некоторые правила обозначения. Буквой А обозначается гибкий диск, буквой С - основной диск вашего компьютера, где расположена система Windows. Буквой D и последующими буквами обозначаются остальные диски. После буквы, обозначающей диск, ставится символ двоеточия “:”, чтобы показать, что буква обозначает именно диск, например А: или С:. Кроме буквы, каждый диск имеет свое уникальное имя, также называемое меткой. Чаще всего при указании диска используется метка и буквенное обозначение в скобках. Например, надпись Main (С:) означает, что основной диск вашего компьютера имеет метку Main.

На каждом диске помещается множество различных файлов. Любой файл может располагаться как прямо на диске, так и в произвольной папке, которая в свою очередь также может располагаться в другой папке (Рис. 1.1).

Рис 1.1. Структура хранения информации на дисках

То, что файлы могут находиться в разных папках, позволяет расположить, на диске несколько файлов с одинаковыми именами. Структура хранения информации на диске, при котором одни папки могут располагаться в других папках, называется иерархической или древовидной. Такая структура действительно похожа на реальное дерево, на котором каждый листок представляет собой отдельный файл, а ветка - папку. Листок может расти как непосредственно из ствола, так и из любой ветки. Возможно, что от ствола отходит одна ветка, от нее - другая, а уже на ней расположены листья. Чтобы однозначно определить конкретный файл, требуется задать его название и местоположение, то есть название диска и имена всех вложенных папок, в которых находится данный файл. Часто точное расположение файла на диске называют полным именем файла или путем к файлу.

При указании пути к файлу имена папок отделяются друг от друга и от имени диска с помощью символа обратной косой черты “\”, например, С:\Мои документы\Мои рисунки\Я в молодости.jpg. Данная запись означает, что файл с именем Я в молодости.jpg расположен в папке Мои рисунки. Эта папка находится в папке Мои документы, размещенной на диске С:.

Обратите внимание, что в рассмотренном примере имя файла содержит в себе символ точки и как бы состоит из двух частей -до точки и после нее. Часть имени, расположенная после точки, называется расширением и используется для обозначения вида информации, хранящейся в файле. Например, расширение doc обозначает текстовый файл, wav - файл, содержащий звуки, а jpg - изображение. В Windows XP многие расширения файлов не показываются, так что, скорее всего, в нашем примере файл будет называться просто Я в молодости, но Windows будет знать, что работает с изображением.

Важным понятием в Windows XP является понятие ярлыка. На любой объект Windows можно сослаться из другого места. Такая ссылка и называется ярлыком. Например, в какой-то папке расположен часто использующийся рисунок. Для быстрого доступа к этому рисунку из разных мест можно поместить в эти места ярлыки, содержащие адрес реального местонахождения рисунка. Не требуется копировать программы и данные в разные папки, достаточно просто разместить ярлыки, ссылающиеся на нужный файл, в нескольких местах. Все эти ярлыки будут указывать на оригинальный файл. Удаление и перемещение ярлыка не влияет на расположение оригинального файла, поэтому использование ярлыков может обеспечить дополнительную защиту.


1.4. Основные принципы работы с системой

Для общения с пользователем в Windows XP используется графический интерфейс, который отображает информацию на экране в виде различных рисунков. Многие функции системы связаны с небольшими рисунками, называемыми значками. Б Windows XP широко используется понятие объекта. Объектами называются файлы и папки, а также некоторые физические устройства, например, диски и принтеры. На экране монитора все объекты представляются значками.

Чтобы управлять системой, нет необходимости вводить с клавиатуры длинные и сложные команды. Управление осуществляется с помощью различных операций над значками с помощью компьютерной мыши или клавиатуры. Выделяя, перемещая и выполняя другие операции со значками, вы в действительности даете команды операционной системе, которая выполняет некоторые действия над объектами, связанными с данными значками.

Однако не все операции выполняются с помощью значков. Иногда проще указать необходимое действие, выбрав его в списке. При этом вам все равно не потребуется вводить команды. Система предложит несколько вариантов работы, и вы укажете подходящий вам вариант. Списки возможных действий называются меню, и работа с меню также распространена в Windows, как и работа со значками.

Слово Windows с английского языка переводится как окна. Окно представляет собой очерченную область на экране, связанную с какой-либо программой. После запуска операционной системы Windows XP весь экран монитора занимает особый рисунок, который называется Рабочим столом или, в английской версии, Desktop (Рис. 1.2). В дальнейшем английские наименования мы будем помещать в скобках: Рабочий стол (Desktop). Все окна располагаются поверх рабочего стола, и их можно перемещать, увеличивать, уменьшать или убирать. Окна могут полностью или частично перекрывать друг друга. Рабочий стол позволяет запускать программы, настраивать систему и выполнять другие действия. Размеры и количество рисунков и надписей на рабочем столе могут сильно различаться в зависимости от особенностей настройки конкретной копии системы на вашем компьютере. Однако в любом случае в нижней части рабочего стола расположена полоса, называемая Панель задач (Taskbar). Основное назначение панели задач - отображение запущенных программ в виде кнопок и значков, а также быстрое переключение между ними. Кроме того, с помощью панели задач можно запускать некоторые полезные программы.

Рис 1.2. Рабочий стол Windows XP

В левой части панели задач находится рамка, внутри которой расположено слово Пуск или Start для английской версии (Рис. 1.3). В системе Windows такие рамки с текстом и рисунками внутри называют кнопками, поэтому в дальнейшем мы будем говорить, что на панели задач расположена кнопка Пуск (Start). Назначение этой кнопки - запуск программ и настройка компьютера. Можно сказать, что почти любая работа в Windows ХР начинается с нажатия данной кнопки.

Рис 1.3. Кнопка Пуск (Start)

Работа в системе Windows представляет собой запуск различных программ с помощью кнопки Пуск (Start) или с помощью значков на рабочем столе. Вы можете также выполнять различные действия с окнами уже запущенных программ. Запуск программ и работа с окнами осуществляются с помощью компьютерной мыши и клавиатуры.

На рабочем столе Windows также расположена панель языка. Она предназначена для быстрого переключения между разными языками. Некоторые приложения, например, программы, входящие в состав Microsoft Office XP, располагают дополнительные кнопки на панели языка. Данная панель всегда расположена поверх других окон, что позволяет быстро определить используемый в настоящее время язык. Если вы работали с предыдущими версиями Windows, то заметили, что переключатель языка изменил свое расположение - вместо панели задач он теперь располагается на панели языка.

Чтобы успешно работать с Windows XP, необходимо овладеть основными приемами работы с системой. После освоения основных понятий и принципов работы систем, вы без труда сможете изучить большинство других программ, работающих под управлением Windows, поскольку в них используются аналогичные принципы. Операции над объектами в Windows можно выполнить с помощью компьютерной мыши. Хотя кнопок у нее всего две, с помощью них можно выполнить очень много действий. Работа с мышью чрезвычайно важна, и ее освоению следует уделить достаточно времени.


1.5. Работа с мышью

Компьютерной мышью называют устройство, представляющее собой небольшую коробочку округлой формы. На ней расположено, как минимум, две кнопки. Некоторые современные мыши имеют пять кнопок и позволяют выполнять значительно больше действий. Кроме того, все чаще на мышах располагается специальное колесо, предоставляющее еще больше дополнительных возможностей. Как уже отмечалось, при работе в Windows мышь используется очень широко, и чрезвычайно важно в совершенстве освоить работу с этим устройством.

Вначале следует научиться правильно держать мышь в руке. Поднесите к мыши ладонь сверху, чтобы пальцы оказались над кнопками. Возьмитесь за бока большим пальцем и мизинцем. При этом не следует сильно сжимать мышь - только слегка касайтесь пальцами боковых граней, указательный палец положите на левую кнопку мыши, а средний палец - на правую. Не следует прижимать ладонь к мыши (Рис. 1.4). Важно, чтобы при работе с мышью ваша рука не уставала, поэтому расслабьте кисть и не напрягайте пальцы.

Рис 1.4. Расположение мыши в руке

Поводите рукой вправо и влево, и мышь легко передвинется вместе с рукой. Посмотрите при этом на экран, и вы увидите, как по нему перемещается небольшая стрелка. Эта стрелка называется указателем мыши. При любом перемещении мыши указатель точно так же перемещается на экране. Внешний вид указателя может быть различным, но чаще всего используется изображение стрелки [image] . Попробуйте подвигать мышь и проследите за передвижениями указателя мыши на экране (Рис. 1.5). Попробуйте переместить указатель мыши в нижнюю часть экрана. При этом, если на экране не было панели задач, то она должна появиться. Теперь перемещайте указатель мыши поочередно к другим краям экрана, чтобы почувствовать, как далеко следует двигать мышь, чтобы перемещать указатель по всему экрану.

Рис 1.5. Связь мыши с указателем на экране

Нажимая кнопки, расположенные на мыши, можно вызвать то или иное действие, определяемое расположением указателя на экране. Левую кнопку нажимают указательным пальцем, а правую - средним. Важно научиться контролировать перемещение указателя при движении мыши, чтобы быстро и легко перемещать указатель к нужному месту экрана. Не стоит расстраиваться, если у вас не получается сразу быстро и без рывков перемещать указатель мыши. Такое умение достигается с опытом и придет к вам со временем. Следует отметить, что большинство мышей лучше двигаются по специальному коврику, так что наличие такого коврика является необходимым условием плодотворной работы с Windows. Исключение составляют современные оптические мыши, которые могут работать практически на любой поверхности.

Перемещение указателя мыши позволяет выбрать нужный объект на экране, а чтобы выполнить с ним какие-либо действия, необходимо использовать кнопки мыши. Значительно чаще используется левая кнопка, но иногда используется и правая, Нажатие с последующим быстрым отпусканием кнопки мыши называется щелчком. Часто у начинающих пользователей не получается щелчок мышью на объекте, так как при щелчке мышь сдвигается в сторону. Нажимать любую кнопку мыши следует с помощью небольшого движения расположенного над ней пальца. При этом все остальные пальцы должны быть расслаблены и практически не прикасаться к мыши. Если вы жестко зажмете мышь в ладони и попытаетесь при этом нажать левую кнопку указательным пальцем, скорее всего, вы сдвинете мышь и выполните щелчок не в том месте, где хотели.
Не сжимайте сильно мышь, не бейте по кнопкам, не прижимайте всю ладонь к мыши. Свободно, без напряжения держите кисть над мышью и легкими движениями пальцев передвигайте ее в стороны и нажимайте кнопки.

Так как чаще используется левая кнопка мыши, то для простоты мы будем говорить не “Щелкните левой кнопкой мыши”, а просто “Щелкните мышью”. Если не указано, какой кнопкой мыши надо щелкнуть, то имеется в виду именно левая кнопка. С помощью левой кнопки происходит выбор различных элементов на экране.

Щелчок правой кнопкой мыши также достаточно чаете используется и предназначен для открытия различных меню, с которых вы узнаете ниже. Двойным щелчком называется быстрое нажатие кнопки мыши два раза подряд. Этот прием более сложен, поэтому у вас он может получиться не сразу главное при двойном щелчке - это нажать два раза кнопку мыши как можно быстрее. Вы должны успеть нажать кнопку мыши два раза менее чем за секунду. Медленное нажатие кнопки воспринимается Windows не как двойной щелчок, а как два обычных одинарных щелчка. В соответствии с этим может быть выполнено совсем не нужное вам действие. С помощью основных приемов работы, таких как перемещение указателя и нажатий на кнопки, в Windows выполняются и более сложные приемы работы с мышью, например, перетаскивание, часто называемое буксировкой. Этот прием используется для перемещения значков по экрану и применяется для различных целей. Например, при перетаскивании значка из папки в папку вы перемещаете связанный с ним файл в новое место. Прием состоит из нескольких частей. Сначала необходимо подвести указатель мыши к буксируемому объекту. После этого надо нажать левую кнопку мыши и, не отпуская ее, начать передвигать мышь. Объект на экране начнет передвигаться вместе с указателем мыши. После того, как вы расположите объект в новом месте, следует отпустить кнопку мыши. Объект останется на новом месте.

Одинарные и двойные щелчки, как и буксировка, постоянно будут использоваться вами при работе с системой. Теперь, после того, как мы познакомились с основными приемами работы с мышью, приступим к освоению системы Windows. По мере И освоения мы расскажем, как использовать мышь в тех или иных случаях, а пока начнем знакомство с изучения того, как запускать операционную систему Windows XP и заканчивать работу с ней.


1.6. Начало и завершение работы, главное меню

После того, как вы включили компьютер и прошло его тестирование, он автоматически начнет загрузку установленной на жесткий диск операционной системы. При этом на экране появится заставка, говорящая о том, что загружается система Windows XP. Возможно, на экране появится несколько заставок, сменяющих друг друга. Процесс загрузки может занять несколько минут, и вам следует подождать его окончания.

Возможно, вам потребуется ввести свое имя и пароль, если на компьютере работает несколько пользователей и вы зарегистрированы как пользователь этого компьютера. По окончании загрузки системы на экране появится изображение рабочего стола Windows, внешний вид которого зависит от настроек вашей системы. Возможно, на рабочем окне появится окно Добро пожаловать в Windows (Getting started with Windows). Для продолжения работы с системой нам нужно убрать это окно с экрана. Если указанное окно появилось, нажмите на клавиатуре клавишу [image] расположенную справа или слева в нижней части клавиатуры, и, не отпуская ее, нажмите клавишу [image] . которая расположена в верхней части клавиатуры. Теперь отпустите обе клавиши, и рисунок пропадет с экрана.

На рабочем столе располагается панель задач и несколько значков, которые позволяют быстро запускать программы или открывать нужные документы. Расположение и состав значков могут быть самыми разными. Например, значок Мой компьютер (My Computer) предназначен для работы с дисками и файлами вашего компьютера, а значок Корзина (Recycle Bin) позволит вам удалять ненужные файлы и восстанавливать ошибочно удаленные файлы. Назначение этих и других значков вы узнаете по мере изучения системы.

В левой части панели задач расположена кнопка Пуск (Start); предназначенная для открытия одноименного меню, которое часто называют главным меню Windows. С помощью главного меню можно запускать различные задачи, открывать документы настраивать систему, пользоваться справочной информацией имногое другое.

Чтобы открыть это меню, необходимо щелкнуть мышью на кнопке Пуск (Start). Подведите указатель мыши к кнопке перемещая мышь в нужную сторону. Кнопка немного изменит свой внешний вид, в частности изменится оттенок фонового цвета. Нажмите левую кнопку мыши и сразу отпустите ее. Haд кнопкой появится рамка с командами, называемая главным, меню системы. Описанные действия и называются щелчком на кнопке Пуск (Start). Часто говорят просто “нажмите кнопку” подразумевая, что необходимо щелкнуть на ней мышью. Если у вас не получилось открыть меню, попробуйте выполнить описанные выше действия еще раз. Кроме того, на большинстве клавиатур есть специальная клавиша для вызова главного меню [image] . Нажав эту клавишу, вы быстро и легко попадаете в главное меню. Повторное нажатие кнопки [image] уберет меню с экрана Каким бы способом вы не воспользовались, результат будет один и тот же - на экране появится главное меню операционной системы Windows XP (Рис. 1.6).

Рис 1.6. Главное меню Windows

Если вы работали с предыдущими версиями Windows, то сразу заметите, как сильно изменилось главное меню. В верхней части меню указано имя пользователя, работающего в настоящий момент на компьютере. В нашем рисунке имя пользователя - Sergei. Рядом с именем расположен рисунок, связанный с этим пользователем. Это может быть стандартный рисунок, поставляемый вместе с Windows, или любое другое изображение, как в нашем случае. Так как Windows XP позволяет работать нескольким пользователям на одном компьютере, настраиваясь под конкретного пользователя, важно знать, кто работает в настоящее время. Подробнее о совместной работе нескольких пользователей на компьютере будет рассказано ниже.

В центральной части меню справа и слева располагаются команды. Слева команды предназначены для запуска различных программ. Команды в верхней части позволяют запустить важные и часто используемые программы, такие как Internet Explorer и Outlook Express. Эти программы предназначены для работы в Интернете. Команды, расположенные ниже, предназначены для запуска программ, с которыми вы недавно работали. Как только вы запустите какую-либо программу, команда для ее запуска появится в левой части главного меню. При этом программы, которые вы давно не запускали, могут быть убраны из меню. Ниже команд запуска часто используемых программ расположена команда Другие программы (More Programs). Выбрав ее, вы можете запустить любую программу, но об этом будет рассказано ниже.

Справа в центральной части меню расположены команды просмотра содержимого важных папок вашего компьютера, а также команды настройки системы. С их помощью вы можете получить справочную информацию, просмотреть ранее созданные документы и выполнить многие другие действия.

В нижней части меню расположены команды для завершения работы Windows. С их помощью можно приостановить работу компьютера, перегрузить компьютер или выключить его. Кроме того, можно закончить работу на компьютере текущего пользователя, чтобы дать возможность поработать другому человеку.

Если установить указатель мыши в область главного меню, в меню появляется горизонтальная полоса, обозначающая выбранную команду меню. При движении указателя мыши вдоль меню, выделение элемента перемещается вслед за указателем. Некоторые элементы меню имеют в правой части изображение стрелки [image] . Это означает, что данная команда меню предназначена для открытия еще одного, вложенного меню. Отметим, что при установке новых программ в меню Другие программы (More Programs) обычно автоматически добавляются новые команды для запуска этих программ. Чтобы перейти к вложенному меню, нужно подвести указатель мыши к изображению стрелки [image] . При этом вложенное меню откроется, и вы можете перемещаться по нему точно так же, как и по главному, то есть, перемещая указатель мыши. Для выбора команды меню достаточно щелкнуть на ней мышью.

Кроме мыши, с главным меню можно работать с помощью клавиатуры, используя клавиши [image] , [image] , [image] и [image] для перемещения по командам меню. Для открытия вспомогательного меню следует нажать клавишу [image] . Выбор команды осуществляется нажатием клавиши [image] . Как уже отмечалось, для вызова меню используется клавиша [image] . Следует отметить, что при многократном нажатии клавиши [image] , вы последовательно будете выделять все команды главного меню. Сначала будут выделены команды в левой части меню, затем команды в правой части меню, а после этого команды завершения сеанса работы данного пользователя и завершения работы Windows, расположенные в нижней части меню.

Если в одном из вложенных меню вы увидите команду [image] , то данное меню показано не полностью. Если вы долго не пользовались одной из команд меню, то можете не найти ее при очередном открытии главного меню. Операционная система Windows XP скрывает редко используемые команды меню, чтобы они не отвлекали вас. Эта возможность настраиваемая, и может быть отключена. Чтобы увидеть все без исключения команды, следует щелкнуть мышью на команде [image] , и на экране появятся скрытые ранее команды вспомогательного меню.

Рано или поздно вы закончите работу с компьютером, и его необходимо будет выключить. Это не такая простая процедура, как могло бы показаться. Очень важно правильно завершить работу компьютера, когда вы используете Windows.
Отключение питания компьютера во время работы Windows может испортить важную системную информацию и привести к неработоспособности системы. Поэтому просто выключить компьютер при работе с Windows нельзя.

Для правильного окончания работы с системой Windows XP необходимо воспользоваться командой главного меню Завершение работы (Shut Down), расположенной рядом с кнопкой [image] в нижней части главного меню. На экране появится диалог Завершение работы Windows (Shut Down Windows) (Рис. 1.7). Этот диалог предлагает вам сделать выбор способа завершения работы, нажав одну из больших кнопок в центре диалога. Если вы нажмете кнопку Отмена (Cancel), то диалог будет убран с экрана, и вы вернетесь к обычной работе с Windows XP. Напоминаем, что для нажатия кнопки следует просто щелкнуть на ней левой кнопкой мыши.

Рис 1.7. Диалог завершения работы Windows

Для обычного завершения работы системы следует нажать кнопку [image] . Начнется процесс завершения работы с Windows, который может занять несколько минут. По его окончании ваш компьютер выключится автоматически, или на экране появится надпись о том, что питание компьютера можно отключить. Во втором случае вам следует самостоятельно отключить питание компьютера. Если вы хотите запустить Windows XP снова, не выключая компьютер, следует нажать кнопку [image] . Перезагрузка может понадобиться, если некоторые программы стали работать ненадежно или перестали отвечать. Однако в Windows XP в большинстве случаев не требуется перезагрузка при ненадежно работающих программах. Иногда перезагрузка системы может потребоваться при установке новых программ или нового оборудования.

Интересный режим выключения компьютера выбирается при нажатии кнопки [image] . Вся текущая информация из памяти компьютера записывается на жесткий диск, и компьютер выключается. При следующем включении компьютера состояние памяти восстанавливается с диска, и вы можете продолжить работу с того места, на котором выбрали команду перехода в спящий режим. При таком способе старта системы загрузка происходит значительно быстрее, чем при обычном способе. Кроме того, при возобновлении работы остаются работающими все программы, с которыми вы работали до выключения компьютера. Однако у данного режима есть и свои недостатки. Далеко не все оборудование и программы правильно восстанавливаются после перехода в спящий режим. Есть вероятность, что некоторые устройства перестанут работать после просыпания. Для восстановления работоспособности вам придется выполнить перезагрузку системы.


1.7. Запуск и завершение программ

Самым простым способом запуска программы является двойной щелчок мышью на значке этой программы, если этот значок расположен на рабочем столе Windows. Например, если вы дважды щелкнете на значке, изображающем корзину [image] , будет запущена программа, показывающая содержимое специальной папки, содержащей удаленные ранее файлы. Однако большинство программ при установке не помещают свои значки на рабочий стол, а добавляют соответствующие команды в главное меню системы. Список установленных на вашем компьютере программ можно увидеть, выбрав команду Другие программы (More Programs) главного меню. Чтобы сделать это, необходимо нажать кнопку Пуск (Start) и переместить указатель мыши к изображению стрелки [image] команды Другие программы (More Programs). Рядом с главным меню будет открыто еще одно меню. В нем тоже есть команды, связанные со вспомогательными меню. Такие команды обозначаются стрелками [image] . Для выбора команды меню щелкните на ней мышью. Перемещаясь по командам, можно выбрать команду меню, которая соответствует нужной нам программе (Рис. 1.8).

Рис 1.8. Запуск программы из главного меню

Последовательность действий по выбору элементов меню мы будем обозначать короткой записью. Например, запись Другие программы * Стандартные * Калькулятор (More Programs * Accessories * Calculator) означает, что нужно нажать кнопку Пуск (Start), затем выбрать команду меню Другие программы (More Programs) и переместить указатель мыши к команде Стандартные (Accessories) в открывшемся вложенном меню. В появившемся следующем вложенном меню необходимо подвести указатель мыши к команде Калькулятор (Calculator) и щелкнуть на ней мышью. После этого соответствующая программа будет запущена, и на экране появится окно этой программы.

В окне программа отображает результаты своей работы. Завершение работы программы зависит от самой программы, но большинство программ имеют специальную команду меню Файл * Выход (File * Exit). Еще одним способом завершения работы программы является закрытие окна этой программы. Закрыть окно можно с помощью клавиатуры, нажав на клавиатуре клавишу [image] , расположенную справа или слева в нижней части клавиатуры, и, не отпуская ее, нажав клавишу [image] , которая расположена в верхней части клавиатуры. После отпускания клавиш, окно программы будет закрыто, и работа программы будет завершена. Если использовать мышь, то нужно щелкнуть мышью на кнопке [image] , расположенной в правом верхнем углу окна программы, в его заголовке. Последний способ самый быстрый и достаточно часто используется.


1.8. Окна и диалоги, панель задач

Все программы в Windows выдают результаты работы в связанные с ними окна. Внешний вид окон может быть самым разным, но есть несколько элементов, которые присутствуют в большинстве окон. Какую бы программу вы не запустили, внешний вид ее окна будет напоминать окна других программ. Конечно, есть и исключения. Некоторые программы непохожи на другие, но таких программ достаточно мало.

В качестве примера типичного окна рассмотрим окно программы WordPad, предназначенной для создания и редактирования текстовых документов. Подробнее об этой программе будет рассказано в следующей части книги, а пока только рассмотрим основные элементы рабочего окна программы. Для запуска программы следует выбрать команду главного меню Другие программы * Стандартные * WordPad (More Programs * Accessories * WordPad). Программа будет запущена, и на рабочем столе появится ее окно. Рассмотрим основные элементы окна программы (Рис. 1.9).

Рис 1.9. Пример рабочего окна программы

Каждое окно программы имеет заголовок, в котором обычно отображаются название программы и название редактируемого документа, например, Документ * WordPad. В левой части заголовка расположен значок программы, а в правой -управляющие кнопки. Отметим, что программа, с которой вы работаете в настоящее время, имеет более яркий заголовок окна, чем остальные программы.

Под заголовком располагается так называемое меню. Как вы уже знаете, меню дает вам возможность выбора различных действий с помощью команд. Та или иная команда меню может быть выбрана с помощью мыши или клавиатуры. Поскольку обычно команд в программе бывает много, они не помещаются в одной строке, и их располагают во множестве вложенных меню. Например, при работе в графическом редакторе Paint, команда меню Вид скрывает целую группу команд, которые также могут вызывать еще одну группу команд. Работа с меню любых программ не отличается от работы с главным меню Windows. С помощью мыши или клавиатуры вы последовательно выбираете нужные команды меню, открывая при необходимости вспомогательные меню (Рис. 1.10). В дальнейшем, при описании каких-либо действий запись Вид * Масштаб * Другой будет означать необходимость последовательного выбора трех команд меню. Некоторые команды в меню могут быть более бледными, чем другие. Такие команды в данный момент недоступны. Например, вы не можете выбрать обычный масштаб просмотра, если уже находитесь в этом режиме. С помощью меню можно выполнить любые действия, однако есть и другие способы работы с программами.

Рис 1.10. Вложенное меню

Чтобы облегчить выполнение часто используемых команд, ниже строки меню расположены одна или несколько панелей инструментов. Эти панели представляют собой полосы, на которых помещено множество рисунков. Когда вы подводите указатель мыши к любому рисунку, вокруг него рисуется рамка и рисунок становится похожим на кнопку. В некоторых программах на панелях инструментов всегда нарисованы кнопки, вне зависимости от местонахождения указателя мыши. Для простоты все рисунки на панелях инструментов мы в дальнейшем будем называть кнопками. Кнопки предназначены для выполнения различных действий, которые поясняются рисунками на кнопках. Например, кнопка [image] предназначена для открытия файлов, кнопка [image] предназначена для записи на диск, а [image] - для печати документа. Если действие в данный момент не может быть выполнено, то изображение соответствующей кнопки будет бледным.

Рабочая область окна предназначена для отображения информации данной программы. В рабочей области вы выполняете те действия, для которых и предназначена программа, например, рисуете или набираете тексты. В нижней части рабочего окна программы обычно располагается строка состояния, которая отображает различную служебную информацию или подсказку о том, что требуется сделать дальше.

Кроме окон программ, в Windows существуют специальные окна, предназначенные для управления и настройки. С помощью таких окон вы ведете диалог с системой Windows, поэтому их называют диалоговыми окнами, или просто диалогами. Вид диалогов может быть самым разным, однако все они содержат некоторые типовые элементы управления. Давайте рассмотрим основные элементы управления, встречающиеся в диалогах.

Любой диалог предполагает выбор дальнейших действий и содержит для этого ряд кнопок. Чаще всего в диалогах имеются кнопки подтверждения, отмены и, возможно, вызова подсказки (Рис. 1.11).

Рис 1.11. Кнопки в диалогах

Нажатие кнопок ОК и Отмена (Cancel) подразумевает завершение диалога и закрытие соответствующего окна. В диалогах может быть достаточно много кнопок. Чаще всего дополнительные кнопки в диалоге вызывают другой диалог. После закрытия нового диалога вы вернетесь к работе с предыдущим диалогом. Если в данное время нажатие кнопки не допускается, она будет выглядеть более бледной, чем другие.

В диалогах кроме кнопок располагаются и другие элементы управления. В большинстве случаев они помогают указать компьютеру необходимое значение какого-либо параметра. При этом чаще всего вам предлагаются правильные варианты для выбора. Чтобы выбрать один вариант из нескольких, удобно использовать переключатели (Рис. 1.12). Выбранный элемент отмечен точкой внутри кружка, и установка переключателя осуществляется путем щелчка мышью на требуемом варианте. При большом количестве вариантов выбора используют списки (Рис. 1.12). При щелчке мышью на названии списка открывается его содержимое. Выбор элемента списка осуществляется щелчком мыши на нужном элементе. Список не обязательно должен быть открывающимся. Иногда все элементы списка отображаются для выбора в поле, которое постоянно находится в диалоге.

Рис 1.12. Различные элементы управления

Часто бывает необходимо ввести какую-либо информацию с клавиатуры. Для этих целей используют поля ввода (Рис. 1.12, второй справа). Вам нужно щелкнуть мышью на этом поле и ввести с клавиатуры требуемое выражение или число. Чтобы включать или выключать некоторые возможности, используются флажки (Рис. 1.12, справа). Галочка в прямоугольнике означает, что флажок установлен. Пустой прямоугольник говорит о том, что флажок сброшен. Для установки или сброса флажка необходимо щелкнуть мышью на соответствующем прямоугольнике. В отличие от переключателя, флажки не связаны друг с другом, и вы можете установить или снять любое количество флажков. Перечисленные элементы управления могут встречаться в диалогах в различных сочетаниях. Достаточно часто в диалогах также встречаются поля предварительного просмотра, в которых виден результат преобразований, заданных вами в диалоге.

Работа с любой программой ведется в ее рабочем окне. В рабочей области окна вы выполняете действия, для которых предназначена данная программа. С помощью команд меню и кнопок на панели инструментов можно задавать различные команды. В результате их выполнения на экране могут появляться диалоги, в которых вы уточняете некоторые параметры. Информация в строке состояния служит для облегчения работы. Чтобы управлять окнами программ, используются специальные кнопки, расположенные в правой верхней части окна, на заголовке (Рис. 1.13).

Рис 1.13. Кнопки изменения размера окна

Кнопка [image] используется для того, чтобы убрать с рабочего стола ненужную вам в данный момент программу, но не завершать ее работу. Если вы нажмете эту кнопку, окно программы будет убрано с рабочего стола. Эта процедура называется сворачиванием окна. В любой момент вы можете развернуть окно и продолжить работу. Следует помнить, что программа работает даже и при свернутом окне. Чтобы прекратить работу программы, необходимо не свернуть, а закрыть ее окно. Кнопка [image] предназначена для закрытия окна и завершения работы программы, связанной с данным окном.

Кнопка [image] позволяет увеличить размер окна программы так, чтобы оно заняло весь рабочий стол. При этом рисунок на кнопке меняется, и кнопка [image] превращается в [image] . Нажатие кнопки [image] приведет к восстановлению исходных размеров окна программы. Увеличение размеров окна во весь экран бывает нужно, когда отображаемой информации много, а уменьшение размеров окна - когда вы хотите увидеть одновременно работу нескольких программ.

Для управления работой нескольких программ удобно использовать панель задач, расположенную в нижней части рабочего стола Windows XP. В английской версии системы она называется Taskbar. В левой части панели расположена кнопка Пуск (Start), с которой вы уже знакомы. Правее этой кнопки обычно расположена панель инструментов почти с такими же значками, как и на рабочем столе Windows (Рис. 1.14).

Рис 1.14. Панель инструментов для быстрого запуска программ

Эта панель называется Быстрый запуск (Quick Launch) и предназначена для запуска популярных и часто используемых программ. Использование данной панели бывает удобно, когда значки для запуска программ расположены на рабочем столе, который загроможден открытыми окнами. Кроме того, удобнее запускать программы нажатием одной кнопки, чем последовательно выбирать несколько команд главного меню Windows. Вы можете добавлять в эту панель любые значки для запуска программ.

В правой части панели задач располагается панель индикации. На ней отображается текущее время и значки различных запущенных программ (Рис. 1.15, слева). В Windows XP значки, которые не используются в настоящее время, могут быть убраны из панели индикации. Скорее всего, в данной панели будет отображаться только текущее время (Рис. 1.15, справа), хотя вы можете изменить настройки и убрать время с панели.

Рис 1.15. Панель индикации

Если вы долго не использовали некоторые значки на панели индикации, они могут быть спрятаны. В этом случае на краю панели появится специальная кнопка [image] (Рис. 1.16, слева).

Рис 1.16. Свернутая и развернутая панель индикации

Нажав эту кнопку, вы развернете панель индикации. При этом будут показаны все значки, а кнопка изменит свой вид на [image] (Рис. 1.16, справа). Щелкнув мышью на любом значке, вы запустите связанную с ним программу. Если вы не выполните никаких действий, панель индикации снова будет свернута.

После того, как программа запущена и на рабочем столе появилось ее окно, в центральной части панели задач появляется кнопка, соответствующая запущенной программе. Подведите указатель мыши к такой кнопке, и она изменит свой цвет. Если вы в данный момент работаете с какой-то программой, то заголовок ее окна на рабочем столе более яркий, чем заголовки окон других программ, а кнопка с названием программы на панели задач выглядит нажатой (Рис. 1.17).

Рис 1.17. Панель задач с кнопками программ

Если вы запустили несколько копий одной программы, например, просматриваете разные Web-страницы с помощью программы Internet Explorer или редактируете несколько рисунков в разных копиях графического редактора Paint, то отдельные копии могут отображаться как несколькими, так и одной кнопкой в панели задач. Это зависит от настроек системы. Если все копии связаны с одной кнопкой, на ней будет написано число, соответствующее количеству работающих копий программы (Рис. 1.18). Если же запущено множество различных программ, и их кнопки не помещаются в панели задач, в правой части панели появятся две кнопки [image] и [image] (Рис. 1.18, слева). Фактически кнопки запущенных программ расположатся на нескольких строках, одна из которых будет отображаться в панели задач. Нажимая кнопки [image] и [image] вы можете переключаться между разными строками. При этом на панели задач будут отображаться кнопки тех или иных программ. Как только количество запущенных программ уменьшится, и их кнопки смогут располагаться на одной строке кнопки [image] и [image] будут убраны из правой части панели задач.

Рис 1.18. Кнопки множества запущенных программ

Если на кнопке в панели задач написано число и название программы, например 4 Проводник (4 Windows Explorer), то с этой кнопкой связано несколько запущенных копий данной программы. Нажав такую кнопку, вы откроете список, в котором сможете выбрать нужную копию (Рис. 1.18, справа). Щелкнув мышью на одном из элементов списка, вы закроете список, при этом текущей станет выбранная копия данной программы.

Если вы с программой в данный момент не работаете, ее кнопка на панели задач будет выглядеть отжатой. Практически кнопка отсутствует, просто на панели задач имеется надпись с именем программы и названием документа, с которым она работает. Щелчок мышью на кнопке программы, расположенной на панели задач, активизирует программу. Ее окно появляется на экране, и кнопка становится нажатой. Если окно программы было свернуто, то нажатие кнопки развернет его. Повторное нажатие кнопки свернет окно программы. Если программе, с которой вы в настоящее время не работаете, требуется ваше вмешательство, кнопка на панели задач начнет мигать. Нажав мигающую кнопку, вы перейдете к данной программе, щелкнув мышью на кнопке. При этом кнопка станет нажатой и перестанет мигать.


1.9. Работа с несколькими программами

Одной из важных особенностей Windows, определяющих удобство работы с этой операционной системой, является

возможность работы с несколькими программами одновременно. Это могут быть различные программы или две копии одной и той же программы. В любой момент у вас есть возможность нажать кнопку Пуск (Start) и выбрать нужную вам программу для запуска без предварительного завершения работы предыдущей программы. Естественно, вы можете воспользоваться и любыми другими способами запуска программ. При этом окно новой программы частично или полностью может перекрывать уже открытые окна других программ, которые ранее располагались на рабочем столе Windows XP (Рис. 1.19).

Рис 1.19. Одновременная работа нескольких программ

Поскольку все работающие программы отображаются на панели задач в виде кнопок, то легко увидеть, сколько в данный момент работает программ. Обратите внимание, что только одна кнопка на панели задач может быть нажатой. Остальные кнопки обязательно будут не нажаты. Нажатая кнопка соответствует той программе, с которой вы в настоящий момент работаете. Ее окно

располагается поверх остальных окон, заголовок ее окна выделен более ярким цветом. Эта программа называется активной (Foreground - передний план), а остальные задачи в этот момент являются фоновыми (Background - задний план). Заметим, что активные задачи работают быстрее, чем фоновые, так как обладают более высоким приоритетом. Однако фоновые задачи не останавливаются, а тоже продолжают работать. Естественно, что одновременная работа множества задач требует дополнительных ресурсов, и ваша работа на компьютере может сильно замедлиться.

Переключаться между программами очень просто. Если на рабочем столе видна хотя бы часть нужного вам окна программы, то, щелкнув на нем мышью, вы сделаете данное окно активным, и оно будет расположено поверх остальных окон. Если окна не видно, то для переключения следует воспользоваться панелью задач. Универсальным способом переключения между программами является нажатие нужной кнопки на панели задач Windows. При этом совершенно не важно, видно ли на экране нужное окно, или нет. Окно в настоящий момент может быть даже свернуто.


1.10. Использование клавиатуры

Клавиатура для управления компьютером используется реже компьютерной мыши, но вводить буквы и цифры вы все равно будете с помощью клавиатуры. Умение работать с клавиатурой также чрезвычайно важно для освоения системы. Хотя внешне компьютерные клавиатуры могут сильно различаться, принцип работы с ними один и тот же.

Клавиатура представляет собой устройство, предназначенное для ввода информации от пользователя в компьютер (Рис. 1.20). Эта информация может быть просто данными, а может управлять работой компьютера. Обычная клавиатура для персонального компьютера имеет более ста клавиш, при этом назначение клавиш не является постоянным. Что происходит при нажатии той или иной клавиши, зависит от того, с какой программой вы в настоящее время работаете. Однако

большинство программ придерживаются некоторых единых правил при работе с клавиатурой, поэтому клавиши можно классифицировать по своему назначению.

Рис 1.20. Компьютерная клавиатура

Алфавитно-цифровые клавиши (Рис. 1.21) представляют собой группу клавиш, которые чаще всего используются для ввода информации, к которой относятся буквы, цифры и знаки препинания. Именно к этим клавишам относится понятие раскладки клавиатуры. Раскладка клавиатуры - это закрепление за определенными клавишами определенных символов.

Рис 1.21. Алфавитно-цифровые клавиши

Поскольку интернациональным языком для компьютеров является английский язык, то в России клавиатура поддерживает две раскладки - русскую и латинскую. На алфавитно-цифровых клавишах изображены два символа - русский и латинский, например, [image] . Переключение между различными раскладками осуществляется путем щелчка мышью на специальном индикаторе раскладки клавиатуры, находящемся на панели языка. Этот индикатор имеет различный вид, в зависимости от текущей раскладки - [image] или [image] . Еще одним способом переключения раскладки клавиатуры является нажатие определенной комбинации ее клавиш. Чаще всего для изменения раскладки используется одновременное нажатие клавиши [image] и клавиши [image] которые расположены в левой части клавиатуры.

Чтобы сократить количество клавиш, строчные и прописные символы набирают, используя одни и те же клавиши. При этом используется еще одна клавиша [image] , нажимаемая одновременно с алфавитно-цифровой клавишей. На клавиатуре имеются две клавиши [image] правая и левая. Их использование для ввода символов равнозначно. Эти клавиши являются одними из большой группы управляющих клавиш (Рис. 1.22).

Рис 1.22. Управляющие клавиши

Если вам требуется вводить много теста прописными буквами, можно зафиксировать клавиатуру в таком режиме. Для этого используется клавиша [image] . Она работает как переключатель -нажатие данной клавиши приводит к тому, что все последующие символы будут вводиться как прописные. Для ввода строчных букв в этом режиме следует нажать и удерживать клавишу [image] . Повторное нажатие клавиши [image] переведет клавиатуру в режим ввода строчных букв. Включение режима ввода прописных букв отображается соответствующим индикатором Caps Lock (Рис. 1.23), расположенным в правой части клавиатуры. Всего на большинстве клавиатур расположено три индикатора, связанных с разными управляющими клавишами.

Рис 1.23. Индикаторы

Управляющие клавиши [image] и [image] обычно действуют в комбинации с другими клавишами, например, одновременное нажатие клавиш [image] и [image] завершает работу программы. Нажатие нескольких клавиш подразумевает сначала нажатие одной клавиши, например, клавиши [image] , и, не отпуская первую клавишу, нажатие второй, например, [image] . После этого обе клавиши можно отпустить в произвольном порядке.

Главной управляющей клавишей компьютерной клавиатуры можно назвать клавишу [image] . Внешний вид этой клавиши может быть различным, как и ее назначение. На многих клавиатурах она выглядит как [image] или [image] . Чаще всего эта клавиша используется для завершения ввода команды компьютеру, переход на новую строку при вводе текста или для выбора команды из меню.

Управляющая клавиша [image] , расположенная в левом верхнем углу клавиатуры, широко используется при управлении программами и служит для отмены каких-либо действий. Также эту клавишу можно использовать для закрытия меню, диалогов и других элементов управления, рассмотренных выше. Основное назначение клавиши [image] - вводить в текст символы табуляции. При работе с элементами управления (списками, переключателями и так далее) эта клавиша используется для переключения между объектами, между элементами управления, между режимами работы программы. Клавиша [image] используется для удаления введенных символов, расположенных слева от текущей позиции в тексте. К управляющим клавишам относится и клавиша [image] о которой рассказывалось выше. На некоторых клавиатурах имеется клавиша [image] нажатие которой чаще всего открывает вспомогательное меню. Такое же меню вызывается с помощью щелчка правой кнопкой мыши.

Клавиши, расположенные в ряд в верхней части клавиатуры, называются функциональными и обозначаются с [image] по [image] . Назначение этих клавиш каждая программа может менять по своему усмотрению, однако существуют некоторые правила назначения функциональных клавиш в программах. Например, клавиша [image] в большинстве программ используется для вызова справочной информации.

Клавиши, обозначенные стрелками (Рис. 1.24) и расположенные в правой части клавиатуры, предназначены для управления курсором. Курсор представляет собой особый символ на экране, который служит для указания чего-либо. При наборе текста курсор показывает место, куда будет введен очередной символ. При работе с некоторыми графическими программами эти клавиши управляют перемещением указателя мыши на экране.

Рис 1.24. Клавиши управления курсором, редактирования и управления питанием

К клавишам управления курсором относятся и клавиши, расположенные выше стрелок. Клавиши [image] , [image] , [image] и [image] предназначены для перемещения курсора при вводе теста на одну страницу вниз, вверх, в начало и конец строки, соответственно. Клавиша редактирования [image] переключает режим ввода текста между вставкой и заменой символов. При работе в режиме вставки символы/введенные с клавиатуры занимают место между ранее существовавшими символами и как бы раздвигают их. В режиме замены новые символы пишутся вместо предыдущих. Клавиша [image] при работе с текстом удаляет символы, находящиеся справа от курсора. При работе с объектами с помощью этой клавиши удаляют предварительно выделенные объекты или группы объектов.

На многих современных клавиатурах есть клавиша [image] с помощью которой можно включить компьютер. Для перевода компьютера в спящий режим используется клавиша [image] а для его пробуждения - [image] . Следует отметить, что операционная система Windows XP поддерживает все данные клавиши, и переводит компьютер в соответствующий режим.

Справа на клавиатуре расположен блок дополнительных клавиш (Рис. 1.25). Их назначение состоит в дублировании некоторых алфавитно-цифровых и управляющих клавиш для упрощения ввода цифр и математических знаков. Кроме того, эти клавиши можно использовать как клавиши управления курсором и редактирования.

Рис 1.25. Блок дополнительных клавиш

В каком режиме работает этот блок клавиш, определяется с помощью специальной клавиши [image] , работающей в режиме переключателя. При нажатии этой клавиши на клавиатуре загорается одноименный индикатор, и клавиатура переходит в режим набора цифр. Если индикатор не горит, клавиши данного блока используются как управляющие.


Пример 1.1. Одновременное использование калькулятора и блокнота

После того, как мы рассмотрели основные принципы работы с Windows XP, закрепим эти базовые навыки с помощью простого примера. Перед началом выполнения примера убедитесь, что система Windows XP загружена и на экране отображается рабочий стол системы.

Предположим, вам необходимо набрать небольшой текст, в котором есть некоторые численные значения. Эти значения вы пока не знаете, и вам необходимо рассчитать их во время работы. Например, необходимо составить калькуляцию на покупаемый компьютер. В данном примере мы воспользуемся только стандартными программами, которые входят в состав операционной системы и автоматически устанавливаются на ваш компьютер после установки Windows XP.

Для набора текста воспользуемся программой Блокнот (Notepad), который является простейшим текстовым редактором. Запустить программу можно из группы программ Стандартные (Accessories) через главное меню Windows. На экране появится окно программы (Рис. 1.26).

Рис 1.26. Ввод текста в простейшем редакторе

Конечно, сразу после запуска программы, текста в рабочей области нет, и вам нужно набрать его. Вводится текст чрезвычайно просто - вы нажимаете нужные клавиши на клавиатуре компьютера, и соответствующие символы появляются в рабочей области программы. Символы появляются в месте, отмеченным текстовым курсором - вертикальной мигающей чертой. При вводе этого текста вам потребуется воспользоваться переключением между строчными и прописными символами. Кроме того, поскольку в тексте встречаются как русские, так и латинские символы, вам придется переключать раскладку клавиатуры. Напоминаем, что переключение между строчными и прописными буквами, а также между цифрами и специальными символами осуществляется с помощью клавиши [image] . Чтобы перейти на новую строку, следует воспользоваться клавишей [image] .

Чтобы вводить символы разных языков, следует использовать разную раскладку клавиатуры. Для переключения раскладки клавиатуры воспользуйтесь панелью языка. Если данная панель отсутствует на экране, аналогичные действия можно выполнить с помощью индикатора языка на панели задач. В случае, когда индикатор расположен в панели языка, рядом с ним имеется надпись с названием выбранного языка. Щелкните мышью на значке, обозначающем индикатор текущей раскладки клавиатуры, который может иметь вид [image] или [image] , в зависимости от текущей раскладки. Рядом появится список установленных в системе языков (Рис. 1.27). Щелкнув мышью на одном из элементов списка, выберите требуемый язык.

Рис 1.27. Выбор языка

Конечно, можно посчитать стоимость собираемого компьютера вручную, однако удобнее для этого воспользоваться

калькулятором. Выберите команду главного меню Другие программы (More Programs), а в нем команду Стандартные (Accessories). Появится вложенное меню стандартных программ. Выберите команду Калькулятор (Calculator). На экране появится еще одно окно программы, которое частично перекроет окно программы Блокнот (Notepad) (Рис. 1.28). Можно начинать работу с калькулятором, но вначале следует выполнить некоторые подготовительные действия.

Рис 1.28. Работа с двумя программами

Обратите внимание, что на панели задач находятся две кнопки, обозначающие, что в данный момент запущены две программы, причем кнопка Калькулятор (Calculator) нажата, что говорит о том, что в данный момент мы работаем с этой программой.

Система Windows позволяет перемещать окна по рабочему столу и размещать их в произвольных местах. Для этого используется способ, называемый перетаскиванием или буксировкой при помощи мыши. Установите указатель мыши на заголовке окна программы Калькулятор (Calculator). При этом под указателем

не должны находиться никакие кнопки. Нажмите левую кнопку мыши и, не отпуская ее, начните передвигать мышь. Вместе с перемещением указателя начнет передвигаться и окно программы. Перемещайте указатель до тех пор, пока окно программы Калькулятор (Calculator) не перестанет закрывать столбец с ценами в окне программы Блокнот (Notepad). После того, как вы добились желаемого положения окна, отпустите кнопку мыши. Кстати, аналогично вы можете переместить и окно программы Блокнот (Notepad), но после этого не забудьте перейти к работе с калькулятором, нажав соответствующую кнопку на панели задач.

Работа с калькулятором очень проста и напоминает работу с обычным калькулятором. Правда кнопки вы будете нажимать не пальцами, а клавишами клавиатуры или щелчками мыши. Можно нажимать мышью соответствующие кнопки в рабочем окне программы, а можно воспользоваться блоком дополнительных клавиш. Давайте попробуем использовать в работе оба способа.

Нажмите с помощью мыши кнопки в окне программы Калькулятор (Calculator) 256+85+50+105=. В окне программы должен появиться промежуточный результат - 496. Перед тем, как воспользоваться блоком дополнительных клавиш убедитесь, что он находится в режиме ввода чисел. Это можно проверить по индикатору NumLock. Если он горит, то все в порядке. В противном случае, нажмите клавишу [image] на клавиатуре, чтобы перейти в нужный режим. Теперь введите с помощью клавиш дополнительного блока [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] [image] . Следует отметить, что для получения результата была нажата клавиша [image] . Ее нажатие аналогично нажатию кнопки [image] в окне программы. В окне программы Калькулятор (Calculator) появится окончательный результат: 1041. Нам нужно вернуться к программе Блокнот (Notepad) и занести полученный результат в калькуляцию.

Переключаться между запущенными программами очень легко. Щелкните мышью на кнопке с именем Блокнот (Notepad) в панели задач и рабочее окно этой программы станет активным. Кстати, на кнопке вначале указано имя редактируемого документа, например Безымянный (Noname). Перейдя к работе с блокнотом, щелкните мышью на том месте текста, куда необходимо внести результат, и в этом месте появится текстовый курсор в виде вертикальной мигающей черты. Наберите на клавиатуре требуемое число и на этом создание калькуляции завершено.

Чаще всего документы создаются для последующего использования. Чтобы использовать созданную только что калькуляцию в дальнейшем, ее необходимо сохранить на диске. Выберите команду меню Файл * Сохранить (File * Save) программы Блокнот (Notepad). На экране появится диалог настройки сохранения документа (Рис. 1.29).

Рис 1.29. Диалог сохранения документа

Программа предлагает сохранить документ в папке Мои документы (My documents) с именем Безымянный (Noname). Эта папка предназначена для хранения ваших личных документов, и лучше не менять место хранения. Однако имя создаваемого файла лучше изменить. Щелкните мышью на поле ввода Имя файла (File Name) и наберите с помощью клавиатуры новое имя Калькуляция. Нажмите кнопку Сохранить (Save), чтобы закрыть диалог и сохранить документ. В другой раз, когда вы запустите программу Блокнот (Notepad), вы сможете открыть сохраненный ранее файл. Для этого следует выбрать команду меню Файл * Открыть (File * Open), после чего можно отредактировать документ.

По окончании работы с программой, необходимо ее завершить. Выберите команду меню Файл * Выход (File * Exit) программы Блокнот (Notepad), чтобы закончить работу с ней. В заключение нашего примера завершим работу с программой Калькулятор (Calculator). Нажмите кнопку [image] в правом верхнем углу окна программы, и ее работа будет завершена.

Так происходит работа в Windows с различными программами. Уже сейчас вы можете использовать простые навыки работы с системой, но существенный прорыв в освоении Windows вы совершите, познакомившись с важнейшей программой, помогающей вам при работе с файлами, дисками и папками вашего компьютера. Эта программа называется проводником Windows.


  • 10. Игры, поставляемые в составе Windows
    • Пасьянс Косынка
    • Пасьянс Свободная ячейка
    • Пасьянс Паук
    • Сапер
    • Пинбол
    • Червы
    • Интернет-игры


10. Игры, поставляемые в составе Windows

Современные компьютерные игры довольно сложны и громоздки, однако в составе Windows есть несколько простых игр, которые помогут вам отвлечься от монотонной работы за компьютером и поднимут вам настроение.

Чтобы запустить любую игру, входящую в состав Windows, необходимо выбрать команду главного меню Другие програимы * Стандартные * Игры (More Programs * Accessories * Games) и выбрать одну из игр в открывшемся вспомогательном меню. Для тех, кто любит раскладывать пасьянсы, Windows предлагает несколько игр. Давайте рассмотрим эти игры.


10.1. Пасьянс Косынка

Цель игры состоит в складывании четырех стопок карт одной масти, начиная с туза и заканчивая королем. Запуск игры осуществляется командой Косынка (Solitaire), расположенной в меню игр. После запуска появляется окно Игры, представляющее собой игровое поле (Рис. 10.1), которое состоит из колоды карт, расположенной в левом верхнем углу окна игры и нескольких столбцов карт, в которые компьютер сдает карты из колоды. Также в правом верхнем углу расположены четыре стопки, называемые домом и предназначенные для размещения карт одной масти по возрастанию, начиная с тузов. Чтобы открыть карты, которые следует переместить в дом, вы можете перемещать карты, находящиеся сверху колоды или сверху столбцов со сданными картами, причем перемещаемые карты должны быть расположены лицом вверх. Чтобы переложить одну или несколько карт из одного столбца в другой, перетащите их с помощью мыши. Чтобы переместить карту в дом, необходимо дважды щелкнуть на ней мышью.

Рис 10.1. Игра Косынка (Solitaire)

Перемещать карты между столбцами можно по определенным правилам: карты в столбцах должны располагаться по убыванию, причем цвет соседних карт должен быть разным, например, на черного короля можно положить даму красной масти, затем в этот столбец должен лечь черный валет и так далее.


10.2. Пасьянс Свободная ячейка

Данная программа находится в той же группе, что и предыдущий пасьянс и во многом похожа на него. Однако правила этой игры более просты, и считается, что пасьянс Свободная ячейка (Free Cell) всегда сходится. Игровое поле пасьянса (Рис. 10.2) содержит четыре ячейки дома, четыре свободные ячейки и восемь столбцов карт, расположенных лицом вверх. Цель игры состоит в том, чтобы переместить все карты в дом, представляющий собой четыре ячейки, находящиеся в верхнем правом углу экрана. При этом пустые ячейки, расположенные левее дома, используются как промежуточные. Каждая ячейка может содержать только одну карту.

Рис 10.2. Игра Свободная ячейка (Free Cell)

Открытые тузы автоматически перемещаются в пустые ячейки дома. Остальные карты необходимо класть поверх тузов по возрастанию: двойку на туза, тройку на двойку и так далее. Чтобы выиграть, следует расположить все карты по возрастанию в четырех ячейках дома, соответствующих четырем мастям. Для перемещения карты нужно щелкнуть на ней мышью, а затем щелкнуть мышью на том месте, куда следует переместить Эту карту.

Согласно правилам игры в свободную ячейку можно переместить любую карту, находящуюся внизу столбца. В ячейку дома можно переместить любую карту, находящуюся в свободной ячейке или внизу столбца. Карту можно положить на карту той же масти в порядке возрастания. Карту, находящуюся в свободной ячейке или внизу столбца, можно переместить в низ другого столбца. Карту можно положить на карту другого цвета в следующем порядке: даму на короля, валета на даму. При игре экономно расходуйте свободные ячейки и не занимайте их без необходимости. Для быстрого перемещения карты в свободную ячейку дважды щелкните мышью на этой карте.


10.3. Пасьянс Паук

Выберите команду главного меню Другие программы * Стандартные * Игры * Пасьянс Паук (More Programs * Accessories * Games * Spider Solitaire), чтобы запустить новую игру. Появится диалог, предлагающий выбрать сложность игры (Рис. 10.3).

Рис 10.3. Рабочее окно пасьянса Паук (Spider Solitaire)

В этом диалоге вы можете с помощью переключателя выбрать сложность игры. Для начала попробуйте самый легкий уровень игры. С помощью переключателя установите уровень игры Легкий (Easy) и нажмите кнопку ОК, чтобы закрыть диалог и начать игру. Появится рабочее окно программы (Рис. 10.3)

Цель этой игры состоит в том, чтобы убрать все карты из десяти стопок за наименьшее число ходов. Чтобы убрать карты из стопок, необходимо, перекладывая их из стопки на стопку, сложить последовательность карт одной масти от короля до туза. Как только полная цепочка карт сложена, они пропадают с экрана, тем самым, освобождая место. Попробуйте сыграть в игру самостоятельно, а после завершите работу программы.


10.4. Сапер

Если вы любите логические игры, то, возможно, эта игра будет вам интересна. Чтобы запустить игру, выберите команду Сапер (Minesweeper) в меню игр. При этом появится рабочее окно игры (Рис. 10.4). Цель игры - разминировать минное поле как можно быстрее и при этом не подорваться на минах. Игровое поле состоит из счетчика мин, секундомера и минного поля. Мины спрятаны на поле и их не видно. Вы можете открыть любую ячейку, щелкнув на ней мышью.

Рис 10.4. Игра Сапер (Minesweeper)

Минное поле представляет собой прямоугольник, на котором “зарыты” мины. Поле считается разминированным только тогда, когда все его клетки либо раскопаны, либо помечены как мины. Количество мин на поле сообщается перед игрой, и нельзя ставить пометок больше, чем мин. Играют в игру с помощью мыши. Щелкнув левой кнопкой мыши на квадрате поля, мы как бы раскапываем его. Если вам повезло, то в этой клетке показывается, сколько мин находится в соседних смежных с ней клетках. Если же в этой клетке оказалась мина, то, как говорится: “сапер ошибается только один раз”. При этом программа показывает вашу ошибку, рисуя на ее месте перечеркнутую мину.

К сожалению, первый ход вам придется сделать наугад. Если вы не уверены, есть ли в предполагаемой для следующего хода ячейке мина, вы можете пометить ячейку. Для этого необходимо щелкнуть на этой ячейке правой кнопкой мыши. После того как все мины, смежные с ячейкой, содержащей номер, будут найдены, укажите на эту ячейку и нажмите одновременно левую и правую кнопки мыши, чтобы вскрыть все оставшиеся невскрытыми смежные ячейки.


10.5. Пинбол

Игра Пинбол (Pinball) является вариантом электронного игрового автомата. Запуск игры осуществляется командой Пинбол (Pinball), расположенной в меню Игры (Games). Цель игры - набрать максимальное число очков, начисляемых за попадание запущенного шарика в амортизаторы, мишени, флажки и норки. Эти объекты образуют игровое поле (Рис. 10.5).

Рис 10.5. Окно программы Пинбол (Pinball)

Амортизаторами называются объекты, отбивающие попадающий в них шарик. Мишени отличаются от амортизаторов тем, что не отбивают попадающий в них шарик, а разбиваются. Шарик запускается нажатием клавиши. Манипулируя двумя рычагами, расположенными внизу экрана, игрок должен не дать упасть шарику вниз. Для управления рычагами нажимаются клавиши и, расположенные по краям клавиатуры. Кроме того, подбрасывая шарик с помощью этих рычагов, необходимо управлять полетом шарика, чтобы он попадал в призовые места на игровом поле. Шарик теряется, провалившись между рычагами. Для начала новой игры надо нажать клавишу И. В ходе игры можно заработать неограниченное число дополнительных шариков. Они вступают в игру сразу после потери текущего шарика.


10.6. Червы

Выберите команду главного меню Другие программы * Стандартные * Игры * Червы (More Programs * Accessories * Games * Hearts), чтобы запустить игру. Появится диалог, предлагающий вам выбрать себе имя. Если ваш компьютер подключен к сети, то будет доступен переключатель для выбора: хотите ли вы начать новую игру или присоединиться к уже идущей. В поле ввода введите свое имя и нажмите кнопку ОК данного диалога, чтобы начать игру. Появится рабочее окно, представляющее собой карточный стол (Рис. 10.6, справа).

Рис 10.6. Рабочее окно игры Червы (Hearts)

Червы (Hearts) - это карточная игра, в которую играют четверо. В роли ваших оппонентов выступают несколько человек компьютеры которых соединены между собой и вами в сеть. Естественно на всех компьютерах должна быть запущена эта игра. Если сети нет, то роль ваших противников может взять на себя ваш компьютер. Счет идет на очки, и побеждает тот, у кого их окажется меньше на конец игры. Вначале вы можете сменить три любые свои карты. Первой ходит двойка треф. Взятку берет тот, у кого оказалась наиболее крупная карта. Цель игры - не брать червы и даму пик. Если вы возьмете все без исключения червы и даму пик, то вы выиграете раунд. Игра идет до тех пор, пока один их игроков не наберет сто очков.


10.7. Интернет-игры

В состав Windows XP включен ряд программ, предназначенных для игр в Интернете. То, что это сетевые игры, видно из их названия, например, Интернет Реверси (Internet Reversi). Для игры вам необходимо подключиться к Интернету и войти на игровой сервер Microsoft. Последнюю операцию система делает автоматически, а подключиться вы должны самостоятельно. Когда вы запускаете сетевую игру, появляется диалог, информирующий о необходимости подключения (Рис. 10.7).

Рис 10.7. Диалог начала сетевой игры

Нажмите кнопку Играть (Play) этого диалога. Появится диалог с информацией о необходимости соединения с поставщиком услуг Интернета. Нажмите кнопку Подключиться (Connect), чтобы установить соединение. После того, как соединение установлено, начнется поиск соперника, и если соперник найден, игра начинается и появится ее рабочее окно. Вначале опишем состав сетевых игр Windows XP, а потом рассмотрим процесс игры на примере одной из сетевых игр. Нарды (Backgammon) - игра, в которую играют двое. Рабочая область представляет собой доску, на которой располагаются фишки (Stones). Каждый игрок имеет пятнадцать фишек одного цвета, которые размещены в двадцати четырех точках (Points), которым присвоены последовательные номера. Доска поделена на две половины с помощью специальной вертикальной полосы (Ваг). Каждый ход игры начинается с бросания кубика, определяющего, как далеко вы можете перемещать фишки. Побеждает тот, кто быстрее соперника переместит свои фишки на ячейки, соответствующие вашему цвету на одной половине поля. Шашки (Checkers) - одна из старейших игр. Рабочее поле представляет собой шахматную доску с шестьюдесятью четырьмя клетками. Игра идет только на темных клетках. Используются два цвета фишек: белый и черный. Черные всегда начинают. Чтобы победить, необходимо съесть все фишки противника или запереть его, не давая ему выполнить ход. Игра Реверси (Reversi) представляет собой компьютерный вариант древней восточной игры. Игровое поле опять представляет собой шахматную доску. Игра идет черными и белыми фишками. Ваша задача съесть все фишки соперника путем их окружения. Игра начинается с двух фишек. Окруженные фишки противника становятся вашими и принимают ваш цвет. Игра Червы (Hearts) аналогична рассмотренной выше одноименной игре. Единственное отличие состоит в том, что вашим противником является не компьютер, а люди, подключенные к Интернету. Игра Пики (Spades) является карточной игрой, в которой играют четыре человека. Причем они разбиваются на пары, и каждая пара сидящих друг напротив друга людей играет сообща. Игрок смотрит свои карты и сообщает число ловушек (Tricks), которые он может взять. Совместное число ловушек двух партнеров образует контракт (Contract). Задача ваших противников не дать вам выиграть контракт, а вы и ваш партнер должны стремиться сделать это.

После обзора Интернет-игр давайте рассмотрим, как происходит игра в Интернете. Прежде всего, установите соединение с Интернетом. Затем выберите команду главного меню Другие программы * Стандартные * Игры * Интернет Нарды (More Programs * Accessories * Games * Internet Backgammon), чтобы запустить игру. Появится диалог, предлагающий начать игру (Рис. 10.7). Нажмите кнопку Играть (Play), чтобы начать игру. Начнется поиск в Интернете игрового сервера с целью выбора противника. После того, как вы автоматически зарегистрируетесь на сервере и будет найден соперник, появится рабочее окно игры.

Отличительной особенностью Интернет-игр Windows XP является наличие в них возможности вести разговор с вашим оппонентом. В данном случае, это делается установкой переключателя Чат (Chat) в положение Вкл (On). С помощью открывающегося списка внизу рабочего окна, вы можете выбирать фразы, которые будут отправлены вашему оппоненту. Выше списка расположена область, где отображается диалог, который вы ведете. Попробуйте поиграть в эту игру. После окончания игры разорвите связь с Интернетом и закройте рабочее окно программы.

Мы кратко рассмотрели основные игры, уделив значительно больше внимания другим программам в составе Windows XP. Если вы любите иногда поиграть, вы без труда сможете освоить достаточно простые игры, включенные в Windows. Возможно, вам больше нравятся другие игры, более сложные, поставляемые отдельно. Windows XP поддерживает новейшие технологии, использующиеся в современных играх. Правда современные игры предъявляют повышенные требования к аппаратуре, и у вас должен быть достаточно мощный современный компьютер. Следует отметить, что в состав Windows XP включено несколько достаточно полезных программ, описанных в данной части книги. Они позволяют работать с текстовыми документами, рисунками и фотографиями, аудио и видео. При этом вам не требуется устанавливать дополнительные дорогостоящие программы, которые были необходимы при использовании старых версий Windows. Присмотритесь к встроенным программам. Они позволяют реализовать многие полезные возможности, и, вполне возможно, что вам хватит этих программ.


  • III. Дополнительные возможности Windows XP
    • Основы совместной работы
      • Работа в локальной вычислительной сети
      • Построение домашней сети
      • Совместное использование принтеров
      • Совместное использование папок и файлов
      • Совместное использование доступа в Интернет
      • Соединение сетей через Интернет
      • Работа нескольких пользователей на компьютер


III. Дополнительные возможности Windows XP

В этой части книги описываются важные средства операционной системы Windows XF которые используются ограниченным кругом пользователей. Однако в некоторых случаях данные средства могут оказаться просто незаменимыми, например, если вы работаете в сети или используете блокнотный компьютер.


11. Основы совместной работы

С помощью операционной системы Windows XP вы можете организовать совместную работу группы пользователей. При этом возможна работа пользователя на компьютере, подключенном к компьютерной сети или работа нескольких пользователей на одном компьютере.


11.1. Работа в локальной вычислительной сети

Если в организации имеется более одного компьютера, то возникает необходимость обмена между ними информацией. Можно переносить файлы с одного компьютера на другой с помощью дискет, но это медленно и неудобно. Кроме того если у вас есть только один принтер, то печать на нем с другого компьютера может оказаться очень непростым делом. Для решения этих проблем компьютеры соединяются в сеть: на них устанавливают специальное оборудование, соединяют проводами и используют программы для обеспечения совместной работы.

Что дает соединение компьютеров в сеть? Прежде всего, появляется возможность работать с информацией, хранящейся на других компьютерах точно так же, как если бы она находилась на вашем компьютере. Кроме этого, становится возможным совместное использование различных устройств. Самым распространенным примером является использование одного принтера несколькими компьютерами. Часто используется один модем для реализации совместного доступа к Интернету.

Если вы работаете в крупной фирме с десятками компьютеров, то у вас наверняка установлена компьютерная сеть. Если же вы трудитесь в небольшой организации, в которой есть всего несколько компьютеров, и у вас нет сети, посоветуйте руководству установить ее. Незначительные дополнительные затраты позволят вам экономить место на дисках компьютеров, не дублируя важную информацию, использовать совместно принтеры, модемы и прочее оборудование. Кроме того, существенно повысится удобство и эффективность работы. Теперь чтобы получить у коллеги нужный файл, вам не потребуется отвлекать его от работы, вставляя свою дискету в дисковод. Вы просто скопируете нужный файл, не вставая со своего рабочего места.

Установкой сети на предприятии должны заниматься профессионалы, но после того как сеть заработала, вы легко сможете освоить ее. Поддержка разнообразных сетевых возможностей встроена в Windows XP, и часто вы можете не замечать, работаете ли вы в сети или нет.


11.1.1. Построение домашней сети

В последнее время все чаще дома люди имеют более одного компьютера. Например, с одним компьютером работает ребенок а с другим - родители. В этом случае также удобно построить несложную сеть на основе двух-трех компьютеров. Простейшие домашние сети легко создаются с помощью Windows XP. Общий доступ в Интернет совместное использование принтеров и дисков - вот только основные возможности предоставляемые домашней сетью. Давайте рассмотрим как настроить Windows для использования домашней сети.
Домашняя сеть может объединить компьютеры с установленными операционными системами Windows 95, 98, Me, 2000, NT 4 и XP.

Необходимым условием для установки домашней сети является наличие у компьютеров сетевых возможностей. Это означает, что на компьютерах должно быть установлено специальное оборудование для сетевой работы, то есть сетевые платы. Выпускаются различные сетевые платы для соединения компьютеров с помощью кабелей, радиоволн, инфракрасного луча и так далее.

Обратите внимание, что если вы хотите использовать общий выход в Интернет для компьютеров домашней сети, то на одном из компьютеров должно быть предварительно настроено соединение с Интернетом, как описано в разделе, посвященном работе с Интернетом.

Настройка домашней сети выполняется с помощью специального мастера. Запустить мастер можно из папки Мое сетевое окружение (My Network Places). При работе с проводником перейдите в данную папку, и в списке задач выберите задачу настройки домашней сети. Также можно запустить мастер из вложенного меню Связь (Communications), вызывающегося из меню стандартных программ Windows. В любом случае будет запущен мастер и появится диалог с приветствием (Рис. 11.1). Нажмите кнопку Далее (Next), чтобы продолжить работу и отобразить второй диалог мастера (Рис. 11.1).

Рис 11.1. Приветствие и общие замечания

В этом диалоге мастер предупреждает вас, что все сетевое оборудование должно быть установлено на компьютеры и правильно настроено в Windows. Если вы приобрели современный комплект для построения сети, вам достаточно установить сетевые платы в компьютеры, после чего соединить все компьютеры прилагающимися кабелями. При очередной загрузке компьютера Windows обнаружит новое устройство и установит для него необходимые драйверы.

Также перед настройкой домашней сети следует включить все компьютеры, которые будут входить в сеть, принтеры и внешние модемы. Если вы планируете использовать совместный доступ к Интернету, перед установкой домашней сети установите соединение с поставщиком услуг Интернета. После ознакомления с общими замечаниями нажмите кнопку Далее (Next) этого диалога.

Появится следующий диалог мастера установки домашней сети (Рис. 11.2). Этот диалог уточняет планируете ли вы использовать соединение с Интернетом на этом компьютере вашей домашней сети. С помощью переключателя вы можете выбрать вариант соединения с Интернетом который вы используете или планируете использовать. Если ваш компьютер соединяется с Интернетом непосредственно, установите переключатель в соответствующее положение. Если для соединения с Интернетом используется другой компьютер в сети, вы также можете выбрать правильное положение переключателя. Если вы не планируете использовать Интернет, установите переключатель в нужное положение.

Рис 11.2. Соединение с Интернетом и имя компьютера

После выбора варианта соединения с Интернетом и установки переключателей нажмите кнопку Далее (Next), чтобы продолжить настройку. Появится очередной диалог: мастера (Рис. 11.2, справа).

Чтобы организовать домашнюю сеть, необходимо определить имена всех компьютеров и дать название всей группе в целом. В поле ввода Имя компьютера (Computer Name) введите уникальное то есть неповторяющееся на других компьютерах, имя. В качестве имени можно использовать свое имя или любой другой набор символов. Можно также воспользоваться именем, генерируемым системой Windows автоматически. Такое имя обычно представляет собой ваше имя и случайный набор цифр, чтобы сделать имя уникальным.

Кроме имени компьютера, вы можете дать описание вашего компьютера, состоящее из одной строки. В этой строке вы можете ввести любую информацию о вашем компьютере, которая будет видна другим участникам сети. Обратите внимание что имя домашней сети не задается в мастере настройки. Предполагается что используется имя MSHOME. Однако вы можете изменить это имя в дальнейшем.

После ввода имени и описания компьютера нажмите кнопку Далее (next), чтобы продолжить настройку. Появится очередной диалог мастера настройки. Обратите внимание, что в зависимости от прав предоставленных вам при установке системы, данный диалог может быть различным или вообще не появится. Рекомендуется устанавливать домашнюю сеть, обладая правами администратора.

Этот диалог позволяет вам определить, какие ресурсы вашего компьютера будут доступны для других пользователей домашней сети. Установите флажок около папки Мои Документы (My Documents), чтобы сделать ее доступной другим пользователям. Вы можете разрешить доступ к любой папке вашего компьютера. Нажмите кнопку Пароль (Password), чтобы открыть одноименный диалог . Поскольку в качестве линий связи для соединения компьютеров в домашнюю сеть могут использоваться открытые линии связи доступные другим людям, следует ввести пароль для доступа к файлам вашего компьютера. Введите пароль и ниже введите его еще раз для проверки. Затем нажмите кнопку ОК, чтобы закрыть этот диалог.

Если к вашему компьютеру подключены принтеры, то их список появится в нижней части диалога . Чтобы принтер стал доступен другим пользователям домашней сети, необходимо установить соответствующий флажок. После настройки доступа к файлам и принтерам вашего компьютера нажмите кнопку Далее (Next) для перехода к следующему диалогу мастера (Рис. 11.3).

Рис 11.3. Готовность к изменениям и завершение мастера

Данный диалог суммирует произведенные вами настройки домашней сети и дает вам возможность при необходимости внести в них изменения. Чтобы внести изменения, следует нажать кнопку Назад (Back) столько раз, сколько нужно, чтобы вернуться к требуемому диалогу настройки. Если все установки сделаны правильно, то смело нажимайте кнопку Далее (Next).

Начнется процесс обновления параметров системы Windows ХР в соответствии с выбранными настройками. Это процесс может занять несколько минут, и по его окончании появится заключительный диалог мастера (Рис. 11.3).

Если вы хотите больше узнать про совместное использование папок и файлов в сети, выберите одну из ссылок этого диалога, чтобы вызвать справочную систему Windows. В противном случае нажмите кнопку Готово (Finish), чтобы закрыть диалог и завершить работу мастера. Поскольку в конфигурацию компьютера были внесены изменения, появится диалог, информирующий о необходимости перезагрузки (Рис. 11.4).

Рис 11.4. Необходимость перезагрузки

Завершите сеанс связи с Интернетом, если вы подключались к сети перед выполнением мастера, и нажмите кнопку Да (Yes) этого диалога, чтобы перезагрузить компьютер. После перезагрузки ваш компьютер готов к работе в составе домашней сети.
Если в результате настройки для работы в составе домашней сети нарушится нормальная работа компьютера, например, вы не сможете подключиться к Интернету, выполните отмену с помощью средства восстановления системы, рассмотренного ниже.

Чтобы домашняя сеть правильно работала, необходимо выполнить настройку на каждом компьютере, которые вы объединяете. Если на всех компьютерах установлена система Windows ХР, то никаких проблем это не вызывает. При использовании операционных систем Windows 95 или 98, следует самостоятельно установить имя рабочей группы и имя компьютера. Если вы используете на других компьютерах Windows Me, то также выполните мастер установки домашней сети на этих компьютерах.

После того, как компьютер настроен для работы в сети, опишем основные принципы сетевой работы. Если вы не подключены к сети, то можете работать с дисками и устройствами, подключенными только к вашему компьютеру. При сетевой работе вы можете использовать диски и устройства всех компьютеров, подключенных к сети. Аналогично остальные пользователи могут использовать ваши ресурсы. Конечно, вы можете запретить использовать ваши ресурсы другим пользователям сети, точно так же, как другие могут запретить использовать свои ресурсы вам. Политикой распределения ресурсов компьютеров для работы в сети занимается специальный человек, являющийся администратором сети. В домашней сети вы сами выполняете функции администратора и запрещаете или разрешаете использование ресурсов.

Если вы работаете в операционной системе Windows ХР, обладая правами администратора, вы можете разрешить или запретить использовать диски вашего компьютера другими пользователями сети. Откройте папку Мой компьютер (My Computer) и щелкните правой кнопкой мыши на диске, доступ к которому вы хотите настроить. В появившемся вспомогательном меню выберите команду Свойства (Options). Появится диалог настройки свойств выбранного диска. Щелкните мышью на ярлычке Доступ (Sharing), чтобы перейти на вкладку настройки доступа к диску (Рис. 11.5). На этой вкладке вы можете указать, разрешен ли доступ к данному диску с других компьютеров или нет, а также выбрать имя для этого диска, под которым он будет виден в сети. Для всего диска произвольное имя задать нельзя, также как и нельзя изменить права доступа к диску. Все пользователи, обладающие правами администратора, будут иметь доступ к дискам вашего компьютера. Вы можете временно запретить доступ, установив переключатель в верхней части диалога в нужное положение, но при следующей загрузке Windows доступ вновь будет разрешен. Более гибкую систему доступа можно настроить для различных папок, расположенных на дисках. В проводнике Windows найдите нужную папку и щелкните на ней правой кнопкой мыши, после чего выберите команду вспомогательного меню Свойства (Options) и перейдите на вкладку Доступ (Sharing) появившегося диалога. Настройка доступа к папке не отличается от настройки доступа к диску.

Рис 11.5. Настройка доступа к папке

Переключателем в верхней части диалога вы разрешаете доступ к папке, а в полях ввода задаете имя для папки и произвольный комментарий. Вы можете ограничить количество пользователей, которые смогут одновременно работать с данной папкой. Нажав кнопку Разрешения (Permissions), можно в появившемся диалоге выбрать пользователей, которым разрешен доступ к данной папке. Вы также можете определить уровень доступа. Например, одним пользователям можно редактировать файлы в папке, а другим - только просматривать. Нажав кнопку ОК, вы закроете диалог и измените параметры доступа к папке.

Еще раз отметим, что диски компьютера доступны администраторам и недоступны обычным пользователям, а доступ к произвольным папкам вы можете настроить, как захотите. Подробнее о подключении сетевых дисков и регистрации пользователей будет рассказано ниже, а пока отметим, что при загрузке Windows вы подключаетесь к сети, то есть вводите свое имя и пароль, и система определяет, какое оборудование вам разрешено использовать. Выполнив подключение, например, диска на соседнем компьютере, вы сможете работать с ним, как со своим собственным диском. Описав, что сетевой принтер будет вами использоваться, вы можете печатать из любой программы так же, как и при использовании своего принтера. Рассмотрим, как это можно сделать и начнем с совместного использования принтеров.


11.1.2. Совместное использование принтеров

Сначала надо указать системе, что мы хотим использовать сетевой принтер. Для этого следует открыть папку Принтеры и факсы (Printers and Faxes), перейдя по ссылкам из панели управления. О том, как добавлять принтер, подробно рассказано выше, поэтому сейчас мы коснемся только особенностей работы с сетевыми принтерами.

После того, как вы открыли папку Принтеры и факсы (Printers and Faxes)/, появится список подключенных к компьютеру принтеров и факсов. Возможно, администратор сети уже подключил сетевой принтер к вашему компьютеру, тогда в окне вы это увидите. Сетевой принтер имеет особый вид значка , так что вы легко сможете определить, установлены ли у вас сетевые принтеры или нет. Давайте рассмотрим, как установить сетевой принтер на ваш компьютер. При этом будем считать, что такой принтер в сети существует, то есть администратор сети подключил его и настроил. Если же вы работаете в домашней сети, то должны самостоятельно установить принтер на один из компьютеров. Дважды щелкните на значке с именем Установка принтера (Add Printer), чтобы запустить мастер установки принтера. Нажмите кнопку Далее (Next) в появившемся диалоге с приветствием, чтобы продолжить работу. Следующий диалог предложит выбрать тип принтера: локальный или сетевой (Рис. 11.6).

Рис 11.6. Выбор типа принтера

Следует установить переключатель в положение Сетевой (Network), установив переключатель в соответствующее положение. Нажмите кнопку Далее (Next), чтобы продолжить установку. Появится очередной диалог мастера (Рис. 11.6). Этот диалог предложит вам указать имя сетевого принтера. Положения переключателя дают вам несколько вариантов для указания этого имени. Если вы используете локальную сеть, то уточните имя принтера у администратора сети вашего предприятия, установите переключатель в среднее положение и введите его в поле ввода. Если вы используете сеть на основе Интернета, то следует выбрать нижнее положение переключателя, узнать у администратора сети адрес принтера и ввести его в поле. В любом случае, после ввода имени или адреса принтера следует нажать кнопку Далее (Next), чтобы продолжить работу.

Однако значительно проще автоматически определить принтер, подключенный к сети. Для этого нужно просто установить переключатель в верхнее положение и нажать кнопку Далее (Next). Будет осуществлен поиск принтеров в сети и появится их список (Рис. 11.7). В этом списке показаны все компьютеры, в настоящий момент подключенные к сети. Просмотрите этот список и найдите компьютер, к которому подключен принтер. Щелкните мышью на имени этого принтера, чтобы выбрать его. Обратите внимание, что в поле ввода автоматически появится адрес принтера, а в нижней части диалога информация об этом принтере.

Рис 11.7. Обзор принтеров

Теперь нажмите кнопку Далее (Next), чтобы продолжить работу. Следующий диалог предназначен для указания имени для подключаемого принтера. Вы можете ввести в поле ввода любое имя или оставить предложенное. После указания имени принтера нажмите кнопку Далее (Next). Следующий диалог предложит вам напечатать пробную страницу. Это бывает полезным для проверки правильности настройки принтера, поэтому установите переключатель в положение Да (Yes) и нажмите кнопку Далее (Next).

Теперь, возможно несколько вариантов дальнейшей работы. Все зависит от того, какая операционная система установлена на компьютере, куда подключен принтер. Если на нем установлена система Windows 2000 или Windows XP, то файлы, необходимые для работы принтера на вашем компьютере, будут переписаны по сети. В противном случае вы увидите диалог с предупреждением о том, что необходима установка драйвера принтера. В этом случае нажмите кнопку ОК данного диалога. При этом появится новый диалог для выбора принтера из списка. Дальнейшая процедура полностью повторяет действия по установке принтера на ваш компьютер, которые описаны ранее. Кратко напомним эти действия. Сначала вы выбираете фирму-производителя вашего принтера, а затем его модель. После того, как принтер выбран, нажмите кнопку Далее (Next), чтобы продолжить работу. Если вы предварительно установили принтер на один из компьютеров сети, как мы вам рекомендовали, то этот диалог не появится, и работа мастера будет успешно завершена.

По окончании работы мастера в списке установленных принтеров появится еще один принтер. Вы можете использовать его для печати во всех программах, установленных в Windows. Печать на сетевой принтер ничем не отличается от печати на локальный принтер, подключенный к вашему компьютеру.

Современные принтеры иногда подключаются непосредственно к сети, а не к одному из компьютеров. Такой вариант более удобен, так как для работы с принтером вам не понадобиться включать еще один компьютер. Если в вашей локальной сети больше компьютеров, чем два-три, лучше приобрести принтер с возможностью подключения к сети. Если ваш принтер не обеспечивает такую возможность, можно приобрести специальный принт-сервер, который позволяет подключить принтер к сети.


11.1.3. Совместное использование папок и файлов

Другая важная задача при работе в сети - получить доступ к папкам и файлам, расположенным на жестком диске другого

компьютера. Это сделать совсем не сложно, если, конечно, владелец другого компьютера разрешил использовать свой диск в сети. О настройке доступа к папкам рассказывалось выше, при описании построения домашней сети.

Чтобы увидеть, какие компьютеры подключены к сети, запустите проводник и перейдите в папку Мое сетевое окружение (My Network Places). При этом в панели задач появится список команд для работы с сетью. Выберите команду Новое место в сетевом окружении (Create a network shortcut)/, чтобы запустить мастер добавления в сетевое окружение. Подробно работа мастера описана в разделе, посвященном описанию работы с Интернетом. По окончании работы мастера сетевая папка доступна для совместной работы во всех программах Windows, например, в проводнике.

Однако значительно удобнее работать с сетевыми папками точно так же, как и с папками своего компьютера. Вы можете подключить сетевой диск, назначив ему одну из букв, не занятую дисками вашего компьютера. При этом в списке дисков вашего компьютера появится еще один диск, работа с которым ничем не отличается от ваших собственных дисков. Имеется возможность подключения множества сетевых дисков, каждый из которых будет связан с одной из папок на каком-то компьютере, подключенном к сети. Если скорость передачи информации по вашей сети достаточно высокая, то вы не заметите разницы в работе с локальными и сетевыми папками.

Откройте папку Мой компьютер (My Computer) из главного меню Windows. Будет открыт список дисков вашего компьютера. Выберите команду меню Сервис * Подключить сетевой диск (Tools * Map Network Drive). Появится диалог мастера подключения сетевого диска.

Прежде всего, следует выбрать букву создаваемого сетевого диска. Это можно сделать в открывающемся списке Диск (Drive). Обратите внимание, что выбор возможен из тех букв, которые не используются для обозначения дисков вашего компьютера. Напоминаем, что дискам присваиваются буквы от А до Z.

После выбора буквы для диска следует выбрать диск иди папку на удаленном компьютере, которая будет представлена на вашем компьютере в виде диска. Вы можете ввести адрес и имя папки в поле ввода, однако удобнее воспользоваться кнопкой для обзора папок в сети. Нажмите кнопку Обзор (Browse), чтобы открыть диалог обзора и отобразить список компьютеров, подключенных к сети. В данном окне отображаются в виде значков сети, которые видны с вашего компьютера. Чтобы посмотреть, какие компьютеры входят в сеть, дважды щелкните на значке, изображающем сеть. Каждый компьютер представлен в виде значка. Один из этих значков всегда обозначает ваш компьютер. Можно увидеть, какие

ресурсы предоставляет в сеть каждый компьютер. Для этого дважды щелкните на каком-либо значке, чтобы выбрать компьютер для просмотра. В окне будут отображены совместно используемые ресурсы.

Выберите в списке компьютер и диск, на котором будет размещена совместно используемая папка. Это может быть и диск на вашем компьютере. Вы можете выбрать уже существующую папку, а можете создать новую, нажав соответствующую кнопку диалога. После выбора папки нажмите кнопку ОК, чтобы закрыть диалог обзора и вернуться к диалогу назначения сетевого диска. Поле ввода Папка (Folder) будет заполнено.

Если вы хотите, чтобы сетевая папка подключалась в качестве дополнительного диска автоматически при вашем входе в систему Windows, установите флажок Подключить при входе в систему (Reconnect at logon). После настройки всех нужных параметров нажмите кнопку Готово (Finish), чтобы закрыть диалог мастера. Будет предпринята попытка подключения указанной вами папки.

Если соединение успешно установлено, диалог мастера будет закрыт и в папке Мой компьютер (My Computer) появится новый значок, обозначающий назначенный сетевой диск. Теперь вы можете работать с сетевой папкой, как с обычным диском. Дважды щелкните на этом значке, чтобы открыть его содержимое. Если соединение установить не удалось, то появится соответствующий диалог с предупреждением, диалог мастера не будет закрыт, предлагая вам указать новое имя и путь к сетевой папке. Содержимое сетевого диска отображается точно так же, как и содержимое диска вашего компьютера.

Сетевой диск содержит папки и файлы, представленные в виде значков. В зависимости от того, какие права вам предоставлены администратором по работе с сетевым диском, вы можете копировать файлы на свой компьютер, запускать программы с сетевого диска, создавать и удалять файлы и папки. Настроив один раз сетевой принтер, сетевые диски и папки, вы можете в любое время ими пользоваться. Правда, для этого необходимо, чтобы был включен компьютер, на котором реально находится это оборудование. Если у вас три-четыре или более компьютеров, то желательно один из них выделить для хранения общей информации. К нему же можно подключить общий принтер. Этот компьютер должен быть всегда включенным, и на нем не должен никто работать, чтобы не мешать совместному использованию его ресурсов. Такой компьютер называется сервером, и его настройками должен заниматься специалист.


11.1.4. Совместное использование доступа в Интернет

В Windows XP имеется возможность использовать доступ в сеть Интернет нескольким компьютерам, входящим в состав локальной сети. Чтобы использовать эту возможность, необходимо выполнить некоторые настройки системы. Прежде всего, необходимо определить компьютер, к которому подключен модем и который будет соединяться с Интернетом непосредственно. Далее необходимо настроить модем и соединение с Интернетом на этом компьютере. Как это сделать, вы можете прочитать в главе, посвященной работе с Интернетом. Для настройки совместного доступа к Интернету лучше всего использовать мастер создания домашней сети, рассмотренный выше. Это позволит автоматизировать настройку параметров и свести к минимуму возможные ошибки.
Для выполнения мастера домашней сети и изменения в настройках компьютера, вы должны обладать правами администратора. О пользователях и их правах вы узнаете ниже.

Когда вы создаете домашнюю сеть, настройке соединения с Интернетом посвящен отдельный диалог мастера. При настройке сети на компьютере, который используется для прямого подключения к Интернету, в этом диалоге необходимо установить переключатель в положение, соответствующее прямому соединению с Интернетом. Для других компьютеров этот переключатель должен быть установлен в положение подключения к Интернету через другой компьютер. Далее следуйте инструкциям мастера, как описано в разделе создания домашней сети.

Теперь необходимо настроить доступ в Интернет на остальных компьютерах вашей сети. Запустите мастер подключения к Интернету и укажите, что вы будете вручную настраивать параметры. Далее укажите, что вы используете локальную сеть для доступа в Интернет. Теперь следуйте инструкциям мастера, как описано в разделе, посвященном работе с Интернетом этой книги. На этом настройка совместного доступа в Интернет завершена.

Чтобы другие могли использовать Интернет через общий компьютер с модемом, они должны быть включены. Если соединение с Интернетом уже установлено, все компьютеры в сети могут его использовать. Если соединение с Интернетом не установлено, а вы, работая на компьютере без модема, открыли программу, требующую доступ в Интернет, то на компьютере с модемом система автоматически запустит программу установки связи с поставщиком услуг Интернета и сама установит соединение.


11.1.5. Соединение сетей через Интернет

Система Windows XP позволяет соединять несколько компьютерных сетей, расположенных далеко друг от друга, используя в качестве линии связи сеть Интернет. Примером такого соединения может служить доступ вашего домашнего компьютера или домашней сети к сети, расположенной у вас на работе. Аналогично можно связать две сети, обслуживающие различные подразделения предприятия и расположенные в различных местах. Вы можете даже связать в единое целое локальные сети, расположенные в различных городах. После настройки соединения, в вашем сетевом окружении появится удаленная сеть, и вы можете воспользоваться всеми предоставляемыми ею ресурсами: принтерами, дисками и так далее.

При соединении двух сетей с помощью Интернета используется такое средство, как виртуальная частная сеть (Virtual Private Network или VPN). Поскольку Интернет является общедоступной сетью, виртуальная частная сеть позволяет надежно защитить данные вашей сети от постороннего вмешательства и взлома. Давайте рассмотрим, как создавать такое соединение при работе с Windows ХР.

Сначала необходимо открыть список сетевых соединений. В главном меню выберите команду открытия панели управления. В списке задач панели управления выберите элемент Сеть и соединения Интернета (Network and Internet Connections). Будет открыта группа значков, предназначенных для настройки работы в сети. Выберите элемент Сетевые соединения (Network Connections), после чего вы перейдете в папку для работы с сетевыми соединениями (Рис. 11.8).

Рис 11.8. Список соединений и мастер создания соединения

В правой части окна проводника при работе с папкой сетевых соединений расположена группа значков, обозначающих созданные сетевые соединения, а также значок создания нового соединения. Для добавления соединения дважды щелкните мышью на значке Создать новое соединение (Make New Connection). Появится первый диалог мастера создания сетевого соединения (Рис. 11.8). Нажмите кнопку Далее (Next), чтобы начать работу и отобразить следующий диалог мастера (Рис. 11.9). В этом диалоге с помощью переключателя вам предлагается указать, какой тип соединения вы создаете. Вы можете создать новое соединение с Интернетом, создать соединение с другой сетью, а также создать соединение с другим компьютером с помощью прямого соединения, например, через инфракрасный порт.

Рис 11.9. Выбор типа и способа соединения

Установите в этом диалоге переключатель в положение Соединение с сетью на моем рабочем месте (Connection to the network at my workplace) и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера (Рис. 11.9). Этот диалог предлагает выбрать способ соединения с сетью на вашем рабочем месте. Выберите положение переключателя Соединение с помощью виртуальной частной сети (Virtual Private Network connection) и нажмите кнопку Далее (Next), чтобы продолжить работу и отобразить очередной диалог мастера.

Данный диалог предназначен для ввода адреса того компьютера в удаленной сети, который имеет соединение с Интернетом, и с которым вы устанавливаете соединение. Если ваша сеть использует DNS, то есть специальное средство преобразования символьных адресов в цифровые, то в поле ввода можно указать символьное имя. В противном случае адрес должен быть цифровым. Введите адрес компьютера, с которым устанавливается соединение, и нажмите кнопку Далее (Next), чтобы продолжить работу и перейти к очередному диалогу мастера сетевого соединения.

В очередном диалоге мастера с помощью флажков вы можете указать, что данное соединение будет использоваться, как соединение с Интернетом по умолчанию. Это бывает полезным, если вы выходите в Интернет через ту сеть, с которой настраиваете соединение. Также вы можете указать имя и пароль для доступа в подключаемую сеть. После настройки параметров нажмите кнопку Далее (Next), чтобы продолжить работу мастера. Появится его заключительный диалог.

В данном диалоге вам предлагается указать имя созданного соединения. Вы можете ввести в поле любое понравившееся вам имя. Кроме того, установив флажок, вы можете добавить ярлык данного соединения на рабочий стол. Введите имя соединения и нажмите кнопку Готово (Finish), чтобы закрыть диалог и завершить работу мастера.

Чтобы установить соединение с другой сетью через Интернет, дважды щелкните на соответствующем значке в списке сетевых соединений. Если вы поместили соответствующий значок на рабочем столе, дважды щелкните на нем. Появится диалог установления соединения. Нажмите кнопку Соединиться (Connect) этого диалога, чтобы начать соединение. Если данный узел поддерживает такой тип соединения, то по окончании установки соединения диалог будет закрыт, и вы можете начинать работу с удаленной сетью.

Откройте папку Мое Сетевое окружение (My Network Places) и выберите элемент Вся сеть (Entire Network), чтобы отобразить список сетей, видимых с вашего компьютера. Поскольку виртуальная частная сеть настроена и соединение с ней установлено, в списке сетей должно появиться название удаленной сети. Если вы подключаетесь к сети, расположенной в вашем офисе, то в списке сетей должно появиться ее название. Дважды щелкните на элементе, обозначающем удаленную сеть, чтобы отобразить список работающих компьютеров и других устройств в этой сети. Далее вы можете выбрать компьютер в удаленной сети и также выбрать требуемые папки и файлы. Теперь можете начинать работу с информацией на компьютере, входящем в состав удаленной сети, как будто работаете с компьютером вашей локальной сети.

Еще раз обращаем ваше внимание, что для соединения нескольких сетей через Интернет удаленный компьютер, к которому вы подключаетесь, должен поддерживать этот вид соединения. В настоящий момент это возможно, если на компьютере установлена операционная система Windows ХР.


11.2. Работа нескольких пользователей на компьютере

Операционная система Windows ХР построена так, что позволяет работать с одним компьютером нескольким людям.

При этом каждый человек регистрируется как пользователь в системе Windows XP. Каждый пользователь имеет свой идентификатор и пароль, используемые для подтверждения личности пользователя. Кроме того, каждый пользователь имеет свои собственные настройки рабочего стола, список установленных программ и так далее.

Например, если ваш компьютер расположен дома, то вы можете каждого члена семьи зарегистрировать как уникального пользователя, и все будут работать на компьютере независимо друг от друга. Поскольку можно создавать пользователей различных категорий, то, например, детям вы можете запретить изменять настройки системы, чтобы они не испортили компьютер по неопытности.
Для создания, удаления и изменения свойств пользователей, вы должны обладать правами администратора системы.

Чтобы перейти в режим работы с пользователями, следует открыть панель управления из главного меню Windows, а затем выбрать элемент Учетные записи пользователей (User Accounts). После этого вы перейдете в папку для работы с пользователями (Рис. 11.10).

Рис 11.10. Работа с пользователями

По умолчанию после установки системы автоматически создаются два пользователя. Это администратор, который обладает всеми правами по изменению настроек системы, а также гость, который обладает минимальными правами. Для работы с пользователями предназначен список задач в соответствующей папке. Вы можете изменять характеристики пользователей, а также удалять и добавлять учетные записи пользователей. -Учетная запись хранит информацию о пользователе и содержит его имя, пароль, права доступа и другую служебную информацию. Давайте рассмотрим работу с учетными записями пользователей в Windows XP.

Если вы хотите зарегистрировать нового пользователя, например одного из членов вашей семьи, выберите задачу Создать новую учетную запись (Create a new account), чтобы запустить мастер создания учетных записей и открыть его первый диалог (Рис. 11.11).

Рис 11.11. Имя и тип учетной записи

В данном диалоге вам предлагается ввести имя новой учетной записи. Это имя будет использоваться для входа в систему, отображаться в экране приглашения, а также в верхней части меню Пуск (Start). Вы можете ввести любое имя в этом диалоге, но лучше посоветоваться с тем человеком, который будет работать с Windows XP под этим именем. После ввода имени нажмите кнопку Далее (Next), чтобы продолжить создание новой учетной записи.

Появится следующий диалог мастера, в котором определяется тип новой учетной записи (Рис. 11.11). В системе поддерживается несколько типов учетных записей: администратор, обычный пользователь и ограниченный пользователь. Администратор обладает всеми правами и может регистрировать других пользователей, устанавливать на компьютер новые программы, менять настройку системы. Обычный пользователь может устанавливать программы и запускать их, однако не может менять настройки системы и создавать учетные записи для других пользователей. Ограниченный пользователь может лишь запускать установленные на компьютере программы.

Выбор типа учетной записи осуществляется с помощью переключателя. При выборе положения переключателя ниже отображается краткий перечень возможностей данного типа пользователей. Более подробно о типах пользователей и их возможностях, вы можете узнать, если выберете ссылку Узнать про (Learn more), расположенную в левой части диалога выбора типа учетной записи. Установите переключатель в нужное положение и нажмите кнопку Создать учетную запись (Create Account).

Появится следующий диалог мастера (Рис. 11.12). По умолчанию записи создаются без пароля, и вы можете ничего не вводить в этом диалоге, а просто нажать кнопку Отмена (Cancel), чтобы закрыть диалог. Но для безопасности хранения информации навашем компьютере рекомендуется устанавливать пароли для всех пользователей.

Рис 11.12. Ввод пароля и параметров входа и выхода

Вам предлагается ввести новый пароль для пользователя, а также повторно его ввести для проверки. Обратите внимание, что регистр символов при вводе пароля является важным, и пароли сергей и Сергей являются разными. Если вы забыли свой пароль, работать с Windows ХР вы не сможете. Пароль любого пользователя сможет изменить администратор, однако, если администратор забыл пароль, то работать в системе станет практически невозможно.

Чтобы облегчить вам процедуру входа в систему, если вы забыли пароль, используется принятая во многих областях система подсказки пароля. Суть состоит в том, что при изменении пароля, вы, кроме нового пароля, вводите ключевое слово или фразу, называемую подсказкой. Обычно в качестве такой фразы используют хорошо запоминающиеся слова, например, девичью фамилию матери. Если вы забудете пароль, то с помощью данной подсказки, система поможет вам его вспомнить. После ввода пароля и подсказки, нажмите кнопку Создать пароль (Create Password), чтобы изменения вступили в силу. При следующей загрузке системы вы должны будете ввести уже новый пароль.

После создания пароля появится следующий диалог мастера, предлагающий выбрать режим подключения и отключения пользователей (Рис. 11.12). Система Windows ХР допускает два режима подключения пользователей. Если сбросить верхний флажок данного диалога, то при запуске системы или при завершении работы пользователя будет появляться диалог, предлагающий ввести имя пользователя и пароль. Такой вход в Windows называется классическим.

Если установить верхний флажок, то при запуске системы или после завершения работы пользователя будет появляться экран приглашения, содержащий список пользователей. Вам предлагается выбрать из списка нужного пользователя. Если при этом требуется пароль, то появится поле ввода для его задания.

Второй флажок отвечает за использование средства Windows ХР, которое называется быстрым переключением между пользователями. При классической смене пользователя первый пользователь должен завершить свою работу, а второй пользователь в ответ на приглашение системы должен ввести имя и пароль, после чего он может приступать к работе. Идея быстрого переключения состоит в том, что первый пользователь, не завершая своей работы, может войти в систему, используя другую учетную запись. Мало того, что первый пользователь при этом не завершил работы, но и все запущенные им программы продолжают работать.

Итак, если нижний флажок в диалоге настройки сброшен, то пользователь не может использовать быстрое переключение на другую учетную запись. Чтобы данный пользователь имел возможность быстрого переключения, следует установить нижний флажок в диалоге настройки. После выбора способа подключения и переключения пользователей нажмите кнопку ОК, чтобы закрыть диалог. Новая учетная запись создана, и вы вернетесь в окно панели управления для работы с пользователями.

Вы можете войти в качестве любого пользователя при запуске Windows, а можете переключиться во время работы системы. Особенно удобным может оказаться быстрое переключение. Для быстрого переключения откройте главное меню Windows и нажмите кнопку , расположенную в нижней части меню. Появится диалог выбора варианта завершения сеанса работы (Рис. 11.13).

Рис 11.13. Завершение сеанса работы Windows

Нажмите кнопку чтобы открыть список пользователей. Выберите нужного пользователя и при необходимости введите пароль. Так вы войдете в систему с новой учетной записью. В любой момент вы можете переключиться обратно, выполнив аналогичные действия. Использование быстрого переключения бывает полезным, например, когда вам нужно внести изменения в настройки системы. При этом вы быстро переключаетесь на пользователя, обладающего правами администратора системы, производите изменения настроек Windows, а затем возвращаетесь к своей работе.

Если же вы хотите уступить место за компьютером другому пользователю, то в диалоге завершения сеанса следует нажать кнопку . Дальнейшие действия не отличаются от действий при быстром переключении, однако ваша работа с Windows будет завершена, все программы завершены, и память системы освобождена. После этого отступления вернемся к описанию процедуры регистрации нового пользователя.

Иногда бывает нужно изменить учетную информацию. Выберите задачу Изменить учетную запись (Change an account) в папке работы с учетными записями, чтобы открыть новое окно для выбора пользователя. Щелкните мышью на значке, обозначающем нужного пользователя, чтобы перейти к настройке параметров пользователя (Рис. 11.14).

Рис 11.14. Настройка параметров пользователя

Давайте рассмотрим возможности настройки параметров пользователя более подробно. Выберите задачу Изменить изображение (Change Picture), чтобы перейти к изменению рисунка (Рис. 11.14). Каждому; пользователю соответствует свое изображение, которое отображается в окне начальной загрузки системы Windows. Вы можете выбрать одно из изображений, предлагаемых вам в списке, щелкнув на нем мышью. Кроме предлагаемых изображений, вы можете использовать любое изображение, например, вашу фотографию. Для выбора произвольного изображения следует нажать кнопку Обзор изображений (Browse Pictures) и в появившемся диалоге выбрать папку и файл с изображением. После выбора, изображение появится в основном списке, и вы можете выбрать его. После выбора изображения нажмите кнопку Изменить изображение (Change picture), чтобы изменения вступили в силу.

Чтобы вернуться к списку задач, нажмите кнопку Назад (Back). В списке задач выберите задачу Изменить пароль (Change password). Изменение пароля не отличается от задания пароля, рассмотренного выше. Вам предлагается ввести измененный пароль для пользователя, а также ввести его повторно для проверки. После ввода пароля и подсказки, нажмите кнопку Изменить пароль (Change Password), чтобы изменения вступили в силу. При следующей загрузке системы вы должны будете ввести уже новый пароль.

Чтобы вернуться к списку задач, нажмите кнопку Назад (Back). В списке задач выберите задачу Отключить учетную запись (Turn off account), чтобы запретить подключение пользователя (Рис. 11.15).

Рис 11.15. Изменение пароля и отключение

Вы можете временно отключить пользователя, так, что он не сможет войти в Windows. Чтобы сделать это, нажмите кнопку Отключить запись (Turn off Account). В дальнейшем эта задача будет называться Включить учетную запись (Turn on account) и вы можете в любой момент включить отключенную учетную запись.

После настройки параметров учетной записи, нажмите кнопку В начало (Ноте), чтобы отобразить главный список задач по работе с учетными записями. Вы можете опять добавить пользователя, изменить параметры другого пользователя или изменить процедуру подключения и отключения для выбранного пользователя.


  • 12. Особенности работы с блокнотными компьютерами
    • Общие принципы работы
    • Создание портфеля
    • Использование портфеля


12. Особенности работы с блокнотными компьютерами

Использование переносных компьютеров, часто называемых ноутбуками (Notebook - блокнот), позволяет людям работать с ними в любом месте. Эти компьютеры, еще называемые блокнотными, имеют малые габариты и массу, могут работать как от электрической сети, так и от батарей. Несмотря на малые габариты, ноутбук - это полноценный компьютер, мощность которого в общем случае хоть и уступает современным настольным компьютерам, но незначительно.


12.1. Общие принципы работы

Система Windows XP имеет ряд средств для улучшения работы с переносными компьютерами. Так, применена новая технология отображения шрифтов на жидкокристаллических экранах. Эта технология получила название Clear Type (Чистое написание). При отображении символов по этой технологии горизонтальное разрешение символа динамически меняется, что приводит к более четкому изображению символов на экранах переносных компьютеров или при использовании жидкокристаллических мониторов на обычных компьютерах.

Также в Windows XP встроено много средств для снижения энергопотребления переносных компьютеров, что продлевает время непрерывной работы последних без подзарядки. Кроме обычных средств, таких, как снижение тактовой частоты, когда вы не работаете, переход в ждущий и спящий режимы, Windows ХР предлагает еще несколько способов снижения потребления электроэнергии. Когда вы закрываете крышку переносного компьютера, автоматически отключается дисплей, чтобы зря не расходовать энергию. Если переносной компьютер работает от батарей, яркость экрана автоматически снижается, чтобы уменьшить потребление энергии. После того, как вы подключаете блок питания и питание начинает идти от электрической сети, нормальная яркость экрана автоматически восстанавливается.

Удобным способом не потерять информацию из-за разряда батарей является переход компьютера, работающего под управлением Windows ХР в спящий режим при сильном разряде батарей. Подробнее о спящем режиме вы можете прочитать ниже, в разделе, посвященном управлению питанием.

Для снижения потребляемой энергии Windows ХР снижает частоту работы процессора переносного компьютера, когда определяет, что компьютер работает от батарей. При восстановлении питания от электрической сети частота работы процессора опять повышается. Естественно, процессор вашего переносного компьютера должен поддерживать изменение частоты работы.

Для удобства передачи файлов между обычными и переносными компьютерами в состав Windows включено такое средство, как Портфель (Briefcase). При частой работе с файлами вне основного компьютера (например, на переносном компьютере) можно использовать портфель для синхронизации соответствующих файлов основного и переносного компьютеров.


12.2. Создание портфеля

Чтобы создать портфель, необходимо выбрать папку, где вы хотите сделать это. Запустите проводник, перейдите в нужную папку, после чего выберите команду Файл * Создать * Портфель (File * New * Briefcase) В выбранной вами папке появится еще один значок с именем Новый портфель (New Briefcase). Вы можете переименовать его и дать портфелю любое имя. В дальнейшем мы будет считать, что это имя - портфель. Также отметим, что можно создавать новый портфель прямо на рабочем столе.

Портфель представляет собой особую папку на диске. Кроме рабочих файлов, он содержит еще ряд служебных файлов, которые вы не видите. Чтобы активировать портфель, следует дважды щелкнуть на значке, его обозначающем. Появится диалог, объясняющий принцип работы. Нажмите кнопку Готово (Finish), и теперь портфель готов к работе.


12.3. Использование портфеля

Использовать портфель можно, если компьютеры соединены по сети или с помощью прямого подключения, например, через инфракрасный порт. Если вы не можете связать компьютеры, можно использовать для передачи информации с помощью портфеля дискету. Если вы можете установить связь между компьютерами, установите эту связь и скопируйте нужные для работы файлы из основного компьютера в папку Портфель (Briefcase) на переносном компьютере (Рис. 12.1).

Рис 12.1. Диалог копирования

Теперь можно разорвать связь между компьютерами и работать на переносном компьютере с документами автономно. Никаких ограничений для такой работы нет, вы можете делать с файлами все, что вам нужно. Завершив работу с файлами, снова соедините два компьютера. Теперь, работая на основном компьютере, дважды щелкните на значке, обозначающем папку Портфель (Briefcase) переносного компьютера (Рис. 12.2).

Для обновления всех элементов портфеля удобно использовать соответствующую задачу в панели задач. Если нужно обновить только часть содержимого портфеля, выберите документы, которые необходимо сделать одинаковыми на обоих компьютерах, и нажмите кнопку на панели инструментов окна с содержимым портфеля. Начнется процедура проверки портфеля. Поскольку во время работы на переносном компьютере в документах были сделаны изменения, программа определит это. Появится диалог обновления портфеля (Рис. 12.2).

Рис 12.2. Содержимое портфеля и его обновление

Выберите в списке файлы, которые вы хотите привести в одинаковое состояние, как на переносном компьютере, так и на основном. Затем нажмите кнопку Обновить (Synchronize), чтобы начать процедуру обновления портфеля. По окончании этой процедуры файлы, хранящиеся в портфеле на переносном компьютере и на диске основного компьютера, будут одинаковыми.

Можно использовать для хранения файлов портфеля сменный носитель информации, например, дискету. В этом случае не требуется соединять компьютеры между собой для передачи документов друг другу. Процесс обмена происходит следующим образом. Вставьте дискету в дисковод основного компьютера и скопируйте нужные файлы в портфель. Теперь перетащите портфель с помощью мыши на гибкий диск. Содержимое папки портфеля будет скопировано на дискету.

Далее извлеките дискету из дисковода и вставьте ее в переносной компьютер. Можно начинать работу с файлами в папке портфеля. По окончании работы снова вставьте дискету с портфелем в основной компьютер, и, работая на основном компьютере, откройте папку портфеля. Выберите задачу Обновить все (Update All), чтобы синхронизировать файлы.


  • 13. Восстановление системы и защита важных файлов
    • Общие сведения о восстановлении
    • Создание точки восстановления
    • Восстановление системы из контрольной точки
    • Настройка системы восстановления
    • Защита системных файлов


13. Восстановление системы и защита важных файлов

Одной из полезных возможностей Windows XP является средство восстановления системы. Изменения в оборудовании компьютера, его настройках, установка новых программ или другие причины, могут привести к его неправильной работе. Используя утилиту восстановления системы, вы можете вернуть компьютеру рабочее состояние путем отмены изменений его конфигурации и восстановления потерянных файлов.


13.1. Общие сведения о восстановлении

Восстановление работоспособности операционной системы Windows XP обеспечивается за счет того, что система отслеживает все изменения, происходящие с компьютером, например, установку новой программы или удаление некоторых служебных файлов. Также происходит сохранение состояния системы через определенные интервалы времени, в моменты, называемые точками восстановления. Точки восстановления могут устанавливаться автоматически или вручную. Выбрав точку восстановления, вы вернете прошлое состояние системы. Например, если вы нечаянно удалили файлы с программами или эти файлы повредились, то можно восстановить эти файлы, если выбрать для восстановления точку/ расположенную по времени до того, как эта неприятность произошла. Отменим, что утилита восстановления системы отслеживает изменения на всех дисках вашего компьютера.
Утилита восстановления устанавливается на ваш компьютер всегда, но работает только, если на системном диске имеется более двухсот мегабайт свободного места.

Объем сохраняемой информации зависит от того, как интенсивно вы работаете, как много программ устанавливаете и удаляете. Также этот объем зависит от количества свободного места на системном диске вашего компьютера. Системным диском называется диск на который установлена операционная система Windows XP. В среднем возможности утилиты восстановления позволяют отслеживать и восстанавливать изменения произошедшие с вашим компьютером за период от одной до трех недель.

Когда Windows XP запускается первый раз она создает начальную системную контрольную точку. Если вы выберете эту точку для восстановления система будет приведена в первоначальное состояние и многие файлы созданные позднее могут быть потеряны.

Во время работы системы утилита восстановления может регулярно создавать контрольные точки даже если вы не вносили изменений в настройки системы. Обратите внимание что компьютер прекращает реагировать на все ваши действия в течение нескольких минут во время создания контрольной точки.


13.2. Создание точки восстановления

Кроме автоматического создания контрольных точек система позволяет создавать контрольные точки вручную в любое удобное для вас время.
Пример, рассмотренный ниже, приведен только для иллюстрации возможностей утилиты восстановления системы. Не рекомендуется повторять этот пример на своем компьютере, чтобы не потерять важную информацию.

В качестве примера рассмотрим процесс восстановления системы после удаления части системных файлов. Прежде всего запустим утилиту восстановления системы. Это можно сделать несколькими способами. Откройте панель управления и выберите задачу Производительность и обслуживание (Performance and Maintenance) а далее выберите задачу Восстановление системы (System Restore). Также можно запустить восстановление системы выбрав команду главного меню Другие программы * Стандартные * Служебные * Восстановление системы (Programs * Accessories * System Tools * System Restore). На экране появится рабочее окно этой программы (Рис. 13.1). Внешне программа очень похожа на один из мастеров Windows и работает с использованием последовательности диалогов.

Рис 13.1. Первый диалог и создание точки восстановления

В первом диалоге описано назначение утилиты восстановления системы и кратко изложен ее принцип действия. Кроме того вам предлагается выбрать один из вариантов работы утилиты. Вы можете создать точку восстановления восстановить компьютер в состояние когда была создана последняя точка восстановления или отменить последнее восстановление. Необходимое действие выбирается с помощью переключателя расположенного в правой части диалога. Если вы раздумали работать с утилитой можно прервать выполнение ее действий нажав кнопку Отмена (Cancel) в диалоге. Для получения справочной информации можно щелкнуть мышью на ссылке Справка (Help).

Для начала мы с помощью данной утилиты создадим точку восстановления. Установите переключатель в положение Создать точку восстановления (Create restore point) и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера (Рис. 13.1), в котором вам будет предложено ввести описание создаваемой точки восстановления.

Имеется возможность создания множества точек восстановления. При последующем восстановлении системы вы сможете выбрать, из какой точки следует восстанавливаться. Тогда вам и понадобится описание введенное в этом диалоге. Кроме вашего описания, к точке восстановления будут автоматически добавлены текущее время и дата. Все это делается, чтобы в будущем вы не спутали разные точки восстановления и не восстановили систему в неприемлемое состояние.

Щелкните мышью на поле ввода и наберите название точки: Проверка системы восстановления. Нажмите кнопку Далее (Next), чтобы продолжить создание точки восстановления. Этот процесс может занять несколько минут, в течение которых компьютер может реагировать с задержкой на нажатия клавиш и перемещение мыши. По окончании работы утилиты компьютер опять станет нормально реагировать на все ваши действия.

Появится заключительный диалог создания точки восстановления (Рис. 13.2).

Рис 13.2. Подтверждение создания точки восстановления

После того, как точка восстановления создана вы можете продолжить работу как обычно. Если вы случайно испортите важные файлы, их можно будет восстановить. Если вы больше не хотите работать с программой восстановления системы, то нажмите кнопку Закрыть (Close), чтобы закрыть диалог. Если вы хотите продолжить работу, нажмите кнопку В начало (Ноте), чтобы вернуться к начальному диалогу системы восстановления и выполнить другие задачи.

Если у вас было создано несколько точек восстановления, вы можете восстановить состояние компьютера с помощью любой из них. Однако следует быть осторожным, так как изменения, внесенные в систему после создания точки восстановления будут утеряны. Поэтому средством восстановления следует пользоваться с большой осторожностью и применять его только действительно в критических случаях.


13.3. Восстановление системы из контрольной точки

В качестве примера для описания работы системы восстановления мы удалили папку Program Files, которая содержит важную системную информацию. Без нее большинство программ, входящих в состав Windows не будут работать или будут допускать ошибки. В предыдущих версиях Windows такая операция привела бы к необходимости устанавливать операционную систему заново, причем многие настройки были бы утеряны безвозвратно.
Еще раз обращаем внимание, что вам не следует повторять этот эксперимент, чтобы не рисковать информацией на своем компьютере.

Теперь настало время проверить, как система восстановления справится с возникшей проблемой. Запустите программу восстановления еще раз. В открывшемся начальном диалоге (Рис. 13.1) установите переключатель расположенный в правой части в положение Восстановить мой компьютер в предыдущее состояние (Restore my computer to an earlier time) и нажмите кнопку Далее (Next). Появится диалог для выбора точки восстановления (Рис. 13.3). В этом диалоге вы сможете выбрать одну из точек восстановления, используя дату и описание, введенное вами при сохранении этой точки. Мы видим в диалоге календарь и список с описанием точек восстановления. На календаре будет установлена текущая дата. Все дни, в которых есть точки восстановления, будут отмечены на календаре жирным шрифтом. В списке, расположенном правее календаря отображаются описания точек восстановления, соответствующие выбранному дню.

Рис 13.3. Выбор точки и подтверждение выбора

Как видно из рисунка, в списке присутствует созданная нами точка восстановления с именем Проверка системы восстановления. Восстановим состояние системы с ее помощью. Щелкните мышью на этом описании и нажмите кнопку Далее (Next), чтобы продолжить восстановление. Если восстановление затрагивает конфигурацию системы, то появится диалог с предупреждением. Нажмите кнопку ОК, чтобы закрыть этот диалог, если он появился. Теперь появится диалог для подтверждения выбора точки восстановления (Рис. 13.3).

Вам предстоит решить, действительно ли вы хотите восстановить состояние системы. Пока еще можно отказаться нажав кнопку Отмена (Cancel) в диалоге. Если вы хотите провести восстановление с другой точки, вам следует нажать кнопку Назад (Back) и заново повторить предыдущую операцию. Не забудьте о предупреждении, что во время процесса восстановления нельзя создавать файлы и запускать программы. Это может привести к непредсказуемым последствиям. Если у вас запущено несколько программ, закройте их все, кроме утилиты восстановления системы. Во время восстановления нельзя будет выполнять никакие работы на компьютере. Если вы твердо решили провести восстановление, нажмите кнопку Далее (Next) этого диалога чтобы начать процесс восстановления информации. Появится диалог с прогресс-индикатором, иллюстрирующим процесс восстановления (Рис. 13.4).

Рис 13.4. Восстановление и заключительный диалог

В зависимости от объема восстанавливаемой информации, работа по восстановлению может занять довольно большое время. После того, как восстановление будет завершено, компьютер автоматически перезагрузится. По окончании загрузки Windows XP на экране появится заключительный диалог мастера восстановления системы (Рис. 13.4), в котором говорится что восстановление вашей системы успешно завершено.

Система восстановлена по состоянию когда была создана выбранная вами точка восстановления. Отметим что если восстановление не решило ваши проблемы, то следует отменить его или попробовать восстановиться с другой точки. Нажмите кнопку ОК, чтобы закрыть этот диалог. Теперь можно продолжить обычную работу за компьютером.

После того, как мы рассмотрели работу системы восстановления, отметим, что для сохранения вашей текущей работы мастер восстановления не трогает файлы в папке Мои документы (My Documents), а также файлы с расширениями doc, в которых хранятся документы популярного текстового редактора Word. В этом же формате может хранить документы редактор WordPad, описанный в нашей книге. Не восстанавливаются также файлы некоторых других популярных форматов. Такое действие системы восстановления объясняется очень просто: если восстанавливать эти файлы, то может оказаться, что будут восстановлены старые версии документов, а текущая работа будет потеряна.

Система восстановления предназначена, в первую очередь, для восстановления работоспособности Windows XP и установленных приложений. Для сохранности разрабатываемых вами документов следует периодически сохранять их на сменных носителях информации, таких как дискеты, сменные диски, стримеры или перезаписываемые компакт-диски.

Научившись создавать точки восстановления и восстанавливать из них систему, кратко рассмотрим некоторые особенности настройки системы восстановления в Windows XP. Если на вашем компьютере установлен жесткий диск большого объема и вы не испытываете проблем со свободным местом, мы не рекомендуем вам отключать систему. В противном случае вам понадобятся сведения, изложенные в следующем разделе.


13.4. Настройка системы восстановления

Не всегда на диске бывает достаточно много места. Освободить место на жестком диске вашего компьютера можно, если отключить систему восстановления. Давайте рассмотрим, как это сделать. Запустите программу восстановления системы и выберите в первом диалоге (Рис. 13.1) ссылку Параметры восстановления системы (System Restore Settings), Появится диалог настройки системы открытый на вкладке настройки восстановления системы (Рис. 13.5). За работу системы восстановления отвечает соответствующий флажок. Если этот флажок установлен то система восстановления отключается, если он сброшен, то система будет включена. Ниже флажка расположен список дисков вашего компьютера, которые контролируются системой восстановления. Для настройки восстановления системы на конкретном диске, следует выбрать диск в списке, а затем нажать кнопку Установки (Settings). На экране компьютера появится диалог настройки (Рис. 13.5).

Рис 13.5. Параметры системы, и установки диска

По умолчанию, система восстановления занимает под свои нужды двенадцать процентов объема жесткого диска. С помощью соответствующего ползунка в этом диалоге можно настроить объем диска, который будет использовать система восстановления. Перетащите с помощью мыши ползунок влево для уменьшения объема, и вправо - для увеличения. Напоминаем, что минимальный объем, необходимый для работы системы восстановления равен двести мегабайт. Однако лучше использовать больший объем. После настройки размера места на жестком диске, который будет использовать система восстановления, закройте диалог настройки нажав кнопку ОК. Теперь вы можете выбрать другой диск для настройки восстановления системы или закрыть диалог параметров системы также нажав кнопку ОК.


13.5. Защита системных файлов

Другой системой, обеспечивающей надежность работы операционной системы Windows XP, является Защита системных файлов (System File Protection). Эта система гарантирует, что при установке новых программ, важные системные файлы, критичные для функционирования Windows ХР не будут заменены более старыми версиями или версиями, не одобренными фирмой Microsoft.

Это означает что даже прикладные программы, разработанные Microsoft не смогут заменять защищенные файлы старыми версиями. Это также означает что программа сторонних производителей может заменить системные файлы но только если новый файл отправлен с каталогом подписанным Microsoft как более новый файл. Данное усовершенствование существенно повышает надежность системы при установке новых версий программ.


  • 14. Прочие полезные возможности
    • Работа в режиме совместимости
    • Режим удаленного доступа
    • Особенности работы с не отвечающими системе приложениями
    • Использование диспетчера задач


14. Прочие полезные возможности

Кроме широкого набора средств для работы с удаленными компьютерами по сети, Windows XP позволяет работать в качестве удаленного терминала, например, вы можете работать с компьютером, расположенным у вас на работе, находясь у себя дома. Более гибкая система управления работающими программами позволяет легко запускать и останавливать работу программ. Кроме того, наличие режима совместимости позволяет вам не беспокоиться, что программы, с которыми вы успешно работали в предыдущих версиях, не будут работать в Windows XP.


14.1. Работа в режиме совместимости

К сожалению, не все программы одинаково хорошо работают в операционных системах Windows различных версий. В Windows ХР предусмотрены специальные меры для того, чтобы программы, написанные для операционных систем Windows 95, 98, 2000 и Windows Me, могли работать в Windows XP. В частности решается проблема неправильного определения некоторыми программами версии операционной системы, а также проблемы немного отличающегося механизма распределения памяти для разных версий Windows.

Для запуска программы, которая написана для предыдущей версии операционной системы, следует воспользоваться значком Запуск в режиме совместимости (Run in Compatibility Mode). Этот значок расположен на рабочем столе, и если дважды щелкнуть на этом значке, то появится первый диалог мастера запуска программ, встроенного в справочную систему Windows. Нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера .

В этом диалоге вам предлагается с помощью переключателя выбрать тип операционной системы, которую требует запускаемая программа. В нижней части диалога в поле ввода следует ввести путь и название программы. Для выбора можно воспользоваться кнопкой Обзор (Browse). После выбора операционной системы и программы нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера, предназначенный для запуска программы . Нажмите кнопку Выполнить программу (Run application), чтобы запустить выбранную ранее программу. На экране появится рабочее окно этой программы. Если все нормально работает, то переключитесь в окно мастера и нажмите кнопку Далее (Next).

Появится заключительный диалог мастера , предлагающий обновить ярлык для запуска программы. Если вы хотите всегда запускать эту программу в режиме совместимости, установите переключатель в верхнее положение. В противном случае, выберите другое положение переключателя. Нажмите кнопку Готово (Finish), чтобы завершить работу мастера.

В заключение отметим, что Windows XP имеет встроенный список проблем совместимости и пути их автоматического решения. Эта база будет пополняться, когда вы выполняете обновление Windows через Интернет.


14.2. Режим удаленного доступа

Операционная система Windows XP позволяет пользователям работать с компьютером, находясь на большом расстоянии от него. Этот механизм называется удаленный доступ. Суть удаленного доступа состоит в том, что вы подключаетесь к -компьютеру по сети, например, по Интернету, и у вас на экране появляется содержимое экрана удаленного компьютера. В отличие от обычного сетевого соединения, вы можете не только работать с дисками и файлами этого компьютера, но и выполнять задачи по его настройке, запускать на нем программы и завершать их работу. Также вы можете добавлять и удалять пользователей, менять пароли и так далее.

Чтобы иметь такую возможность, следует выполнить соответствующую настройку как удаленного компьютера, так и настройку того компьютера, который будет использоваться для доступа к удаленному компьютеру. Давайте рассмотрим, как это можно сделать, если на компьютер, к которому предполагается осуществлять удаленный доступ, установлена операционная система Windows XP.

Для удаленного доступа к компьютеру предусмотрена особая группа пользователей, которая называется Пользователи удаленного доступа (Remote Desktop Users). Чтобы разрешить удаленный доступ любому конкретному пользователю, необходимо добавить его в эту группу. Откройте панель управления, выбрав одноименную команду из главного меню Windows. Перейдите в классический режим отображения, выбрав соответствующую ссылку в панели задач. Дважды щелкните на значке Система (System), и в появившемся диалоге выберите вкладку Удаленный доступ (Remote), чтобы настроить особенности реализации удаленного доступа на данном компьютере (Рис. 14.2).

Рис 14.2. Настройка удаленного доступа

Чтобы включить использование удаленного доступа, установите флажок Разрешить удаленный доступ к этому компьютеру (Allow users connect remotely to this computer). После этого нажмите кнопку Выбрать удаленных пользователей (Select remote users) и будет открыт диалог выбора пользователей для удаленного доступа (Рис. 14.2). В данном диалоге отображаются все пользователи, имеющие право удаленного доступа к этому компьютеру. Обратите внимание, что пользователи, входящие в группу администраторов, автоматически получают право удаленного доступа, даже если их нет в этом списке. С помощью кнопок, расположенных ниже списка, вы можете добавлять или удалять пользователей. Чтобы удалить пользователя, его необходимо выбрать в списке и нажать кнопку Удалить (Remove). Чтобы добавить пользователя в список, нажмите кнопку Добавить (Add). Появится диалог со списком всех пользователей. Выберите пользователя в этом списке и нажмите кнопку ОК, чтобы закрыть диалог. Новый пользователь появится в списке удаленного доступа. После выбора пользователей для удаленного доступа, нажмите кнопку OK, что закрыть диалог настройки. Теперь нажмите кнопку ОК, чтобы закрыть диалог изменения свойств системы.

Вторым шагом при настройке удаленного доступа является настройка соединения на компьютере, с которого будет осуществлен удаленный доступ. Чтобы сделать это, выберите команду меню Другие программы * Стандартные * Связь* Соединение удаленного доступа (More Programs * Accessories * Communications * Remote Desktop Connection). Будет запущен мастер для создания соединения, и появится его первый диалог. Нажмите кнопку Далее (Next) чтобы продолжить работу мастера, по окончании которой в списке сетевых соединений появится значок соединения удаленного доступа.

Чтобы установить соединение, дважды щелкните на этом значке. Начнется процесс соединения, по окончании которого будет открыто окно, изображающее рабочий стол удаленного компьютера. В этом окне вы можете выполнять различные действия, точно так же, как если бы это был экран вашего компьютера.


14.3. Особенности работы с не отвечающими системе приложениями

Если во время работы какая-то программа перестает реагировать на нажатие клавиш или при перемещении мыши по столу ее указатель не перемещается по экрану, значит, программа перестала реагировать на запросы системы или, как говорят, “зависла”. Для работы с программами в состав Windows ХР входит программа Диспетчер задач (Task Manager). Проще всего запустить эту служебную программу, нажав одновременно на клавиатуре клавиши. В случае, если зависание системы не критическое, то появится рабочее окно диспетчера задач. Его появление говорит о том, что зависла не вся система, а какая-либо из программ, работающих под ее управлением. В некоторых случаях диспетчер появляется с задержкой, так как зависшая программа активно использует мощности вашего компьютера. Следует отметить, что зависание операционной системы Windows ХР, при котором невозможно запустить диспетчер задач, вещь достаточно редкая. Система работает надежно, и даже использование программ с ошибками не приводит к ее поломке.

Причин зависания программы может быть очень много. Например, программе не хватает памяти, или осталось мало места на диске, а программе оно понадобилось. Возможен также конфликт оборудования вашего компьютера. Если раньше все работало нормально, а теперь программа зависает, постарайтесь вспомнить, что вы делали с компьютером в последнее время. Возможно, вы добавляли или удаляли оборудование, устанавливали или удаляли программы. Это поможет вам установить причину зависания. Наконец, возможно в системе появился вирус, который разрушает вашу информацию.

Прежде, чем искать причину зависания, необходимо завершить работу зависшей программы. Для этого используется программа Диспетчер задач (Task manager), в рабочем окне которой имеется несколько вкладок, содержащих списки выполняющихся задач, процессов, индикатор загрузки системы и некоторую другую информацию (Рис. 14.3).

Рис 14.3. Окно диспетчера задач

На первой вкладке расположен список запущенных программ. Каждый элемент списка обозначает отдельную программу. Кроме названия программы отображается ее состояние. Наличие в этом списке слова Не отвечает (No response) говорит о том, что, скорее всего данная программа зависла. Хотя справедливости ради следует отметить, что программа может зависнуть и без появления этой надписи. Если в списке есть зависшие задачи, чтобы их завершить, необходимо выбрать задачу, выделив соответствующий элемент списка. Затем необходимо щелкнуть на выделенном элементе правой кнопкой мыши. Появится вспомогательное меню, в котором следует выбрать команду завершения задачи. Задача будет завершена и ее имя исчезнет из списка задач. Также можно воспользоваться кнопкой Снять задачу (End Task) в окне диспетчера задач. Появится диалог, требующий подтверждения необходимости завершения программы.

Если вы уверены, что данная программа зависла окончательно и вам не удастся восстановить ее работу, нажмите кнопку Завершить сейчас (End Now). Диалог будет закрыт, а работа не отвечающей программы будет принудительно завершена. В заключение отметим, что принудительно завершать работу программы с помощью диспетчера задач нужно лишь в крайнем случае, так как все рабочие данные программы будут утеряны. Чтобы уменьшить риск потери данных, в систему Windows XP встроен ряд дополнительных средств, позволяющих выполнять некоторые действия с приложениями, которые не отвечают на вызовы системы или, говоря другими словами, зависли. Если программа не отвечает на системные запросы, у вас есть возможность работы с окном этой программы. Вы можете менять размер окна, перемещать его по рабочему столу, минимизировать и опять раскрывать окно на экране. Все эти действия, конечно, не помогут зависшей программе снова начать работать, однако они помогут вам работать с другими программами.


14.4. Использование диспетчера задач

Кроме работы с приложениями, программа Диспетчер задач (Task Manager) выполняет еще ряд функций по наблюдению за состоянием системы. Давайте рассмотрим эти функции. Щелкните мышью на ярлычке Процессы (Processes), чтобы перейти на новую вкладку.

Рис 14.4. Наблюдение за процессами и загрузкой системы

На данной вкладке в виде списка представлены все выполняющиеся в системе процессы. Процессом называется часть приложения, выполняющая определенные функции. То есть приложение может состоять из нескольких процессов, а может состоять только из одного процесса. В списке указывается имя процесса, сколько процессорного времени и сколько оперативной памяти использует процесс. Щелкнув правой кнопкой мыши на каком-либо процессе, вы откроете вспомогательное меню. В этом меню вы можете выполнять различные действия над процессом, например, менять приоритет выполнения процесса.

В современных компьютерах одновременно выполняется много приложений и еще больше процессов. Одновременность эта кажущаяся, так как процессор в компьютере обычно один, а процессов много. Так как через определенные малые промежутки времени процессор переключается от одного процесса к другому, кажется, что программы работают о дновр еменно.

Приоритет представляет собой общий показатель того, как часто это процесс будет получать в свое распоряжение ресурсы компьютера, и, следовательно, как быстро будет работать. Подняв приоритет процессу, вы можете ускорить его работу, а опустив приоритет - наоборот, замедлить его работу. С помощью кнопки Завершить (End Process) вы можете завершить работу выбранного процесса, однако мы не рекомендуем это делать, так как вы можете случайно завершить процесс, жизненно необходимый для нормального функционирования Windows XP. Кроме того, установив флажок в нижней части диалога, вы можете наблюдать состояние не только своих процессов, но и процессов других пользователей, если они работают в системе.

Щелкните мышью на ярлычке Производительность (Performance), чтобы перейти на другую вкладку (Рис. 14.4). На данной вкладке нет элементов управления и она является информационной. С помощью измерителей в левой части диалога вы можете наблюдать за использованием времени процессора и оперативной памяти. В правой части диалога, в виде графика, рисуется журнал использования измеряемых параметров за прошедшее время. В нижней части этой вкладки отображается статистическая информация: количество процессов, количество памяти, используемое системой и приложениями и так далее.

Щелкните мышью на ярлычке Сеть (Network), чтобы перейти на еще одну вкладку диспетчера задач. Это также информационная вкладка, показывающая использование сетевых возможностей компьютера. В виде графика рисуется история загрузки сети, а в нижней части вкладки отображается количество переданных и принятых по сети байт информации. Щелкните мышью на ярлычке Пользователи (Users), чтобы перейти на последнюю вкладку программы. На данной вкладке в виде списка отображаются все пользователи, в настоящий момент работающие в системе Windows XP.

Если вы обладаете правами администратора, то вы можете принудительно отключить выбранного пользователя, нормально завершить работу выбранного пользователя, а также послать выбранному пользователю сообщение, которое появится у него на экране. Все эти действия выполняются с помощью кнопок, расположенных в нижней части вкладки Пользователи (Users).

Следует отметить, что программа Диспетчер задач (Task Manager) может оказаться чрезвычайно полезной в самых разных случаях. Вы можете с ее помощью управлять работой программ на вашем компьютере, подключением и отключением пользователей, работой в сети. Кроме того, вы сможете получить множество полезной информации, например, узнать, какие программы требуют больше ресурсов при работе, а какие меньше.

Операционная система Windows XP является достаточно сложным продуктом, и для ее полного описания потребовалось бы более объемная книга, чем та, которую вы читаете. В нашей книге не описаны многие важные моменты, касающиеся, прежде всего, настройки системы и работы в сложных компьютерных сетях. Предлагаемая вашему вниманию книга предназначена в первую очередь для знакомства с новой операционной системой широкого круга пользователей, а не для обучения узкого круга специалистов. Однако информация, представленная в данной части книги, может быть достаточно полезна и для специалистов. Если же вы хотите более подробно изучить некоторые вопросы, мы можем посоветовать изучить интересующий вас вопрос в справочной системе. Оставшаяся часть книги посвящена установке операционной системы Windows XP, добавлению программ и оборудования, а также некоторым настройкам функционирования системы. Многие люди могут годами работать с Windows и не пользоваться данными средствами системы, однако в случае возникновении проблем предлагаемые вашему вниманию сведения могут оказаться достаточно полезными.


  • IV. Установка и настройка системы
    • У становка системы и ее компонентов
      • Установка Windows XP на новый компьютер
      • Установка Windows XP на компьютер вместо предыдущей версии Windows
      • Установка и удаление компонентов Windows
      • Установка и удаление программ


IV. Установка и настройка системы

Если Windows XP уже установлена на компьютере, информация данной части книги вам может и не понадобится. Однако для повышения удобства и эффективности работы с системой желательно изменить настройки, принятые по умолчанию. Поэтому о настройке мы рекомендуем вам прочитать обязательно.


15. Установка системы и ее компонентов

Если вы приобрели новый компьютер или работаете за чужим компьютером, то, скорее всего, операционная система Windows XP на нем уже установлена. Если же вы приобрели компьютер без операционной системы, или хотите установить Windows XP вместо старой операционной системы, то вам потребуется самостоятельно установить систему на компьютер. Сделать это достаточно просто, так как Windows XP большинство необходимых действий выполнит самостоятельно, без вашего участия.

Если же система у вас установлена, то в какой-то момент может возникнуть потребность в установке и удалении дополнительных компонент а также других программ, не входящих в состав операционной системы.


15.1. Установка Windows XP на новый компьютер

Система Windows может устанавливаться как на новые компьютеры, так и заменять собой предыдущие версии Windows на старых компьютерах. Давайте рассмотрим процесс установки системы на новый, только, что приобретенный или собранный вами самостоятельно компьютер.

Операционная система Windows XP поставляется на загружаемом компакт-диске, следовательно, необходимо вставить этот диск в соответствующее устройство вашего компьютера и перезагрузить компьютер, установив возможность

загрузки с компакт-диска. После перезагрузки будет запущена программа установки, которая попросит вас указать, где расположен дистрибутивный диск Windows. В поле ввода уже указан путь к диску и вам остается только проверить, правильный ли это путь. Если все правильно, нажмите клавишу на клавиатуре, чтобы продолжить установку. Появится лицензионное соглашение, которое вы должны прочитать и нажать клавишу на клавиатуре, в знак того, что вы принимаете соглашение.
Для установки Windows необходимо предварительно подготовить жесткий диск вашего компьютера. Диск должен содержать, хотя бы один отформатированный раздел, с размером свободного места не менее 1 Гбайт.

Программа установки начнет копировать информацию с компакт-диска на жесткий диск вашего компьютера. После того как копирование завершено, программа установки отобразит список доступных разделов жесткого диска и попросит вас указать, в какой раздел следует установить операционную систему Windows XP. Выберите раздел для установки и нажмите клавишу продолжения на клавиатуре. Какая это клавиша, зависит от вашего выбора, поэтому внимательно читайте на экране о предлагаемых вариантах действий. Далее программа продолжит копировать файлы на диск вашего компьютера. По окончании копирования компьютер будет автоматически перезагружен и начнется второй этап установки начинающийся с ввода серийного номера вашей копии Windows XP. Дальнейшие действия не отличаются от аналогичной работы при установке Windows XP поверх старой операционной системы, описанной ниже.


15.2. Установка Windows XP на компьютер вместо предыдущей версии Windows

Если вы устанавливаете Windows XP поверх существующей версии Windows, то первый этап установки будет пропущен.

Когда вы вставите установочный компакт-диск в дисковод, будет запущена программа установки, и на экране появится ее приветствие (Рис. 15.1).

Рис 15.1. Начальный диалог программы установки

В данном диалоге вы можете выбрать действия, которые вы хотите предпринять. Вы можете установить Windows XP просмотреть содержимое диска, а также выполнить некоторые дополнительные действия. К дополнительным действиям, в частности, относится запуск мастера переноса файлов и настроек на другой компьютер без установки Windows XP. Подробно о назначении и работе этого мастера вы узнаете ниже.

Выберите ссылку Установить Microsoft Windows (Install Microsoft Windows) чтобы начать установку Windows XP. Откроется основное окно программы установки и начнется сбор информации о вашем компьютере. После того как информация будет собрана и завершится анализ конфигурации вашего компьютера, появится диалог для выбора варианта установки Windows (Рис. 15.2). Вы можете выбрать новую установку или обновление старой версии Windows. Если вы выберете новую установку то вам в дальнейшем придется указать на какой диск вы хотите устанавливать Windows XP, выбрать язык системы, а также указать хотите ли вы преобразовать раздел, на который устанавливается Windows, в файловую систему NTFS.

Рис 15.2. Выбор варианта установки

После выбора способа установки нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера установки предлагающий ознакомиться с лицензионным соглашением. Ознакомьтесь с лицензионным соглашением корпорации Microsoft. При необходимости используйте вертикальную полосу прокрутки, чтобы прочитать весь текст. После знакомства с соглашением установите переключатель в положение Я принимаю (I Accept) и нажмите кнопку Далее (Next), чтобы продолжить установку. Появится диалог для указания серийного номера вашей копии Windows XP (Рис. 15.3). Каждый продукт компании Microsoft имеет серийный номер. Как правило, он находится на задней стороне обложки компакт-диска Windows или на подтверждающем сертификате, который прилагается к каждой копии Windows. Введите этот номер в поле ввода и нажмите кнопку Далее (Next), чтобы продолжить установку. Появится диалог для указания дополнительных параметров установки (Рис. 15.3). Вам следует указать язык системы выбрать папку, в которой система будет располагаться, и параметры копирования. Также можно настроить использование специальных возможностей, которые могут помочь некоторым людям с ограниченной трудоспособностью.

Рис 15.3. Серийный номер

Нажмите кнопку Параметры языка (Language options), чтобы открыть диалог для выбора языков, используемых системой. В открывающемся списке выберите основной язык системы, а в списке, расположенном ниже, можно выбрать дополнительные языки. После выбора языка нажмите кнопку ОК, чтобы закрыть диалог.

Нажмите кнопку Дополнительные параметры (Advanced Options), чтобы открыть диалог настройки. В этом диалоге имеются два поля ввода. Первое поле ввода указывает путь и имя папки с установочными файлами, второе поле определяет папку, куда будет устанавливаться система. Обычно система Windows располагается в одноименной папке, но может так случиться, что вы захотите изменить это имя. Вы можете это сделать, однако лучше не менять предлагаемые варианты папок. Нажмите кнопку ОК, чтобы закрыть диалог. Специальные возможности при установке обычно не используются, поэтому мы не будем на них останавливаться. Нажмите кнопку Далее (Next), чтобы продолжить установку и отобразить основной диалог, иллюстрирующий ход установки (Рис. 15.4).

Операционная система Windows должна быть персонифицирована, поэтому в ходе установки появится диалог, предназначенный для ввода информации о вас. Поле Имя (Name) должно быть заполнено обязательно, а поле Организация (Company) можно не заполнять. После ввода информации о себе нажмите кнопку Далее (Next), чтобы продолжить установку.

Рис 15.4. Ход установки

Далее во время установки появится диалог для выбора страны, где вы проживаете. От того, какую страну вы выберете, зависит настройка системы Windows. К таким настройкам относятся изображение значка национальной валюты, форма записи даты, и времени и многое другое. Кроме того, многие программы, работающие под управлением Windows, определяют в какой стране вы живете, и в соответствии с этим настраивают свою работу. Выберите в списке страну Россия и нажмите кнопку Далее (Next), чтобы продолжить установку. Теперь система собрала достаточно сведений, чтобы начать установку Windows в автоматическом режиме. Этот процесс не требует вашего вмешательства и может занять достаточно продолжительное время, измеряемое десятками минут.

Во время установки несколько раз будет появляться диалог о необходимости перезагрузки. Вы можете ничего не нажимать в этом диалоге, и перезагрузка будет автоматически осуществлена через пятнадцать секунд. После того, как компьютер перезагрузился, начнется следующий этап установки Windows. На этом этапе программа установки настраивает систему в соответствии с особенностями вашего компьютера определяет состав оборудования. При этом на экране будут появляться соответствующие диалоги. После окончания второго этапа установки еще раз появится диалог о необходимости перезагрузки компьютера. После его перезагрузки система Windows будет установлена.

Обратите внимание, что если вы устанавливаете Windows ХР поверх предыдущей версии Windows, то вы можете отменить установку в любой момент вплоть до самого последнего момента и вернуться к предыдущей версии Windows.


15.3. Установка и удаление компонентов Windows

Когда система Windows ХР устанавливается на ваш компьютер у вас нет возможности выбрать, какие программы устанавливать, а какие нет. По умолчанию принят стандартный вариант установки, и он автоматически выбирается. Однако в этом случае не устанавливается ряд полезных программ. В процессе работы вы можете установить недостающие компоненты Windows, используя панель управления Windows.

Чтобы установить недостающие компоненты Windows, откройте панель управления Windows, выбрав соответствующую команду главного меню. В списке задач выберите Установка и удаление программ (Add or Remove Programs), чтобы запустить процедуру установки или удаления различных программ. При этом на экране появится одноименный диалог с нажатой кнопкой Замена или удаление программ (Change or Remove Program). Кроме этой кнопки в левой части диалога расположено еще несколько кнопок для выбора различных режимов работы при установке и удалении программ. В настоящий момент нас интересует установка компонент Windows поэтому нажмите кнопку Установка и удаление компонентов Windows (Add or Remove Windows Component), чтобы запустить мастер компонент Windows (Рис. 15.5).

В списке Компоненты (Components) выбираются компоненты Windows а кнопка Состав (Details) данного диалога позволяет отобразить список устанавливаемых компонент. Чтобы установить нужный компонент, необходимо установить флажок у соответствующего элемента списка. Обратите внимание, что в нижней части диалога отображается объем, требуемый для установки выбранных компонент Windows, а- также объем свободного места на системном диске.

Рис 15.5. Удаление компонент Windows и программ

После того как нужные компоненты выбраны, нажмите кнопку Далее (Next), чтобы начать процесс установки. Ход этого процесса сопровождается появлением диалога, в котором будет наглядно отображаться выполнение установки дополнительных компонент Windows. Удаление компонент Windows происходит аналогично, только в этом случае необходимо сбрасывать соответствующие флажки в списке компонент. Для установки некоторых компонент Windows может потребоваться установочный компакт-диск. Если диск понадобится, то появится диалог о вставке компакт-диска. Вставьте компакт-диск в дисковод и нажмите кнопку ОК, чтобы продолжить установку набора программ Windows. Операционную систему Windows XP можно устанавливать не только с компакт-диска, но и из любой папки как на жестком диске вашего компьютера, так и расположенной на сетевом диске. В этом случае при появлении диалога о вставке компакт-диска также нажмите кнопку ОК. Появится диалог для указания пути к установочной папке. Нажмите кнопку Обзор (Browse), чтобы в появившемся диалоге выбрать нужную папку.

Если вы устанавливали Windows XP не на новый компьютер а поверх уже установленных систем Windows 98 или Windows Me, то в диалоге для установки и удаления программ появится кнопка для отмены установки Windows. Выполнив отмену установки, вы вернетесь к предыдущей версии Windows. Обратите внимание, что при этом оборудование и программы установленные в Windows XP будут продолжать работать и под управлением старой версии Windows.


15.4. Установка и удаление программ

Персональный компьютер используется Для достаточно широкого круга задач поэтому не удивительно что часто встает задача установки новых программ на ваш компьютер. Иногда бывает так что вы перестаете пользоваться какой-либо программой. В этом случае лучше удалить ее с вашего компьютера чтобы она не занимала лишнее место. Давайте рассмотрим/ как эти задачи решаются в Windows XP.

Нажмите кнопку Добавление и удаление программ (Change or Remove Program) чтобы снова открыть список установленных программ (Рис. 15.6). В списке появившемся в диалоге отображаются все установленные на ваш компьютер программы. Выбрав одну из них/ вы можете удалить ее с вашего компьютера. Когда программ установлено много, бывает сложно найти нужную. В верхней части диалога расположен список, позволяющий выбрать различные варианты сортировки. Вы можете выбрать сортировку по алфавиту, по частоте использования программы и так далее.

Рис 15.6. Замена и удаление программ

Обратите внимание, что при выборе программы с помощью щелчка мыши на соответствующей строке, в списке появляется дополнительная информация о ней. Вы можете узнать какой объем она занимает и как часто используется, а также выяснить дату последнего использования данной программы. Чтобы удалить выбранную программу, нажмите кнопку Удалить (Remove), расположенную в поле описания программы. При этом будет запущен мастер удаления программ. Прежде всего в появившемся диалоге будет задан вопрос, действительно ли вы хотите удалить программу. Если вы уверены, отвечайте утвердительно. Работа мастера продолжится, и программа будет удалена с вашего компьютера. Следует отметить, что иногда программа удаления не полностью удаляет все компоненты программы. Это зависит от многих причин. В этом случае вам предлагается удалить оставшиеся компоненты самостоятельно. Вы должны перейти в нужную папку с помощью любой программы, например, с помощью проводника, и удалить оставшиеся файлы, конечно если они вам не нужны.

Установить новую программу вы можете самостоятельно, или поручив эту задачу Windows. Если вы будете устанавливать программу самостоятельно, то с помощью проводника следует открыть диск, на котором поставляется новая программа, и найти на нем программу с именем Setup. Дальше нужно просто запустить ее и следовать появляющимся на экране инструкциям. Скоре всего, вам не придется это делать, так как при установке компакт-диска с программой в дисковод установочная программа будет запущена автоматически.

Второй способ установки программ состоит в использовании кнопки Добавить новые программы (Add New Programs) в диалоге установки и удаления программ. При нажатии этой кнопки внешний вид диалога изменится (Рис. 15.7).

Рис 15.7. Добавление программы

Данный диалог предназначен для добавления новых программ, а также для обновления Windows. Последняя операция происходит через Интернет, поэтому на компьютере должно быть настроено соединение с Интернетом. Обновление Windows представляет собой полностью автоматизированный процесс. От вас требуется установить соединение с Интернетом и нажать кнопку Обновление Windows (Windows update). Далее система все сделает сама.

Чтобы установить новую программу, следует нажать кнопку Диск (CD or Floppy). При нажатии на эту кнопку запускается мастер установки программ (Рис. 15.8). Ваша задача -вставить компакт-диск или дискету с программой в дисковод и нажать кнопку Далее (Next) этого диалога. После этого система произведет поиск программы установки, и результаты этого поиска будут отображены в следующем диалоге мастера (Рис. 15.8).

Рис 15.8. Диалоги мастера установки программ

Если в поле ввода отображается правильная информация, нажмите кнопку Готово (Finish) этого диалога чтобы запустить программу установки. Если система не смогла найти программу установки, нажмите кнопку Обзор (Browse) и в появившемся диалоге выберите путь для программы установки. После того, как путь к программе установки указан, нажмите кнопку Готово (Finish), чтобы запустить программу и начать процесс установки.

Многие программы при своей установке создают в главном меню Windows группы, содержащие несколько элементов, в том числе команду для удаления программы. Выбор такой команды главного меню также приводит к запуску мастера удаления программ. Некоторые программы позволяют выборочно устанавливать или удалять компоненты. В этом случае при запуске мастера удаления или замены программ будет запущена программа установки, похожая на аналогичную программу, которая используется при установке компонентов Windows. Например пакеты программ Microsoft Office или CorelDRAW позволяют установить или удалить любые компоненты, когда вам это понадобится.


  • 16. Настройка системы
    • Использование панели управления
    • Красота и удобство работы
    • Основные сведения о настройке интерфейса
    • Удобство работы
    • Настройка внешнего вида
    • Темы рабочего стола
    • Создание красивого и удобного интерфейса
    • Настройка для эффективной работы
    • Управление питанием
    • Настройка мыши
    • Установка нового оборудования
    • Перенос файлов на новый компьютер


16. Настройка системы

Система Windows XP имеет широкий набор возможностей по изменению внешнего вида рабочего стола. Вы можете изменить внешний вид системы до неузнаваемости. В этой главе мы рассмотрим основные подходы к настройке системы, ни в коем случае не претендуя на полноту охвата темы.


16.1. Использование панели управления

Основные настройки Windows XP сосредоточены в специальной папке, которая называется Панель управления (Control Panel). Чтобы открыть эту папку, следует выбрать одноименную команду в главном меню Windows. Описывая различные возможности операционной системы, мы не раз использовали панель управления. В этом разделе мы подведем итог в использовании этой папки при настройке различных возможностей Windows. Панель управления может отображаться в одном из двух различных режимов. Первый режим, используемый по умолчанию, группирует значки различных настроек (Рис. 16.1, верхний). При этом внешний вид панели управления похож на Web-страницу. Переходя по ссылкам, вы выбираете группу настроек и находите нужную программу.

Рис. 16.1. Различный вид панели управления

Второй режим, называемый классическим, отображает все значки вместе, не выделяя отдельные группы (Рис. 16.1). В этом режиме панель управления не отличается от обычной папки. Режим отображения панели управления в виде Web-страницы более удобен, однако некоторые люди предпочитают использовать классический режим. Для перехода из одного режима в другой используется ссылка в левой части окна панели управления, на панели задач.

Давайте кратко рассмотрим основные группы панели управления. При этом обратите внимание, что в Windows XP с помощью панели управления можно легко запускать различные программы, которые раньше запускались из главного меню Windows с помощью громоздкой и запутанной последовательности команд.

Если панель управления отображается в классическом виде, выберите задачу Перейти в категории (Switch in category view). Выберите в появившемся списке ссылку Оформление и темы (Appearance and Themes), чтобы отобразить список настроек в данной группе (Рис. 16.2).

Рис. 16.2. Настройка внешнего вида и сетевых возможностей

В данной группе вы можете выбрать вариант оформления рабочего стола, называемый темой, выбрать фоновый рисунок, заставку и изменить размер изображения на экране монитора. Более подробно о настройках внешнего вида Windows XP вы узнаете ниже.

Нажмите кнопку Назад (Back) в панели инструментов проводника, чтобы вернуться к основной папке панели управления. Выберите ссылку Сеть и соединения с Интернетом (Network and Internet Connections), чтобы отобразить список настроек в данной группе (Рис. 16.2). Данная папка предназначена для настройки сетевых возможностей Windows XP. Настройка соединения с Интернетом, создание и настройка домашней сети, соединение нескольких сетей - вот далеко не полный перечень задач, решаемых с помощью ссылок в этой папке. Большинство из настроек сетевых возможностей описано выше в данной книге.

Нажмите кнопку Назад (Back), чтобы вернуться к основной странице панели управления. Выберите ссылку Звуки, речь и аудиоустройства /(Sounds, Speech and Audio Devices), чтобы отобразить список настроек в данной группе (Рис. 16.3), которые предназначены для настройки звуковых возможностей вашего компьютера. Большинство из настроек рассмотрено выше, при описании работы в Windows с аудио и видео, поэтому мы не будем останавливаться на них.

Рис. 16.3. Настройка звука и обслуживание

Нажмите кнопку Назад (Back), чтобы вернуться к основной странице панели управления. Выберите ссылку Производительность и обслуживание (Performance and Maintenance), чтобы отобразить список настроек в данной группе (Рис. 16.3, справа). Настройки этой группы позволяют повысить общую эффективность работы компьютера. Вы можете очистить место на диске от ненужных файлов, создать резервную копию важных данных, повысить скорость запуска программ. Из данной папки вы можете также запустить программу восстановления системы, которая поможет вам отменить нежелательные изменения в настройках Windows, которые могут нарушить ее правильную работу. Нажмите кнопку Назад (Back), чтобы вернуться обратно. Выберите ссылку Принтеры и другое оборудование (Printers and other devices), чтобы отобразить список настроек в данной группе (Рис. 16.4).

Рис. 16.4. Настройка оборудования и времени

В этой папке вы можете настраивать параметры большинства подключенных к компьютеру устройств. В их число входит мышь, клавиатура, принтеры, модемы, сканеры и так далее. Для настройки конкретного устройства или группы устройств, следует выбрать нужную ссылку или дважды щелкнуть на нужном значке.

Нажмите кнопку Назад (Back), чтобы вернуться к первой странице панели управления. Выберите ссылку Дата, время, язык и региональные настройки (Date, Time, Language and regional settings), чтобы отобразить список настроек в данной группе (Рис. 16.4). В этой группе вы можете настроить некоторые параметры, которые связаны с особенностями языка и страны вашего проживания. Например, вы можете установить формат чисел и дат, выбрать используемую денежную единицу. Также вы можете установить текущую дату и время. Кроме того, у вас есть возможность использовать несколько языков в работе, например русский и английский. Здесь вы можете выбрать дополнительные языки, а также указать способ переключения между языками. Нажмите кнопку Назад (Back) в панели инструментов, чтобы вернуться к основной странице панели управления. Выберите ссылку Учетные записи пользователей (User Accounts), чтобы отобразить список настроек в данной группе (Рис. 16.5).

Рис. 16.5. Работа с пользователями и специальные возможности

Работа с пользователями подробно описана в предыдущих разделах данной книги. Сейчас же напомним, что Windows XP позволяет работать на одном компьютере нескольким людям, каждый из которых будет иметь свои настройки и внешний вид рабочего стола. Можно быстро переключаться между различными пользователями. В данной группе настроек вы можете добавить нового пользователя, а также изменить настройки для уже существующих пользователей. Нажмите кнопку Назад (Back) в верхней части диалога, чтобы вернуться к первой странице панели управления. Выберите ссылку Специальные возможности (Accessibility Options), чтобы отобразить список настроек в данной группе (Рис. 16.5). С их помощью Windows настраивается для людей с нарушениями зрения, слуха или подвижности рук. Вы можете выбрать крупный шрифт надписей, высокую контрастность изображения, звуковые эффекты, а также настроить экранную клавиатуру.

В заключение знакомства с панелью управления закройте ее окно. Еще раз отметим, что в новой версии Windows XP работа по настройке системы с помощью панели управления стала очень удобной. Все похожие настройки сосредоточены в одном месте, тут же есть ссылки на связанные по смыслу настройки из различных групп. Выбор нужных настроек сводится к выбору группы и последующему выбору нужной задачи.


16.2. Красота и удобство работы

От того, каков порядок у вас на столе, во многом зависит ваша производительность труда. При работе с Windows правильная организация рабочего стола также имеет большое значение и влияет на удобство работы с системой. Естественно, что настройка внешнего вида и удобство - вещи сугубо индивидуальные. Одному человеку нравятся крупные значки и яркие цвета, а другому - совсем наоборот.

Ниже мы рассмотрим основные подходы к настройке внешнего вида Windows, не претендуя на обязательность повторения наших настроек, а демонстрируя общие принципы их изменения. Окончательно решить для себя, каким будет внешний вид рабочего стола Windows на вашем компьютере, вы должны самостоятельно.


16.2.1. Основные сведения о настройке интерфейса

На рабочем столе Windows расположены значки, обозначающие программы, папки и файлы. Манипулируя этими значками, вы выполняете нужные вам действия над файлами, решая ваши задачи. Чтобы с Windows было удобно работать, ее можно настроить по собственному вкусу. Вы можете изменить разрешение экрана, настроить внешний вид указателя мыши, раскладку клавиатуры, определить, какие звуки будет издавать компьютер во время тех или иных действий, а также настроить внешний вид рабочего стола.

Иногда при изменении параметров интерфейса Windows может потребоваться перезагрузка системы, и вы увидите диалог с предложением о перезагрузке. В этом случае, чтобы изменения вступили в силу, необходимо ответить на вопрос о перезагрузке утвердительно, однако в Windows XP перезагрузка требуется очень редко.


16.2.2. Удобство работы

Чтобы перейти к настройке внешнего вида рабочего стола Windows, откройте панель управления и выберите задачу Оформление и темы (Appearance and Themes), щелкнув мышью на соответствующей ссылке. Внешний вид панели управления изменится и появится список задач для настройки внешнего вида (Рис. 16.2). Вам предлагается несколько ссылок, позволяющих устанавливать фон рабочего стола, заставку, которая появляется, если вы долго не работаете за компьютером, элементы оформления рабочего стола, разрешение экрана и так далее. Выберите ссылку Изменить разрешение экрана (Change screen Resolution), чтобы открыть диалог настройки (Рис. 16.6). Кстати, для настройки экрана можно также щелкнуть правой кнопкой мыши на свободном месте рабочего стола и выбрать в появившемся вспомогательном меню команду Свойства (Properties). Будет открыт тот же диалог, что и при использовании команд панели управления.

Рис. 16.6. Настройка разрешения экрана

У вас есть возможность менять размер рабочего стола и количество отображаемых на экране цветов. Чем больше разрешение экрана, то есть количество отображаемых пикселей, тем больше информации можно разместить на экране монитора, но тем мельче будут элементы изображения. Для работы с высокими разрешениями, порядка 1600 на 1200 пикселей, нужны мониторы с Диагональю экрана не менее девятнадцати дюймов. Для мониторов с диагональю пятнадцать дюймов оптимально разрешение 1024 на 768 пикселей, а если вы хотите работать с разрешением 1280 на 1024 пикселя, то вам потребуется монитор с диагональю не менее семнадцати дюймов. Следует подчеркнуть, что предельная величина разрешения зависит не только от возможностей монитора, но и от видеоадаптера, установленного на вашем компьютере.

Величину разрешения экрана можно менять с помощью ползунка Область экрана (Screen Area). После выбора нужного значения следует нажать кнопку Применить (Apply). Чтобы защитить ваш компьютер от установки недопустимых разрешений, Windows, после того, как изменение разрешения произошло, попросит вас подтвердить это изменение (Рис. 16.7). В противном случае, через пятнадцать секунд будет восстановлено прежнее разрешение экрана.

Рис. 16.7. Диалог о применении новых параметров

Такой подход удобен тем, что при установке неверных параметров изображение на экране может исчезнуть, и вы не сможете отменить операцию. В этом случае следует просто подождать пятнадцать секунд, чтобы отменить операцию автоматически.

Сколько цветов будет отображаться при выбранном разрешении, зависит от вашей видеокарты. Открывающийся список Цветовая палитра (Colors) позволяет вам выбрать глубину цвета. Минимальным для нормальной работы считается количество одновременно отображаемых цветов, равное 65536, что соответствует глубине цвета шестнадцать бит. По окончании настройки разрешения экрана, нажмите кнопку ОК, чтобы закрыть диалог настройки и вернуться к выбору задачи в панели управления. Однако вы можете не закрывать диалог, а перейти на другую вкладку и продолжить настройку внешнего вида. Мы же опишем, как настраивать внешний вид, выбирая ссылки в панели управления.


16.2.3. Настройка внешнего вида

Фон рабочего стола вовсе не должен быть одноцветным, вы можете использовать рисунки в качестве фона. Выберите ссылку Изменить фон рабочего стола (Change the desktop background) в панели управления, чтобы открыть диалог настройки (Рис. 16.8).

Рис. 16.8. Настройка фона рабочего стола

Вы можете изменить фон рабочего стола, определив фоновый рисунок, или задав специальный узор, которым будет заполнен рабочий стол. Фоновый рисунок представляет собой графический файл, отображаемый на поверхности рабочего стола в качестве его фона. Вы можете использовать готовые рисунки или создать свой собственный. Рисунки, поставляемые вместе с Windows, выбираются из списка. Если вы хотите использовать собственный рисунок, воспользуйтесь кнопкой Обзор (Browse), чтобы указать, где он расположен.

Если размер рисунка отличается от размера рабочего стола, то в открывающемся списке Отображение (Position) вы можете выбрать вариант решения этой проблемы. Можно отобразить рисунок по центру, растянуть его на весь экран или размножить, покрыв рабочий стол повторяющимся узором. Вы также можете выбрать фоновый цвет рабочего стола, выбрав его в соответствующем списке.

Нажмите кнопку Настроить рабочий стол (Customize Desktop), чтобы открыть диалог дополнительной настройки параметров рабочего стола (Рис. 16.9). С помощью вкладки Общие (Common) данного диалога вы можете изменить изображение некоторых обязательных значков, располагающихся на рабочем столе, и даже вообще убрать значки с экрана. Устанавливая и убирая флажки в верхней части диалога, вы помещаете и убираете соответствующие значки на рабочем столе. Выбрав рисунок одного из значков, щелкнув на нем мышью, вы можете изменить его. Для этого следует нажать кнопку Сменить значок (Change Icon) и выбрать новый значок в появившемся диалоге. Нижняя часть диалога предназначена для настройки мастера очистки рабочего стола. Если установить расположенный внизу флажок, то раз в шестьдесят дней будет запускаться мастер, который займется очисткой рабочего стола от мусора. Все значки, которые вы давно не использовали, будут перемещены в специальную папку, значок которой появится на рабочем столе. Чтобы запустить очистку немедленно, нажмите кнопку Очистить сейчас (Clean Desktop Now). С помощью данной процедуры вы сможете убраться на своем компьютерном рабочем столе, спрятав ненужные значки.

Рис. 16.9. Выбор значков для элементов рабочего стола

Вторая вкладка диалога позволяет выбрать в качестве рабочего стола Web-страницу в Интернете, локальной сети или на вашем компьютере. По окончании настройки нажмите кнопку ОК, чтобы закрыть диалог. Также нажмите кнопку ОК, чтобы закрыть диалог настройки, и вернуться к выбору задачи в панели управления.

Выберите ссылку Выбрать заставку (Choose Screen Saver) в панели управления. Появится диалог настройки, открытый на вкладке настройки заставки, часто называемой скринсейвером, от английского слова Screen Saver (Рис. 16.10). Как вы можете заметить, на эту вкладку можно было перейти и, не завершая работу программы настройки. Заставка представляет собой изображение, появляющееся на экране, если вы не работаете с компьютером какое-то время, но он не выключен. Данный диалог позволяет настроить вид заставки. Вы можете выбрать из списка динамическое изображение и установить интервалы времени, после которого заставка будет включена. Вид заставки можно наблюдать в области предварительного просмотра, а если вы хотите посмотреть заставку, увеличенную на весь экран, воспользуйтесь кнопкой Просмотр (View). Заставка исчезнет, когда вы начнете работать с компьютером, например, пошевелите мышь или нажмете клавишу клавиатуры. Можно задать пароль, чтобы убрать заставку с экрана могли только вы. Кроме настроек заставки, данная вкладка позволяет настроить энергосберегающие функции монитора.

Рис. 16.10. Настройка заставки

Интересной возможностью Windows XP является использование в качестве заставки рисунков, хранящихся в папке Мои рисунки (My Pictures). В списке Заставка (Screen Saver) появляется элемент, обозначающий показ слайдов из этой папки. Вы можете поместить в папку Мои рисунки (My Pictures) любые свои изображения. При выборе показа слайдов в списке заставок, рисунки будут последовательно отображаться на экране.

Настроить длительность отображения и другие параметры можно, нажав кнопку Настройка (Settings). Щелкните мышью на ярлычке Оформление (Appearance), чтобы отобразить соответствующую вкладку диалога настройки (Рис. 16.11). У вас есть возможность настроить вид, цвет и размер шрифтов для заголовков окон и названий команд меню. Но настраивать все элементы оформления - достаточно трудоемкая задача.

Рис. 16.11. Настройка оформления

Чтобы облегчить настройку, вводится понятие схемы оформления и существует ряд заранее настроенных схем. Вы можете выбрать готовую схему оформления, а можете создать ее самостоятельно. Кроме того, вы можете модифицировать уже существующую схему. Для сохранения схемы оформления служит кнопка Сохранить как (Save As). Вид схемы можно посмотреть в поле предварительного просмотра, представляющего собой рисунок набора окон со всеми атрибутами, чтобы при их изменении вы оперативно могли наблюдать эти изменения. По окончании настройки нажмите кнопку ОК, чтобы закрыть диалог, и вернуться к выбору задачи в панели управления.


16.2.4. Темы рабочего стола

Тема рабочего стола объединяет в единую композицию схему оформления рабочего стола, звуковые эффекты, фоновый рисунок, заставку экрана, форму указателей мыши, а также внешний вид стандартных значков, таких, как, например, Корзина (Recycle Bin). Поскольку все компоненты объединены единым стилем, то оформление получается довольно красивым. Выбрать и настроить темы рабочего стола можно, выбрав ссылку на панели управления, открытой в режиме работы с отображением и темами. Выберите ссылку Изменить тему (Change Computer's theme), чтобы открыть диалог (Рис. 16.12).

Рис. 16.12. Выбор темы

Открывающийся список Тема (Theme) позволяет выбрать одну из предлагаемых в комплекте Windows схем. В поле просмотра, расположенном внизу диалога, отображается внешний вид окон и надписей для выбранной схемы. Чтобы увидеть, как изменится рабочий стол при выборе новой схемы, можно нажать кнопку Применить (Apply). При этом диалог настройки не будет закрыт, и вы можете отменить при желании все изменения, нажав кнопку Отмена (Cancel). Чтобы подтвердить изменения схемы и закрыть диалог настройки, нажмите кнопку ОК.

Кроме тем рабочего стола, поставляемых с Windows, существует большое количество разнообразных тем, готовых к использованию. Многие из них можно найти в Интернете. В частности, если вы выберете в списке Тема (Theme) элемент Другие темы (More Themes), то будет предложено установить соединение с Интернетом. В случае если вы ответите утвердительно, будет запущена программа Internet Explorer, и вы перейдете на страницу, содержащую разнообразные темы для рабочего стола Windows.


Пример 16.1. Создание красивого и удобного интерфейса

Используем рассмотренные возможности настройки внешнего вида рабочего стола, чтобы создать оригинальный вариант интерфейса Windows XP. Откройте панель управления и выберите ссылку Оформление и темы (Appearance and Themes).

Вначале изменим фоновый рисунок. Выберите задачу Изменить фон рабочего стола (Change the desktop background). Появится диалог настройки. В списке доступных фоновых рисунков выберите элемент Рай (Azul), а в списке Отображение (Position) выберите элемент По центру (On Center). Нажмите кнопку ОК, чтобы закрыть диалог настройки и изменения вступили в силу. На экране появится новый фоновый рисунок.

В нашем случае получилось так, что фон под надписями не совпадает с фоновым рисунком рабочего стола. Чаще всего так и бывает. Давайте попробуем решить эту проблему. Еще раз выберите задачу Изменить фон рабочего стола (Change the desktop background) и в появившемся диалоге Застройки откройте список Цвет (Color), чтобы отобразить палитру (Рис. 16.13).

Рис. 16.13. Диалог выбора цвета

Нам нужен оттенок темно-синего цвета, которого в предлагаемой палитре нет. Нажмите кнопку Другие (Other), чтобы открыть расширенную палитру (Рис. 16.13). Можно подобрать цвет прямо на палитре, щелкнув мышью на нужном оттенке, а можно ввести цифровое представление цвета в соответствующие поля ввода. Используя указатель мыши, щелкните мышью в нужном месте палитры, расположенной в правой части диалога. Теперь нажмите кнопку Добавить в набор (Add to Custom Colors) и щелкните мышью на появившемся цвете среди дополнительных цветов. Нажмите кнопку ОК, чтобы закрыть диалог Цвет (Color). Нажмите кнопку Применить (Apply) диалога настройки фона, чтобы отобразить изменения. Нажмите кнопку ОК этого диалога, чтобы закрыть его. Настройка внешнего оформления рабочего стола завершена.

Теперь к получившемуся оформлению можно добавить звуковое оформление. Нажмите кнопку В начало (Ноте) в панели управления. Выберите задачу Звуки, речь и аудиоустройства (Sounds, Speech and Audio Devices), чтобы открыть список задач этой группы. Выберите задачу Изменить звуковую схему (Change the sound scheme). Появится диалог настройки. В открывающемся списке Схема (Scheme) выберите музыкальную схему Утопия (Utopia) и нажмите кнопку ОК, чтобы закрыть диалог и применить новую схему. Вы также можете изменить и другие элементы рабочего стола, например, вид указателя мыши. О настройке указателя мыши вы узнаете ниже.

Создание интерфейса на этом завершено. В заключение добавим, что для восстановления исходных настроек интерфейса Windows необходимо восстановить исходный фон, схему оформления рабочего стола и звуковую схему - как стандартные схемы Windows.


16.3. Настройка для эффективной работы

Кроме настроек внешнего вида, система Windows XP позволяет настраивать много других параметров, которые могут также повысить эффективность работы. В качестве иллюстрации таких возможностей Windows ниже мы рассмотрим настройку управления питанием вашего компьютера, а также настройку указателя мыши, значительно повышающую удобство работы с ней.


16.3.1. Управление питанием

Современные компьютеры позволяют управлять своим источником питания с помощью работающих программ. Кроме того, операционная система Windows XP позволяет снижать энергопотребление компьютера, если вы долго не работаете с ним. При использовании переносных компьютеров или компьютеров, использующих источники бесперебойного питания, система Windows XP определяет тип питания: от сети или от батарей. Если компьютер питается от батарей, то система автоматически снижает тактовую частоту в зависимости от загрузки системы. Чем выше загрузка, тем сильнее система понижает частоту процессора. Это позволяет значительно снизить потребление энергии и увеличить время работы от батарей.

Откройте панель управления и выберите задачу Производительность и обслуживание (Performance and Maintenance), чтобы перейти к нужной группе настроек (Рис. 16.3, снизу). Выберите ссылку Управление электропитанием (Power Options), чтобы открыть диалог настройки, открытый на первой вкладке (Рис. 16.14).

Рис. 16.14. Выбор схемы управления питанием

Данная вкладка диалога предназначена для выбора схемы управления питанием. В открывающемся списке можно выбрать уже настроенную схему управления. Можно также изменить параметры выбранной схемы в группе элементов управления Настройка схемы (Power Schemes). Настройка заключается в выборе времени наступления событий энергосбережения: включение ждущего режима (System Stand by), отключения дисплея (Display turn off), а также остановки дисков (Disk turn off).

В системе заданы определенные интервалы времени для каждого события, и вы можете выбрать их в открывающихся списках. Если у вас не блокнотный компьютер, то чаще всего используется схема Домашний или настольный компьютер (Home/Office Desk). Чтобы изменения схемы электропитания вступили в силу, нажмите кнопку Применить (Apply) этого диалога.

Щелкните мышью на ярлычке Дополнительно (Advanced), чтобы перейти на одноименную вкладку (Рис. 16.15). Одним из дополнительных параметров, устанавливаемых на этой вкладке, является требование ввода пароля при выходе из спящего режима. Установка данного флажка позволит вам не беспокоиться о том, что кто-то воспользуется вашим компьютером, когда вы отлучились, но не выключили его. Установка второго флажка инструктирует систему помещать значок для вызова настройки управления питанием на панель задач Windows.

Рис. 16.15. Настройка дополнительных параметров

Современные клавиатуры имеют в своем составе клавиши управления питанием, позволяющие включать и выключать компьютер, а также переводить его в спящий режим. Кроме того,

можно настроить кнопки на корпусе компьютера. Нижняя половина данного диалога предназначена для настройки действий, выполняемых при нажатии кнопки включения питания. В открывающемся списке вы можете выбрать одно из предлагаемых действий.

Если ваш компьютер поддерживает переход в спящий режим, то в диалоге настройки будет присутствовать соответствующая вкладка. Щелкните мышью на ярлычке Спящий режим (Hibernate), чтобы открыть новую вкладку диалога настройки управления электропитанием (Рис. 16.16).

Рис. 16.16. Настройка спящего режима

Идея спящего режима состоит в следующем. При переходе в этот режим содержимое оперативной памяти компьютера переписывается на жесткий диск и компьютер выключается. При включении компьютера содержимое оперативной памяти восстанавливается с жесткого диска, и компьютер продолжает работу с того места, когда он был остановлен.

В группе элементов управления данного диалога всего один флажок: Разрешить поддержку спящего режима (Enable Hibernate Support). Если есть такая возможность, то лучше установить этот флажок. Использование спящего режима дает

вам ряд преимуществ в работе на компьютере. Например, вы вечером выключаете компьютер, а когда включите его утром, то работа продолжится с того места, где вы остановились вчера. После установки данного флажка в диалоге о завершении работы Windows появится новый элемент списка о переходе компьютера в спящий режим.

Система Windows XP может работать с устройствами бесперебойного питания, обеспечивающими работу настольного компьютера и другого оборудования компьютера от батарей в течение некоторого интервала времени. Длительность этого интервала зависит от мощности источника бесперебойного питания. Щелкните мышью на ярлычке ИБП (UPS), чтобы перейти на соответствующую вкладку диалога настройки управления электропитанием (Рис. 16.17).

Рис. 16.17. Настройка службы бесперебойного питания

В данном диалоге отображается текущее состояние источника, его модель и фирма-производитель. Также вы можете настроить работу с источником бесперебойного питания. Если система не смогла определить модель, то вы можете ее выбрать вручную, нажав кнопку Выбрать (Select). В появившемся списке выберите фирму-производителя источника бесперебойного питания. После выбора изготовителя выберите вашу модель источника бесперебойного питания. Теперь устройство выбрано или распознано, и вы можете настроить источник бесперебойного питания. Нажмите кнопку Настройка (Configure) и в появившемся диалоге укажите, что система должна делать, когда питание компьютера осуществляется от батарей. В заключение нажмите кнопку ОК, чтобы закрыть диалог настройки управления электропитанием.


16.3.2. Настройка мыши

Как вы уже почувствовали, удобная работа с мышью в Windows является очень важной. Система Windows XP предлагает вам ряд новых возможностей по настройке указателя мыши, которые мы рассмотрим ниже. Откройте панель управления и перейдите в группу Принтер и другое оборудование (Printer and Other Hardware), после чего выберите ссылку Мышь (Mouse). Будет открыт диалог настройки свойств мыши (Рис. 16.18). Данная вкладка диалога позволяет настроить использование кнопок мыши. Прежде всего, установив флажок в верхней части диалога, вы можете поменять местами назначение правой и левой кнопок мыши. Это бывает полезно, если вы левша. Также на данной вкладке регулируется скорость двойного щелчка. Как вы уже знаете, двойной щелчок часто используется при работе с Windows. Начинающие пользователи часто не могут надежно выполнять двойной щелчок, поэтому правильная настройка его скорости под ваши особенности нажатия кнопок является очень важной. Дважды щелкните мышью на папке, расположенной в центре диалога. Если она откроется или закроется, значит, скорость двойного щелчка настроена правильно. В противном случае измените скорость с помощью ползунка, расположенного левее, и повторите попытку. Настроив скорость двойного щелчка, используйте такую же скорость при работе со всеми программами.

Рис. 16.18. Настройка использования кнопок мыши

К удобным возможностям Windows XP относится появление на этой вкладке группы элементов управления Фиксация щелчка (Click Lock). Часто при работе, например, с текстом, приходится выделять его фрагменты. Обычно это делается так: вы нажимаете кнопку мыши, и, не отпуская ее, перемещаете указатель вдоль текста. Когда текст выделен, вы отпускаете кнопку мыши. Между первой и второй частью операции может пройти значительное время, и все это время надо удерживать кнопку мыши нажатой. Это не всегда бывает удобно. Если вы установите флажок в этой группе, то работать с выделением или с перетаскиванием станет значительно удобнее. Теперь процедура будет выглядеть так. Вы нажимаете кнопку мыши на короткое время, но дольше, чем просто щелчок, а затем отпускаете кнопку. Происходит как бы фиксация нажатого состояния кнопки. Вы перемещаете указатель в нужное место, а затем еще раз щелкаете кнопкой, чтобы снять фиксацию нажатого состояния.

Вы можете выбрать различный вид указателей мыши для работы. Чтобы сделать это, щелкните мышью на ярлычке Указатели (Pointers). Будет открыта новая вкладка диалога (Рис. 16.19). На этой вкладке вы можете выбрать набор указателей для различных событий в Windows. Такой набор называется схемой. Для выбора схемы используется одноименный открывающийся список. Кроме того, вы можете модифицировать готовую схему, изменяя вид указателей вручную.

Рис. 16.19. Настройка схемы указателей

Чтобы изменить вид указателя для какого-либо события, следует выбрать событие в списке, расположенном в нижней части диалога, и нажать кнопку Обзор (Browse) для выбора указателя. Если вы хотите восстановить исходный вид указателя, нажмите кнопку По умолчанию (Use Default).

Дополнительную красоту придает тень у указателя мыши. Чтобы включить такую возможность, установите соответствующий флажок в нижней части диалога настройки.

Все изменения, которые вы вносите в стандартные схемы указателей, вы можете сохранить. Для этого нажмите кнопку Сохранить как (Save As). Появится диалог для ввода имени сохраняемой схемы. Введите любое удобное для вас имя и нажмите кнопку ОК. Схема будет сохранена, и вы сможете в дальнейшем выбрать ее повторно, если перед этим поменяете схему.

Щелкните мышью на ярлычке Параметры указателя (Pointer Options), чтобы перейти на другую вкладку (Рис. 16.20). Группа элементов управления Движение (Motion) с помощью перемещения ползунка позволяет выбрать скорость перемещения указателя по экрану вслед за перемещением мыши по столу. Этот параметр выбирается индивидуально, в зависимости от особенностей вашей работы с мышью. Если установить флажок в этой группе, то указатель будет двигаться не равномерно, а с ускорением.

Рис. 16.20. Настройка параметров указателя мыши

Если установлен флажок в средней группе элементов управления, то при появлении на экране различных диалогов указатель мыши автоматически будет устанавливаться на кнопке диалога, используемой по умолчанию. Последняя группа элементов управления настраивает эффекты при движении указателя мыши и наборе текста. Вы можете включить формирование вслед за перемещением указателя своеобразного шлейфа.

Когда на экране отображено много окон, в которых много рисунков, текста и другой информации, часто бывает трудно найти, где в настоящий момент расположен указатель мыши. Установка флажка Показывать положение указателя (Show Location of pointer) облегчит вам решение задачи. Если флажок установлен, то при нажатии клавиши Н а клавиатуре, на экране будут появляться концентрические круги, сходящиеся в место расположения указателя мыши. После знакомства с основными настройками указателя мыши, нажмите кнопку ОК, чтобы закрыть диалог настройки.


16.4. Установка нового оборудования

Когда вы устанавливаете в ваш компьютер новое оборудование, при запуске Windows система автоматически определяет его наличие и пытается установить необходимое для его работы. Однако если по каким-то причинам автоматического определения нового оборудования не произошло, вы можете запустить мастер установки оборудования самостоятельно. Следует отметить, что автоматически не распознаются чаще всего очень старые или очень новые устройства. Старые устройства не поддерживают автоматическое распознавание, а новые устройства просто не известны Windows XP, так как появились после выпуска системы. Иногда не могут быть опознаны некоторые экзотические устройства, не получившие широкого распространения. Следует также учитывать, что некоторые устройства могут быть не совместимы с Windows XP. В таком случае ничего сделать нельзя, и установить устройство у вас не получится. Если же устройство в принципе должно работать в системе Windows XP, но автоматически нужные драйверы не установились, следует воспользоваться услугами мастера установки оборудования.

Откройте панель управления и выберите ссылку Принтер и другое оборудование (Printer and Other Hardware), после чего в панели задач выберите ссылку Установка оборудования (Add Hardware). Появится первый диалог мастера установки оборудования (Рис. 16.21).

Рис. 16.21. Приветствие и выбор устройства

Нажмите кнопку Далее (Next), чтобы продолжить работу. Будет произведен поиск установленного оборудования, и результаты этого поиска будут отображены в виде списка в следующем диалоге мастера установки оборудования (Рис. 16.21, справа). Устройства, для которых не установлены драйверы или которые работают с ошибками, в этом списке имеют знак вопроса. Выбрав такое устройство и нажав кнопку Далее (Next), вы продолжите работу мастера в режиме обновления драйверов для оборудования. Если вы добавляете новое оборудование, то выберите элемент Добавление нового устройства (Add New Hardware Device) и нажмите кнопку Далее (Next). Появится следующий диалог мастера, который предлагает вам осуществить автоматический поиск новых устройств (Рис. 16.22). Режим автоматического поиска предлагается по умолчанию и помечен как рекомендуемый для использования. Однако если вы точно знаете модель вашего устройства, можно выбрать его из списка, тем самым не тратя лишнего времени на поиск. Если переключатель установлен в режим автоматического поиска и нажата кнопка Далее (Next), то следующий диалог отобразит прогресс-индикатор, иллюстрирующий процесс поиска (Рис. 16.22, справа). По окончании поиска его результаты будут отображены в диалоге мастера.

Рис. 16.22. Приветствие и выбор устройства

Иногда программа не может автоматически обнаружить новое устройство. В этом случае нажмите кнопку Назад (Back), чтобы вернуться к выбору режима добавления и установить переключатель в положение Выбор оборудования из списка (Manually Select from list). Теперь снова нажмите кнопку Далее (Next). Появится следующий диалог мастера, отображающий список групп устройств (Рис. 16.23).

Рис. 16.23. Выбор группы оборудования и модели

Выберите в списке группу, к которой относится ваше устройство. Если такой группы в списке нет, выберите элемент Показать все устройства (List All Devices). После выбора группы устройств нажмите кнопку Далее (Next), чтобы отобразить следующий диалог мастера (Рис. 16.23).

Диалог содержит список производителей и список моделей выбранной группы оборудования. Сначала в списке производителей выберите фирму-производителя вашего оборудования, а затем в списке моделей выберите его модель. Обратите внимание, что слева от названий моделей модемов расположен значок zzzz . Это значок цифровой подписи, говорящий о том, что работа данного оборудования испытана в системе Windows XP. Может так случиться, что вы не найдете в этих списках ваше оборудование. Тогда придется воспользоваться дискетой или компакт-диском, который должен присутствовать в комплекте поставки оборудования. Для использования дискеты нажмите кнопку Установить с диска (Have disk). Появится диалог выбора папки и диска. Вставьте дискету, которая должна быть в комплекте поставки оборудования, и нажмите кнопку ОК, чтобы закрыть диалог. Если драйвер устройства находится на компакт-диске, то укажите букву диска в поле ввода и затем нажмите кнопку ОК. В появившемся диалоге выбора файла выберите нужный файл и нажмите кнопку Открыть (Open), чтобы открыть файл и закрыть диалог поиска. Появится новый диалог, показывающий, драйверы каких устройств есть на диске. Выберите драйвер устройства и нажмите кнопку ОК, чтобы продолжить установку. В зависимости от типа устанавливаемого оборудования возможно появление еще нескольких диалогов мастера установки для указания, специфических параметров оборудования. По окончании работы мастера новое оборудование будет установлено на ваш компьютер, и вы можете приступать к работе с ним.

После установки нового драйвера, даже если вы все делали правильно, оборудование может работать неправильно, или система будет работать нестабильно. Операционная система Windows XP позволяет отменить установку драйвера устройства и вернуться к предыдущему драйверу. Чтобы вернуться к предыдущему работоспособному драйверу устройства, следует на рабочем столе щелкнуть правой кнопкой мыши на значке Мой компьютер (My Computer), чтобы отобразить вспомогательное меню. В этом меню выберите команду Свойства (Properties). В появившемся диалоге выберите вкладку Диспетчер устройств (Device Manager). Далее выберите в списке устройство, драйвер которого вы хотите вернуть, и нажмите кнопку Свойства (Properties). В появившемся диалоге выберите вкладку Драйвер (Driver) и нажмите кнопку Возврат драйвера (Rollback Driver). Будет восстановлена предыдущая версия драйвера устройства.

Когда вы обновляете драйверы устройств, система запоминает последний работоспособный драйвер. Это происходит автоматически во время каждой загрузки системы Windows. Если у вас возникнут проблемы с новыми драйверами и вы не сможете загрузить систему, чтобы выполнить возврат драйвера, следует воспользоваться средством последней удачной конфигурации. Для этого во время загрузки следует нажать клавишу Щ на клавиатуре, чтобы выбрать особые режимы загрузки. В появившемся меню следует выбрать конфигурацию, называемую Последняя известная удачная (Last Known Good). Компьютер успешно загрузится, и вы можете принять решение о том, что делать дальше, уже работая в Windows.


16.5. Перенос файлов на новый компьютер

Если вы хотите, чтобы настройки Windows на нескольких компьютерах были одинаковы, то для этих целей удобно воспользоваться средством, которое называется мастер переноса файлов и настроек. Этот мастер может оказаться полезным, если вы приобрели новый компьютер и хотите перенести на него всю информацию со старого. Используя данный мастер, вам не придется запоминать множество настроек системы, а затем устанавливать их на новом компьютере. Перенос заключается в следующем. На старом и новом компьютерах необходимо запустить мастер. В первом случае мастеру необходимо указать, что он работает на старом компьютере, а во втором - что на новом компьютере. Мастер на старом компьютере автоматически соберет необходимую информацию и запишет ее на дискету или передаст на новый компьютер по сети. Мастер на новом компьютере прочитает эту информацию, автоматически настроит Windows и перенесет необходимые файлы. Выберите команду меню Другие программы → Стандартные → Служебные → Мастер переноса файлов и настроек (More Programs → Accessories → System Tools → Files and Settings Transfer Wizard). Появится первый диалог мастера (Рис. 16.24).

Рис. 16.24. Приветствие и выбор типа компьютера

Нажмите кнопку Далее (Next) этого диалога, чтобы перейти к следующему диалогу мастера (Рис. 16.24). В этом диалоге вам следует уточнить, на каком компьютере запущен мастер: на новом или на старом. Чтобы собрать информацию о файлах и настройках, установите переключатель в положение Старый компьютер (Old Computer) и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера переноса файлов и настроек (Рис. 16.25).

Рис. 16.25. Выбор носителя и файлов

В этом диалоге следует указать, какой носитель информации будет использован для переноса файлов и настроек. Для больших объемов данных рекомендуется использовать домашнюю сеть, а для маленьких объемов, например, только настроек, подойдет и гибкий диск. Установите переключатель в нужное положение и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится диалог мастера, определяющий, какую информацию следует переносить (Рис. 16.25). С помощью переключателя выберите, что необходимо переносить: только настройки, только файлы или и то и другое. Если вы хотите переносить не все файлы или не все настройки, установите флажок Выбрать (Customize). Теперь нажмите кнопку Далее (Next), чтобы продолжить работу. Появится диалог мастера переноса файлов и настроек, в котором следует уточнить, какие файлы и какие настройки нужно переносить (Рис. 16.26).

Рис. 16.26. Конкретизация файлов и сбор информации

В левой части диалога расположен список переносимой информации. Вы можете удалять и добавлять различную информацию с помощью кнопок, расположенных в правой части диалога. После уточнения, какую информацию следует переносить, нажмите кнопку Далее (Next), чтобы начать процесс переноса. Этот процесс сопровождается появлением диалога с прогресс-индикатором, показывающим степень завершения процесса (Рис. 16.26).

Если в качестве носителя была выбрана дискета, появится диалог с предложением вставить диск. Вставьте дискету и нажмите кнопку ОК для продолжения. По окончании записи информации диалог с прогресс-индикатором исчезнет и появится заключительный диалог мастера. Нажмите кнопку Готовь (Finish) этого диалога, чтобы закрыть его и завершить работу мастера.

Второй этап переноса файлов и настроек происходит на новом компьютере. Запустите на нем мастер переноса файлов и настроек и укажите в соответствующем диалоге, что вы работаете за новым компьютером. Появится диалог, спрашивающий, есть ли у вас установочный компакт-диск с Windows XP. Установите переключатель в положение Мне не нужен компакт-диск (I don't need CD) и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится диалог для выбора носителя. В зависимости от того, что вы использовали как носитель на старом компьютере, установите переключатель в нужное положение.

Если в качестве носителя используется сетевой диск, то в поле ввода следует ввести его адрес. После выбора носителя нажмите кнопку Далее (Next). Начнется процесс переноса файлов и настроек, сопровождающийся появлением диалога мастера с прогресс-индикатором. По окончании процесса появится заключительный диалог мастера. Нажмите кнопку Готово, чтобы закрыть диалог. После переноса настроек вам будет предложено выйти из Windows XP и затем снова зарегистрироваться в системе, чтобы изменения настроек вступили в силу.


  • 2. Работа с помощью проводника Windows
    • Знакомство с проводником Windows
    • Переход по дискам и папкам
    • Копирование, перемещение и переименование файлов
    • Создание новых папок, файлов и ярлыков
    • Удаление и восстановление файлов
    • Пример 2.1. Создание и удаление папок и файлов
    • Поиск информации в компьютере
    • Работа со сжатыми папками
    • Запуск программ из проводник
    • Форматирование дискет
    • Пример 2.2. Перенос документов на другой компьютер
    • Запись на компакт-диски
    • Особенности работы с файловой системой NTFS
    • Дополнительные возможности проводника


2. Работа с помощью проводника Windows

Проводник в английской версии операционной системы называется Windows Explorer, что можно перевести как “Исследователь Windows”. Действительно, с помощью проводника вы можете исследовать все диски и папки вашего компьютера, а также локальную сеть, к которой подключен ваш компьютер и даже Интернет. Проводник является удобным инструментом для работы с файлами вашего компьютера. При работе с этой программой содержимое вашего компьютера представлено в виде иерархического дерева. При этом вы можете видеть содержимое каждого диска и папки, как на вашем компьютере, так и на тех компьютерах, которые связаны с вашим по компьютерной сети. Проводник одновременно отображает, как иерархию находящихся на компьютере папок, так и содержимое выбранной вами папки. Это особенно удобно при копировании и перемещении данных, в чем вы сами сможете убедиться после знакомства с программой.


2.1. Знакомство с проводником Windows

Для запуска проводника следует выбрать команду главного меню Windows Другие программы * Стандартные * Проводник (More Programs * Accessories * Windows Explorer). После запуска программы на рабочем столе появится ее окно (Рис. 2.1), внешний вид которого может значительно различаться, в зависимости от настроек программы. В основном эти различия связаны с внешним видом области просмотра содержимого выбранной папки.

Рис. 2.1. рабочее окно проводника Windows

В верхней части окна программы, как и во всех других программах, расположен заголовок. В качестве названия в заголовке используется имя текущей папки, с которой проводник работает в настоящее время. Ниже расположены меню и панели инструментов, с помощью которых вы можете выполнять различные действия с файлами и папками компьютера. Возможно, на вашем компьютере некоторые кнопки на панели инструментов будут сопровождаться надписями, поясняющими назначение данных кнопок. Поле Адрес (Address) позволяет вводить полный путь к файлу или папке для быстрого доступа к ним.

Центральная часть рабочего окна проводника разбита на несколько областей. Слева расположен список всех дисков и папок вашего компьютера. С его помощью вы можете легко выбрать любую папку, чтобы просмотреть ее содержимое. Содержимое выбранной папки отображается в правой области окна программы. В центральной области расположены команды, с помощью которых вы можете выполнять различные операции над файлами, переходить к важным папкам и просматривать информацию о выбранном файле. Чтобы изменить пропорции между этими областями, необходимо подвести указатель мыши к разделяющей их границе. Указатель мыши изменит свою форму. Если вы нажмете кнопку мыши и, не отпуская ее, переместите границу вправо или влево, вы можете установить новые размеры областей.

Вы можете вызвать проводник и другим способом, например, щелкнув мышью на значке Мои документы (My Documents) или на значке Мой компьютер (My Computer) на рабочем столе Windows. Также вы можете выбрать аналогичные команды в главном меню Windows. В любом случае, когда вы захотите просмотреть какую-либо папку вашего компьютера, будет запущен проводник, и данная папка станет текущей. При таком способе запуска дерево дисков и папок не будет отображаться, и центральная часть окна будет разбита только на две части (Рис. 2.2). Стоит отметить, что вы можете отобразить или убрать список папок в любой момент при работе с проводником. Для этого следует нажать кнопку с надписью Папки (Holders), расположенную на панели задач. При каждом нажатии кнопка фиксируется в нажатом или отжатом состоянии. Когда кнопка нажата, список папок отображается в левой части окна программы. Если кнопка отжата, список не отображается.

Рис. 2.2. Различный вид проводника

Вы также можете раскрывать и сворачивать списки задач, расположенные левее содержимого выбранной папки. Все действия, которые вы можете выполнить, разделены на три списка. В верхней части расположен список действий по работе с текущей папкой или с выделенным файлом. Ниже расположены ссылки на важные папки вашего компьютера. Эти ссылки позволяют быстро перейти к нужной папке. Последний список, расположенный еще ниже, содержит информацию о выбранной папке или файле. Каждый список имеет свой заголовок, в правой части которого расположена круглая кнопка. Если кнопка выглядит, как, список свернут, и в панели виден только его заголовок. Нажмите кнопку, список раскроется, и кнопка изменится. Нажав кнопку, вы свернете список. Можно свернуть некоторые списки, Оставив другие раскрытыми (Рис. 2.2,).

Список файлов текущей папки, отображаемый в правой части окна, также может иметь самый разный вид. Нажав кнопку на панели задач, вы откроете вспомогательное меню с командами выбора внешнего вида списка. Можно отображать файлы в виде маленьких или больших значков, причем рядом будет выведена дополнительная информация о файле (Рис. 2.2). Если в папках, которые вложены в текущую папку, находятся графические файлы, на значках этих папок вы увидите эскизы нескольких изображений из таких файлов. Вариант табличного просмотра кроме имени файла выводит его размер, дату последнего сохранения и тип. Щелкнув мышью на заголовке любого столбца таблицы, вы отсортируете список файлов по возрастанию этого параметра. Повторный щелчок отсортирует файлы по убыванию. С помощью этих приемов легко найти, например, самый большой файл в данной папке, или самый новый. Очень удобен просмотр эскизов файлов (Рис. 2.2). Чаще всего такой режим используется при работе с изображениями. Вы можете попробовать самостоятельно переключиться в разные режимы и познакомиться с особенностями отображения информации в этих режимах.


2.2. Переход по дискам и папкам

Если вы точно знаете, где расположен требуемый файл, вы можете ввести полный путь к нему в поле ввода Адрес (Address). При этом будет осуществлен переход непосредственно к папке, где расположен нужный файл. После ввода адреса с помощью клавиатуры, для выполнения перехода к нужной папке, следует нажать кнопку Q, расположенную правее поля Адрес (Address), или нажать клавишу. Однако часто точный адрес файла неизвестен. Кроме того, вводить адрес с клавиатуры менее удобно, чем выбрать адрес в списке с помощью мыши. Вы можете путешествовать по дискам и папкам вашего компьютера, просматривая содержимое папок и выполняя различные действия над файлами. Нажав кнопку И, расположенную в правой части поля Адрес (Address), вы откроете список папок компьютера. Щелкнув мышью на нужной папке, вы сделаете ее текущей. Однако удобнее работать со списком папок, который расположен в левой части окна программы.

При работе с проводником все диски и папки вашего компьютера представляются в виде дерева (Рис. 2.3). В основании дерева, часто называемого корнем, располагается особая папка с именем Рабочий стол (Desktop). В этой папке расположены служебные папки, все диски компьютера и другие важные папки. Именно так иллюстрируется идея о том, что все файлы и папки вашего компьютера лежат на рабочем столе Windows.

Рис. 2.3. Иерархический список папок

Если какая-то папка содержит другие папки, то слева от ее значка будет расположена рамка со знаком или Папки, в которых находятся только файлы, и в которых нет вложенных папок, не отмечены такой рамкой. Если папка отмечена значком , содержимое папки не раскрыто в списке. Если же вы видите значок, то содержимое папки расположено ниже в списке. С помощью щелчка мыши на этих значках вы можете соответственно раскрывать или скрывать содержимое папок. Диски также представлены в виде значков, и чтобы открыть содержимое диска, достаточно щелкнуть мышью на значке, обозначающем нужный диск. При работе в проводнике любой диск является обычной папкой.

Обратите внимание, что в левой области окна проводника отображаются только диски и папки, а отдельные файлы не отображаются. Для этого предназначена правая Ьбласгь. Если вы щелкнете мышью на папке в левой области, ее содержимбе отобразиться в правой части в виде значков. Открыть содержимое папки или диска можно и другим способом. Если дважды щелкнуть мышью на значке папки в правой области проводника, то папка будет открыта. Этот способ особенно удобен, если вы работаете в режиме, когда список папок не отображается. Последовательно выполняя двойные щелчки на нужных папках, вы переходите вниз по иерархии папок. Если же вам нужно выполнить противоположное действие, следует воспользоваться кнопкой на панели инструментов. Нажав кнопку, вы переместитесь на один уровень вверх в иерархии вложенных папок.

Все ваши передвижения по папкам, в рамках текущего сеанса работы с проводником, запоминаются. Вы можете в любой момент вернуться назад к папке, просмотренной вами ранее. Нажимая кнопки и, расположенные на панели инструментов, вы перейдете при путешествии по папкам и дискам на шаг назад и вперед, соответственно.

Как отмечалось выше, в панели задач, расположенной левее списка файлов, есть ссылки к важным папкам вашего компьютера. Щелкнув мышью на любой из таких ссылок, вы перейдете к работе с выбранной папкой.

Все описанные способы путешествия по дискам и папкам вашего компьютера преследуют одну, цель - найти нужную папку и выполнить некоторые действия с расположенными в ней файлами. Наиболее распространенным действием, выполняемым с файлами в проводнике, является их копирование и перемещение.


2.3. Копирование, перемещение и переименование файлов

Часто возникает необходимость в перемещении документов из одной папки в другую. Возможно, необходимо расположить целиком какую-то папку в .другом месте. Не реже возникает потребность в копировании различных файлов. Для лучшего понимания разных способов перемещения файлов представьте себе, что вы сидите за обычным столом, на котором лежит несколько папок с документами. Вам надо переложить какой-либо документ из одной папки в другую. Выполняя данную задачу, вы вначале должны открыть первую папку. После этого следует открыть вторую папку. Далее вы берете документ из первой папки и кладете его во вторую. Теперь обе папки можно закрыть. Однако есть и другой способ выполнения этой операции. Он заключается в том, что вы должны открыть первую папку и вынуть из нее документ, оставив его в руках. После этого вы можете закрыть первую папку. Теперь вы открываете вторую папку и кладете в нее документ. При последнем способе не требуется одновременно иметь под рукой обе папки, но нужно иметь место, где документ будет находиться, пока вы закрываете первую папку и открываете вторую. Особенно сильно эти способы различаются, когда папки лежат далеко друг от друга. При работе с проводником можно использовать оба описанных способа.

Прежде всего, отметим, что файлы и папки на компьютере можно как перемещать, так и копировать. Операции копирования, перемещения и удаления выполняются совершенно одинаково как для файлов, так и для папок с файлами. Естественно, операция с папкой подразумевает, что требуемое действие будет применено ко всему содержимому этой папки. Эти операции очень похожи, и сейчас мы рассмотрим общие принципы их выполнения.

При наличии списка папок в левой части окна программы, задача решается очень просто. Вы выбираете исходный файл в правой части и перетаскиваете его на новое место назначения, которое выбирается в списке всех папок. Определив место в списке папок, куда вы хотите переместить файл, подведите указатель мыши к значку файла в правой области. Нажмите кнопку мыши и, не отпуская ее, переместите указатель мыши на выбранное место в левой области окна, после чего отпустите кнопку мыши. При перемещении выделенного значка на место, где расположен список, папка назначения будет выделена. После того, как вы отпустите кнопку мыши, будет начата соответствующая операция. Отметим, что если перемещение значка или группы значков в выбранное вами место назначения невозможно, то в момент перетаскивания указатель мыши изменит свою форму на. При копировании и перемещении файлов часто появляется диалог, иллюстрирующий этот процесс (Рис. 2.4). Если вы копировали небольшой файл, диалог очень быстро закроется или даже вовсе не появится. При работе с большими файлами постепенное увеличение полоски в нижней части диалога иллюстрирует процент выполнения операции. Нажав кнопку Отмена (Cancel), вы можете прервать операцию. Когда процедура копирования или перемещения будет завершена, диалог закроется.

Рис. 2.4. Диалог копирования файла

Если в списке расположено слишком много папок и дисков, место назначения может быть не видно. В таком случае вам нужно перетащить значок в верхнюю или нижнюю часть списка и подождать, не отпуская при этом кнопку мыши. Через некоторое время список начнет смещаться в окне, и вы увидите нужную папку. Если вы хотите скопировать файл во вложенную папку, которая не видна в списке, следует поступить точно так же. Подведите при перетаскивании указатель мыши к папке, в которой находится нужная вам папка. Подождите, не отпуская кнопку мыши. Через некоторое время список раскроется, и вы сможете выбрать необходимое место для копирования или перемещения файла.

Теперь давайте разберемся, а что же происходит при перемещении значка - копирование или перемещение файла? В системе Windows имеется ряд правил, по которым определяется конкретная выполняемая операция. Если вы перемещаете значок из одной папки в другую, расположенную на том же диске, что и исходная, то операция приведет к перемещению файла, связанного со значком, ! и 'новую папку. При этом файл в старой папке будет удален. Если вы хотите не переместить, а скопировать файл в папку на том же диске, вы должны при выполнении операции перемещения значка нажать и удерживать клавишу на клавиатуре.

Если вы перемещаете значок в папку, расположенную на другом диске, соответствующий файл будет скопирован. Чтобы переместить файл в папку на другом диске, во время перемещения удерживайте нажатой клавишу. Иногда при перетаскивании значков; программ связанные с ними программы не копируются, а в новом месте только создается ссылка на них. При копировании или перемещении программ всегда следует нажимать соответствующуюклавишу или. Если при перетаскивании любого файла нажать клавишу то файл останется на старом месте, а в новом месте будет создан ярлык, указывающий на него.

Возможны операции копирования или перемещения не одного, а группы файлов или папок. При этом следует вначале выделить группу значков, а после перетащить их в нужное место. Чтобы выделить все значки в выбранной папке, необходимо нажать на клавиатуре одновременно управляющую клавишу и клавишу с латинской буквой (при нажатии клавиши с русской буквой файлы не будут выделены). Если необходимо выделить группу значков, расположенных рядом, следует нажать и удерживать клавишу. Далее щелкните мышью на первом значке группы и на последнем значке, после чего отпустите клавишу. Все значки, расположенные между ними, будут выделены. Если вы хотите выделить произвольную группу значков, нажмите клавишу и, Н е отпуская ее, щелкайте мышью на нужных значках. Обратите внимание, что повторный щелчок мышью на значке снимет выделение.

Выделив рее нужные значки, отпустите клавишу. После того, как нужная группа файлов и папок выделена, перетащите ее в нужное место списка в левой части окна программы. При э,том можно использовать клавиши или. чтобы выбрать операцию копирования или перемещения.

Хотя перемещение и копирование с помощью перетаскивания очень удобно, этот способ не работает, когда ! в окне проводника отсутствует список папок. Кроме того перемещение и копирование с помощью мыши требует некоторый опыт работы с мышью и может не получиться у начинающих пользователей. Есть несколько способов копирования и перемещения файлов в проводнике, которые значительно проще. Однако следует помнить, что часто простые способы являются более длительными, а более сложные способы существенно экономят время.

Если щелкнуть правой кнопкой мыши на каком-либо значке или группе выделенных значков, рядом появится вспомогательное меню (Рис. 2.5). Вызвать вспомогательное меню для выделенного элемента можно также с помощью клавиши, имеющейся на многих клавиатурах.

Рис. 2.5. Вспомогательное меню

Количество команд меню и их состав зависит от установленных на ваш компьютер программ, однако команды копирования, удаления и переименования будут в этом меню всегда. Чтобы скопировать файл или группу файлов, необходимо выбрать команду Копировать (Сору) данного меню. Далее необходимо перейти в папку назначения и снова отобразить вспомогательное меню щелкнув правой кнопкой мыши на свободном месте в рабочей области программы. В меню нужно выбрать команду Вставить (Insert), чтобы произошло копирование файлов. При таком способе в качестве временного места хранения перемещаемых и копируемых файлов служит так называемый буфер обмена Windows. Для перемещения файла нужно вместо команды Копировать (Сору) вспомогательного меню выбрать команду Вырезать (Cut). При этом файл будет удален из текущей папки и помещен в буфер обмена Windows. Если после этого вы не вставите файл в другую папку, он будет утерян.

Вспомогательное меню содержит еще ряд полезных команд, например команду Переименовать (Rename). При выборе этой команды вместо имени выбранного значка появляется поле ввода, в котором вы с помощью клавиатуры можете ввести новое имя для значка по своему усмотрению. Ввод имени заканчивается нажатием клавиши на клавиатуре.

Есть еще один, очень удобный, способ копирования и перемещения файлов. Как отмечалось выше, в центре окна, в панели задач, расположены разные команды, позволяющие выполнить с выделенным файлом необходимые действия. Для этого следует развернуть верхний список панели задач, нажав кнопку , если список свернут. В списке все действия обозначены кнопками с надписями. Выделите файл или группу файлов и нажмите кнопку расположенную на панели задач в средней части окна программы. Рядом с кнопкой написано Копировать этот файл (Copy this file). На экране появится диалог, в котором вам предлагается выбрать место для копирования (Рис. 2.6). В списке можно найти все диски и папки вашего компьютера. Вы также можете создать новую папку, выделив папку, в которой она будет располагаться, и нажав кнопку Создать папку (Create folder). Работа со списком папок не отличается от аналогичных действий, описанных ранее. Выбрав нужное место и нажав кнопку Копировать (Сору), вы запустите процесс копирования файлов. Над кнопкой имеется кнопка предназначенная для перемещения файлов.

Работа с ней точно такая же. Выделив файл или группу файлов, вы нажимаете кнопку. В появившемся диалоге выбираете новое место для файлов, после чего нажимаете кнопку Переместить (Move), чтобы переместить файлы.

Рис. 2.6. Выбор места для копирования

В списке задач есть и другие кнопки, которые облегчают выполнение некоторых распространенных задач. Нажав кнопку Я, вы сможете переименовать выделенный файл или папку. После нажатия кнопки выделенный файл будет распечатан, а нажатие кнопки удалит его. Для публикации файла в Интернете следует нажать кнопку, а нажатие кнопки отправит файл по электронной почте.

Есть еще один способ копирования и перемещения файлов. Очень просто для этого воспользоваться двумя окнами проводника. Для этого следует запустить две копии данной программы и расположить их окна рядом на рабочем столе. В одном окне сделайте текущей исходную папку, а в другом - ту, в которую хотите скопировать файлы. Далее просто перетащите мышью нужные файлы из одного окна в другое. При этом значительно сложнее промахнуться, чем При использований дерейа дисков и папок в щрюм;окне проводника.

Мы рассмбтрёли множество способов манипулирования файлами, так как эта операция очень важная и широко распространенная. Какой бы способ вы ни выбрали, результат будет совершенно Одинаковым. Попробуйте работу с помощью разных способов, и выберите наиболее удобный для вас вариант.


2.4. Создание новых папок, файлов и ярлыков

Чаще всего новые ) файлы создаются с помощью разных программ, например, Текстовый редактор создает текстовые документы, а графический редактор создает рисунки. Однако вы можете создать файлы и папки непосредственно в проводнике. Чаще всего так создаются новые папки и ярлыки, ссылающиеся на другиефайлы.

Чтоб создать папку, файл или ярлык, требуется, прежде всего, путем перемещение по папкам и дискам вашего компьютера перейти к папке, в которой вы будете создавать новый объект. После этого нужно вызвать вспомогательное меню, щелкнув правой кнопкой мыши на свободном месте в правой части окна проводника, где расположен список содержимого текущей папки. В появившемся меню следует выбрать команду Создать (New). Также можно выбрать команду меню программы Файл * Создать (File * New), В любом случае на экране появится вспомогательное меню с перечнем объектов, которые вы можете создать.

Если вы хотите создать папку, то следует выбрать команду Папка (Folder) этого меню. В правой области окна проводника в списке появится новый значок папки. Обратите внимание, что система предлагает вам для создаваемой папки имя Новая папка (New Folder). Вы можете изменить это имя на любое другое, введя его с помощью клавиатуры. По окончании ввода имени необходимо нажать клавишу. После того, как папка создана, ее имя появится в списке папок вашего компьютера, и вы сможете работать с этой папкой как с любой другой то есть создавать в ней файлы, перемещать ее и так далее.

Можно создать папку и более простым способом. Нажмите кнопку в верхней части панели задач, и новая папка будет создана. Чтобы данная кнопка появилась в панели задач, нужно, чтобы в папке не был выделен ни один файл. Если один или несколько файлов выделены, следует щелкнуть мышью на свободном месте в правой части окна проводника, и выделение будет снято.

Выбрав во вспомогательном меню один из предлагаемых типов файлов, вы можете создать новый файл. Однако будет создан пустой файл, то есть просто заготовка. Для его наполнения требуется воспользоваться соответствующей программой и добавить в файл тексты, звуки, рисунки или иное содержимое.

Если вы хотите создать ярлык, который представляет собой небольшой файл, содержащий ссылку на какой-либо файл, расположенный в любом месте среди дисков и папок вашего компьютера, вы должны выбрать команду Ярлык (Shortcut) меню создания новых файлов. При этом будет запущен мастер создания ярлыка. Первый диалог мастера (Рис. 2.7) предлагает вам указать местоположение объекта, для которого создается ярлык.

Рис. 2.7. Первый диалог мастера создания ярлыка

Полный путь и имя файла следует ввести в поле ввода, расположенное в центре диалога. Если же вы не помните точное местонахождение объекта, нажмите кнопку Обзор (Browse). Появиться диалог выбора папки, очень похожий на диалог, появляющийся при копировании файла с помощью команды панели задач (Рис. 2.6). Выбрав нужный файл, нажмите кнопку ОК в диалоге, чтобы закрыть его и вернуться к работе с мастером создания ярлыка.

Выбрав в отдельном диалоге или введя с клавиатуры адрес нужного файла, нажмите кнопку Далее (Next), чтобы продолжить создание ярлыка. Появится второй диалог мастера (Рис. 2.8), предназначенный для указания имени создаваемого ярлыка. В качестве имени можно использовать любое предложение, состоящее из одного или нескольких слов на русском или любом другом языке.

Рис. 2.8. Заключительный диалог мастера

Введите имя и нажмите кнопку Готово (Finish), чтобы завершить работу мастера. Когда ярлык создан, его значок появится в списке файлов текущей папки. Подобным образом вы можете создать несколько ярлыков для одной программы.

Значительно проще создать ярлык любого файла, щелкнув правой кнопкой мыши на этом файле, и выбрав во вспомогательном меню команду Создать ярлык (Create Shortcut). Созданный ярлык вы можете переместить в любое нужное вам место. Еще один способ создания ярлыков уже описывался. Если во время перетаскивания мышью значка файла вы нажмете клавишу вместо копирований или перемещения в указанном месте будет создан ярлык файла.


2.5. Удаление и восстановление файлов

Потребность в некоторых старых документах может со временем исчезнуть. В таком случае их лучше удалить, чтобы они не занимали лишнее место. Ненужные файлы и папки можно очень просто удалить с вашего компьютера, используя для этого проводник. Вначале следует выбрать объект для удаления, щелкнув на нем мышью в правой области окна программы. Это может быть файл, папка или их группа. О выделении группы объектов только что рассказывалось. После этого следует нажать кнопку в верхнем списке на панели задач расположенной в центре окна программы. Можно также выбрать команду меню Файл * Удалить (File * Delete) или нажать клавишу на клавиатуре. Можно также перетащить значок удаляемого файла из окна проводника на значок корзины , расположенный на рабочем столе Windows. При любом способе вызова операции удаления, кроме последнего, на экране компьютера появится диалог для подтверждения удаления (Рис. 2.9). С помощью этого диалога Windows XP пытается предотвратить удаление нужной информации.

Рис. 2.9. Запрос на подтверждение удаления файла

Если вы нажмете кнопку Да (Yes), выбранные файлы будут удалены и их значки исчезнут из списка файлов текущей папки. Нажав кнопку Нет (No), вы отмените операцию удаления. Аналогичные диалоги подтверждения появляются достаточно часто, когда вы хотите выполнить потенциально опасные действия. А что делать, если вам снова понадобятся удаленные файлы? У вас есть возможность восстановить их, и сделать это можно несколькими способами.
Будьте осторожны при удалении файлов. К сожалению, восстановить можно далеко не все удаленные файлы. Возможность восстановления зависит от настроек Windows, размера удаляемых файлов и свободного места на диске компьютера. Кроме того, файлы, удаленные с дискеты, восстановить нельзя.

Прежде всего, в проводнике есть возможность отмены последней выполненной операции. Если вы хотите восстановить только что удаленные файлы, нажмите одновременно клавиши и. Последовательно нажимая эту комбинацию клавиш несколько раз, можно отменять любые ваши предыдущие действия при работе с проводником, в том числе и отменять удаление папок и файлов. Система запоминает несколько последних действий и дает вам возможность отменить их. Помните об этом при возникновении критических ситуаций. Однако количество отменяемых действий ограничено, и давно удаленный файл невозможно восстановить таким образом.

Если использование функции отмены не даст нужного результата, не стоит отчаиваться. На случай, если вам вновь понадобятся удаленные ранее файлы, система Windows XP предприняла некоторые меры. Файлы, которые вы удаляете, перемещаются в специальную папку, называемую Корзина (Recycle Bin). Это особая папка, и ее значок выделен в отдельную ветвь дерева файлов и каталогов вашего компьютера и помещен на рабочий стол Windows.

Для просмотра, восстановления или безвозвратного удаления из системы ранее удаленных файлов необходимо открыть корзину с помощью проводника. Чтобы открыть корзину, нужно дважды щелкнуть на значке, расположенном на рабочем столе Windows, или щелкнуть мышью на значке корзины в проводнике Windows. Внешний вид окна проводника при работе с корзиной почти не отличается от окна этой программы при работе с любой другой папкой вашего компьютера (Рис. 2.10).

Рис. 2.10. Удаленные файлы в корзине

Удаленные файлы находятся в корзине, пока в ней есть место. Если для нового удаляемого файла места не хватает, давно удаленные файлы будут безвозвратно утеряны. Чтобы восстановить ранее удаленные файлы, необходимо открыть корзину, выделить требуемый файл или группу файлов, после чего нажать кнопку в панели задач. Также можно выбрать команду меню Файл * Восстановить (File * Restore). Для восстановления всех файлов, находящихся в корзине, следует отменить выделение файлов, щелкнув мышью на свободном месте в правой части окна программы, после чего нажать кнопку с надписью Восстановить все (Restore all items) на панели задач.

Поскольку корзина является такой же папкой, как и любая другая, никто не запрещает вам удалять файлы, хранящиеся в этой папке. В этом случае удаленные файлы будут потеряны окончательно, и их уже нельзя будет восстановить. Чтобы удалить все файлы из корзины, можно воспользоваться кнопкой с надписью Очистить корзину (Empty the Recycle Bin), расположенной на панели задач.


Пример 2.1. Создание и удаление папок и файлов

Закрепим основные навыки работы с файлами в проводнике Windows, такие как перемещение по дискам и папкам, а также создание и удаление папок и файлов.

Прежде чем создавать папку или файл, необходимо решить, в каком месте на диске вы будете это делать. Мы рекомендуем для хранения собственных документов использовать папку Мои документы (My Documents). Для просмотра этой папки можно запустить проводник и найти ее в списке папок, но мы воспользуемся более простым способом. Нажмите кнопку Пуск (Start), и будет открыто главное меню Windows. В нем есть команда Мои документы (My Documents). Щелкните на ней мышью, и будет запущен проводник, а текущей станет нужная папка. В зависимости от того, что вы ранее делали за компьютером, в этой папке могут оказаться различные документы.

Сначала создадим в папке Мои документы (My Documents) новую папку для дальнейшей работы. Нажмите кнопку в верхней части панели задач, и новая папка будет создана. Чтобы данная кнопка появилась в панели задач, нужно, чтобы в папке не был выделен ни один файл. Если один или несколько файлов выделены, следует щелкнуть мышью на свободном месте в правой части окна проводника, и выделение будет снято. Нажмите кнопку на панели задач для переименования папки. Введите с помощью клавиатуры имя Рабочая папка и нажмите клавишу. чтобы завершить ввод. В списке папок и файлов, расположенных в папке Мои документы (My Documents), появится новая папка. Дважды щелкните мышью на значке этой папки, чтобы сделать ее текущей. Естественно, содержимое вновь созданной папки будет пустым. Вы можете создавать в ней различные документы или другие папки.

Щелкните правой кнопкой мыши в любом свободном месте правой области окна проводника, чтобы открыть вспомогательное меню. В качестве примера создадим простой текстовый документ. Во вспомогательном меню выберите команду Создать (New), что приведет к появлению еще одного вспомогательного меню. В этом меню выберите команду Документ WordPad (WordPad Document). В созданной нами папке появится значок нового документа. Введите имя создаваемого документа Документ и нажмите клавишуl. чтобы завершить ввод.

Теперь в созданной нами папке появился значок созданного документа. Однако документ пока еще пуст, в нем нет никакого текста. Чтобы добавить содержимое в документ, необходимо его открыть, дважды щелкнув мышью на значке. В нашем случае будет запущен текстовый редактор WordPad. Подробнее об этом редакторе будет рассказано в следующей части нашей книги, а пока только отметим, что WordPad является более мощным текстовым редактором, чем блокнот, упоминавшийся выше. В открывшемся окне программы WordPad наберите простой текст, например, Вводим простой текст для выполнения примера из книги (Рис. 2.11).

Рис. 2.11. Открытый документ

По окончании н ввода текста выберите команду меню Файл * Сохранить (File * Save), чтобы сохранить набранный текст. Теперь можно закрыть окно программы WordPad. Сделайте это, щелкнув мышью на кнопке X в правой части заголовка окна программы. Подобным образом можно создавать различные документы. При этом, в зависимости от типа созданного документа, будет вызываться та или иная, связанная с ним, программа.

В заключение примера удалим только что созданный документ и папку. Выберите значок с именем Документ в правой области окна проводника и нажмите клавишу. Появится диалог для подтверждения удаления файла. Нажмите кнопку Да (Yes) этого диалога, чтобы подтвердить удаление. Теперь удалим созданную папку. Нажмите кнопку на панели инструментов, чтобы перейти на один уровень вверх в иерархии папок. Вы сделаете текущей папку Мои документы (My Documents). Выберите папку Рабочая папка и нажмите клавишу. В появившемся диалоге нажмите кнопку Да (Yes), чтобы подтвердить удаление папки. Можете открыть корзину и убедиться, что удаленный файл оказался в ней. Если вы удалите файл из корзины, он будет потерян безвозвратно.


2.6. Поиск информации в компьютере

После некоторого времени работы за компьютером, вы обнаружите, что не всегда можете вспомнить место, где расположен тот или иной нужный вам документ. В таком случае вам следует воспользоваться средствами поиска информации, включенными в операционную систему. При этом следует помнить, что для успешного поиска файла необходимо правильно указать критерии поиска.

В общем случае поиск информации в Windows XP удобно проводить, выбрав команду главного меню Найти (Search). При этом будет запущен проводник Windows в режиме поиска файлов и папок. Если вы уже работаете с проводником, то можете запустить поиск искомого файла, не выходя из этой программы. Чтобы воспользоваться средствами поиска информации, нужно нажать кнопку на панели инструментов проводника. При этом кнопка зафиксируется в нажатом состоянии, а в левой части окна программы появится панель с группой элементов управления для настройки поиска (Рис. 2.12). С их помощью вы можете задать критерии поиска и дать команду начала процедуры поиска нужного файла.

Рис. 2.12. Поиск файлов и папок

Наиболее часто файлы ищут по имени и типу, то есть по их расширению. Если известно имя файла вместе с расширением, его вводят в верхнее поле ввода. Напоминаем, что имя от расширения отделяется точкой. В открывающемся списке Где искать (Folder) выбирается диск или папка, в которой предполагается произвести поиск. По умолчанию вам предлагается текущая папка, содержимое которой отображается в правой части окна программы. Вы можете задать поиск по всем дискам вашего компьютера, но уточнение места поиска существенно ускорит его. Можно усложнить условия поиска, задав в поле ввода Искать текст (Containing text) фразу, которая должна содержаться в искомом файле. При этом следует помнить, что поиск в содержимом файлов может занять очень много времени.

Часто бывает, что имя файла известно не полностью. В этом случае при поиске недостающую часть имени или расширения файла заменяют специальными символами подстановки? Символ * заменяет любое количество любых символов, например, поиск по шаблону *.* задает поиск всех файлов. Часто применяют шаблоны типа *.htm или *.doc, то есть шаблоны поиска всех файлов заданного типа. Символ ? в шаблоне замещает только один, но любой символ, например, по шаблону Д?м будут найдены файлы Дом и Дым. Если имя файла имеет внутри пробелы, например, состоит из нескольких слов, то при поиске это имя необходимо заключать в кавычки, например "Любимая песня.wav".

После того, как вы ввели критерии поиска, можно начать искать файлы. Поиск начинается после нажатия кнопки Найти (Search Now). По мере нахождения нужных файлов и папок, их значки будут появляться в правой части окна проводника. Возможно, поиск займет достаточно много времени. Вы можете в любой момент прервать процедуру поиска, нажав кнопку Остановить (Stop Search). По результатам поиска выдается список файлов, соответствующих заданным условиям поиска. Вы можете работать с файлами из списка, но иногда бывает полезно перейти к папке, где расположен нужный файл. Для этого следует выделить один из найденных файлов и нажать кнопку расположенную на панели инструментов. Нужная папка станет текущей, и вы можете продолжить работу с ней обычным способом. Одновременно из окна проводника будет убрана панель с полями настройки поиска. Вы также можете остаться работать в системной папке с результатами поиска. Если вам мешает панель настройки поиска, нажмите кнопку на панели инструментов, и данная панель будет убрана.

В нижней части панели настройки поиска есть несколько ссылок для поиска компьютеров в сети, людей или информации в Интернете. Мы не будем останавливаться на особенностях такого поиска, но заметим, что принципы поиска остаются всегда одинаковыми. Вы задаете область поиска и критерии, после чего запускаете процедуру поиска. Но вернемся к поиску файлов и папок вашего компьютера.

Часто бывает, что вы не знаете имени искомого файла, но знаете дату его создания или его размер. В таком случае вы можете осуществить поиск по этим параметрам файла. Такой поиск нужен, если вам необходим список файлов, созданных например, за последние два дня. Данные возможности поиска устанавливаются с помощью дополнительных полей настройки, которые появляются в панели поиска при щелчке мышью на ссылке Параметры поиска (Search Options) (Рис. 2.13). Вид поиска задается с помощью установки соответствующих флажков. При установке конкретных флажков, под ними появляются дополнительные поля для уточнения критериев поиска. Установите флажок Дата (Date), и ниже появятся поля для настройки поиска по дате файла (Рис. 2.13,).

Давайте попробуем найти файлы, созданные вами или самой системой Windows за несколько последних дней. Сначала необходимо указать, какие файлы мы ищем. В поле ввода Искать имена файлов или папок (Search for Files and Folders) введите символ *, чтобы искать все файлы. Кстати/если вы ничего не введете в это поле, все равно будут найдены все файлы. Далее в списке, расположенном под флажком Дата (Date), следует выбрать элемент файлы созданные (files created). В этом списке также можно выбрать поиск измененных или открытых файлов. После этого установите переключатель в положение За последние дней (Last days), и в поле ввода рядом с данным положением переключателя введите число 2. Вы также можете выбрать поиск за последние несколько месяцев или явно указать начальную и конечную даты поиска. Нажмите кнопку Найти (Search) для запуска процедуры поиска. По окончании поиска результат будет отображен в правой части рабочего окна проводника.

Рис. 2.13. Дополнительные поля настройки параметров поиска

Если установить флажки Тип (Туре) и Размер (Size), убрав флажок Дата (Date), в панели появятся другие поля (Рис. 2.13. Как и в случае поиска по дате, вы можете выбрать тип и размер искомого файла. Причем можно указывать минимальный или максимальный размер файла. Последний флажок Дополнительные параметры (Advanced Options) позволяет установить или снять несколько флажков, задающих особенности выполнения поиска (Рис. 2.13). Вы можете задать просмотр при поиске системных папок и скрытых файлов, а можете не искать среди них. Также можно задать поиск во вложенных папках. Если вы уберете этот значок, поиск будет выполняться среди файлов только одной папки. При поиске можно учитывать различие строчных и прописных букв, а можно игнорировать такие различия. Настроив различные параметры поиска, вы можете существенно повысить его эффективность. Щелчок мышью на заголовке рамки Параметры поиска (Search Options) уберет дополнительные поля из панели настройки поиска.


2.7. Работа со сжатыми папками

В Windows XP, в отличие от большинства предыдущих версий операционной системы Windows, имеется возможность архивации файлов без использования дополнительных программ. Архивы в Windows называются Сжатыми папками (Compressed Folder) и обозначаются значком. Система работает с архивами типа ZIP, совместимыми с архивами популярной программы WinZip. Теперь у вас не возникнет никаких проблем при необходимости сжать файл, чтобы он поместился на дискету или занял меньше места при передаче по электронной почте. Так же легко вы сможете извлечь файлы из полученного архива.

Чтобы сжать или, как часто говорят, заархивировать, файл, нужно вызвать вспомогательное меню, щелкнув правой кнопкой мыши на значке файла в правой области окна проводника и выбрать команду Отправить (Send to). Откроется вспомогательное меню, в котором следует выбрать команду Сжатая папка (Compressed Folder). Можно также выделить файл и выбрать команду меню программы Файл * Отправить * Сжатая папка (File * Send to * Compressed Folder). В любом случае в текущем каталоге будет создан новый файл архива с таким же именем, что и исходный файл. В архиве в сжатом виде будет расположен ваш файл.

Вы можете создать пустой архив, выбрав команду меню Файл * Создать * Сжатая папка (File * New * Compressed Folder). Создание сжатой папки практически не отличается от создания обычной папки. Создан архив пустым или из любого файла, получен с другого компьютера или из Интернета, вы можете легко добавлять файлы в архив и извлекать их из него. Для работы с архивом следует дважды щелкнуть мышью на его значке, и вы перейдете к работе с ним. Вы можете не заметить, что работаете с архивом, так как внешне все будет выглядеть точно так же, как и при переходе во вложенную папку. Работа с архивом не отличается от работы с обычной папкой в проводнике. Как и при работе в любой другой папке, вы можете просматривать и удалять файлы. Если вы скопируете или переместите файл из архива в любую другую папку, файл будет разархивирован. При перемещении файла из обычной папки в сжатую, выполняется архивация выбранного файла. Добавить файл в архив можно и путем перетаскивания его значка на значок архива в проводнике. Разархивировать все файлы архива можно, выбрав команду меню Файл * Извлечь все (File * Extract All).

При работе с архивами можно задать пароль, который ограничит доступ к архиву. Следует помнить, что данный пароль не является надежной защитой от квалифицированных пользователей компьютера, так как может быть достаточно легко взломан. Для шифрования архива следует выбрать команду меню Файл * Зашифровать (File * Encrypt). На экране появится диалог, в котором вам будет предложено два раза ввести пароль. Будьте внимательны, так как вводимые символы не отображаются, а заменяются черными точками.

После ввода пароля и повторного его ввода для контроля, нажмите кнопку ОК, и в дальнейшем для работы с архивом потребуется пароль. Система будет запрашивать пароль при каждой попытке разархивировать любой файл из данного архива.

При работе с Windows XP сжатые папки не отличаются от обычных папок. В списке дисков и папок вашего компьютера они располагаются наравне с другими папками. Однако если вы перепишите сжатую папку на дискету и попытаетесь просмотреть ее содержимое на компьютере, где установлена операционная система, отличная от Windows XP или Windows Me, вы увидите файл архива с расширением ZIP. Для просмотра содержимого архива и разархивирования файлов вам понадобится дополнительная программа, например WinZip.


2.8. Запуск программ из проводника

Поскольку в Windows двойной щелчок на значке приводит к запуску программы, связанной с этим значком, запустить программу, работая в проводнике, очень легко. Достаточно дважды щелкнуть мышью на нужном значке, и программа будет запущена, а ее окно появится на рабочем столе.

Запущенной программе, которая имеет окно на рабочем столе Windows, соответствует кнопка на панели задач, и проводник не является исключением. Чтобы вернуться к этой программе, нужно нажать соответствующую кнопку на панели задач Windows. Завершить работу запущенной программы можно, нажав кнопку в правом верхнем углу рабочего окна программы. Подобным образом можно запускать из проводника столько программ, сколько вам нужно.

Другим способом запуска программ является двойной щелчок на файле, с которым связана программа. Например, при двойном щелчке на звуковом файле запустится проигрыватель Windows Media, а при двойном щелчке на текстовом документе будет запущен текстовый редактор. При установке большинства программ в Windows XP они связываются с определенными типами файлов. Например, вначале текстовые документы с расширением doc связаны с текстовым редактором WordPad. Однако после установки пакета программ Microsoft Office файлы данного типа будут связаны с мощным текстовым редактором Microsoft Word.


2.9. Форматирование дискет

Любой магнитный носитель информации должен быть отформатирован, прежде чем он сможет хранить ее.

Форматирование дискеты представляет собой процесс записи на нее специальных меток, которые позволяют хранить информацию. Подавляющее большинство дискет после приобретения не требуют форматирования, так как продаются уже отформатированными, однако в процессе работы может потребоваться повторное форматирование дискеты. Это может происходить по разным причинам, например, вы хотите быстро уничтожить содержимое дискеты или под влиянием магнитных полей окружающего нас мира информация на дискете испортилась. Если при работе с дискетой начинают происходить сбои при ее чтении, такую дискету больше использовать нельзя. Однако можно попробовать восстановить способность дискеты хранить информацию путем ее форматирования.

Применять форматирование следует только в случае, если компьютер сообщает об ошибках чтения информации с дискеты. Не забывайте, что форматирование как дискеты, так и жесткого диска, уничтожает хранящуюся на нем информацию и в общем случае ее восстановить нельзя.

Работая в проводнике, вы можете отформатировать дискету. Прежде всего, надо вставить дискету в дисковод. Далее запустите проводник Windows и сделайте текущей папку Мой компьютер (My Computer). Теперь следует перейти на дискету, дважды щелкнув мышью на значке ^ с именем Диск 3.5 (А:) (3.5 Floppy (А:)). Если в этот момент дискета в дисковод не вставлена или она является дефектной или неформатированной, на экране появится диалог с сообщением об ошибке чтения (Рис. 2.15). Нажав кнопку Отмена (Cancel), вы закроете его.

Рис. 2.15. Сообщение об ошибке чтения с дискеты

Очень полезно перед форматированием убедиться, что на дискете нет важных файлов. Нажав кнопку на панели инструментов, вы вернетесь к работе с папкой Мой компьютер (My Computer). Теперь необходимо щелкнуть правой кнопкой мыши на значке чтобы вызвать вспомогательное меню и выбрать в нем команду Форматировать (Format). Выбор этой команды приведет к появлению диалога настройки форматирования (Рис. 2.16).

Рис. 2.16. Диалог форматирования дискеты

Для надежности рекомендуется полное форматирование, поэтому лучше не устанавливать флажок быстрого форматирования в рамке Способы форматирования (Format type). Вы можете ввести метку тома, то есть задать название дискеты, хотя это делать совсем не обязательно. Для задания метки нужно ввести имя в поле Метка тома (Volume label). Остальные параметры в подавляющем большинстве случаев не требуется менять. Чтобы начать форматирование, нужно просто нажать кнопку Начать (Start) диалога. На экране появится диалог, предупреждающий о том, что при форматировании все файлы на дискете будут безвозвратно утеряны. Нажав кнопку ОК, вы закроете диалог и вернетесь к предыдущему диалогу. При этом начнется форматирование дискеты. Для большей наглядности, процесс форматирования сопровождается появлением в нижней части диалога полоски изменяющегося размера, называемой прогресс-индикатором, изменение которого иллюстрирует процесс форматирования. По окончании форматирования индикатор будет полностью заполнен и появится диалог, информирующий об успешном завершении операции. Нажав кнопку ОК, вы закроете диалог.

Обращаем ваше внимание, что в зависимости от степени износа дискеты и ее качества, полезный объем хранимой на ней информации может уменьшиться. Это происходит из-за того, что плохие участки дискеты помечаются как неисправные и не используются для хранения информации.


Пример 2.2. Перенос документов на другой компьютер

В основном перенос документов с одного компьютера на другой осуществляется с помощью дискет, хотя в последнее время все чаще для передачи файлов используют записываемые и перезаписываемые компакт-диски. Однако мы в качестве примера рассмотрим, как перенести файлы на другой компьютер с помощью дискеты в системе Windows XP. Перед выполнением примера убедитесь, что запущен проводник и при необходимости запустите его.

Прежде всего, нужно выбрать документ, который вы хотите перенести на другой компьютер. В качестве тренировки создайте текстовый документ с именем Документ для переноса на другой компьютер в папке Мои Документы (My Documents), как это описано в предыдущем примере. В результате в папке должен появиться новый документ.

После того, как документ подготовлен, можно приступать к его копированию на дискету. Щелкните правой кнопкой мыши на нужном файле и в появившемся вспомогательном меню выберите команду Отправить (Send To). Рядом появится еще одно вспомогательное меню. Выберите в нем команду Диск 3.5 (А:) (Floppy (А:)), и начнется процесс копирования документа, сопровождающийся появлением соответствующего диалога. Прогресс-индикатор в диалоге позволяет наблюдать степень завершения операции копирования. По окончании процесса копирования диалог будет закрыт. Подобным образом можно копировать на дискету несколько документов. В случае, если место на дискете закончиться, система Windows предупредит вас об этом с помощью соответствующего диалога.

Теперь убедимся, что копирование прошло успешно. Щелкните мышью на ссылке Мой компьютер (My Computer) в панели задач, чтобы увидеть в правой части окна программы все диски вашего компьютера. Щелкните мышью на значке с именем Диск 3.5 (А:) (3.5 Floppy (А:)), чтобы перейти на дискету. Найдите в списке файл Документ для переноса на другой компьютер.

Теперь вы можете извлечь дискету из дисковода, нажав на кнопку выброса диска, и использовать эту дискету на другом компьютере. Вставьте дискету в дисковод другого компьютера и запустите на нем проводник. Перейдите к работе с дискетой, и убедитесь, что файл находится на ней. Можно скопировать его в нужную папку другого компьютера. Для этого выделите файл, щелкнув на нем мышью, и нажмите кнопку расположенную на панели задач. Рядом с кнопкой написано Копировать этот файл (Copy this file). На экране появится диалог, в котором вам предлагается выбрать место для копирования. Выбрав нужное место в списке, нажмите кнопку Копировать (Сору), и вы запустите процесс копирования файла. Можно также работать с файлом прямо на дискете, но это не совсем удобно.

Если копируемый файл вам больше не нужен, вы можете удалить его со своего компьютера. В нашем примере, чтобы сделать это, перейдите в папку Мои Документы (My Documents). Убедитесь, что значок с именем Документ для переноса на другой компьютер имеется в списке файлов данной папки. Щелкните на нем мышью, чтобы выделить файл. Нажмите кнопку в верхнем списке на панели задач. Появится диалог для подтверждения удаления файла. Нажмите кнопку Да (Yes) данного диалога, и документ будет удален. При желании вы можете аналогично удалить скопированный на дискету документ.


2.10. Запись на компакт-диски

Одним из чрезвычайно полезных новшеств Windows XP является возможность записи информации на записываемые и перезаписываемые компакт-диски (CD-R и CD-RW). В последнее время популярность устройств записи компакт-дисков чрезвычайно выросла, и они превратились из экзотического дорогого оборудования в необходимый и удобный инструмент. Для записи файлов на компакт-диск следует вставить заготовку в устройство и скопировать с помощью проводника нужные файлы на данный диск. Однако реально на диск не будет ничего записано. Для дальнейшей работы следует открыть в проводнике компакт-диск.

Вы можете увидеть, что все файлы, находящиеся на диске, разделены на две группы - действительно записанные на диск и готовые для записи, но пока не записанные. Вверху списка файлов в правой части окна проводника расположены файлы и папки, ранее записанные на компакт-диск. Если вы вставили чистую заготовку, на ней, естественно, не будет записанных файлов. В нижней части списка расположены файлы, которые вы только что скопировали на диск. Физически они пока не записаны на компакт-диск, а располагаются в специальной папке, предназначенной для временного хранения. Эти файлы вы можете удалить, в то время как файлы, уже физически записанные на компакт-диск, удалить нельзя. Если вы хотите удалить все файлы, предназначенные для записи, следует нажать кнопку расположенную на панели задач. Копируйте и перемещайте файлы на компакт-диск пока вы не сформируете нужный набор файлов. После этого вы готовы к физической записи информации на диск. Эта процедура часто называется прожигом. Нажмите кнопку на панели задач, и будет запущен мастер прожига компакт-дисков. В первом диалоге мастера вам предлагается ввести имя создаваемого диска. По умолчанию в качестве имени предлагается текущая дата, но вы можете ввести любое другое имя. Если вы установите флажок в нижней части диалога, по окончании прожига диалог мастера автоматически закроется. Нажмите кнопку Далее (Next), и вы перейдете к следующему диалогу мастера.

Одновременно начнется прожиг компакт-диска. О том, кака; конкретно операция выполняется в настоящий момент, можно узнать из сообщений мастера. Кроме того, процент выполнения операции отображается с помощью прогресс-индикатора. Время записи зависит от объема записываемой информации и скорости записи. Например, записать 640 мегабайт на восьмой скорости займет около десяти минут. По окончании прожига на экране появится последний диалог мастера. Если вы установите в нем флажок, то сможете записать вторую копию диска. В противном случае просто нажмите кнопку Готово (Ready), чтобы закрыть диалог. На этом запись на компакт-диск закончена. Вы можете использовать его как обычный компьютерный компакт-диск.

Если вы попытаетесь извлечь диск, не записав подготовленные файлы, на экране появится диалог, в котором с помощью переключателя вы сможете выбрать один из трех вариантов. Можно записать файлы сейчас, сохранить файлы во временной папке для последующей записи или удалить подготовленные файлы, не записывая их на компакт-диск.

Если в качестве заготовки вы используете перезаписываемый диск, называющийся CD-RW, вы можете очистить его, удалив все файлы. После этого диск можно использовать для записи точно так же, как и новый. Нажмите кнопку [§g на панели задач, и начнет работу мастер очистки диска. В первом диалоге мастера не требуется ничего вводить, просто нажмите кнопку Далее (Next), чтобы перейти ко второму диалогу мастера.

При этом начнется очистка диска. Процент выполнения очистки демонстрируется с помощью прогресс-индикатора. По окончании очистки появится заключительный диалог мастера. Он информирует об успешном завершении операции. Нажмите кнопку Готово (Ready), чтобы закрыть диалог.

Возможно, вы захотите настроить некоторые параметры записи диска. Для этого нужно перейти в папку Мой компьютер (My Computer) и щелкнуть правой кнопкой мыши на значке устройства для записи компакт-дисков . В появившемся вспомогательном меню следует выбрать команду Свойства (Properties), и на экране появится диалог настройки параметров. Перейдите на вкладку Запись (Recording) этого диалога, щелкнув мышью на соответствующем ярлычке.

Флажок в верхней части диалога разрешает запись компакт-дисков на данном устройстве. Если убрать флажок, Windows XP не будет записывать на нем диски. В верхнем списке выбирается жесткий диск, на котором будет размещаться папка с временными файлами. Так как в этой папке должны поместиться все файлы, подготовленные вами для записи на компакт-диск, требуется 700 мегабайт свободного места на выбранном жестком диске. Во втором списке выбирается скорость записи. Перечень доступных скоростей определяется используемым вами устройством. Следует напомнить, что заготовки компакт-дисков также поддерживают не все скорости записи. Если у вас нет проблем с чтением записанных дисков, лучше использовать максимально возможную скорость. Если установлен флажок в нижней части диалога, после прожига диск будет извлечен из устройства. Убрав флажок, вы оставите диск в дисководе. Настроив параметры, нажмите кнопку ОК, чтобы закрыть диалог и запомнить настройки.

Как вы видите, записать файлы на компакт-диск в операционной системе Windows XP достаточно просто. Однако следует сделать небольшое отступление, чтобы рассказать, в каком формате записываются диски. Все диски создаются как мультисессионные, то есть содержащие несколько отдельных сессий, которые могут быть записаны в разное время. Наличие множества сессий позволяет записывать информацию отдельными частями, превращая CD-R и CD-RW в удобное средство ведения рабочего архива. Однако следует помнить, что запись первой сессии требует дополнительно двадцать два мегабайта, а запись каждой последующей сессии отнимает тринадцать мегабайт. Впрочем, это не так много, учитывая, что на диск можно записать 650-700 мегабайт информации, а на некоторые современные диски и еще больше. Хотя нужно учитывать, что часто записывая небольшие файлы, вы впустую тратите много места. Не все дисководы и операционные системы могут работать с мультисессионными дисками. В ДОС обычно видна только первая сессия, а в Windows 95 - последняя. На устаревших дисководах CD-ROM также часто видна только первая сессия. Так что, диски, записанные в Windows XP, могут неверно читаться на устаревших компьютерах. Если же вы не планируете читать диски на таких компьютерах, проблем в совместимости не возникнет. Кстати, при записи используется файловая система Joliet, которая позволяет записывать длинные имена, использовать пробелы и русские буквы. Все это не поддерживается в операционной системе ДОС. Вы наверно заметили, что многие компакт-диски автоматически запускаются при вставке их в устройство чтения дисков. В Windows XP можно настроить автоматическое воспроизведение музыкальных произведений и видеофильмов, просмотр рисунков и некоторые другие действия. Если же вы хотите запускать свою собственную программу или желаете, чтобы созданный вами диск автоматически запускался и в предыдущих версиях Windows, вам следует разместить в корневом каталоге текстовый файл с именем autorun.inf. В нем располагаются команды автозапуска. С их помощью можно создавать достаточно сложные сценарии, но для начала вполне достаточно использовать такие команды:

[autorun]

icon=myicon.ico

open=myprogram.exe

Естественно, следует указать названия ваших собственных файлов вместо myicon.ico и myprogram.exe. Команда open запускает нужную программу, а команда icon меняет значок диска в проводнике Windows. Конечно, данные файлы также должны быть расположены на компакт-диске.


2.11. Особенности работы с файловой системой NTFS

Как упоминалось выше, файловой системой называется структура, которая определяет правила хранения и размещения файлов на дисках вашего компьютера. Операционная система Windows XP поддерживает файловые системы FAT, FAT32 и NTFS. Выбрать файловую систему для любого жесткого диска можно при его форматировании. При установке Windows XP вы можете отформатировать жесткий диск, выбрав нужнук систему. Кроме того, выбор файловой системы актуален при установке в компьютер нового жесткого диска. Самая старая файловая система FAT сегодня практически не используется, так как она поддерживает жесткие диски ограниченного объема, не более двух гигабайт. Даже самые простые современные жесткие диски имеют существенно больший объем. Система FAT 32 является модификацией FAT, поддерживающей диски размером от 512 мегабайт до 2 терабайт. Система NTFS также поддерживает диски до 2 терабайт, но вместе с этим обеспечивает повышенную надежность, безопасность и эффективность работы. Благодаря особенностям построения системы NTFS, при увеличении объема диска не происходит снижения производительности.

Однако есть недостатки и у системы NTFS. Прежде всего, если на компьютере одновременно установлено несколько операционных систем, то из систем ДОС, Windows 3 или Windows 95/98/Me данные диски прочитать невозможно. Однако такое многообразие систем встречается достаточно редко. Кроме того, для эффективной работы с дисками NTFS требуется большой объем оперативной памяти. Однако Windows ХР и так требует не менее 128 мегабайт памяти для нормальной работы, так что в любом случае вам потребуется достаточно много памяти. Рекомендуем использовать файловую систему NTFS, так как она дает ряд дополнительных возможностей. Вы можете изменить некоторые параметры любых файлов и папок, однако, если они расположены на диске с файловой системой NTFS, появляются дополнительные возможности настройки. Щелкните правой кнопкой мыши на значке любого файла или папки, а в появившемся вспомогательном меню выберите команду Свойства (Properties). На экране появится диалог просмотра и настройки свойств (Рис. 2.17). В верхней части диалога выведена подробная информация о типе и расположении файла, его размере и других характеристиках. При просмотре свойств папки в диалоге указан суммарный размер всех файлов, расположенных в ней и во всех вложенных папках. Флажки в нижней части диалога позволяют изменить атрибуты файла. Можно сделать файл или папку скрытой или разрешить только чтение. Эти атрибуты можно установить для дисков с любой файловой системой.

Рис. 2.17. Параметры папки

Если файлы или папки расположены на диске с файловой системой NTFS, допускается устанавливать дополнительные атрибуты. Нажмите кнопку Другие (Advanced), и на экране появится диалог настройки дополнительных параметров. С помощью флажков в этом диалоге можно задать или снять некоторые атрибуты файлов и папок. Флажки в группе Атрибуты индексирования и архивации (Archive and Index attributes) служат для использования некоторыми вспомогательными программами. Более интересны два оставшихся флажка. Флажок Сжимать содержимое для экономии места на диске (Compress contents to save disk space) позволяет сжимать данные при записи на диск. При этом вы практически не заметите разницы в работе, так как сжатие и восстановление данных будет происходить автоматически, при обращении к жесткому диску.

Флажок Шифровать содержимое для защиты данных (Encrypt contents to secure data) позволяет зашифровать файлы, так что никто не сможет прочитать вашу конфиденциальную информацию. Причем, в отличие от шифрования сжатых папок, данный вид защиты очень надежен.

Установив нужные флажки, нажмите кнопку ОК, чтобы закрыть диалог и вернуться к предыдущему диалогу. В этом диалоге также нажмите кнопку ОК. Если вы изменили атрибуты папки, появится диалог, спрашивающий, хотите ли вы изменить атрибуты только данной папки или нужно изменить атрибуты всех вложенных файлов и папок. Установив переключатель в нужное положение, нажмите кнопку ОК, и атрибуты файлов изменятся. Если вы выбрали сжатие или шифрование папки, в этот момент начнется процедура данного преобразования файлов. Это может занять достаточно много времени. В Windows XP можно настроить, чтобы сжатые файлы и папки отображались в списке синим цветом, а зашифрованные -зеленым.

Следует особо отметить, что после того, как файл или папка зашифрованы или сжаты, с ними работают так же, как и с другими файлами или папками. Шифрование и сжатие являются прозрачными для пользователя, выполнившего эти операции. Перед использованием вовсе не требуется расшифровывать или разархивировать файл. Открытие, редактирование и сохранение файла выполняется как обычно. При этом посторонний человек, пытающийся получить доступ к зашифрованным файлам, не сможет этого сделать. Только пользователь, зашифровавший файл, может открыть его. Естественно, если злоумышленник вошел в Windows XP под вашим именем, система не сможет оградить от него файлы.

Следует помнить, что можно зашифровать только файлы и папки, находящиеся на дисках с файловой системой NTFS. Если вы перенесете файл на другой диск, он может быть расшифрован. Одновременное использование сжатия и шифрования не допускается. Шифрование папки или файла не защищает их от удаления. Любой пользователь, имеющий права на удаление, может удалить зашифрованные папки или файлы.


2.12. Дополнительные возможности проводника

Проводник является очень важной программой, поэтому мы так подробно описали разные варианты работы с ним. Как уже отмечалось, проводник можно запустить с помощью главного меню Windows, а можно выбрать команду просмотра любой папки. При этом проводник будут запущен автоматически. Внешний вид проводника может быть очень сильно изменен. Вы можете открыть или убрать панели поиска и списка папок. Список файлов текущей папки может быть отображен в разном виде, а также отсортирован по различным критериям. Панель задач может присутствовать, а может и быть скрыта. Кроме того, некоторые важные папки имеют свой особый внешний вид. Об особенностях работы с папками Мои рисунки (My Pictures), Мои музыкальные записи (My Music) и Мои видеозаписи (My Videos) будет рассказано ниже. Однако вы можете выбрать аналогичное оформление для любой папки вашего компьютера.

Для этого следует перейти в проводнике к нужной папке и щелкнуть правой кнопкой мыши на свободной области в списке файлов. В появившемся вспомогательном меню выберите команду Настроить вид папки (Customize folder view). На экране появится диалог настройки свойств, открытый на вкладке изменения внешнего вида папки.

В списке, расположенном в верхней части диалога, вы можете выбрать шаблон оформления папки. Вам на выбор предлагается несколько вариантов, разработанных для папок с рисунками, музыкальными произведениями и обычными документами. Установив расположенный ниже флажок, вы измените оформление не только данной папки, но и всех папок, вложенных в нее.

В группе полей Рисунок папки (Folder picture) определяется, какие рисунки расположатся на увеличенном изображении папки. Можно расположить четыре рисунка. Для их выбора следует нажать кнопку Выбрать рисунок (Choose picture) и в диалоге выбора файла, который похож на окно проводника, выбрать нужные графические файлы. Рисунок на папке виден в режиме просмотра эскизов, а также в поле предварительного просмотра на панели задач. В группе полей Значок папки (Folder icons) имеется возможность смены стандартного значка папки. Нажав кнопку Изменить значок (Change icon), вы можете выбрать другой значок для папки. Значок будет отображаться во всех режимах просмотра, кроме режима работы с эскизами. Настроив параметры, нажмите кнопку ОК, диалог закроется, и папка изменит свой внешний вид.

С помощью проводника также можно получать файлы из Интернета и отправлять файлы на другие компьютеры через Интернет. Об этих и некоторых других возможностях проводника будет рассказано ниже.


  • 3. Печать из Windows
    • Добавление и настройка принтера
    • Работа с диспетчером печати
    • Особенности работы с различными принтерами


3. Печать из Windows

Хотя еще недавно много говорили о безбумажных технологиях, время показало, что традиционные документы используются так же широко, как ранее. С помощью различных программ создают и редактируют документы, после чего их распечатывают на принтере. Подготовив текстовый документ, бланк, рисунок, график, диаграмму или любой другой документ с помощью какой-то программы, вы можете отправить его на печать. С помощью принтера создается бумажная копия документа. Для печати документа в большинстве программ достаточно нажать кнопку на панели инструментов или выбрать команду меню Файл * Печать (File * Print). Можно распечатать многие документы непосредственно из проводника. Для этого следует выбрать соответствующую команду панели задач. Также можно распечатать документ, выбрав команду из вспомогательного меню, открывающегося при щелчке правой кнопкой мыши на значке нужного файла.


3.1. Добавление и настройка принтера

Подавляющее большинство современных принтеров не требует специальной процедуры установки в Windows XP. Если по время работы с системой вы включите принтер, предварительно подсоединив его к компьютеру, операционная система обнаружит его и сделает необходимые настройки, чтобы вы могли использовать его при работе с Windows. Через непродолжительное время, необходимое для настройки, новый принтер готов к работе. Однако иногда автоматическая установка может не сработать, и вам придется устанавливать принтер вручную.

Чтобы установить новый принтер, а также для проверки и настройки установленных ранее принтеров, следует открыть специальную папку. Все папки, связанные с оборудованием и настройками системы, расположены в папке Панель управления (Control Panel). Выбрав одноименную команду главного меню Windows XP, вы запустите проводник и откроете соответствующую папку. Подробнее о работе с данной папкой будет рассказано ниже, а пока отметим, что имеются два режима просмотра содержимого папки - классический и режим Web-просмотра. По умолчанию используется второй режим. В этом режиме в правой части окна проводника выведены значки основных групп элементов управления. Щелкните мышью на значке с названием Принтеры и другие устройства (Printers and Other Hardware), чтобы перейти к работе с принтерами, сканерами, цифровыми фотокамерами, клавиатурой, мышью, игровыми устройствами и факсами. В проводнике появятся значки, обозначающие доступные задачи и различные устройства (Рис. 3.1). При этом в панели задач появятся ссылки на другие группы элементов управления. Вы можете запустить процедуру установки принтера, щелкнув мышью на соответствующей ссылке, но лучше сначала перейти к папке, содержащей описание всех установленных в системе принтеров и факсов.

Рис 3.1. Группа в панели управления

Щелкните мышью на значке с названием Принтеры и факсы (Printers and Faxes), чтобы перейти в папку для работы с данным оборудованием. Кстати, если вы используете классический вид панели управления, все значки появятся в правой части окна проводника при выборе команды главного меню Панель управления (Control Panel). Дважды щелкнув на значке, вы перейдете в нужную папку.

Каким бы способом вы не открыли нужную папку, в правой части окна проводника появятся значки, обозначающие все принтеры, установленные на вашем компьютере. Кроме того, в папке расположен значок мастера, облегчающего подключение нового принтера в систему. В этой же папке могут быть значки факсов, о которых будет рассказано ниже. Если ни один из значков не выделен, в панели задач вы увидите команду установки нового принтера. При выделении значка принтера, в панели задач появляются команды для его настройки (Рис. 3.2).

Рис 3.2. Папка для работы с принтерами и факсами

Система Windows ХР позволяет подключать к компьютеру несколько принтеров, поэтому и значков также может быть несколько. Если значок с именем вашего принтера присутствует в папке, то все в порядке, и вы можете печатать на принтере из любой программы, работающей под управлением Windows. Если такого значка нет, то необходимо выполнить процедуру установки принтера. Для облегчения этой процедуры используется специальный мастер установки принтера. Однако следует отметить, что некоторые производители принтеров, такие как, например, Hewlett Packard, снабжают свои устройства дискетой или компакт-диском, содержащим собственную программу установки программного обеспечения принтера, без использования мастера установки Windows. Хотя и для таких принтеров можно воспользоваться мастером, В этом случае будут установлена поддержка принтера, встроенная в систему Windows, а не предлагаемая производителем принтера на диске, который распространяется вместе с ним.

Чтобы запустить мастер установки принтера, надо дважды щелкнуть мышью на значке Установка принтера (Add printer). Первый диалог мастера вводит вас в курс дела и объясняет, что данный мастер шаг за шагом поможет вам установить принтер (Рис. 3.3, слева). Так как в этом диалоге ничего вводить не требуется, сразу перейдем к следующему диалогу. Переход ко второму диалогу осуществляется нажатием кнопки Далее (Next). Второй диалог мастера установки принтера просит вас уточнить, подключен ли принтер непосредственно к вашему компьютеру или этот принтер подключен к компьютерной сети, так же как и ваш компьютер (Рис. 3.3).

Рис 3.3. Первые диалоги мастера установки принтера

Если вы хотите подключить сетевой принтер, следует прочитать раздел нашей книги, касающийся сетевой работы в Windows, или обратиться к администратору сети за помощью. Сейчас мы рассмотрим вариант прямого подключения принтера к вашему компьютеру. Установив флажок в диалоге, вы дадите команду Windows автоматически найти и установить принтер. Нажмите кнопку Далее (Next), чтобы продолжить работу. Если принтер автоматически обнаружен и установлен, вы пропустите несколько последующих шагов. Если же Windows не удалось подключить принтер, об этом вас проинформирует соответствующий диалог (Рис. 3.3, справа). В этом случае вам потребуется указать вручную все нужные параметры, для чего нажмите кнопку Далее (Next). На экране появится следующий диалог мастера, предлагающий вам определить порт, к которому подключен принтер (Рис. 3.4, слева). Этот же диалог появится сразу после второго диалога мастера, если вы не установили флажок автоматического поиска принтера. Обычно используется стандартный порт принтера LPT1 или порт универсальной последовательной шины USB. Для облегчения в диалоге нарисован стандартный разъем, использующийся для подключения с помощью порта LPT1,

Отметим порт с именем FILE. Он описывает виртуальный принтер, который в действительности может отсутствовать на компьютере. Если установить принтер, указав, что он подключен к этому порту, то при печати на таком принтере будет создаваться специальный файл, который вы можете перенести на другой компьютер. Если на этом компьютере установлен принтер, вы можете распечатать его. Таким образом, вы можете, например, печатать на высококачественном принтере с компьютера, к которому такой принтер не подключен. Реально же распечатка будет вестись совсем в ином месте.

Выберите нужный порт, выбрав его в списке, после чего нажмите кнопку Далее (Next), чтобы продолжить установку. После указания порта принтера очередной диалог мастера предлагает вам выбрать модель принтера из списка (Рис. 3.4,). Этот диалог содержит списки производителей и моделей принтеров. Выберите в списке изготовителей производителя вашего принтера, щелкнув на нем мышью. Затем в списке принтеров выберите конкретную модель принтера.

Рис 3.4. Выбор порта и модели принтера

Если вашего принтера в списках нет, то следует воспользоваться дискетой или компакт-диском, который должен быть в комплекте поставки вашего принтера. В этом случае нажмите кнопку Установить с диска (Have disk). На экране появится диалог выбора места, где расположены драйверы (Рис. 3.4). Вы можете ввести путь в поле ввода, а можете нажать кнопку Обзор (Browse), чтобы выбрать нужную папку в появившемся диалоге. После указания адреса драйвера, поставляемого на диске, вы вернетесь к мастеру. Указав одним из способов модель принтера, нажмите кнопку Далее (Next), чтобы перейти к следующему диалогу.

В новом диалоге мастер попросит вас выбрать название для принтера, а также предложит использовать его как принтер по умолчанию (Рис. 3.5). В качестве названия вы можете использовать любое имя, но лучше оставить то название, которое вам предлагает система. Если к вашему компьютеру подключено несколько принтеров, то все программы будут печатать на принтере, используемом по умолчанию. Конечно, вы в любое время можете поменять принтер, используемый по умолчанию, на другой. Скорее всего, к вашему компьютеру подключен один единственный принтер, поэтому вам не надо ничего вводить в диалоге.

Нажмите кнопку Далее (Next), и вы перейдете к следующему диалогу (Рис. 3.5). В нем указывается, будет ли использоваться ваш принтер как сетевой. Если ваш компьютер установлен в сети и другие пользователи будут печатать на принтере, следует ответить утвердительно. В большинстве случаев принтер не будет использоваться совместно.

Рис 3.5. Заключительные диалоги мастера установки принтера

Новый принтер практически установлен. Осталось только проверить его работу, напечатав на нем что-нибудь. Для этого нажмите кнопку Далее (Next) и перейдите к следующему диалогу мастера установки принтеров. Появится диалог, предлагающий напечатать пробную страницу для проверки правильной работы принтера (Рис. 3.5). Лучше установить переключатель в положение, разрешающее печать пробной страницы, после чего следует нажать кнопку Далее (Next) в диалоге.

На экране появится последний диалог мастера, в котором подведен итог выполненной работы (Рис. 3.6). После этого обязательно нужно проверить принтер. Он должен быть подключен к компьютеру, включен и заправлен чистой бумагой. Если принтер готов к работе, нажмите кнопку Готово (Ready), чтобы завершить работу мастера и установить принтер в систему.

Мастер закончит работу, нужные драйверы будут установлены, после чего начнется печать тестовой страницы на принтере. Пробная страница печати предназначена для демонстрации того, что принтер может работать в Windows, а также визуальной проверки качества печати принтера. Кроме того, на этой странице напечатана различная техническая информация, относящаяся к настройкам вашего принтера (Рис. 3.6).

Рис 3.6. Печать пробной страницы

По окончании отправки на печать пробной страницы появится диалог, спрашивающий вас о том, правильно ли напечатана пробная страница (Рис. 3.6). Если вы можете прочитать напечатанный текст пробной страницы и дефектов печати не видно, нажимайте кнопку ОК этого диалога, чтобы закрыть его. Нажатие кнопки Диагностика (Troubleshot) приводит к вызову справочной системы, помогающей решить проблемы при печати. На этом установка нового принтера в операционную систему Windows ХР завершена.

В папке принтеров и факсов появится еще один значок с именем подключешшго принтера. Теперь, когда принтер подключен, он уже настроен по умолчанию, и для большинства случаев такой настройки достаточно. Однако иногда бывает необходимо изменить настройки принтера. Для этого следует выделить значок принтера, щелкнув на нем мышью, и выбрать в панели задач ссылку Настройка печати (Select printing preferences).

На экране появится диалог настройки принтера, имеющий несколько вкладок (Рис. 3.7). Внешний вид диалога настройки сильно различается для разных типов принтеров, но среди параметров, скорее всего, будут присутствовать несколько обязательных. На первой вкладке диалога (Рис. 3.7) устанавливается ориентация листа бумаги, то есть определяется, как будет идти печать - вдоль короткой или вдоль длинной стороны листа бумаги. В списке можно выбрать печать нескольких страниц документа на одном листе бумаги. Это часто используется для экономии бумаги при печати черновиков. Естественно, размеры страниц будут сильно уменьшены. Кроме того, можно установить порядок печати многостраничных документов от начала к концу или наоборот. Изменение порядка печати на некоторых принтерах облегчает сборку листов в правильной последовательности.

Рис 3.7. Настройка печати

На второй вкладке диалога (Рис. 3.7) настраивается качество печати и выбирается бумага. Задается разрешение печати, которое определяет качество получаемых отпечатков. Обычно этот параметр содержит число точек, печатаемое на отрезке бумаги, равном одному дюйму. Чем больше это значение, тем выше качество печати. Иногда этот параметр зам/еняют словесным описанием качеству печати. Задается высокое среднее, низкое качество, при этом не используются цифры. Большинство принтеров имеют несколько источников подачи бумаги, например, для обычных листов и для конвертов. В списке, расположенном в диалоге, определяется, откуда будет поступать бумага при печати. Для некоторых принтеров можно выбрать используемый тип бумаги. Если принтер поддерживает цветную печать, можно выбрать между черно-белой и цветной печатью.

Для более сложной настройки принтера следует нажать кнопку Дополнительно (Advanced). При этом появится диалог настройки, позволяющий изменить абсолютно все параметры печати, которые можно настраивать в данной модели принтера. Однако в большинстве случаев такая настройка не понадобится.

Дополнительные возможности работы с некоторыми принтерами реализованы с помощью специальных программ, ссылки на которые находятся на отдельной вкладке диалога (Рис. 3.7). С помощью этих программ можно, например, проверить работоспособность принтера и в некоторых случаях восстановить ее. Настроив все параметры, нажмите кнопку ОК в диалоге, чтобы закрыть его. Следует отметить, что изменения настроек, выполненные описанным способом, будут действовать при использовании принтера во всех программах. Если же вы при работе с какой-то программой измените текущие настройки принтера, перейдя к настройке из диалога печати, изменения будут действовать только при печати из этой программы И отменяться, когда вы завершите работу с программой. При следующем запуске программы настройки печати вновь будут прежними.


3.2. Работа с диспетчером печати

Как отмечалось ранее, в Windows одновременно могут работать несколько программ. И все они могут одновременно начать печатать. Естественно, в этом случае принтер не сможет ничего напечатать. Кроме того, программы могут отправлять документы на печать значительно быстрее, чем принтер сможет их напечатать. Желательно организовать очередь из заданий йа печать. Для решения этих прбблем каждая программа работает не напрямую с принтером, а через диспетчер печати. Основная задача диспетчера - осуществлять очередность печати различных документов. Когда печать запущена, на панели задач Windows появляется значок ^, показывающий, что запущен диспетчер печати. Если дважды щелкнуть мышью на этом значке, то откроется рабочее окно диспетчера печати (Рис. 3.8). Также открыть окно можно с помощью двойного щелчка на значке принтера в папке Принтеры и факсы (Printers and Faxes).

Рис 3.8. Рабочее окно диспетчера печати

В заголовке окна написано имя используемого принтера. Все документы, которые были отправлены на печать, представлены в рабочем окне в биде таблицы. Каждый документ занимает строку таблицы, и в этой строке содержатся имя документа, состояние документа (постановка в очередь, печать и так далее), общее количество страниц документа, число напечатанных страниц, размер, время и дата отправки документа на печать. Во время работы принтера вы можете управлять им, например, приостанавливать и возобновлять печать, удалять документы из очереди и так далее. Действия над всеми документами в очереди печати осуществляются с помощью команды меню Принтер (Printer). Команда в этом меню Настройка печати (Printing preferences) позволит настроить параметры принтера, о чем рассказывалось выше. Команда Использовать по умолчанию (Set As Default Printer) установит использование по умолчанию данного принтера во всех программах. Выбрав команду Приостановить печать (Pause Printing), вы временно запретите печать на этом принтере. Повторный выбор команды разрешит печать. Команда Очистить очередь печати (Cancel All Documents) удалит все задания, поставленные в очередь к данному принтеру.

Кроме управления всей очередью, можно управлять каждым документом в очереди отдельно. Следует выбрать какой-либо документ в очереди, щелкнув на нем правой кнопкой мыши. При этом появится вспомогательное меню, позволяющее управлять печатью выбранного документа. Вы можете сделать паузу в печати документа, возобновить печать, повторить печать сначала, а также отменить печать. Кроме того, команда вспомогательного меню Свойства (Options) позволит вам менять параметры печати выбранного документа, такие как приоритет печати, качество печати, ориентацию страницы при печати, число копий и тому подобные.


3.3. Особенности работы с различными принтерами

Несмотря на то, что существует много типов принтеров, имеющих различный принцип действия, работа с принтерами в Windows происходит практически одинаково. Однако при печати следует все же учитывать особенности работы с различными принтерами. Например, один и тот же текстовый документ на разных принтерах будет напечатан по-разному. Это происходит потому, что программа работы с принтером, называемая драйвером и обычно разрабатываемая фирмой-производителем этого принтера, по-разному воспринимает те шрифты, которыми набран документ. При печати документа происходит его преобразование в набор точек, которые и выводятся на принтер. Каждый драйвер принтера преобразует шрифты в набор точек по-своему, из-за чего может меняться размер страницы и форматирование документа.

В последнее время широкое распространение получили так называемые Win-принтеры, в которых, в отличие от других принтеров, задачу формирования изображения выполняют центральный процессор и память вашего компьютера.

Особенностью применения таких принтеров является требование достаточно мощного процессора на компьютере, чтобы он успевал формировать изображение для принтера при печати и работать с другими программами. Если мощности процессора недостаточно, то при печати изображение будет искажаться.

Особенность работы лазерных принтеров в том, что они печатают страницу целиком и не могут печатать ее по частям. Если на странице слишком много элементов для печати, памяти принтера может не хватить для правильной работы. Если ваш лазерный принтер отказывается печатать некоторые документы, попробуйте упростить их или добавить в принтер память.

Чернила в струйных принтерах могут высыхать, засоряя печатающую головку. Если при печати цветных рисунков не хватает одного цвета, следует прочистить печатающую головку, запустив специальную программу, или сменить картридж с чернилами.

Качество печати струйных принтеров сильно зависит от качества бумаги. Для получения высококачественных отпечатков необходимо использовать специальную бумагу для струйной печати, которая стоит дороже обычной.

Как лазерные, так и струйные принтеры позволяют печатать на прозрачной пленке, самоклеющихся этикетках и прочих оригинальных материалах. Если вы заинтересованы в использовании необычных материалов для печати, приобретите их в специализированном магазине.


  • 4. Использование справочной системы
    • Использование содержания
    • Использование предметного указателя
    • Поиск необходимой информации


4. Использование справочной системы

Если при работе с Windows XP у вас возникают какие-либо вопросы или трудности, система поможет вам быстро и легко найти ответы на многие ваши вопросы. Кроме того, что каждая программа обладает своей системой подсказок, существует общее справочное руководство по Windows XP. К этому руководству можно обратиться, выбрав команду главного меню Справка и поддержка (Help and Support). Будет запущена справочная служба операционной системы Windows XP (Рис. 4.1). Появившееся окно напоминает Web-страницу Интернета. Оно красиво оформлено и содержит ссылки на различные темы. Кроме того, предусмотрено поле ввода для поиска справочной информации.

Рис 4.1. Главное окно справочной системы

Обычно ссылки выделяются в документе цветом или подчеркиванием. Указатель мыши, проходя над ссылкой, меняет свою форму на стилизованное изображение руки. Если щелкнуть мышью на ссылке, будет осуществлен переход на новую страницу, и она будет загружена в рабочее окно программы просмотра справочной информации. Щелкая мышью на интересующих вас ссылках, вы можете ознакомиться с необходимой справочной информацией.


4.1. Использование содержания

После того, как справочная система запущена, в рабочем окне отображается содержание, показывающее полный список статей справочника, оформленного в виде ссылок. Каждая тема содержания описывает отдельную область подсказок, например, печать в Windows или работа в Интернете. Выбор темы из содержания осуществляется щелчком мыши на соответствующей ссылке. В некоторых случаях ссылки организованы в виде дерева, как папки в проводнике Windows. Последовательно переходя по ссылкам, вы загрузите в окно содержимое выбранной темы (Рис. 4.2).

Рис 4.2. Использование разделов содержания

Окно разделено на две части. В левой части отображается список разделов выбранной темы содержания, а в правой части отображается текст выбранного раздела. Чтобы выбрать конкретный раздел, надо щелкнуть мышью на ссылке с его названием, расположенной в левой части окна. После этого в правой части окна появится текст справки по конкретному разделу. Для перехода к другому разделу справочника необходимо щелкнуть на другой ссылке. Ссылка Начало (Ноте), расположенная под заголовком окна, вернет вас к первому окну справочной системы. Кроме того, для возврата к ранее

просмотренным разделам справки, можно нажать кнопку, расположенную слева в верхней части окна. При желании вы можете распечатать просматриваемый раздел справки, щелкнув мышью на соответствующей ссылке. Чрезвычайно полезным может оказаться использование журнала просмотренных разделов. Щелкнув мышью на ссылке Журнал (History), вы откроете список разделов, просмотренных вами ранее. Так вы сможете легко найти нужную информацию.


4.2. Использование предметного указателя

Чтобы воспользоваться предметным указателем, необходимо щелкнуть мышью на ссылке Указатель (Index), расположенной в верхней части окна. При этом в рабочее окно будет загружен список всех терминов, которые встречаются в справочной системе, причем эти термины отсортированы в алфавитном порядке (Рис. 4.3). Вы можете с помощью полосы прокрутки найти нужный вам термин. Чтобы отобразить содержимое статьи, включающей данный термин, необходимо дважды щелкнуть мышью на интересующей нас ссылке. Можно просто выбрать ссылку, один раз щелкнув на ней мышью, а затем нажать кнопку Показать (Display).

Рис 4.3. Использование предметного указателя

Удобнее воспользоваться полем ввода для быстрого поиска термина среди тем, имеющихся в указателе. Щелкните мышью в поле, расположенном над списком слов, после чего начните набирать на клавиатуре интересующее вас слово. При этом указатель будет автоматически перемещаться к разделу, содержащему это слово. Указатель представляет собой темную полосу, выделяющую элемент списка. Отобразить выделенный раздел можно точно так же, как описано выше, например, нажать кнопку Показать (Display). В правой части окна появится содержимое раздела, содержащее выбранный термин.


4.3. Поиск необходимой информации

Если вы не знаете точно, в каком разделе справочной системы находится интересующая вас информация, и затрудняетесь с формулированием термина для использования указателя, можно попытаться воспользоваться средством поиска информации. Вы можете задать для поиска одно или несколько слов, и справочная система предложит список разделов, в которых встречается данное слово или словосочетание. Средство поиска может найти разделы, которые вам нужны, но их названия не говорят вам ни о чем, так как информация ищется не только в заголовке, но и в содержимом разделов справки.

При использовании справочной системы в любое время можно найти интересующее нас слово или фразу с помощью поля ввода Поиск (Search), расположенного в правом верхнем углу окна справочной системы. Требуется просто щелкнуть мышью на этом поле и ввести при помощи клавиатуры одно или несколько слов. После ввода слова или фразы необходимо нажать кнопку Найти (Search), расположенную рядом с полем. Список разделов справочной системы, в которых находится интересующая вас информация, будет показан в левой части окна (Рис. 4.4). Далее вы можете выбрать нужный раздел и просмотреть его содержимое.

Вы также можете уточнить запрос, проведя повторный поиск. Установив флажок, расположенный над списком найденных разделов, и введя новое слово или предложение для поиска, вы будете искать в разделах, отобранных ранее. Если поиск выполняется слишком долго, вы можете остановить его, нажав одноименную кнопку.

Рис 4.4. Использование поисковой системы

Использование поисковой системы позволяет разыскать в статьях справочника любые слова, в том числе и не отображаемые с помощью указателя. Особенно ценной является возможность совместного использования разных методов работы со справкой. Например, вы можете перейти по ссылкам в интересующий вас раздел, установить флажок поиска внутри раздела, расположенный ниже поля поиска, и выполнить поиск. Это существенно сузит область поиска и, как следствие, повысит качество полученных результатов.

Следует отметить, что справочная система Windows XP достаточно подробно описывает все особенности работы системы. При возникновении трудностей вы всегда сможете найти в ней подробный и квалифицированный ответ.


  • II. Работа с программами в составе Windows ХР
    • Создание текстовых документов
      • Знакомство с окном редактора WordPad
      • Ввод первого текста
      • Особенности работы с клавиатурой
      • Использование мыши
      • Редактирование текста
      • Оформление документа
      • Выделение фрагментов текста
      • Форматирование символов
      • Форматирование абзацев
      • Печать и сохранение документов
      • Печать документов
      • Сохранение документов в файлах
      • Открытие ранее созданных документов
      • Дополнительные возможности редактора
      • Добавление даты и времени
      • Поиск в тексте
      • Отмена, буфер обмена и использование цвета


II. Работа с программами в составе Windows ХР

В состав Windows ХР включено несколько программ обеспечивающих работу с текстами и рисунками, доступ в Интернет, редактирование и прослушивание звуковых файлов, создание и просмотр видеоклипов. Для многих действий вам не понадобиться устанавливать дополнительных программ, вы сможете обойтись средствами, включенными в состав операционной системы Windows ХР.


5. Создание текстовых документов

Самым распространенным занятием на компьютере является создание текстовых документов. Ввести текст с клавиатуры красиво его оформить, распечатать на принтере и сохранить для дальнейшей работы поможет вам любой текстовый редактор. В состав Windows ХР входит текстовый редактор WordPad. С его помощью можно создавать достаточно сложные документы.


5.1. Знакомство с окном редактора WordPad

Нажмите кнопку Пуск (Start) и выберите команду меню Все программы (More Programs), а во вложенном меню выберите команду Стандартные (Accessories), чтобы открыть еще одно вложенное меню. В этом меню и находится искомый текстовый редактор. Запустите программу WordPad, щелкнув мышью на соответствующей команде меню. Будет запущен простой текстовый редактор, входящий в состав Windows. Если вы ранее запускали его, нужная команда может находиться и в первом меню, которое открывается нажатием кнопки Пуск (Start).

Рассмотрим основные элементы окна данного редактора (Рис. 5.1). Как и у большинства программ, работающих под управлением Windows ХР в верхней части рабочего окна находятся заголовок, меню и панели инструментов. В WordPad есть основная панель инструментов и панель форматирования.

В нижней части окна расположена строка состояния/ в которой выводится различная полезная информация. В центре окна имеется рабочая область, то есть место/ на котором будет отображаться вводимый вами текст. Для облегчени я оформления текстов над рабочей областью помещена измерительная линейка.

Рис 5.1. Рабочее окно текстового редактора WordPad

Редактор работает с текстом в виде документов. Документ - это то, что вы видите на рабочем поле текстового редактора. Документ включает в себя текст который вы набираете, красиво оформленный, в соответствии с вашими пожеланиями. Кроме этого, документ может содержать рисунки таблицы и другие элементы оформления, но для начала мы познакомимся с исключительно текстовыми документами. Документы хранятся в отдельных файлах на диске. При запуске текстового редактора создается новый, пустой документ. Вы можете вводить в него текст, сохранять его в файле на диске, чтобы в следующий раз прочитать его и продолжить работу.

Важным понятием в текстовых редакторах является понятие абзаца. Это понятие отличается от традиционного представления. Если традиционно абзацем считается группа предложений, объединенных одной мыслью, то в текстовых редакторах абзацем называется отрывок текста, оканчивающийся там, где была нажата клавиша . Абзацем может быть и одна буква, и многостраничный текст, при этом редактор сам разбивает вводимый текст на отдельные строки. Смысловое содержание текста для редактора значения не имеет. Помните, что, нажимая клавишу , вы не просто переходите к новой строке, а начинаете новый абзац. Но пора закончить с теорией и начать создание вашего первого документа.


5.2. Ввод первого текста

После запуска текстового редактора WordPad и автоматического создания нового документа, настала пора приступить к вводу текста. Текст вводится предельно просто. Вы нажимаете на клавиши клавиатуры, и на экране появляются символы. Символы появляются в месте, обозначенном мигающей вертикальной чертой, называемой текстовым курсором (Рис. 5.2). При создании нового документа текстовый курсор располагается в левой верхней части рабочей области.

Рис 5.2. Текстовый курсор

Найдите текстовый курсор и нажмите любую клавишу на клавиатуре. Соответствующая буква появится на экране, а текстовый курсор переместится на одно место вправо. Нажмите клавишу и курсор передвинется еще правее. Таким образом, добавляются пробелы между словами. Нажимая различные клавиши, введите десять-пятнадцать слов. Обратите внимание, что при достижении правой границы документа WordPad автоматически начнет располагать слова на новой строке. Чтобы перейти к новой строке не доходя до правой границы документа, следует перейти к новому абзацу. Нажмите клавишу , и текстовый курсор переместится к началу следующей строки. Этим действием вы начали новый абзац.

Попробуйте ввести несколько абзацев, каждый из которых будет состоять из нескольких предложений. Пока наша работа мало отличается от печати на пишущей машинке но текстовый редактор предоставляет значительно больше возможностей. Для начала познакомимся с особенностями использования клавиатуры компьютера.


5.3. Особенности работы с клавиатурой

Вначале остановимся на клавишах, аналог которых есть и на пишущей машинке. Если вам надо ввести прописную букву, нажмите клавишу и, не отпуская ее, нажмите клавишу с нужной буквой после чего отпустите обе клавиши. Для ввода фрагмента текста, состоящего из прописных букв, нажмите клавишу .При этом на клавиатуре зажжется индикатор с такой же надписью. Теперь все вводимые буквы будут прописными. Повторное нажатие клавиши погасит индикатор, после чего будут вводиться строчные буквы.

На компьютере можно вводить как русский, так и английский текст. Есть несколько способов выбора языка но мы опишем самый простой. Найдите на рабочем столе панель со значком или и названием соответствующего языка - русский (RU) или английский (EN). Чаще всего эта панель расположена в правом верхнем углу рабочего стола. Она называется панелью языка. Отметим, что возможность выбора того или иного языка определяется при установке Windows. Щелкните мышью на названии языка в панели и рядом появится вспомогательное меню выбора языка (Рис. 5.3).

Рис 5.3. Меню выбора языка

Галочкой в меню отмечен установленный в настоящее время язык. Щелкните мышью на строке с необходимым языком, меню будет убрано с экрана, и язык для ввода текста поменяется. При этом изменится и значок с на или наоборот, а также название языка на панели языка. Если панель языка отсутствует, аналогичный значок можно найти в правой части панели задач. Щелкните мышью на значке, и рядом появится вспомогательное меню, в котором вы можете выбрать нужный язык.

Другим способом переключения между языками является нажатие определенной комбинации клавиш. Чаще всего надо одновременно нажать клавиши и , расположенные в левой части клавиатуры. Нажатие таких же клавиш в правой части не приведет к желаемому результату. Значительно реже используются клавиши и . Если с помощью клавиш у вас не получается переключать язык значит на вашем компьютере используется иная комбинация и вам лучше переключать язык с помощью панели языка.

У начинающих пользователей компьютера часто возникают проблемы с вводом различных знаков препинания, поэтому мы остановимся на этой проблеме. На большинстве клавиатур нарисованы знаки препинания черного и красного цвета. Знаки препинания черного цвета проставляются при выбранном английском языке а красного - при выбранном русском. Символы нарисованные в верхней части клавиши вызываются нажатием клавиши одновременно с клавишей . Например если у вас на клавиатуре есть клавиша на которой буква Ж красного цвета то при выбранном русском языке в текст вставляется строчная буква ж, а при нажатии клавиш и в текст будет вставлена прописная буква Ж . Если же выбран английский язык то при нажатии клавиши в текст будет вставлен знак точки с запятой а при нажатии клавиш и в текст вставится двоеточие. Но некоторые клавиши могут быть связаны с символами отличными от тех что нарисованы на них. Это относится только к символам вводимым при выбранном русском языке. Например на многих клавиатурах есть клавиша . Однако выбрав русский язык и нажав эту клавишу вы не увидите русскую букву а в текст будет вставлена точка. При нажатии клавиш и , в текст будет вставлена запятая. Выяснить точно какие символы связаны с какими клавишами, можно экспериментально. Попробуйте нажимать различные клавиши и смотрите какие символы появятся на экране. Возможно некоторые надписи на клавишах вашей клавиатуры окажутся ошибочными.

Чтобы вводить текст в любое место документа а также для просмотра различных частей большого документа необходимо уметь передвигаться по тексту. Как уже отмечалось символы вводятся в место отмеченное курсором. Чтобы поместить курсор в нужное место используется несколько клавиш. В правой части клавиатуры расположены четыре клавиши . и Они называются клавишами управления курсором и перемещают его в направлении стрелки изображенной на клавише. Нажмите несколько раз эти клавиши и вы увидите как текстовый курсор будет передвигаться по тексту.

Вместо того чтобы нажимать одну и ту же клавишу много раз можно нажать ее и удерживать некоторое время. Через небольшое время курсор начнет непрерывно двигаться пока вы не отпустите клавишу. Попробуйте например нажать и удерживать клавишу и через некоторое время курсор разместится в конце текста. Далее передвинуть курсор нельзя.

Чтобы быстрее передвигаться вперед и назад по большому документу можно использовать клавиши и . Нажатие клавиши передвигает курсор на страницу вперед а клавиша передвигает курсор на страницу назад. Введите несколько страниц текста и попробуйте воспользоваться этими клавишами.


5.4. Использование мыши

Если вы не испытываете затруднений при работе с компьютерной мышью то вам покажется более удобным использовать для передвижения по тексту не клавиши клавиатуры а мышь. Подведите указатель мыши к месту куда вы хотите перейти и щелкните левой кнопкой. Текстовый курсор появится именно в этом месте. Это произойдет только в том случае если указатель мыши находится в допустимом для ввода символов месте что указывается специальным видом указателя мыши - I. Если же указатель принял вид или , то в данном месте вводить текст нельзя и щелчок мыши приведет к другим действиям. Если ваш текст не помещается целиком на одном экране то требуется прокрутить текст в окне таким образом чтобы на экране был виден нужный фрагмент текста. Для этого в правой части окна документа располагается специальный элемент называемый полосой прокрутки (Рис. 5.4). По краям полосы прокрутки расположены кнопки со стрелками. Прямоугольник помещенный между кнопками, называется ползунком. Он показывает текущее относительное положение просматриваемого фрагмента в тексте. Относительное означает, что, если ползунок находится в середине полосы прокрутки, то и текущий фрагмент текста в окне находится в середине документа. Размеры ползунка могут изменяться в зависимости от соотношения размера видимого фрагмента текста и размера всего текста целиком. Если текст помещается целиком в окне то полоса прокрутки может отсутствовать.

Рис 5.4. Полоса прокрутки и ползунок

Проще всего прокручивать текст с помощью кнопок полосы прокрутки. Щелкните мышью несколько раз на кнопках и и текст будет сдвинут в сторону, в которую указывает стрелка на кнопке. Причем, если нажать одну из этих кнопок и не отпускать ее, то текст начнет непрерывно двигаться в указанную сторону. Движение прекратится после того, как вы достигнете конца или начала документа, или отпустите кнопку. Передвигаться вверх или вниз можно также, щелкая по вертикальной полосе прокрутке выше или ниже ползунка.

Еще одним способом прокрутки документа является перетаскивание ползунка. Подведите указатель мыши к ползунку на полосе прокрутке, нажмите левую кнопку мыши, и, не отпуская ее передвиньте указатель мыши вниз. Вместе с указателем начнет двигаться ползунок, а документ начнет прокручиваться от начала к концу. Перетащите мышью ползунок полосы прокрутки вниз до упора, после чего отпустите кнопку мыши. Вы увидите нижний край страницы. Если ваш документ состоит из нескольких страниц, то таким образом вы можете переходить со страницы на страницу.

После того, как вы перешли к просмотру нужного фрагмента текста, щелкните мышью в необходимом месте текста, и в этом месте появится текстовый курсор.

Вы уже знаете, как вводить текст и передвигаться по введенному тексту но для реальной работы требуется иметь возможность исправлять ранее введенные фрагменты. Эти действия называются редактированием текста, и сейчас мы ими займемся.


5.5. Редактирование текста

Вначале рассмотрим, как удалять введенные ранее символы. Установите курсор в середину любого слова и нажмите клавишу . Будет удален символ, расположенный справа от курсора. Нажмите клавишу и вы удалите символ слева от курсора. Многократное нажатие любой из этих клавиш удаляет множество символов. Попробуйте и убедитесь в этом сами. Чтобы добавить символы в любое место документа, требуется установить в это место текстовый курсор и просто ввести фрагмент текста с клавиатуры. Все символы, расположенные за курсором, будут сдвинуты вправо а новые символы будут вставлены в освободившееся место. Вставьте несколько новых слов в середину введенного текста.

Отметим, что символ конца абзаца является таким же символом, как и другие. Установите курсор в конец предпоследнего абзаца и нажмите клавишу . Символ конца абзаца будет удален, и два последних абзаца будут объединены в один. Нажмите клавишу и абзац будет снова разбит на два.

Вот и все, что можно сказать о редактировании текста в редакторе WordPad. Далее мы остановимся на превращении текста в красиво оформленный документ.


5.6. Оформление документа

В отличие от пишущей машинки в которой внешний вид букв изменить нельзя текстовый редактор позволяет менять написание символов расстояние между буквами словами строками а также многое другое. Изменение внешнего вида текста при котором не меняется его содержимое, называется форматированием. Например слово «пример» можно отформатировать такими различными способами: Пример, пример, Пример . При этом буквы из которых состоит слово не изменятся. Изменится только их начертание, то есть внешний вид. Такое форматирование называется форматированием символов. Кроме него, в текстовых редакторах используется форматирование абзацев, то есть установка отступов абзацев и их выравнивание. Например, следующие два абзаца отформатированы иначе, чем остальной текст книги.

В этом абзаце используется выравнивание по центру и отступ от краев текста.

При этом форматирование абзацев может сочетаться с форматированием символов .

Давайте приступим к форматированию текста и на примерах разберемся с возможностями текстового редактора WordPad по оформлению документов. Однако перед тем как приступить к форматированию, надо научиться выделять фрагменты текста. Форматируется выделенная часть текста. Давайте разберемся, что такое выделение и как его делать.


5.6.1. Выделение фрагментов текста

Выделенный текст на экране отображается негативом, то есть белыми буквами на темном фоне (Рис. 5.5). В нашем примере выделены четыре буквы слова. Если выбрать команды меню или нажать кнопки на панелях инструментов, которые меняют форматирование символов, то изменится начертание только этих четырех букв.

Рис 5.5. Выделенный фрагмент

Выделять фрагменты можно, как мышью, так и клавиатурой, но без определенного навыка работать с мышью несколько сложно, поэтому мы вначале рассмотрим способы выделения фрагментов с помощью клавиатуры.

Установите текстовый курсор перед первой буквой любого введенного ранее слова. Нажмите клавишу и, не отпуская ее, нажмите несколько раз клавишу Н. после чего отпустите . Несколько букв данного слова остались выделенными.

Нажмите еще раз клавишу и выделение будет снято. Таким способом удобно выделять небольшие фрагменты текста от одного символа до нескольких слов. Если же вам надо выделить одну или несколько строк или целый абзац (Рис. 5.6), то можно воспользоваться немного иным способом.

Рис 5.6. Выделение строк и абзаца

Установите курсор в начало любого абзаца, нажмите клавишу и не отпуская ее нажмите клавишу Shift . Будет выделена первая строка абзаца (Рис. 5.6, слева). Все еще удерживая клавишу нажмите несколько раз клавишу Shift пока не будут выделены все строки абзаца (Рис. 5.6, справа). Теперь можно отпустить клавишу

Иногда требуется выделить весь текст целиком. В этом случае установите курсор перед первым символом текста, нажмите клавишу и, не отпуская ее, несколько раз нажмите клавишу пока не будет выделен весь текст после чего отпустите клавишу

С помощью нескольких описанных приемов вы можете выделять любой фрагмент текста. Для этого необходимо установить курсор в начало фрагмента, нажать клавишу и, не отпуская ее, переместить курсор в конец выделяемого фрагмента, после чего отпустить клавишу Существует также возможность выделения всего текста. Выделение всего текста осуществляется при одновременном нажатии клавиш и . Попробуйте самостоятельно выделить различные фрагменты текста.

Следует отметить что если после выделения фрагмента текста вы нажмете клавишу или то весь выделенный фрагмент будет удален. При начале ввода любого текста если имеется выделенный фрагмент новый текст заменит старый. Так можно удалять и заменять целые блоки текста.

Текст можно выделять и с помощью мыши. Чтобы выделить отдельное слово необходимо дважды щелкнуть на нем мышью. Если щелкнуть на слове трижды будет выделен целиком весь абзац. Если вы хотите выделить произвольный фрагмент текста необходимо выполнить более сложные действия. Сначала подведите указатель мыши к началу выделяемого текста. Затем нажмите кнопку мыши и не отпуская ее перемещайте указатель в сторону конца выделяемого фрагмента. По мере передвижения указателя текст будет выделяться. После того, как вы достигнете конца выделяемого фрагмента текста отпустите кнопку мыши. Текст между местом, на котором вы нажали кнопку мыши и местом где вы ее отпустили останется выделенным. Щелкнув мышью в произвольном месте вы снимете выделение.

Для выделения больших фрагментов текста используются щелчки на левом поле документа, левее текста, которое называется полосой выделения. Подведите указатель мыши левее текста абзацев и он примет вид . Если указатель примет вид значит, вы не попали на полосу выделения. Установите указатель мыши на полосу выделения левее абзаца и щелкните мышью один раз. Одна строка текста, напротив которой находился указатель будет выделена. Не двигая мышь, щелкните дважды. Выделен будет уже весь абзац. Щелкните мышью трижды, и будет выделен весь текст. Возможно, тройной щелчок у вас не получится с первого раза. В этом случае попытайтесь еще раз выделить текст.

Научившись выделять с помощью мыши произвольные фрагменты текста, вы существенно ускорите редактирование и форматирование документов. Помните, что мышь является основным инструментом в любой программе работающей под управлением Windows. После того, как вы научились выделять любые части текста, можно приступать к форматированию и начнем мы с форматирования символов.


5.6.2. Форматирование символов

Форматирование символов заключается в задании их шрифта/ размера и начертания. Если всем ясно что такое размер (Рис. 5.7, в центре), то о шрифте и начертании следует рассказать более подробно.

Рис 5.7. Примеры форматирования символов

Шрифтом называется ранее разработанный набор изображений всех букв алфавита, цифр, знаков препинания и специальных символов. Одни и те же символы, отформатированные с использованием различных шрифтов, могут сильно отличаться друг от друга (Рис. 5.7, слева). Вместе с Windows поставляется несколько Шрифтов кроме того имеется возможность установки в Систему Дополнительных шрифтов широко представленных на рынке.

Символы отформатированные с помощью одного шрифта могут иметь различные размеры и начертание. Под начертанием понимается внешний вид символов: обычный полужирный курсив (то есть наклонный) или подчеркнутый (Рис. 5.7, справа). При этом возможно сочетание нескольких видов начертания.

Проще всего выполнить форматирование символов с помощью управляющих элементов расположенных на панели форматирования. Для этого используются три элемента: список шрифтов список размеров и кнопки выбора начертания. В последних версиях программ вместо кнопок на панели инструментов расположены только рисунки а обрамляющие рамки появляются только тогда, когда к рисунку подводится указатель мыши. Но мы все равно, для простоты будем называть их кнопками.

Список шрифтов выглядит как название шрифта на панели форматирования Шрифт с названием Times New Roman входит в состав Windows. Возможно у вас выбран другой шрифт но в любом случае вы можете найти на панели инструментов элемент с названием шрифта. Подведите указатель мыши к значку расположенному в правой части списка шрифтов после чего нажмите и отпустите левую кнопку мыши то есть щелкните мышью на кнопке Ниже появится список установленных у вас. шрифтов (Рис. 5.8). Если вы щелкнете мышью на названии одного из шрифтов то он будет назначен выделенному фрагменту текста. Однако в Windows бывает установлено достаточно много шрифтов и они могут не поместиться в появившейся рамке. Чтобы просмотреть все варианты следует воспользоваться специальной полосой расположенной в правой части списка. Сверху и снизу полосы имеются кнопки и . Они предназначены для передвижения по списку шрифтов. Нажмите несколько раз кнопку и вы передвинетесь вниз по списку шрифтов, а нажатие кнопки позволит передвинуться вверх. Найдя нужный шрифт следует щелкнуть на его названии мышью, и он будет выбран.

Рис 5.8. Выбор шрифтов

Выбор нужного шрифта является важным делом, и мы остановимся на нем подробнее. Рядом с названиями большинства шрифтов можно увидеть значок или . Эти значки обозначают, что данный шрифт будет одинаково хорошо выглядеть на экране и при печати на принтере. Кроме того, такие шрифты позволяют выбрать любой размер, сохраняя при этом высокое качество. Мы рекомендуем использовать только шрифты, отмеченные значками или .

Текстовый редактор WordPad добавляет к названию шрифта особенности выбранного языка (Кириллица или Cyrillic). В списке , расположенном в панели форматирования вы можете выбрать нужный язык для выбранного шрифта.

Какие же шрифты следует использовать при создании документов? Тут нет точных рекомендаций, однако чаще всего для форматирования заголовков, надписей и выделения небольших фрагментов используется шрифт Arial, а для форматирования основного текста используется Times New Roman. Если вам нужно, чтобы документ напоминал напечатанный на пишущей машинке, следует использовать шрифт Courier New. Для оригинальных надписей можно рекомендовать шрифт Comic Sans Ms.

Выбор размера символов очень похож на выбор шрифта. Правее списка шрифтов в панели инструментов находится список размеров . Нажмите на кнопку , и рядом появится перечень возможных размеров. Точно так же, как в списке шрифтов вы можете выбрать любой размер символов.

Но что означает десятый размер шрифта? Много это или мало? В текстовых редакторах используется типографская единица измерения, называемая пунктами. Один пункт равен примерно 0,353 миллиметра, соответственно 10 пунктов равно примерно трем с половиной миллиметрам. Высота прописных букв шрифта равна приблизительно трем четвертям указанного размера, а строчных - немного более половины. Для большинства документов используется шрифт размером 12 пунктов. Многостраничные документы, книги и брошюры лучше форматировать шрифтом десятого или одиннадцатого размера.

Чтобы часть текста отличалась от остального часто используют различное начертание. Для изменения начертания используют три кнопки на панели форматирования: кнопка или в английской версии используется для выбора полужирного начертания, кнопка , для использования курсива и для подчеркивания. После того, как вы нажмете нужную кнопку, она останется в нажатом состоянии. Повторное нажатие отменит выбранное начертание, и кнопка будет отжата. Если вы одновременно нажмете две или все три кнопки, то будет выбрана комбинация начертания.

После того, как вы познакомились с различными вариантами форматирования символов, надо поэкспериментировать с изменением форматирования введенного текста. Выделите весь текст и выберите для него шрифт Times New Roman размером 12. После этого выделите несколько слов и выберите шрифт Arial. Нажмите кнопки и , чтобы слова изменили начертание на полужирный курсив. Попробуйте самостоятельно изменить форматирование различных фрагментов текста.

Рассмотрим еще один способ форматирования символов. Установите текстовый курсор в середине текста. При этом ни один фрагмент текста не выделен. Выберите шрифт Courier New размером 24. Внешне ничего не изменилось, но текстовый редактор изменил форматирование для вновь вводимых символов. Введите несколько ело», и вы увидите, что новые символы будут отформатированы указанным шрифтом
Форматируются только выделенные символы. Если в тексте не выделен фрагмент, после изменения форматирования, по-новому будут выглядеть все вновь введенные символы.

Форматирование символов позволяет значительно украсить документ, однако придать ему законченный вид позволит форматирование абзацев.


5.6.3. Форматирование абзацев

Если вам понадобится поместить заголовок документа в центре строки, что вы сделаете? Добавите в начало строки множество пробелов? Этого делать не надо ни в коем случае! Следует просто установить выравнивание по центру для абзаца, в котором содержится заголовок. Что такое выравнивание, можно понять из примера (Рис. 5.9).

Рис 5.9. Разные варианты выравнивания

Чтобы выполнить форматирование одного абзаца, достаточно установить в нем текстовый курсор. Выделять абзац не обязательно. Если же вы хотите изменить форматирование нескольких абзацев то следует выделить их. Также требуется выделить весть текст чтобы изменить форматирование всех абзацев документа. После того, как вы установили курсор в нужном абзаце или выделили несколько абзацев, можно изменить форматирование с помощью кнопок на панели форматирования.

Для назначения определенного выравнивания используют кнопки: для выравнивания по левому краю, для выравнивания по правому краю, для выравнивания по центру. Рисунки на кнопках показывают, как будет выравниваться текст и их легко запомнить. К сожалению, в текстовом редакторе WordPad отсутствует возможность выравнивания по обоим краям, она имеется только в более мощных редакторах, таких как, например. Word.

Возвращаясь к созданию заголовков, давайте попробуем это сделать. Установите курсор в начало текста введите несколько слов заголовка и нажмите клавишу чтобы выделить заголовок в отдельный абзац. Снова установите курсор в начало текста после чего нажмите кнопку на панели инструментов. Заголовок будет расположен точно по центру документа.

Выделите все оставшиеся абзацы и нажмите кнопку С помощью выравнивания удобно делать подписи к письмам.

Установите курсор в самый конец текста нажмите клавишу , чтобы создать новый абзац и введите в нем свое имя. После этого нажмите кнопку и имя разместится в правой части документа.

Кроме выравнивания вы можете задать дополнительные отступы текста от края документа для любого абзаца настроив их в специальном диалоге. Выберите команду меню Формат * Абзац (Format * Para graph). На экране появится диалог настройки параметров абзаца (Рис. 5.10).

Рис 5.10. Настройка отступов и выравнивания

Список, расположенный в нижней части диалога, позволяет выбрать выравнивание, однако для этой цеди удобнее использовать кнопки на панели форматирования. В группе полей Отступ (Indentation) задаются отступы текста от края. Вы можете ввести отступы справа и слева. Кроме того, можно задать отступ первой строки, чтобы получить эффект, называемый красной строкой.

При задании отступов слева и справа, а также отступа первой строки, вы можете получить примерно такое форматирование текста.

Выравнивание по левому краю вместе с отступом слева часто используется в шапке документа.

Задав все параметры, нажмите кнопку ОК. Диалог закроется, и форматирование выделенных абзацев будет изменено. Если до вызова диалога не было выделено ни одного абзаца, изменится форматирование абзаца, в котором находился текстовый курсор.

Изменить отступы можно также с помощью специальных значков, расположенных на линейке (Рис. 5.11). В левой части линейки находится маркер , отмечающий отступ слева, и маркер , отмечающий отступ первой строки. Маркер размещающийся справа, определяет отступ справа. Установите указатель мыши на любом маркере, нажмите кнопку мыши и, не отпуская ее, передвиньте маркер вправо или влево, после чего отпустите кнопку мыши. Вместе с изменением позиции маркера поменяются и отступы выделенного абзаца. Выделяя различные абзацы и перемещая маркеры отступа, вы легко сможете создать нужное оформление документа.

Рис 5.11. Линейка с маркерами и символами табуляции

Щелкнув мышью в любом месте линейки, вы добавите символ табуляции . Табуляция может помочь при необходимости вводить слова в точно отведенные позиции, например при создании списков и таблиц (Рис. 5.12). После ввода текста в первый столбец вы нажимаете клавишу и текстовый курсор устанавливается в позицию, отмеченную символом табуляции. Вы вводите текст во второй столбец и снова нажимаете клавишу Для перехода к новой строке следует начать новый абзац нажав клавишу , после чего следует аналогично ввести текст в столбцы, используя табуляцию.

Рис 5.12. Использование табуляции

Символы табуляции также можно перетащить с помощью мыши. Если при перетаскивании символа будет выделено несколько абзацев, то в этих абзацах изменится расположение текста. Помните, что позиции табуляции связаны с конкретным абзацем, и в другом абзаце может быть установлена совсем другая табуляция. Для точного задания позиций табуляции следует выбрать команду меню Формат * Табуляция (Format * Tabs). На экране появится диалог настройки табуляции (Рис. 5.13). В списке представлены все имеющиеся позиции табуляции. Введя новое Значение в поле ввода и нажав кнопку Установить (Set), вы добавите еще одну позицию табуляции. Для удаления позиции следует выделить ее, щелкнув мышью на нужном элементе списка, после чего нажать кнопку Очистить (Clear). Чтобы удалить всю табуляцию из текущего абзаца, нажмите кнопку Очистить все (Clear All). После того как все нужные позиции табуляции установлены, нажмите кнопку ОК. Диалог закроется, а на линейке будут отмечены новые позиции табуляции. Использование табуляции существенно облегчает создание разнообразных таблиц. Советуем не забывать об этой удобной возможности редактора WordPad.

Рис 5.13. Настройка табуляции

Для создания различных списков часто используются специальные символы, называемые маркерами, которые располагаются в начале списка (Рис. 5.14). Чаще всего в качестве маркеров используются небольшие черные кружки и текстовый редактор WordPad позволяет очень просто создавать такие списки.

Рис 5.14. Использование маркеров в списке

Установите курсор в конце одного из абзацев текста и нажмите клавишу , чтобы создать новый абзац. Нажмите кнопку , расположенную на панели форматирования, и в начале абзаца появится маркер. Теперь введите несколько названий, расположив каждое из них в отдельном абзаце. Все вновь введенные абзацы будут помечены маркерами. Чтобы убрать маркер из любого абзаца, требуется установить курсор в этот абзац и повторно нажать кнопку .

Выбрав необходимый шрифт, его размер и начертание, а также применив к абзаца выравнивание, установив отступы и добавив в списки маркеры, вы отформатировали свой текст. С помощью описанных возможностей легко создать красивый профессионально оформленный документ. Хотя мощные текстовые редакторы, такие как Word предлагают несравненно больше вариантов форматирования символов и абзацев, для работы с простыми документами вполне хватит описанных нами возможностей.


5.7. Печать и сохранение документов

Создавать документы и красиво оформлять - только часть необходимых действий. Требуется уметь получить этот же документ в бумажном виде. Также необходимо уметь сохранять документ для дальнейшего использования и для передачи его другим людям. Научившись создавать, оформлять, сохранять и печатать документы, вы можете утверждать, что освоили работу с документами на компьютере.


5.7.1. Печать документов

После того, как вы набрали текст документа, отредактировали его и красиво оформили вам, скорее всего захочется распечатать документ на принтере. Печать в текстовых редакторах осуществляется предельно просто. Включите принтер подсоединенный к вашему компьютеру после чего нажмите кнопку на панели инструментов текстового редактора. Возможно, в строке состояния программы или в отдельном окне появится информация о подготовке документа к печати, но она быстро исчезнет и принтер начнет печать вашего документа. Если печать не началась, возможно, у вас на экране появится сообщение об ошибке. Конкретный текст сообщения может различаться, но в любом случае следует устранить неисправность и нажать кнопку Повторить (Repeat). Принтер может не печатать по многим причинам. Он может быть не подсоединен к компьютеру. В этом случае следует выключить питание принтера, проверить надежность соединения разъемов, после чего снова включить питание. Возможно, принтер не включен в электрическую сеть. Если при включении питания не загорелась ни одна лампочка на принтере, проверьте наличие тока в розетке и надежность соединения с ней принтера.
Каждый принтер имеет некоторые особенности, поэтому мы настоятельно рекомендуем перед работой изучить руководство, прилагаемое изготовителем. Этим вы избежите поломок и решите все проблемы печати.

Может быть принтер не установлен в Windows. В этом случае требуется его установить. И, наконец, самый распространенный случай - в принтере кончилась бумага. Добавьте бумагу и нажмите кнопку на принтере для продолжения работы.

Возможно, вас не устроило то, как распечатан документ. Может быть, следует изменить настройки принтера, о которых рассказывалось в предыдущей части книги. Если же принтер настроен правильно то нужно изменить параметры печатной страницы. Выберите команду меню Файл * Параметры страницы (File * Page Setup), и на экране появится диалог настройки параметров страницы (Рис. 5.15). В списке Размер (Size) выбирается размер используемой бумаги. Чаще всего используется стандартная бумага формата А4. В списке Подача (Source) можно выбрать вариант устройства подачи принтера. В большинстве случаев используется стандартное устройство подачи бумаги. С помощью переключателя вы можете выбрать книжную или альбомную ориентацию листа бумаги. В группе полей Поля (Margins) задаются отступы от края листа при печати. Чаще всего изменяются именно эти поля. Примерный вид напечатанной страницы, с учетом указанных параметров, виден в поле просмотра, расположенном в верхней части диалога. Нажав кнопку Принтер (Printer), вы можете выбрать принтер, на котором хотите печатать, а также настроить параметры печати. Задав все нужные характеристики, нажмите кнопку ОК, чтобы закрыть диалог. После этого можно распечатать документ с учетом изменений параметров.

Рис 5.15. Настройка параметров страницы для печати

Создав и распечатав документ, вы можете прекратить работу с ним, но возможно, он понадобится вам в дальнейшей работе, поэтому следует сохранить документ в таком месте где вы его легко найдете.


5.7.2. Сохранение документов в файлах

Чтобы сохранить созданный вами документ в файле на жестком диске или на дискете следует нажать кнопку на панели инструментов. На экране появится диалог сохранения документа (Рис. 5.16). Работа в этом диалоге похожа на работу с проводником, описанную выше. Аналогичные диалоги появляются при сохранении документа в любой программе, работающей под управлением Windows ХР.

Рис 5.16. Диалог сохранения документа

В верхней части диалога содержится список содержащий перечень папок компьютера. Пока в нем видно название одной папки, в которую предлагается сохранить документ. Ниже расположено большое поле с перечнем файлов, которые уже расположены в данной папке. Далее мы видим поле с заголовком Имя файла (File name). В этом поле следует ввести имя, под которым вы хотите сохранить документ. Рассмотрим процесс сохранения документа с помощью этого диалога.

Нажмите кнопку расположенную в правой части перечня папок, и рядом появится список всех дисков и папок вашего компьютера. Найдите строки, описывающие диски вашего компьютера. Скорее всего на вашем компьютере установлен один дисковод для дискет и один винчестер. В списке дисковод для дискет обозначается значком и названием Диск 3,5 (А;) (3 1 / 2 Floppy (A:)). Жесткий диск обозначается символом и именем, которым назван диск вашего компьютера. Рядом стоит в скобках буква С:. Щелкните мышью на строке с описанием жесткого диска, и в диалоге появится содержание корневого каталога этого диска. Выбрав диск, вы можете просмотреть список папок, расположенных на нем, в большом поле диалога. Для перехода на уровень вверх, к предыдущей папке, следует использовать кнопку , расположенную правее перечня папок. С ее помощью вы двигаетесь вверх, а с помощью двойного щелчка на названии папки вы двигаетесь вниз. Так вы можете найти любую папку, чтобы сохранить в ней документ. Мы рекомендуем сохранять документы в папке Мои документы (My documents). Щелкните мышью на названии этой папки в левой части диалога, и вы увидите содержимое выбранной папки.

После выбора папки следует ввести имя файла. Щелкните мышью в поле Имя файла (File name) и там появится текстовый курсор. Удалите предлагаемое вам имя и введите свое. Так будет назван созданный вами документ. В списке Тип файла (Save as type) можно выбрать один из поддерживаемых типов файлов. Рекомендуем выбрать формат RTF, так как файлы этого типа сохранят особенности форматирования документа, кроме того, данный формат поддерживается практически всеми текстовыми редакторами.

Теперь осталось нажать кнопку Сохранить (Save) и документ будет сохранен в выбранной папке в файле с заданным вами именем. Следует отметить, что если вы хотите сохранить файл на дискету выберите в перечне папок Диск 3,5 (А;) (З 1 / 2 Floppy (А:)), а после точно также сохраните документ в файле. Однако мы рекомендуем сохранять все документы на винчестере, а после скопировать их на дискету. О том, как это делается, рассказывалось ранее.

После того, как мы создали и отформатировали документ, распечатали и сохранили его в файле, следует завершить работу с текстовым редактором. Для этого следует выбрать команду меню Файл * Выход (File * Exit). Расскажем более подробно, как это делается. Подведите указатель мыши к слову Файл (File) в меню, и щелкните на нем мышью. Рядом появится список команд этого меню. Внизу списка расположена команда Выход (Exit). Щелкните на ней мышью, и текстовый редактор прекратит работу. Вы можете заняться другими работами или выключить компьютер. Созданный вами документ сохранен и может быть доступен по первому требованию.


5.8. Открытие ранее созданных документов

Когда в следующий раз вам понадобится ранее созданный документ вы можете открыть его несколькими способами. Самый простой - это использование проводника Windows. Нажмите кнопку Пуск (Start) и выберите в появившемся меню команду Мои документы (My Documents). Будет запущен проводник и вы увидите содержимое выбранной папки. Если вы сохранили документ в иной папке, перейдите к ней. Дважды щелкните мышью на документе, только что сохраненном вами, и будет запущен текстовый редактор, а выбранный документ загружен для редактирования. При этом следует помнить, что если на компьютере установлено несколько текстовых редакторов, то может запуститься не тот с которым вы хотите работать. Например если ранее был установлен редактор Word, то запуститься именно он, а не WordPad.

Вы можете редактировать выбранный документ, менять его форматирование и распечатывать его на принтере. Когда вы закончите работу с документом, сохраните его нажав кнопку на панели инструментов. В этот раз диалог не появится так как имя файла и его местонахождение известно. Измененный текст просто заменит старую версию документа. Будьте внимательны при сохранении, так как восстановить предыдущую версию файла будет невозможно.

Если вам не нравится работать с проводником, можно воспользоваться иным способом открытия файлов. Запустите текстовый редактор как это описывалось в начале главы. При запуске будет создан новый документ. Нажмите кнопку расположенную на панели инструментов и на экране появится диалог открытия файлов. Этот диалог очень похож на диалог сохранения, с которым вы уже познакомились. Точно так же, как и при сохранении файла, необходимо перейти в папку, где находятся сохраненные файлы. Для перехода на уровень вверх, к предыдущей папке следует использовать кнопку а с помощью двойного щелчка на названии папки вы двигаетесь вниз. Напоминаем что скорее всего вы сохранили документы в папке Мои документы (My documents). После того как вы нашли необходимый файл, следует открыть его. Для этого можно дважды щелкнуть на нем мышью или щелкнуть один раз и нажать кнопку Открыть (Open). После этого выбранный файл будет загружен в редактор, и вы сможете редактировать его по своему усмотрению.

Следует отметить, что для редактирования нового файла не обязательно выходить из редактора. После сохранения редактируемого файла можно нажать кнопку на панели инструментов, и будет создан новый пустой документ. При этом WordPad спросит, какой документ стоит создавать (Рис. 5.17).

Рис 5.17. Выбор типа создаваемого файла

Мы рекомендуем создавать документы в формате RTF, для совместимости. Так как этот тип и предлагается, вам не надо ничего менять а просто нажмите кнопку ОК.


5.9. Дополнительные возможности редактора

Мы рассмотрели процедуры создания редактирования и оформления текстовых документов, их печати и сохранения, а также повторного открытия. Этого вам должно хватить для создания самых разных документов, но для повышения эффективности работы можно использовать ряд дополнительных возможностей WordPad. Ниже мы опишем возможности поиска, отмены неверных действий, использование буфера обмена и некоторые другие процедуры.


5.9.1. Добавление даты и времени

Достаточно часто в документ необходимо вставить сегодняшнюю дату или текущее время. При работе в WordPad эта процедура автоматизирована. Нажмите кнопку на панели инструментов, и на экране появится диалог выбора формата времени (Рис. 5.18).

Рис 5.18. Выбор формата даты и времени

Вы можете выбрать нужный вам формат даты и времени щелкнув на нем мышью. Нажмите кнопку О К, диалог закроется, и в текст будет добавлен соответствующий текст. При этом используются системные часы вашего компьютера. Если они идут неправильно так как вы не установили их ранее, дата и время будут неверными. Следует отметить что после вставки в документ время или дата не отличаются от остального текста. Вы можете произвольно редактировать и форматировать их.


5.9.2. Поиск в тексте

При работе над большими документами бывает трудно найти нужный фрагмент. Для быстрого обнаружения текста следует воспользоваться системой поиска, встроенной в WordPad. Нажмите кнопку на панели инструментов, и на экране появится диалог настройки параметров поиска (Рис. 5.19). В поле ввода следует ввести слово или словосочетание, которое вы хотите найти. С помощью флажков можно уточнить параметры поиска. Вы можете искать только слова целиком или слова, включающие указанную вами часть. Также можно учитывать или игнорировать различия строчных и прописных букв.

Рис 5.19. Диалог задания критериев поиска

Нажав кнопку Найти далее (Find Next), вы найдете первое место в документе где встречается заданное слово. Найденное слово будет выделено. Повторное нажатие кнопки найдет следующее место. Если больше ничего не найдено, редактор проинформирует вас об этом в соответствующем диалоге. После того, как вы нашли искомое место документа, нажмите кнопку Отмена (Cancel), чтобы закрыть диалог и вернуться к редактированию документа.


5.9.3. Отмена, буфер обмена и использование цвета

При редактировании и форматировании документов вы можете случайно выполнить ненужное действие. Например, вы можете удалить важный фрагмент текста или отформатировать текст не так, как вам бы хотелось. Неверные действия можно отменить. Введите несколько слов, затем удалите одно слово в середине. Нажмите кнопку на панели инструментов, и последняя операция будет отменена. Нажмите кнопку еще раз, и будет отменена предыдущая операция. Мы рекомендуем помнить об этой возможности. После сохранения документа в файле отмены невозможны, так что не сохраняйте на диске неверную информацию.

Для работы с большими фрагментами, для копирования и перемещения фрагментов текста очень удобно использовать, буфер обмена Windows. Буфер обмена можно сравнить с карманом в который вы кладете куски текста, чтобы после достать их и вставить в другое место. Рассмотрим возможности текстового редактора WordPad по работе с буфером обмена.

Откройте ранее созданный документ. Выделите фрагмент текста и нажмите кнопку на панели инструментов. Выделенный фрагмент пропадет, но в отличие от удаления, которое мы рассмотрели ранее, фрагмент перенесется в буфер обмена, откуда его можно в любой момент достать. Нажмите кнопку , и пропавший фрагмент вернется на свое место. Однако в буфере обмена сохранилась его копия, и мы можем вставить его еще раз.

Снова нажмите кнопку и в текст будет вставлена вторая копия нашего фрагмента.

Текст из буфера обмена вставляется в место, отмеченное курсором. Установите курсор в конец текста и нажмите кнопку . Фрагмент будет добавлен в конец документа. Аналогично можно добавить фрагмент в начало или в любое другое место. Чтобы скопировать текст в буфер, совсем не обязательно удалять его. Выделите произвольный фрагмент и нажмите кнопку . Кажется, ничего не произошло, выделенный фрагмент остался на месте. Но если вы установите курсор в другое место и нажмете кнопку то в указанное место будет вставлен новый фрагмент.

Следует отметить, что при копировании в буфер обмена сохраняется форматирование как символов так и абзацев. С помощью этого буфера вы легко можете копировать и перемещать любые фрагменты документов. Но буфер обмена позволяет вам сделать еще больше. Если вы поместили фрагмент в буфер обмена, можно с помощью кнопки создать новый документ и вставить фрагмент уже в него. Это позволяет вам переносить части одного документа в другой, вплоть до копирования всего текста целиком. С помощью буфера обмена можно обмениваться между разными программами. Так вы можете вставлять в текстовые документы рисунки. Создайте рисунок с помощью любого графического редактора например с помощью Paint описанного в нашей книге. Поместите в графическом редакторе созданный рисунок в буфер обмена после чего переключитесь в WordPad и вставьте содержимое буфера обмена в позицию курсора. Так вы сможете создавать красивые и необычные документы.

Небольшие фрагменты текста очень удобно копировать и перемещать с помощью мыши. Если вы успели привыкнуть к компьютерной мыши и работа с ней у вас не вызывает проблем, активнее используйте это устройство. Работа с текстом не отличается от работы с любым объектом Windows с помощью мыши.

Чтобы переместить любой фрагмент текста, следует выделить его и перетащить мышью в новое место. Рассмотрим эту операцию более подробно. Подведите указатель мыши к любому слову в тексте и дважды щелкните мышью на этом слове чтобы выделить его. Напоминаем что вы можете выделять любые фрагменты текста произвольным способом. Копировать с помощью мыши можно фрагменты текста любого размера. Далее установите указатель мыши на выделенном фрагменте, нажмите левую кнопку мыши и, не отпуская ее, начните передвигать мышь. Указатель мыши при этом изменится на . В соответствии с передвижениями указателя мыши в тексте будет перемещаться и текстовый курсор. После того, как курсор будет установлен в месте, в которое вы хотите переместить фрагмент отпустите кнопку мыши. Выделенный фрагмент будет перемещен на новое место.

Для копирования фрагмента применяется такая же технология. Выделите фрагмент, подведите указатель мыши, нажмите левую кнопку и начните перемещение. При этом следует нажать и удерживать клавишу . Указатель мыши изменится на . Установите указатель мыши в нужном месте отпустите кнопку мыши, а затем отпустите клавишу . В выбранном месте появится копия выделенного фрагмента.

Если у вас есть цветной принтер или вы читаете тексты на экране монитора, то вы можете захотеть украсить ваш документ разноцветными надписями. При этом не следует разукрашивать текст всеми цветами радуги, так как это ухудшит читаемость документа. В текстовом редакторе WordPad вы можете выбрать один из шестнадцати заранее определенных цветов. Выделите фрагмент текста после чего нажмите кнопку на панели форматирования. Под кнопкой появится список из нескольких распространенных цветов с образцами (Рис. 5.20).

Рис 5.20. Список цветов в редакторе

Вы должны щелкнуть мышью на необходимом цвете, список будет убран с экрана, а выделенный фрагмент изменит свой цвет. Конечно, более мощные текстовые редакторы позволяют работать с большим количеством цветов, но и шестнадцать цветов тоже неплохо. Часто простое изменение цвета заголовка может значительно украсить документ.


  • 6. Работа с изображениями
    • Работа с папкой Мои рисунки
    • Установка сканеров и цифровых фотокамер
    • Графический редактор Paint
    • Знакомство с программой
    • Рисование разными инструментами
    • Работа с цветом и закрашивание областей
    • Быстрое рисование простых фигур
    • Вставка фрагментов текста в рисунок
    • Изменение масштаба просмотра
    • Выделение фрагментов
    • Сохранение, открытие и печать рисунков
    • Дополнительные возможности Paint


6. Работа с изображениями

В состав операционной системы Windows XP входят простые и удобные средства для работы с графическими файлами. Вам не потребуется помощь никакой дополнительной программы, чтобы получить изображение со сканера или цифровой фотокамеры, нарисовать простой рисунок, отредактировать готовую иллюстрацию и распечатать результат на принтере.

Программы, входящие в поставку Windows помогут вам в работе с рисунками. Простые операции над изображениями в системе выполняются без использования какой-либо специальной программы. Просто нужно поместить графические файлы в специальную папку Мои рисунки (My pictures). Познакомимся с возможностями этой папки.


6.1. Работа с папкой Мои рисунки

Выберите команду главного меню Мои рисунки (My pictures), чтобы открыть одноименную папку. Внешний вид содержимого папки с рисунками несколько отличается от вида других папок при работе в проводнике Windows (Рис. 6.1).

Рис 6.1. Папка Мои рисунки (My Pictures)

Все графические файлы, расположенные в данной папке, представлены небольшими эскизами. Вы можете увидеть содержимое папки без помощи дополнительных средств, верхней части окна над эскизами расположено поле предварительного просмотра. Щелкните мышью на одном из эскизов, и в поле предварительного просмотра появится выбранный рисунок. Вы можете выполнить некоторые операции над этим рисунком с помощью кнопок, расположенных немного ниже на специальной панели инструментов. Рассмотрим действие этих кнопок.

Нажмите кнопку а затем щелкните мышью на рисунке в поле предварительного просмотра, чтобы увеличить масштаб просмотра. Рисунок не поместится полностью в поле и по его краям появятся полосы прокрутки для просмотра всего изображения. Повторный щелчок мышью увеличит масштаб еще раз. Так вы можете сильно увеличить масштаб просмотра рисунка чтобы рассмотреть мелкие детали изображения. Для уменьшения масштаба следует нажать кнопку и щелкнуть мышью на рисунке. При каждом щелчке мышью масштаб будет уменьшаться. С помощью кнопок и вы можете выбрать любой масштаб просмотра рисунка, но есть и более удобный способ. Если вы нажмете кнопку рисунок будет показан в своем истинном размере, без увеличения и уменьшения. Кнопка позволяет подогнать масштаб таким образом чтобы рисунок занимал все поле предварительного просмотра и целиком помещался в нем.

При работе с фотографиями часто возникает необходимость поворота изображения на девяносто градусов. Теперь для выполнения этой процедуры не требуется никакая специальная программа - вы можете повернуть рисунок прямо в папке Мои рисунки (My pictures). Для этого следует нажать кнопку. Вы повернете рисунок на девяносто градусов по часовой стрелке. Повторное нажатие кнопки повернет изображение еще раз. Нажатие кнопки позволит повернуть изображение в противоположном направлении. В отличие от изменения масштаба, данная операция поменяет информацию в файле.

Три работе с папкой Мои рисунки (My pictures) в панели задач являются дополнительные ссылки, связанные с рисунками.

Чтобы распечатать рисунок на принтере, следует выбрать ссылку на панели задач. После этого на экране появится стандартный диалог Windows, в котором можно выбрать и настроить принтер. После того, как вы нажмете кнопку ОК в диалоге, выбранный рисунок начнет печататься на подключенном к вашему компьютеру принтере. Ссылка в панели задач позволяет отправить рисунок через Интернет в специальную службу где рисунок распечатают на высококачественном принтере и отправят вам отпечаток по почте. Насколько нам известно, в нашей стране такие службы не работают.

Вы можете просмотреть все рисунки, расположенные в папке, в полноэкранном режиме с автоматической сменой одного другим. Этот режим называется показом слайдов или слайд-шоу. Щелкните мышью на ссылке в панели задач. Текущий рисунок будет показан на весь экран. Через некоторое время будет показан следующий рисунок а потом - еще один. Так вы можете просмотреть все рисунки, расположенные в папке Мои рисунки (My pictures).

Чтобы управлять режимом просмотра рисунков при показе слайдов, немного подвигайте мышь. При этом в правом верхнем углу экрана появится панель управления просмотром, на которой расположено несколько кнопок (Рис. 6.2).

Рис 6.2. Панель управления показом слайдов

Кнопка приостанавливает показ слайдов а кнопка - снова запускает эту процедуру. Для перехода к предыдущему рисунку следует нажать кнопку а для перехода к следующему - кнопку. К следующему рисунку можно перейти, просто щелкнув мышью в любом месте экрана. Для выхода из режима полноэкранного показа следует нажать кнопку в панели управления.

Если к вашему компьютеру подключен сканер или цифровая фотокамера, вы можете получить с них изображение прямо из папки работы с рисунками. Для этого следует выбрать ссылку в панели задач. Будет запущен мастер получения изображений, следуя советам которого, вы легко сможете получить новый рисунок. Данная ссылка появляется только в том случае, когда у вас имеется устройство, поддерживаемое системными средствами Windows XP. Такие цифровые камеры и сканеры устанавливаются с помощью специального мастера. Подробнее о работе мастера установки оборудования рассказано ниже.

Если у вас установлено несколько устройств получения изображений после щелчка мышью на ссылке на экране появится диалог выбора устройства (Рис. 6.3). Выбрав нужное устройство, щелкнув на нем мышью, нажмите кнопку ОК. Будет запущен мастер получения рисунков, особенности работы которого зависят от типа выбранного устройства.

Рис 6.3. Выбор устройства для получения изображения

Если вы выбрали для получения рисунка сканер то появится первый диалог мастера, содержащий приветствие и название выбранной модели сканера. Положите лист с нужным рисунком на стекло сканера и закройте крышку. Естественно для получения рисунка сканер должен быть включен. Нажав в диалоге кнопку Далее (Next), вы перейдете к основному диалогу мастера сканирования. Автоматически будет выполнено предварительное сканирование, и его результат будет виден в правой части диалога. С помощью переключателя в левой части диалога следует выбрать параметры получаемого изображения. Можно задать черно-белое или цветное сканирование различного качества. Вы также можете сдвинуть или заменить оригинал, лежащий в сканере. Для повторного предварительного сканирования следует нажать кнопку Просмотр (Preview). В поле предварительного просмотра можно ограничить область сканирования, перетащив с помощью мыши маркеры, расположенные по краям рамки ограничения рисунка. Чтобы лучше рассмотреть детали рисунка, следует воспользоваться кнопками под полем просмотра. Если вы нажмете кнопку, рисунок будет показан в своем истинном размере, без увеличения и уменьшения. Кнопка позволяет подогнать масштаб таким образом, чтобы рисунок занимал все поле предварительного просмотра и целиком помещался в нем.

Нажав кнопку Настройка (Custom settings), вы откроете диалог более точной настройки параметров сканирования . В нем можно вручную настроить яркость и контрастность сканирования, а также задать нужное разрешение. Выполнив настройку, нажмите кнопку ОК, чтобы вернуться к предыдущему диалогу. В нем нажмите кнопку Далее (Next) для перехода к следующему диалогу мастера сканирования. В этом диалоге выбирается место для сохранения файла рисунка вводится его имя и выбирается формат файла в котором вы хотите сохранить отсканированное изображение. Также вы можете установить флажок для отправки рисунка в Интернет. Обратите внимание что рисунки могут сохраняться не в папке Мои рисунки (My Pictures), а в любой другой папке. При создании рисунка к указанному вами имени будет добавлен порядковый номер.

Введя нужные значения в поля диалога, нажмите кнопку Далее (Next). После этого начнется процедура основного сканирования. Во время сканирования на экране будет отображаться диалог, показывающий ход выполнения этого процесса. По окончании сканирования появится завершающий диалог мастера. Нажмите кнопку Готово (Ready), диалог закроется а в нужной папке на жестком диске вашего компьютера появится новый графический файл, содержащий отсканированное изображение.

Если вы выбрали для получения изображения цифровую камеру получить изображение будет еще проще. На экране появится окно, в котором будут расположены небольшие эскизы всех фотографий, находящихся в памяти камеры. Необходимо выбрать одну из фотографий, щелкнув на ней мышью, и нажать кнопку Получить (Get picture) в окне. Кроме того, вы можете в диалоге просмотреть некоторую дополнительную информацию о фотографиях, хранящихся в памяти фотокамеры например, узнать дату и время, когда они были сделаны. Для этого следует просто щелкнуть мышью на соответствующей ссылке, предварительно выделив интересующую вас фотографию. Вы также можете очистить память камеры, освободив ее для новых снимков. Полученный снимок, как и при работе со сканером, можно расположить в нужной папке.

После рассмотрения способов получения изображений вернемся к рассмотрению особенностей работы с папкой Мои рисунки (My pictures). Для перехода к следующему и предыдущему рисунку в папке можно воспользоваться кнопками и . Выбрав ссылку на панели задач, вы сможете использовать понравившийся вам рисунок в качестве фона рабочего стола Windows.

Для просмотра любого рисунка расположенного в папке в отдельном окне, можно воспользоваться простой программой вызываемой двойным щелчком мыши. На экране появится окно программы в котором будет расположен текущий графический файл (Рис. 6.4). Кнопки, расположенные на панели инструментов программы не отличаются от кнопок в папке Мои рисунки (My pictures), рассмотренных выше. Точно также вы можете менять масштаб просмотра, поворачивать рисунок и просматривать следующий или предыдущий рисунок. Несколько дополнительных кнопок позволяют выполнить некоторые другие действия. Нажав кнопку вы распечатаете графический файл. Кнопка откроет диалог настройки и изменения свойств рисунка. Вы можете например, указать автора и тему иллюстрации. Кнопка позволяет сохранить текущее изображение в другом файле. При этом старый файл останется неизменным. Если вы нажмете кнопку файл с текущим рисунком будет удален. Для выхода из программы просмотра следует нажать кнопку в заголовке окна.

Рис 6.4. Программа просмотра рисунков

Дополнительные возможности папки Мои рисунки (My pictures) существенно облегчают работу с графическими файлами в операционной системе Windows ХР, и мы рекомендуем хранить свои рисунки именно в этой папке. Кстати, как отмечалось при описании проводника, вы можете назначить любой папке компьютера внешний вид, как у данной папки.


6.2. Установка сканеров и цифровых фотокамер

Чтобы получить возможность использовать все преимущества работы со сканерами и цифровыми камерами в Windows ХР, необходимо правильно установить их. Многие современные устройства не требуют дополнительной установки. Если подсоединить и включить их, система сама обнаружит новое устройство и установит необходимые драйверы. Однако иногда автоматическое обнаружение устройств не срабатывает, и приходится вручную устанавливать оборудование.

Для установки сканера или цифровой фотокамеры требуется подсоединить их к компьютеру, включить и загрузить Windows ХР. Далее следует выбрать команду главного меню Панель управления (Control Panel), и будет открыта одноименная папка. Если вы работаете в основном режиме работы с этой папкой, щелкните мышью на значке с названием Принтеры и другие устройства (Printers and Other Hardware), чтобы перейти к работе с принтерами сканерами, цифровыми фотокамерами, клавиатурой, мышью, игровыми устройствами и факсами.

Щелкните мышью на значке с названием Сканеры и фотокамеры (Scanners and cameras), чтобы перейти в нужную папку. Если вы используете классический вид панели управления, все значки появятся в правой части окна проводника при выборе команды главного меню Панель управления (Control Panel). Дважды щелкнув на значке , вы перейдете в нужную папку. В этой папке описаны подключенные к вашему компьютеру устройства работы с изображениями (Рис. 6.5).

Рис 6.5. Папка Сканеры и камеры (Scanners and Cameras)

В папке значками представлены все сканеры и цифровые фотокамеры, а также аналогичные устройства работы с изображениями. Кроме того в папке расположен мастер подключения новых устройств. Если в папке отсутствует значок вашего устройства, то необходимо установить его. Щелкните дважды на значке Установка устройства (Add Device), и будет запущен мастер подключения сканеров и цифровых, камер. В первом диалоге мастера кратко описаны действия, которые он должен выполнить (Рис. 6.6).

Рис 6.6. Первые диалоги мастера установки сканеров и цифровых фотокамер

Нажмите кнопку Далее (Continue) для перехода к следующему диалогу мастера (Рис. 6.6). В нем вам предлагается выбрать из списка устанавливаемое устройство. В левой части диалога расположен список производителей. После выбора названия производителя оборудования следует выбрать конкретную модель в правом списке. Если же вы не найдете в списке свою модель, то, возможно, в комплекте с устройством находился диск с драйверами. В таком случае следует нажать кнопку Установить с диска (Have Disk) и ввести адрес драйверов в появившемся диалоге (Рис. 6.7), после чего нажать кнопку ОК для продолжения работы с мастером. Если точный адрес вам не известен, нажмите кнопку Обзор (Browse) и найдите искомые драйверы переходя по дискам и папкам компьютера.

Если на прилагаемом к устройству диске система не обнаружит требуемых драйверов, то ваш сканер не удастся подключить с помощью мастера. В таком случае можно попробовать получить драйверы из Интернета, со страницы производителя оборудования, или установить поддержку, пользуясь руководством к сканеру или цифровой фотокамере. Однако если вы установите оборудование не с помощью мастера а иным способом, некоторые возможности поддержки таких устройств в Windows XP будут недоступны, например не будет работать мастер, облегчающий получение рисунков и фотографий. Возможно ваше устройство не поддерживается операционной системой Windows XP. В этом случае ничего сделать нельзя. Вам придется сменить устройство или сменить операционную систему. Напоминаем, что при покупке нового оборудования всегда следует интересоваться, работает ли оно в вашей операционной системе.

Рис 6.7. Диалоги установки и настройки оборудования

Если же вы нашли свое устройство в списке или система обнаружила требуемые файлы на диске, вам следует нажать кнопку Далее (Continue) для перехода к следующему диалогу мастера (Рис. 6.7). В нем вы должны определить, к какому порту подключено ваше устройство. Если вы не уверены, лучше выбрать вариант Автоматический выбор порта (Automatic port select). После выбора порта, нажмите кнопку Далее (Continue). Вы перейдете к предпоследнему диалогу мастера (Рис. 6.8). В этом диалоге вам предлагается назвать устанавливаемое устройство. Под этим именем оно будет присутствовать во всех диалогах, меню и папках, где используются сканеры и цифровые камеры.

После ввода имени, нажмите кнопку Далее (Continue), и вы перейдете к завершающему диалогу (Рис. 6.8). В нем ничего вводить не надо, просто нажмите кнопку Готово (Ready). Теперь система установит все необходимое программное обеспечение, и вы сможете работать с новым устройством. В папке Сканеры и камеры (Scanners and cameras) появится новый значок, связанный с ним.

Рис 6.8. Завершающие диалоги мастера установки оборудования

Для получения отсканированного изображения или фотографии из цифровой фотокамеры можно воспользоваться специальным мастером. О работе с ним рассказывалось выше, при описании особенностей работы с папкой Мои рисунки (My Pictures). Кроме того, после установки устройства, оно станет доступным из любых программ, работающих с изображениями. Одна из таких программ, входящая в состав Windows XP и называющаяся Paint, будет описана ниже. С ее помощью также можно самому создавать любые рисунки.


6.3. Графический редактор Paint

Создание простых рисунков для поздравительных открыток или для небольших документов - достаточно распространенное занятие. Многие люди любят рисовать и если они работают за компьютером, у них есть возможность использовать его для своего хобби. В состав системы Windows XP включена программа для создания и редактирования простых рисунков, называемая графическим редактором Paint.


6.3.1. Знакомство с программой

Чтобы запустить эту программу нужно выбрать команду главного меню Windows Все программы * Стандартные * Paint (More Programs * Accessories * Paint). После запуска программы на рабочем столе Windows появится ее рабочее окно (Рис. 6.9).

Рис 6.9. Рабочее окно программы Paint

Заголовок окна, меню и строка состояния выполняют те же функции, что и в окнах других программ. Панель инструментов расположена в левой части окна вертикально. Инструменты выбираются щелчком мыши на соответствующей кнопке. В центре окна расположена рабочая область, предназначенная для рисования. Палитра расположенная внизу рабочего окна, позволяет выбрать цвет для рисования.

Рисовать в программе Paint можно с помощью мыши, точно так же, как вы рисуете карандашом на бумаге. Конечно, для этого требуется определенная сноровка. Выбрав инструмент, например, карандаш, вы нажимаете кнопку мыши и передвигаете мышь. На экране остается след от передвижения указателя мыши как будто вы рисовали карандашом.

В качестве инструментов рисования используются карандаш, кисть и пульверизатор. Стирать часть изображения можно с помощью инструмента «ластик». Для облегчения рисования геометрических фигур предусмотрены дополнительные инструменты. Вы можете легко нарисовать эллипс, прямоугольник или другую фигуру. Дополняет картину инструмент для заливки, то есть закрашивания, областей изображения выбранным вами цветом.


6.3.2. Рисование разными инструментами

Рассмотрим создание простого рисунка с помощью основных инструментов графического редактора. Щелкните мышью на кнопке , чтобы выбрать кисть в качестве инструмента для рисования. Ниже панели инструментов появится поле для выбора вида используемой кисти (Рис. 6.10).

Рис 6.10. Выбор вариантов инструментов

Вам предлагаются четыре варианта кисти: круглая квадратная и две линейных. С помощью двух последних вариантов можно рисовать каллиграфические надписи, толщина контура которых зависит от наклона кисти. Для каждого варианта кисти предлагаются три размера: крупный, средний и мелкий. Всего вам предлагаются двенадцать разных вариантов рисования инструментом «кисть». Чаще всего применяется круглая кисть среднего размера.

Выберите один из вариантов кисти, щелкнув на нем мышью. Теперь, установив указатель мыши в область для рисования нажмите левую кнопку мыши и не отпуская ее, передвиньте мышь в сторону. После этого отпустите кнопку мыши. Так вы нарисуете первую линию. Установите указатель мыши в новое место, нажмите кнопку мыши и, не отпуская ее проведите мышью круг. Отпустите кнопку мыши. Таким способом вы можете рисовать любые как замкнутые, так и разомкнутые контуры. Попробуйте нарисовать простой рисунок, передвигая мышь, нажимая и отпуская кнопку мыши.

Очень похожим на кисть инструментом является карандаш. Нажмите кнопку на панели инструментов и проведите произвольную линию. Вы видите, что кисть и карандаш рисуют немного по-разному. Кроме того, для карандаша нельзя выбрать форму грифеля. Он всегда рисует тонкие линии.

Попробуем использовать еще один интересный инструмент. Выберите инструмент который рисует как пульверизатор. Работает пульверизатор так же как и кисть или карандаш. Вам предлагаются три варианта формы распыляемой струи (Рис. 6.13, в центре). Они различаются размерами получаемого отпечатка. Нарисуйте рисунок с использованием этого инструмента. Обратите внимание, что получаемый отпечаток струи пульверизатора зависит от скорости передвижения мыши. Чем медленнее вы двигаете мышь тем более насыщенным получается рисунок как и при использовании настоящего пульверизатора.

Если у вас не получился рисунок или вы хотите его подправить следует воспользоваться инструментом который стирает рисунок как ластик. Размер ластика также можно выбрать в окне расположенном ниже панели инструментов (Рис. 6.13, справа). Работа с ластиком принципиально не отличается от работы с иными инструментами. Подведите указатель мыши к стираемому фрагменту и нажмите левую кнопку мыши. Далее не отпуская кнопку передвигайте указатель над стираемым изображением после чего отпустите кнопку мыши. Все фрагменты изображения попавшие под ластик будут стерты.

С помощью кисти карандаша пульверизатора и ластика можно нарисовать любой, самый сложный, рисунок. Однако в Paint есть дополнительные инструменты, облегчающие рисование. О них речь пойдет немного позже, а пока рассмотрим особенности работы с цветом в редакторе.


6.3.3. Работа с цветом и закрашивание областей

Пока мы использовали только черный цвет для рисования. Однако с помощью графического редактора Paint можно создавать и цветные рисунки. Для этого в нижней части окна программы расположена палитра с двадцатью восемью распространенными цветами (Рис. 6.11).

Рис 6.11. Палитра цветов

Можно изменять цвета в палитре с помощью команды меню Палитра * Изменить палитру (Colors * Change Colors), однако в подавляющем большинстве случаев предлагаемых цветов хватает для создания простых рисунков. Если же вы захотели поменять один из цветов в палитре, щелкните дважды мышью на этом цвете и на экране появится диалог выбора цвета (Рис. 6.12). Вам предлагается сорок восемь основных цветов. Щелкнув на любом из них мышью и нажав кнопку ОК, вы замените цвет в палитре Paint. Все изменения в палитре потеряются, когда вы завершите работу Paint. При следующем запуске вам вновь будет предложена стандартная палитра.

Рис 6.12. Дополнительные возможности выбора цвета

Если же вам потребовался совсем необычный цвет, нажмите кнопку Определить цвет (Define Custom Colors), и в диалоге появятся дополнительные поля (Рис. 6.12). Вы можете выбрать цвет и его оттенок с помощью маркеров в цветовых полях. Щелкнув мышью на цвете в большом поле, вы выбираете цвет и оттенок а с помощью ползунка в вертикальной шкале, расположенной в правой части диалога, вы задаете яркость выбранного оттенка. Можно задать числовые значения цвета в соответствующих полях. Нажав кнопку ОК, вы замените цвет в палитре графического редактора. Теперь, после этого небольшого отступления, вернемся к выбору цвета в палитре.

Для выбора цвета следует щелкнуть мышью на его образце в палитре. После этого вы можете рисовать любым инструментом, и в документе останутся цветные линии. Выбранный цвет отобразится в одном из квадратов , расположенных левее палитры. Второй квадрат предназначен для отображения дополнительного цвета. Чтобы выбрать дополнительный цвет в палитре, следует щелкнуть правой (а не левой как ранее) кнопкой мыши на образце цвета. Выбранный дополнительный цвет будет отображен во втором, нижнем, квадрате поля. Дополнительный цвет часто называют фоновым, так как при некоторых операциях он используется для закраски фона рисунка.

Чтобы рисовать с помощью дополнительного цвета следует при работе с любым инструментом использовать правую кнопку мыши вместо левой кнопки. Например вы щелкнули мышью на желтом цвете в палитре поле чего щелкнули правой кнопкой мыши на синем цвете. Таким образом вы выбрали основной и дополнительный цвета. После этого нажав кнопку на панели инструментов, вы можете рисовать желтым карандашом. Чтобы использовать синий карандаш, следует нажать правую кнопку мыши и, не отпуская ее, передвинуть мышь после чего отпустить кнопку мыши. Аналогично при использовании правой кнопки, все другие инструменты работают с дополнительным цветом. Таким образом, при работе над рисунком у вас всегда находятся под рукой по два разноцветных инструмента каждого типа.

Для создания цветных иллюстраций можно закрашивать кистью карандашом или пульверизатором любые участки рисунка, но иногда это бывает не очень удобно. Для закрашивания больших фрагментов однородным цветом лучше воспользоваться специальным инструментом графического редактора, похожим на ведро с краской.

Закрашивать или, как принято говорить, заливать, произвольным цветом любые фрагменты в программе Paint очень просто. Нарисуйте любой замкнутый контур (Рис. 6.16, слева). Нажмите кнопку в панели инструментов, после чего щелкните мышью внутри контура. Вся внутренняя часть будет закрашена выбранным цветом (Рис. 6.13).

Рис 6.13 Заливка замкнутого контура

Щелкните мышью на другом цвете в нижней палитре после чего щелкните мышью снаружи контура. Теперь внешняя часть закрашена другим цветом. При заливке также можно использовать дополнительные цвета. Для этого после выбора инструмента следует щелкнуть правой кнопкой мыши в нужном месте рисунка.

Если вы хотите рисовать цветом, который уже есть в рисунке, следует воспользоваться пипеткой Выберите этот инструмент в панели инструментов, после чего щелкните мышью на любом цвете в рисунке. Выбранный цвет появится в поле, и далее вы будете работать с ним. После щелчка автоматически вернется ранее используемый инструмент. Если до работы с пипеткой вы использовали инструмент для заливки то после выбора цвета он снова стал доступен и вы можете залить фрагмент рисунка выбранным цветом. Как и при работе с другими инструментами после выбора вы можете щелкнуть правой кнопкой мыши. В этом случае будет установлен дополнительный цвет.


6.3.4. Быстрое рисование простых фигур

Нарисовать карандашом прямую линию достаточно сложно. Скорее всего она получится не совсем ровной. Для рисования прямых линий в редакторе есть специальный инструмент. Нажмите кнопку на панели инструментов. Ниже появится поле выбора варианта толщины линий (Рис. 6.14). Выберите толщину линии щелкнув мышью на варианте. После этого установите указатель мыши в начало рисуемого отрезка. Нажмите кнопку мыши и не отпуская ее начните перемещать мышь. Между начальным и текущим положением указателя мыши появится прямая линия. Установите указатель мыши в место окончания линии и отпустите кнопку мыши. Отрезок прямой останется в рисунке. Как вы уже догадались если все то же сделать с помощью правой кнопки мыши будет использован дополнительный цвет.

Рис 6.14. Варианты инструментов рисования фигур

Если вы хотите нарисовать строго горизонтальную, вертикальную или диагональную линию то следует воспользоваться клавишей. Нажмите эту клавишу и не отпуская ее начните рисовать прямую линию. Редактор позволит создавать только горизонтальные и вертикальные линии а также линии наклоненные под углом в сорок пять градусов. Нарисовав отрезок отпустите клавишу.

Чтобы нарисовать гладкую кривую следует воспользоваться инструментом . Выберите этот инструмент и рисуйте отрезок, как будто вы работаете предыдущим инструментом. После того, как вы отпустите кнопку мыши снова ее нажмите, и, не отпуская, начните передвигать мышь. При этом начнет меняться кривизна только что построенной линии. Отпустите кнопку мыши, снова нажмите ее и передвиньте мышь. Кривизна начнет меняться с другой стороны. Добившись требуемого внешнего вида, отпустите кнопку мыши. Построение гладких кривых требует определенного навыка и редко используется при создании простых рисунков.

Для создания эллипсов прямоугольников, прямоугольников с закругленными краями и многоугольников в Paint имеются четыре инструмента - . Работа с ними очень похожа друг на друга. Выберите любой из этих инструментов, и ниже появится поле выбора варианта фигуры (Рис. 6.14). Пояснить эти варианты можно с помощью рисунка (Рис. 6.15).

Рис 6.15. Контур и заливка фигур

Любая фигура состоит из контура и закрашенной области внутри контура называемой заливкой. Вы можете нарисовать фигуру, состоящую только из контура. При этом внутренняя часть фигуры будет прозрачной. Для рисования только контура следует выбрать вариант . Вариант позволяет создавать фигуры, закрашенные внутри. Если же вы выберете вариант то сможете создавать фигуры не имеющие контура, а состоящие исключительно из заливки.

Чтобы задать толщину контура создаваемой фигуры, следует нажать кнопку или и выбрать среди предлагаемых вариантов нужную вам толщину. Выбранная толщина будет применяться для всех вновь создаваемых фигур.

Выбрав нужный вариант создания фигуры, установите указатель мыши в левой верхней точке будущей фигуры. Нажмите кнопку мыши и, не отпуская ее начните передвигать мышь. Подведя указатель к месту где должен располагаться правый нижний угол фигуры отпустите кнопку мыши. Фигура будет нарисована в выбранном месте. Исключение составляет многоугольник. Если был выбран инструмент то вы создали только первую сторону фигуры. Последовательно щелкните мышью в местах где предполагается поместить вершины многоугольника а в месте последней вершины дважды щелкните мышью. Сложный контур будет замкнут и вы увидите произвольный многоугольник. Отметим что создавать фигуру можно начиная с любой вершины а не только с левой верхней, как мы описали.

При создании фигур используется основной цвет за исключением варианта с одновременным рисованием контура и заливки. В этом случае контур рисуется с помощью основного цвета а заливка - с помощью дополнительного. Если вы при рисовании используете правую кнопку мыши то цвета меняются местами.

Для создания правильных фигур - квадрата и круга при рисовании прямоугольника и эллипса следует нажимать клавишу . Аналогично можно нарисовать квадрат с закругленными углами. Если вы примените клавишу при рисовании произвольного многоугольника его стороны будут расположены вертикально горизонтально и под углом в сорок пять градусов.


6.3.5. Вставка фрагментов текста в рисунок

В любой рисунок можно вставить произвольное количество фрагментов текста. Для этого следует выбрать инструмент в панели инструментов. Под панелью появятся два варианта для выбора особенностей вставки текста (Рис. 6.16).

Рис 6.16. Варианты инструментов

Любой текст в редакторе Paint вставляется в прямоугольной рамке. Первый вариант предлагает рисовать непрозрачную рамку, а второй - прозрачную. При использовании прозрачной рамки в рисунок будут добавлены только введенные символы, а при использовании непрозрачной рамки в рисунок будет добавлен прямоугольник, на котором и расположится введенный текст. Если вы выберете непрозрачную рамку, в качестве фона будет использоваться дополнительный цвет.

После выбора варианта работы инструмента вам необходимо определить место для рамки текста. Если вы щелкнете мышью в любом месте рисунка, там появится небольшая рамка. По мере ввода текста она будет увеличиваться. Если же вы хотите определить точные размеры рамки, то вам следует выполнить несколько иную операцию. Установите указатель мыши в левой верхней точке будущей рамки. Нажмите кнопку мыши и, не отпуская ее начните передвигать мышь. Подведя указатель к месту, где должен располагаться правый нижний угол рамки, отпустите кнопку мыши. Рамка выбранного размера появится на экране, и вы можете набирать текст (Рис. 6.17).

При вводе текста с клавиатуры, вновь вводимые символы будут располагаться в месте, отмеченном текстовым курсором - вертикальной мигающей чертой. Вы можете добавлять и удалять символы, как и в любом текстовом редакторе, например, в редакторе WordPad, описанном нами выше. Если вы захотите изменить размеры рамки для вводимого текста, следует перетащить с помощью мыши один из маркеров прямоугольников, расположенных по краям рамки.

Рис 6.17. Вставляемый текст

В графическом редакторе Paint имеется возможность выбора шрифта размера и начертания вводимого текста. При работе с текстом на экране появится панель для выбора параметров текста (Рис. 6.18), очень похожая на панель форматирования текстового редактора.

Рис 6.18. Панель выбора шрифта

С помощью первого открывающегося списка в панели вы выбираете шрифт, во втором списке устанавливаете размер, а в третьем - язык. Кнопками вы выбираете начертание символов. Форматирование применяется ко всему вводимому тексту. Если вам надо создать надписи разного стиля, то необходимо вставить несколько фрагментов текста указав различное форматирование для каждого из них. Выбранный в панели вариант форматирования сохранится для всех вновь вводимых текстов.

Как и при работе с другими инструментами, вы можете задавать цвет для символов с помощью палитры. Цвет, как и форматирование, одинаков для всего вводимого фрагмента текста.

Введя и отредактировав фрагмент текста задав для него нужное форматирование вы должны закончить работу с текстом. Для этого следует щелкнуть мышью в произвольном месте рабочей области вне рамки с текстом, или выбрать в, панели инструментов другой инструмент. Рамка исчезнет и набранные символы будут вставлены в рисунок.
Редактировать и форматировать текст можно только до окончания работы с фрагментом. После того, как пропала рамка текста, он превратился в обычный рисунок. Работать с ним, как с текстом, станет невозможно.

После вставки текста в рисунок, вы можете редактировать его с помощью карандаша/ кисти или ластика, но это не очень удобно поэтому будьте внимательны и проверьте правильность введенных символов до окончания работы с текстом.


6.3.6. Изменение масштаба просмотра

Иногда бывает нужно аккуратно прорисовать мелкие детали рисунка. Для этого используют увеличение масштаба просмотра изображения (Рис. 6.19). Нажмите кнопку на панели инструментов и ниже появится поле выбора масштаба (Рис. 6.16). Вы можете выбрать из нескольких вариантов - от масштаба без увеличения до восьмикратного увеличения.

Рис 6.19. Различный масштаб просмотра

Можно не пользоваться выбором варианта увеличения в панели. После нажатия кнопки установите указатель мыши в рабочей области рисунка. Вокруг указатели будет нарисована рамка показывающая размеры отображаемого фрагмента при изменении масштаба. Выберите какой фрагмент рисунка вы хотите увеличить после чего щелкните на нем мышью. Масштаб будет увеличен. Для возврата к обычному масштабу следует нажать кнопку и щелкнуть мышью в любом месте рисунка.

Следует отметить что некоторые операции невозможны при работе в увеличенном масштабе. Например текст можно вставить только в обычном масштабе.


6.3.7. Выделение фрагментов

При создании рисунков иногда возникает потребность перемещения копирования или удаления целых фрагментов. Для этого следует воспользоваться средствами выделения, Нажмите кнопку на панели инструментов чтобы выделить фрагмент изображения. Установите указатель мыши в левой верхней точке планируемой области выделения. Нажмите левую кнопку мыши и, не отпуская ее начните передвигать мышь вправо и вниз. Подведя указатель к правому нижнему углу области выделения отпустите кнопку мыши. Вокруг выделенной области останется пунктирная рамка с небольшими прямоугольниками по бокам (Рис. 6.20). Эта рамка, называемая рамкой выделения, показывает, какой фрагмент иллюстрации в настоящий момент выделен.

Рис 6.20. Рамка выделения с маркерами

Если вы хотите выделить весь рисунок то следует нажать комбинацию клавиш. При этом рамка выделения будет нарисована вокруг всего рисунка.

Рассмотрим операции которые вы можете выполнить с выделенной областью. Во-первых, вы можете очистить ее.

Нажмите клавишу и все рисунки в выделенной области будут удалены. Точнее, она будет залита дополнительным цветом. При запуске Paint в качестве дополнительного цвета используется белый, и заливка белым цветом похожа на удаление всех рисунков.

Для выделения не прямоугольного, а произвольного фрагмента следует нажать кнопку . После этого, установив указатель мыши в область для рисования, нажмите левую кнопку мыши, и, не отпуская ее, обведите указателем мыши выделяемую область. При перемещении мыши на рисунке появится след указателя. После того как вы обведете область для выделения, отпустите кнопку мыши. Появится прямоугольная рамка выделения однако в действительности будет выделен обведенный фрагмент сложной формы.

При работе с выделением можно выбрать один из вариантов использования инструмента (Рис. 6.16). Верхний вариант предполагает работу с непрозрачным фоном, а нижний - с прозрачным. Если вы работаете с непрозрачным фоном, при копировании, перемещении и других преобразованиях будет использоваться весь рисунок, включая фоновую закраску. При использовании прозрачного фона редактор работает только с рисунками, цвет которых отличается от цвета фона. При этом все рисунки совпадающие по цвету с фоном то есть закрашенные дополнительным цветом, считаются прозрачными.

Если вы перетащите мышью один из маркеров рамки выделения, будет изменен размер выделенного фрагмента. Установив указатель мыши внутри выделенного фрагмента, нажав кнопку мыши, и не отпуская ее, передвинув мышь, вы переместите выделенный фрагмент. При этом его старое место будет закрашено дополнительным цветом.

Для копирования фрагмента удобнее всего использовать буфер обмена Windows. Чтобы поместить выделенный фрагмент в буфер обмена, следует нажать комбинацию клавиш. Нажав после этого клавиши вы вставите копию фрагмента в рисунок. Копия будет выделена и вы можете переместить ее или изменить размер. Если, выделив фрагмент рисунка, вы нажмете комбинацию клавиш то фрагмент будет вырезан то есть редактор его поместит в буфер обмена и удалит из рисунка. После этого вы можете вставить фрагмент в любое место, нажав комбинацию клавиш .

С помощью буфера обмена вы можете копировать фрагменты из одного рисунка в другой. Для этого следует поместить фрагмент в буфер обмена, открыть другой рисунок и вставить в него фрагмент. Рассмотрим как открывать файлы с рисунками и сохранять их на диске.


6.3.8. Сохранение, открытие и печать рисунков

Чтобы сохранить созданный рисунок для последующего использования следует выбрать команду меню Файл * Сохранить (File * Save). На экране появится диалог, не отличающийся от обычного диалога сохранения Windows. Аналогичный диалог описывался в разделе нашей книги посвященной текстовому редактору WordPad. Вы должны выбрать папку для сохранения и ввести имя файла. Мы рекомендуем использовать для хранения рисунков папку Мои рисунки (My pictures) имеющую дополнительные средства для работы с изображениями. В открывающемся списке Тип файла (Save as type) можно выбрать один из форматов графических файлов.

Формат BMP является стандартным для Windows, поэтому рекомендуется хранить рисунки в нем. Если вы использовали всего несколько цветов, не следует использовать 24-разрядный формат, так как он займет слишком много места. Для последующего использования в Интернете следует сохранять рисунки в формате GIF или JPEG. Удобный формат PNG позволяет сжимать рисунки без потери качества.

Открыть ранее сохраненный файл можно с помощью команды меню Файл * Открыть (File * Open). На экране появится диалог открытия, похожий на ранее рассмотренный диалог сохранения файла. Перейдя в нужную папку, дважды щелкните мышью на названии файла, и он будет загружен в графический редактор.

Редактор Paint позволяет работать только с одним файлом в одно время, поэтому при загрузке нового файла старый будет закрыт. Если вы пытаетесь загрузить новый файл или выйти из редактора, изменив рисунок и не сохранив его. Paint предупредит вас об этом.

Нажав кнопку Да (Yes) в диалоге вы вызовете диалог сохранения файла. Если же вы нажмете кнопку Нет (No), ранее редактируемый файл будет потерян. Для возврата к редактированию следует нажать кнопку Отмена (Cancel).

При запуске редактора Paint всегда создается новый пустой рисунок. Если же вы хотите создать новый рисунок во время работы программы, то следует выбрать команду меню Файл * Создать (File * New).

Чтобы распечатать на принтере любой рисунок, следует выбрать команду меню Файл * Печать (File * Print). После этого на экране появится диалог выбора и настройки принтера, в котором следует нажать кнопку ОК. Рисунок будет распечатан на вашем принтере.

Вы можете получить рисунок в редактор Paint со сканера или цифровой фотокамеры. Для этого следует выбрать команду меню Файл * Со сканера или фотокамеры (File * From Scanner or Camera). Далее будет запущен мастер получения изображений, описанный нами выше. Отметим, что данная команда меню недоступна, если в системе не установлены сканеры или фотокамеры,


6.3.9. Дополнительные возможности Paint

Если вы допустили ошибку при рисовании, вы можете отменить несколько последних действий. Для этого следует нажать комбинацию клавиш . Для возврата отмененного действия следует нажать комбинацию клавиш . Кстати все действия, которые выполняются с помощью нажатия комбинации клавиш, можно выполнить и с помощью команд меню. Вы можете самостоятельно попробовать использовать команды меню вместо нажатия комбинаций клавиш.

Графический редактор Paint имеет несколько дополнительных средств редактирования, облегчающих создание разнообразных иллюстраций. Средства преобразования фрагментов работают с выделенным участком рисунка. Если вы не выделили ни один из участков, преобразованию будет подвергнут весь рисунок.

Чтобы зеркально отразить рисунок или повернуть его вокруг центра на некоторый угол, следует нажать комбинацию клавиш . На экране появится диалог настройки преобразования (Рис. 6.21). Установив переключатель в нужное положение вы можете отразить рисунок или повернуть его на заданный угол. Нажмите кнопку ОК, диалог закроется и будет Выполнено преобразование.

Рис 6.21. Настройка отражения и поворота

Для изменения пропорций, растяжения по горизонтали и вертикали, а также для наклона рисунка следует нажать комбинацию клавиш . При этом на экране появится диалог настройки выбранных преобразований (Рис. 6.22). Рисунки в диалоге поясняют какие действия выполняются с выделенным фрагментом изображения. Введя в соответствующие поля численные значения нажмите кнопку ОК. Диалог закроется и фрагмент изображения изменит свою форму.

Рис 6.22. Настройка растяжения и наклона

Иногда возникает необходимость преобразования рисунка в негатив. Обратить цвета на противоположные можно с помощью комбинации клавиш . Повторное нажатие этих клавиш снова изменит цвета возвратив исходные. Напоминаем, что все преобразования работают с выделенным фрагментом или со всем рисунком если нет выделенных фрагментов. Чтобы очистить весь рисунок то есть залить его дополнительным цветом следует воспользоваться комбинацией клавиш . При этом необходимо чтобы не был выделен фрагмент рисунка.

Для настройки атрибутов рисунка следует нажать комбинацию клавиш . На экране—появится диалог Атрибуты (Attributes) (Рис. 6.23). В этом диалоге вы можете установить размеры изображения единицы измерения и цветовую палитру. Кроме того в верхней части диалога выведена некоторая полезная информация о редактируемом рисунке. Если вы нажмете кнопку Default (По умолчанию) новые рисунки будут создаваться с заданными атрибутами. Установив необходимые атрибуты, нажмите кнопку ОК диалог закроется и атрибуты рисунка будут изменены.

Рис 6.23. Изменение атрибутов рисунка

С помощью графического редактора Paint вы можете создавать простые рисунки. Для создания более сложных иллюстраций требуются более мощные программы которые применяют профессиональные художники. Однако и графический редактор Paint позволяет создавать достаточно красивые иллюстрации. Возможностей этого редактора вполне хватит большинству пользователей компьютера не занимающихся графическими работами профессионально.


  • 7. Работа в сети Интернет
    • Настройка системы для работы с Интернетом
    • Путешествие по всемирной паутине
    • Посылка и прием электронных писем
    • Облегчение работы с Интернетом
    • Размещение файлов в Интернете и получение файлов


7. Работа в сети Интернет

Последнее десятилетие отмечено бурным развитием Интернета. Наша страна также переживает Интернет-бум. Любая срирма сейчас должна иметь свою страницу в Интернете, а без адреса электронной почты вы не сможете полноценно общаться с вашими деловыми партнерами. Сегодня работа в сети Интернет превратилась из деятельности особого рода в каждодневную работу множества людей, и компьютерная грамотность уже не мыслима без умения использовать Интернет. Поэтому в состав операционной системы Windows XP включен ряд средств для работы в Интернете. Кроме известных программ Internet Explorer и Outlook Express, встроенных в предыдущие версии Windows, в системе появились новые средства, позволяющие расширить ваши возможности по работе в сети Интернет.


7.1. Настройка системы для работы с Интернетом

Чтобы начать работать с Интернетом, вам следует настроить операционную систему Windows XP под ту информацию, которую вы получили у поставщика услуг Интернета, также часто называемого провайдером. Вы должны получить у поставщика идентификатор, пароль, адрес электронной почты, а также номера телефонов, по которым следует звонить для доступа в Интернет.

Настройка Windows для работы с Интернетом осуществляется с помощью специального мастера подключения к Интернету. Этот мастер запустится автоматически, когда вы первый раз захотите работать в сети и запустите какую-либо программу, например Internet Explorer. Напомним, что запустить программы для работы в Интернете можно с помощью панели быстрого запуска Windows или с помощью команды главного меню. Программа обозревателя Интернета имеет значок программа для работы с электронной почтой - значок.

После запуска мастера на экране появится его первый диалог, предназначенный для выбора способа подключения к Интернету , (Рис. 7.1). Вы можете все параметры настраивать вручную, получить параметры из Интернета или воспользоваться готовой учетной записью. Учетная запись представляет собой набор нгГстроек Windows для подключения к поставщику услуг Интернета. Можно создавать несколько независимых учетных записей в случае необходимости.

Рис 7.1. Выбор способа подключения

Автоматически, получить учетную запись конечно удобно. Однако, скорее всего, Windows XP не знает о вашем провайдере. Поэтому следует выбрать вариант ручной установки всех параметров. Чтобы сделать это, установите переключатель в нужное положение и нажмите кнопку Далее (Next), чтобы продолжить настройку.

Следующий диалог мастера (Рис. 7.1) предложит вам выбрать, как вы будете подключаться к Интернету: через локальную сеть или модем. Скорее всего, вы будете использовать модем, поэтому щелкните мышью на соответствующем переключателе и нажмите кнопку Далее (Next).
Если вы используете для доступа к Интернету локальную вычислительную сеть, вы должны проконсультироваться о настройке параметров Windows XP у администратора сети.

При использовании модема для доступа к Интернету необходимо указать ваше географическое расположение и определить особенности вашей телефонной сети. Поэтому далее появится диалог мастера для настройки этих параметров (Рис. 7.2). Прежде всего, в открывающемся списке этого диалога вы должны выбрать страну, в которой вы находитесь. Затем нужно в соответствующем поле ввода указать телефонный код вашего города. Код несущей используется, если оборудование вашего поставщика услуг Интернета требует этого. Обычно это бывает нужно, чтобы включить ответ оборудования поставщика услуг на ваш звонок. Отметим, что в подавляющем большинстве случаев данный код не нужен. Если вы используете офисную телефонную станцию и для выхода в город нужно набирать номер, укажите этот номер в соответствующем поле ввода. В заключение следует указать, какой тип набора номера использует ваша телефонная станция. В большинстве случаев используется импульсный набор номера. Тональный набор можно использовать, если вы подключены к современной цифровой телефонной станции. После настройки параметров местонахождения нажмите кнопку Далее (Next) диалога настройки, чтобы продолжить работу. Появится диалог Телефон и модем (Phone and Modem Options) (Рис. 7.2). Ничего не меняйте в этом диалоге, а просто нажмите кнопку ОК, чтобы продолжить работу.

Рис 7.2. Ввод сведений о местонахождении

Для использования модема в Windows, он должен быть подключен и настроен. Если вы не делали этого раньше, то сейчас будет запущен мастер установки оборудования и появится его первый диалог (Рис. 7.3). Мастер установки вначале предлагает вам доверить компьютеру автоматически определить тип модема.

Рис 7.3. Выбор модема из списка

Если у вас внешний модем, включите его, после чего нажмите кнопку Далее (Next) диалога. Иногда процедура автоматического определения модема не может указать его тип или вообще найти модем. Если Windows определила, что у вас Стандартный модем (Standard Modem), значит, программа установки не смогла определить тип вашего модема. В таком случае для работы с модемом будут использоваться только стандартные команды, что не позволит полностью использовать все возможности вашего модема. Вы можете согласиться с этим, а можете выбрать модем из списка самостоятельно, установив соответствующий флажок в первом диалоге мастера и нажав кнопку Далее (Next). Если модем не удается определить, вам также будет предложено выбрать его из списка (Рис. 7.3).

Диалог содержит список производителей и список моделей модемов. Сначала в списке производителей выберите фирму -производителя вашего модема, а затем в списке моделей выберите его модель. Обратите внимание, что слева от названий моделей модемов расположен значок. Это значок цифровой подписи, говорящий о том, что работа данного модема испытана в системе Windows XP.

Может так случиться, что вы не найдете в этих списках вашего модема. Тогда придется воспользоваться дискетой или компакт-диском, который должен присутствовать в комплекте поставки вашего модема. Если дискеты или диска в комплекте вашего модема не было, то придется довольствоваться тем, что Windows опознала ваш модем как стандартный. В дальнейшем вы можете попытаться найти нужный драйвер в Интернете и заново установить модем. Для использования дискеты нажмите кнопку Установить с диска (Have disk). Появится диалог выбора папки и диска (Рис. 7.4).

Рис 7.4. Диалоги установки с диска и поиска файла

Вставьте дискету, которая должна быть в комплекте модема, и нажмите кнопку ОК, чтобы закрыть диалог. Если драйвер модема находится на компакт-диске, то укажите букву диска в поле ввода и затем нажмите кнопку ОК. В любом случае появится диалог для поиска файла (Рис. 7.4) Если на указанном вами диске есть файлы, требуемые для установки модема, то их список появится в центральной части диалога. Выберите нужный файл и нажмите кнопку Открыть (Open), чтобы открыть файл и закрыть диалог поиска. Появится новый диалог, показывающий, описания каких модемов есть на диске (Рис. 7.5).

Рис 7.5. Использование диска для установки модема

Этот диалог похож на предыдущий диалог для выбора модели модема. Обращаем ваше внимание, что большинство драйверов оборудования, выпущенного недавно, имеют цифровую подпись компании Microsoft. Большинство оборудования, выпущенного несколько лет назад, такой подписи не имеет, и в дальнейшем вы увидите предупреждение об этом. Выберите в появившемся списке тип вашего модема и нажмите кнопку Далее (Next). Появится следующий диалог (Рис. 7.5),, который предложит выбрать порт для подключения модема.

Установите переключатель в положение Выбранные порты (Selected Ports), выберите в списке порт, к которому подключен ваш модем и нажмите кнопку Далее (Next). Начнется установка необходимых программ для работы вашего модема. Если вы использовали драйвер, разработанный не фирмой Microsoft, a производителем модема, возможно в драйвере будет отсутствовать цифровая подпись. В этом случае появится диалог с предупреждением. Данный диалог предупреждает вас о том, что не гарантируется работа драйвера, если он не был сертифицирован Microsoft. Однако в большинстве случаев драйвер модема даже при отсутствии сертификации будет работать вполне надежно, так что можно игнорировать данное предупреждение.

Нажмите кнопку Продолжить (Continue Anyway), чтобы продолжить установку. После небольшой паузы, связанной с копированием необходимых программ на ваш компьютер, появится заключительный диалог мастера установки оборудования. Нажмите кнопку Готово (Finish), чтобы закрыть этот диалог.

Теперь, когда модем установлен, система вернется к мастеру подключения к Интернету, от которого мы отвлеклись, чтобы установить и настроить модем. Появится очередной диалог мастера подключения к Интернету (Рис. 7.6). В этом диалоге необходимо указать телефонный номер вашего поставщика услуг Интернета, а также, при необходимости, настроить дополнительные параметры. В соответствующих полях ввода введите телефонный код и номер вашего поставщика услуг Интернета. Обязательно указывайте код города и не бойтесь, чтр пррграмма устанрвления связи с поставщиком услух Интернета будет звонить с использованием междугородней телефонной связи. Если код города в этом поле совпадает с кодом, установленным при настройке вашего месторасположения (Рис, 7.2), то междугородняя связь использоваться не будет. Большинство современны поставщиков услуг Интернета не требуют указания никакю дополнительных параметров для подключения. Во необходимая информация будет автоматически получен непосредственно при подключении. Для работы с некрторымт другими поставщиками требуется настройка дополнительных параметров.

Рис 7.6. Сведения для подключения

Особенности настройки параметров подключения к поставщику услуг Интернета можно указать с помощью кнопки Дополнительно (Advanced). Нажмите эту кнопку, чтобы открыть диалог дополнительной настройки, который содержит две вкладки. Щелкните мышью на вкладе Соединение (Connection), чтобы открыть соответствующую вкладку.

На данной вкладке настраиваются протокол соединения с поставщиком услуг Интернета, а также процедура соединения.

Под этой процедурой понимается последовательность команд по вводу имени, пароля и других параметров. Подавляющее большинство поставщиков услуг Интернета работают по протоколу РРР и не требуют процедуры входа. Поэтому ничего менять на этой вкладке вам, скорее всего, не придется. Щелкните мышью на вкладке Адреса (Addresses), чтобы перейти на соответствующую вкладку диалога дополнительных настроек соединения. Группа элементов управления Адрес IP (IP Address) определяет ваш адрес в Интернете. Скорее всего, ваш адрес в Интернете будет автоматически назначаться поставщиком услуг, и в этом случае не нужно менять положение переключателя, предлагаемого по умолчанию. Однако иногда вам может быть выделен постоянный адрес. В этом случае, следует установить переключатель в положение Всегда используется (Always use the following) и в поле ввода ввести полученный у поставщика услуг выделенный вам адрес. Группа элементов управления Адрес сервера DNS (DNS Server Address) определяет адреса мест в Интернете, где происходит преобразование символьных адресов, которыми пользуются люди, в цифровые адреса, которые используют компьютеры. По умолчанию предполагается, что адрес DNS назначается автоматически вашим поставщиком услуг. Некоторые поставщики услуг Интернета не предоставляют такой услуги, а сообщают вам конкретные адреса серверов DNS. В этом случае вам следует установить переключатель в положение Всегда используется (Always use the following) и ввести в полях ввода адреса основного и дополнительного серверов. После окончания настройки дополнительных параметров нажмите кнопку ОК, чтобы закрыть диалог, а затем нажмите кнопку Далее (Next), чтобы продолжить настройку. Появится диалог ввода имени и пароля. Для подключения к поставщику услуг Интернета требуется знать ваш личный идентификатор и пароль. Данные сведения вы также должны получить у поставщика услуг Интернета и ввести в соответствующие поля ввода. Обратите внимание, что пароль при вводе отображается в виде звездочек. Кроме того, при вводе пароля важен регистр вводимых символов. Например, пароль и Пароль различаются. Помните, что также важна текущая раскладка клавиатуры, то есть язык, используемый при вводе букв с клавиатуры.

После ввода имени пользователя и пароля, нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера. Данный диалог предназначен для задания имени создаваемого соединения с Интернетом. Вы можете задать произвольное название соединения. После того, как вы нажмете кнопку Далее (Next), будет создана новая учетная запись и появится заключительный диалог мастера подключения к Интернету. Если вы не хотите сразу одключаться к Интернету, уберите флажок в этом диалоге.

Нажмите кнопку Готово (Finish), чтобы закрыть диалог. Работа мастера завершена, и теперь при использований программ для работы с Интернетом будет осуществляться установка связи с поставщиком Интернета, когда это необходимо.


7.2. Путешествие по всемирной паутине

Для путешествия по всемирной паутине используются обозреватели Интернета. В состав Windows XP входит несколько таких программ. Прежде всего, это обозреватель Internet Explorer. Давайте рассмотрим, как можно путешествовать по паутине с помощью этой программы. Сначала необходимо запустить программу Internet Explorer. Это можно сделать, щелкнув на значке в панели быстрого запуска или выбрав нужную команду в главном меню Windows. Программа будет запущена и, если вы не подключены к Интернету, появится диалог о невозможности загрузить Web-страницу без подключения к сети (Рис. 7.7).

Рис 7.7. Предупреждение

Пока мы не будем подключаться к Интернету, поэтому нажмите кнопку Автономно (Stay Offline). На экране появится рабочее окно программы Internet Explorer. Давайте рассмотрим основные элементы рабочего окна. Как и в других программах, в верхней части окна расположены заголовок, меню и панели инструментов. Под полосой панели инструментов имеется поле для ввода адреса страницы, которую вы хотите просматривать. Центральная часть окна программы предназначена для отображения открытой в настоящий момент Web-страницы. Строка состояния предназначена для индикации тех действий, которые в данный момент выполняет программа Internet Explorer. Например, в этой строке отображаются адрес текущей загружаемой страницы, выполняемое в настоящий момент действие, а также прогресс-индикатор, информирующий о степени завершения текущей операции.

Одним из главных понятий при работе с всемирной паутиной является понятие Web-страницы. Под такой страницей понимается документ, содержащий в себе кроме текста еще и графические изображения, звуковое сопровождение и видео. Web-страница может содержать ссылки на другие страницы или почтовые ящики. Обычно ссылки выделяются в документе цветом или подчеркиванием. Указатель мыши, проходя над ссылкой, меняет свою форму на стилизованное изображение руки. Работа программы, предназначенной для просмотра Web-страниц, всегда начинается с загрузки особой страницы, которая называется домашней страницей (на английском языке Home page). Переход на нужную вам страницу осуществляется путем ввода ее адреса в предназначенное для этого поле. Завершение ввода адреса происходит после нажатия кнопки Переход (Go). Если в загруженной странице есть ссылки, то далее можно переходить по ним на другие страницы.

Чтобы подключиться к Интернету во время автономной работы, вначале следует изменить режим работы программы. Для этого сбросьте флажок у команды меню Файл * Автономная работа (File * Work Offline). Теперь в поле адреса введите адрес требуемой страницы и нажмите кнопку Переход (Go) правее поля для адреса. Опять появится диалог с предупреждением о невозможности загрузки страницы (Рис. 7.6). Нажмите кнопку Подключиться (Connect) и появится диалог настройки подключения.

Поля ввода данного диалога уже заполнены в соответствии с настройками соединения с Интернетом, произведенными ранее. Однако вы можете изменить имя и пароль, а также выбрать иное соединение, если у вас их несколько. После того, как вы убедитесь, что все поля заполнены правильно, нажмите кнопку Подключиться (Connect). Начнется процесс соединения с поставщиком услуг Интернета, по окончании которого диалог исчезнет, а в правой части панели задач Windows появится значок, говорящий, что соединение установлено. Дважды щелкните мышью на этом значке, чтобы открыть диалог состояния соединения. В этом диалоге показано, сколько времени вы подключены к сети, какой объем информации получен из Интернета, и какой объем передан, а также другая полезная информация. Вы можете в любой момент разорвать соединение, нажав кнопку Отключиться (Disconnect). Нажав кнопку Закрыть (Close), вы опять свернете диалог в значок на панели индикации. Теперь можно приступить собственно к просмотру Web-страниц.

После подключения к Интернету в окне программы Internet Explorer появится Web-страница. Вы можете ввести в поле Адрес (Address) нужный вам адрес Web-страницы и нажать кнопку Переход (Go) правее поля адреса. Также вы можете перейти на другую страницу, щелкнув мышью на интересующей вас ссылке. С помощью задания адресов страниц и перехода по ссылкам вы можете путешествовать по всему Интернету. Если вы передумали просматривать страницу во время ее загрузки на ваш компьютер, вы можете прервать этот процесс, нажав кнопку остановки щ на панели инструментов.

Обозреватель Internet Explorer запоминает введенные ранее адреса, и вы можете вернуться к просмотренным ранее страницам без повторного ввода адреса. Если вы захотите вернуться к ранее просмотренным страницам в текущем сеансе работы с Интернетом, вы можете воспользоваться кнопками, расположенными на панели инструментов. Эти кнопки осуществляют переход на один шаг, то есть на предыдущую или последующую страницы из тех, которые вы уже просмотрели. Чтобы перейти на несколько страниц вперед или назад, следует использовать кнопки q расположенные рядом с кнопками. Нажмите кнопку, расположенную правее. Появится список просмотренных страниц. Обратите внимание, что это не переход по ссылке. Программа Internet Explorer вместо вас подставляет в поле Адрес (Address) нужный адрес. Если вы хотите повторно посетить страницы, на которых вы были не только в текущем сеансе связи, но и ранее, следует воспользоваться кнопкой в правой части поля Адрес (Address).

Поскольку в Интернете очень много информации, важным является умение искать информацию в сети. Существуют специализированные поисковые системы, облегчающие ее поиск. Поисковая система - это место в Интернете, которое помогает вам найти нужную информацию среди огромного количества Web-страниц. В России существует несколько таких систем, и программа знает об этом. Чтобы искать информацию с помощью программы Internet Explorer, нажмите кнопку Поиск (Search) на панели инструментов. При этом в левой части рабочего окна появится группап элементов управления, в которой вы задаете фразу для поиска. Поиск в Интернете похож на поиск файлов в проводнике, описанный нами выше.

Чтобы завершить работу обозревателя Интернета, нажмите кнопку X в правом верхнем углу рабочего окна программы. При этом если больше ни одна программа не работает с Интернетом, появится диалог отключения. Если вы хотите продолжать работать в сети, нажмите кнопку Не отключаться (Stay Connected). В противном случае следует нажать кнопку Отключиться (Disconnect Now).


7.3. Посылка и прием электронных писем

Информация, передаваемая с помощью электронной почты, может быть самой различной. Вы можете посылать текст, программы, изображения, звуки. Электронная почта доставит сообщение в любую точку мира в течение считанных минут. Система Windows XP имеет в своем составе программу для работы с электронной почтой, которая называется Outlook Express.

Чтобы запустить эту программу, щелкните мышью на значке Цзр, расположенном на панели задач Windows или выберите соответствующую команду в главном меню Windows. Если вы работаете с программой Internet Explorer, запустите Outlook Express, нажав кнопку на панели инструментов обозревателя Интернета. Если вы запускаете программу для работы с электронной почтой в первый раз, будет запущен мастер настройки параметров электронной почты. Первый диалог этого мастера предложит вам ввести ваше имя (Рис. 7.8). В этом диалоге следует ввести имя, по которому к вам будут обращаться ваши партнеры по переписке в Интернете. Обычно в этом поле пишут свое имя и фамилию. Если вы планируете вести переписку с зарубежными корреспондентами, то лучше использовать латинские буквы. Для переписки по России желательно написать ваше имя на русском языке. После ввода имени нажмите кнопку Далее (Next), чтобы открыть следующий диалог (Рис. 7.8).

Рис 7.8. Диалоги ввода имени и адреса

Данный диалог содержит переключатель, который определяет различные варианты получения вами адреса электронной почты. Большинство поставщиков услуг Интернета предоставляют вам адрес электронной почты, когда вы подключаетесь у этих поставщиков. Если вы хотите использовать этот адрес, установите переключатель в верхнее положение и введите в поле адрес электронной почты, полученный у поставщика услуг Интернета.

Кроме, как у поставщика услуг Интернета, вы можете получить бесплатный адрес электронной почты и в других местах. В Интернете есть множество компаний, которые оказывают такую услугу. Если вы хотите получить такой адрес, то установите переключатель в нижнее положение и выберите в списке одну из компаний, предоставляющих такую услугу. В любом случае, после ввода адреса электронной почты нажмите кнопку Далее (Next).

Появится очередной диалог мастера для настройки параметров электронной почты (Рис. 7.9). Кроме адреса электронной почты, поставщик должен предоставить вам имена серверов для приема и отправки почты. Можно привести аналогию, что для отправки обычного письма необходимо указывать индекс почтового отделения. В зависимости от возможностей поставщика услуг Интернета, для приема почты могут использоваться серверы РОРЗ или IMAP. В списке Сервер входящих сообщений (Incoming mail Server) надо выбрать соответствующий элемент, а в поле ввода ввести его имя. Для отправки почты используется сервер SMTP, и диалог предусматривает соответствующее поле для ввода его имени. Часто имена серверов для приема и отправки почты совпадают. В этом случае в оба поля надо ввести одно и тоже имя. После указания параметров электронной почты нажмите кнопку Далее (Next) данного диалога, чтобы открыть следующий диалог (Рис. 7.9).

Рис 7.9. Диалог ввода имен серверов для почты

Этот диалог предназначен для ввода идентификатора и пароля, необходимых для доступа к вашему почтовому ящику. Эти данные вы также должны получить от вашего поставщика услуг Интернета. Обычно идентификатор и пароль для доступа к почте совпадают с теми, которые требуются для подключения к поставщику услуг Интернета, однако в некоторых случаях идентификатор для электронной почты может быть другим. В поле ввода Имя пользователя (Account Name) и Пароль (Password) введите полученные имя и пароль. Лучше установить флажок Запомнить пароль (Remember Password), чтобы в дальнейшем он использовался автоматически. Если на вашем компьютере могут работать посторонние лица, пароль лучше не сохранять, чтобы только вы смогли работать с вашей почтой. После ввода параметров нажмите кнопку Далее (Next).

Появится заключительный диалог мастера, предлагающий немедленно подключиться к Интернету. Мы сейчас не будем этого делать, поэтому сбросьте соответствующий флажок и нажмите кнопку Готово (Finish). Работа мастера будет завершена и появится рабочее окно программы Outlook Express. Данная программа позволяет работать с электронной почтой, новостями иди адресной книгой. Вы можете принимать, создавать и отправлять письма. После ? отпуска программы в появившемся окне вас могут попросить выбрать режим работы. Щелкните мышью на ссылке Электронная почта (E-mail), чтобы перейти в этот режим работы. Теперь рассмотрим элементы рабочего окна программы Outlook Express (Рис. 7.10).

Рис 7.10. Рабочее окно программы Outlook Express

Заголовок окна, меню и панель инструментов похожи на аналогичные элементы других программ Windows. Внешний вид панели инструментов может меняться в зависимости от настройки программы. Под панелью инструментов, в левой части окна, расположен список Папки (Folders). В этом списке перечислены папки для хранения корреспонденции.

Все письма, которые приходят вам из Интернета, попадают в папку Входящие (Inbox). Те письма, которые вы создаете для отправки в Интернет, хранятся в папке Исходящие (Outbox). Когда письма отправлены, они перемещаются из папки Исходящие (Outbox) в папку Отправленные (Sent). Ну и, наконец, же письма, которые вы удаляете, попадают в специальную папку, называемую Удаленные (Deleted). Вы можете перемещать корреспонденцию по папкам и создавать свои собственные папки.

Центральная область окна программы поделена на две части. Верхняя часть отображает содержимое выбранной в данный момент папки в виде заголовков сообщений. Нижняя часть окна предназначена для отображения содержимого писем. Строка состояния показывает различные действия, которые в данный момент выполняет программа, а также количество сообщений в открытой папке.

При работе с электронной почтой используются почтовые ящики. Как и в почтовом отделении, у поставщика услуг Интернета расположено много почтовых ящиков, которые имеют разные адреса. Чтобы отправить бумажные письма, вы можете зайти на почту и отдать конверт. Также вы можете взять пришедшую вам корреспонденцию. С электронной почтой работают точно также. Давайте рассмотрим некоторые особенности работы с электронной почтой.

Корреспонденцию из почтового ящика у поставщика услуг Интернета вы должны забирать сами. Никакой почтальон не постучит к вам в дверь, чтобы передать электронное письмо. Для работы с электронной почтой очень важны адреса. Когда вы подключаетесь К Интернету, вы получаете адрес электронной почты. То же самое происходит и с остальными людьми в Интернете. Если вы неправильно напишете адрес получателя, скорее всего, оно вернется обратно с пометкой, что адресат не найден. У вас может быть несколько личных адресов электронной почты.

Для создания писем предназначен элемент на панели инструментов программы. Если кнопка предназначена для простого создания писем, то расположенная рядом кнопка позволяет выбрать различные стили оформления создаваемых писем. Выбирая из списка ряд заранее подготовленных форм и заполняя их, можно создавать красиво оформленные почтовые сообщения. Нажмите кнопку чтобы начать создавать простое письмо. Появится окно, предназначенное для создания писем (Рис. 7.11). В верхней части окна расположены поля для ввода адреса и темы письма, а в большой рабочей области вводится текст письма.

Рис 7.11. Окно создания сообщения

Сначала нужно указать, кому мы хотим отправить письмо. Для этого предназначено поле ввода Кому (То). Если вы одновременно хотите отправить кому-то копию письма, его адрес следует ввести в поле Копия (СС). Поле Тема (Subject) предназначено для ввода краткой аннотации письма. Обратите внимание, что тема сообщения также выносится в заголовок окна. При получении письма эта строка будет отображаться в списке заголовков писем, и корреспондент легко поймет, о чем полученное письмо. Это поле заполняется только вручную и его заполнение не обязательно, хотя и желательно. Если вы не заполните данное поле, программа предупредит вас об этом в специальном диалоге.

Теперь настало время приступать к собственно написанию текста отправляемого сообщения. Для этого используется нижняя область окна для создания письма. Щелкните мышью в этой области и наберите с помощью клавиатуры текст сообщения. Вы можете использовать возможности форматирования программы, похожие на форматирование текстов в любом текстовом редакторе, например, в редакторе WordPad, описанном выше.

После указания адреса и создания письма следует отправить сообщение адресату. Для этой цели предназначена кнопка на панели инструментов окна создания сообщения. Если вы нажмете эту кнопку, система предложит установить соединение с Интернетом, чтобы отправить его (Рис. 7.12). Если вы действительно хотите отправить письмо, нажмите кнопку Подключиться (Connect). Начнется процесс соединения с Интернетом. После того, как соединение установлено, начнется процесс отправки почты, сопровождаемый появлением диалога с прогресс-индикатором (Рис. 7.12, справа). Если вы установите флажок Разорвать соединение по окончании (Hang Up when Finished), то после того, как письмо будет отправлено, связь с Интернетом будет автоматически разорвана.

Рис 7.12. Диалоги при отправке почты

Электронные письма, которые поступают на ваш адрес, хранятся у поставщика услуг Интернета. Это продолжается до тех пор, пока вы не перепишете их на свой компьютер. Для проверки вашего почтового ящика у поставщика услуг Интернета и доставки почты предназначена кнопка на панели инструментов программы Outlook Express. Если нажать эту кнопку, то появится диалог с сообщением о том, что необходимо подключиться к Интернету. Нужно нажать кнопку Подключиться (Connect) этого диалога. После того как соединение установлено, вся почта, ожидающая отправки, будет отправлена. Если для вас есть почта на почтовом сервере, она перепишется на ваш компьютер. Не забудьте по окончании приема почты разорвать соединение с Интернетом.

Письма, которые вы получаете из Интернета, накапливаются в папке Входящие (Inbox). Щелкните мышью на этом элементе списка папок в левой части рабочего окна. В правой верхней части окна появится содержимое папки, представляющее собой список заголовков писем. Чтобы просмотреть интересующее вас письмо, достаточно выбрать его из списка, щелкнув мышью на его заголовке. Содержимое письма появится в правой нижней части окна программы. Двойной щелчок мыши откроет отдельное окно с содержимым выбранного письма.

Вы можете ответить на полученное письмо. Для этого щелкните мышью на нужном письме и нажмите кнопку на панели инструментов. При этом появится окно для создания писем, в котором находится содержимое отмеченного вами письма, и в поле Кому (То) уже будет подставлен адрес автора этого письма. В начале каждой строки исходного письма находится символ “>”, которым принято обозначать цитаты. Вы можете изменить текст письма и добавлять свои замечания. Так можно организовать дискуссию. Пришедшее письмо можно просто переслать без изменений другому корреспонденту. Для этого предназначена кнопка на панели задач.


7.4. Облегчение работы с Интернетом

Для облегчения работы с Интернетом можно использовать программу MSN Explorer. MSN представляет собой аббревиатуру от Microsoft Network - сеть компании Microsoft. Программа MSN Explorer упрощает работу с Интернетом, объединяя в себе многочисленные функции. Вместо множества различных программ вы можете пользоваться исключительно MSN Explorer. Программа MSN Explorer предоставляет вам органайзер, который напомнит вам о важных делах и позволяет хранить ваши записи в записной книжке. Естественно, вы можете путешествовать по Интернету, и в помощь вам предлагается множество ссылок на полезную информацию.

Чтобы запустить MSN Explorer, щелкните мышью на значке 41 в панели быстрого запуска. При первом запуске начнет работу мастер, который настроит программу. В дальнейшем этот мастер не будет появляться при запуске программы MSN Explorer. Первый диалог мастера предназначен для указания способа соединения с Интернетом (Рис. 7.13).

Рис 7.13. Выбор устройства соединения и соединение

Выберите в предлагаемом списке созданное ранее соединение с Интернетом и нажмите кнопку, чтобы продолжить работу. Появится диалог, информирующий о соединении с Интернетом (Рис. 7.13). В дальнейшем подобное окно всегда будет на экране, и в этом окне вы можете выполнять различные команды. После того, как соединение с Интернетом установлено, работа мастера будет продолжена. Чтобы работать с сетью MSN, вам нужно зарегистрироваться, и в появляющихся диалогах вы должны будете ввести информацию о себе. Следует ввести имя и фамилию, ваш адрес, род занятий, дату рождения. Также вам будет предложено ввести пароль для доступа к сети MSN. Кроме того, если у вас нет адреса электронной почты, зарегистрированного в сети MSN, вам будет предложено выбрать себе этот адрес.

После ответа на все вопросы, вы будете зарегистрированы, и начнет работу программа MSN Explorer. В заголовке окна отображается имя программы и текущий режим работы. Если вы путешествуете по Интернету, то в заголовке окна отображается название текущей загруженной страницы. Для перехода на страницу с произвольным адресом этот адрес следует ввести в соответствующее поле и нажать кнопку Переход (Go), расположенную правее поля адреса. Панель инструментов содержит ряд кнопок, которые вызывают часто выполняемые действия, например, работу с электронной почтой или прямое общение в Интернете.

Когда вы регистрируетесь в сети MSN, на соответствующем компьютере в Интернете вам выделяется место на диеке и создается несколько папок, таких, например, как папки с изображениями. Для работы с такими папками, а также других действий предназначена панель с папками, расположенная в левой части рабочего окна. Нажав соответствующую кнопку, вы откроете содержимое выбранной папки в центральной части рабочего окна программы. Также в левой части расположено поле ввода для поиска информации в Интернете. Для прослушивания музыкальных записей прямо во время работы в Интернете предназначен проигрыватель, расположенный в левом нижнем углу окна. Этот проигрыватель содержит кнопки управления, напоминающие кнопки управления обычного магнитофона.

Если-вы нажмете кнопку Мой календарь (My Calendar) в панели папок, то содержимое центральной части рабочего окна изменится. Работа с календарем напоминает аналогичную работу в программе Microsoft Outlook, входящей в состав пакета программ Microsoft Office. Более того, вы можете импортировать все записи календаря из Outlook в MSN Calendar. Календарь позволяет вести расписание, создавать заметки, программировать различного рода напоминания и так далее. Работа с календарем ведется так же, как с Web-страницей, где команды оформлены в виде ссылок.

Когда вы регистрируетесь в MSN, вы получаете адрес электронной почты, и программа MSN Explorer позволяет работать с электронной почтой. Нажав соответствующую кнопку на панели инструментов, вы переходите в режим работы с почтой. Если для вас есть почта, то, перейдя в режим работы с почтой, вы автоматически откроете папку Входящие (Inbox), куда попадают все письма, адресованные вам. Письма отображаются в виде списка заголовков, и, выбрав элемент списка, вы отобразите содержимое письма. Создать письмо вы можете, нажав соответствующую кнопку на панели инструментов.

В заключение отметим, что при последующих запусках программы MSN Explorer мастер регистрации не будет появляться, а после соединения с Интернетом для входа в сеть MSN появится диалог ввода имени и пароля. Введите пароль, который вы установили при первом зацуске мастера нажмите кндпку Регистрация (Sign In). Если пароль верен, то будет запущена программа MSN Explorer. Также вы можете попробовать работу с MSN как гость, без регистрации. Для этого выберите соответствующую ссылку в верхней части окна программы.

Программа MSN Explorer достаточно проста в освоении, но предоставляет пользователю множество дополнительных услуг. Возможно, вам понравится работать с Интернетом, используя эту программу.


7.5. Размещение файлов в Интернете и получение файлов

Кроме путешествия по всемирной паутине и обмена электронной почтой, часто Интернет используется для обмена файлами. Windows XP позволяет легко передавать файлы по Интернету, используя для этого программу Проводник (Windows Explorer). Давайте рассмотрим, как это можно сделать.

Запустите проводник, после чего следует указать место в Интернете, где мы хотим разместить файлы или откуда мы хотим их переписать. Для этого перейдите в папку Мое сетевое окружение (My Network Places). В панели задач появится список команд для работы с сетью. Выберите команду Новое место в сетевом окружении (Create a network shortcut), чтобы запустить мастер добавления в сетевое окружение.

Нажмите кнопку Далее (Next), чтобы начать работу мастера. Появится диалог, который содержит список служб Интернета, предоставляющих услуги по размещению файлов (Рис. 7.23). Если вы планируете размещать файлы в ином месте, выберите в этом списке элемент Другие места в сети (Other Network Places) и нажмите кнопку Далее (Next), чтобы продолжить работу.

Следующий диалог мастера предназначен для ввода адреса того узла в Интернете, который вы планируете использовать для обмена файлами. Обратите внимание, что здесь необходимо вводить полный адрес, включая тип используемого соединения, например, http://www.provider.ru/~user или ftp://ftp.company.com. Ниже поля ввода адреса расположена ссылка, щелкнув на которой мышью, вы увидите несколько примеров, как правильно вводить адреса в этом поле.

После ввода адреса нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера, который предназначен для ввода имени пользователя (Рис. 7.24). Подавляющее большинство FTP узлов в Интернете требуют идентификации для доступа к ним. Если вы хотите получить или разместить файлы на общедоступном узле, то можно использовать для доступа анонимный вход. Анонимный вход представляет собой регистрацию на узле под именем Anonymous, а в качестве пароля выступает ваш адрес электронной почты. Однако такой способ имеет и недостатки, главным из которых является ограниченный доступ к файлам и папкам данного узла Интернета. Обычно это одна или несколько общедоступных папок. Если такой способ доступа вас устраивает, установите флажок Подключаться анонимно (Log on anonymously). В этом случае пароль будет сгенерирован Windows автоматически.

Если вы хотите использовать для обмена файлами узел Интернета, требующий обязательной регистрации, то флажок анонимного подключения следует сбросить, а в поле ввода ввести идентификатор для доступа к узлу. В целях безопасности пароль не вводится. Он будет запрошен позднее, непосредственно при подключении к узлу. После ввода имени пользователя нажмите кнопку Далее (Next), чтобы продолжить работу и отобразить следующий диалог мастера.

Данный диалог предназначен для указания названия того места, к которому вы подключаетесь. Введите в соответствующем поле любое название,, какое вам нравится, и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится заключительный диалог мастера. Нажмите кнопку Готово (Finish), чтобы закрыть этот диалог. Будет осуществлена попытка соединения с указанным местом в сети и появится диалог о необходимости соединения. Нажмите кнопку Подключиться (Connect) этого диалога, чтобы начать соединение с поставщиком услуг Интернета.

После того, как связь с Интернетом установлена, появится диалог ввода пароля к узлу Интернета. Введите пароль и нажмите кнопку ОК, чтобы закрыть диалог. Содержимое корневой папки выбранного узла будет отображено в окне проводника

Теперь, вы можете копировать файлы и папки, как с вашего компьютера на узел в Интернете, так и с узла на ваш компьютер. При этом работа с файлами и папками на узле Интернета ничем не отличается от работы с файлами и папками на вашем компьютере. Все способы работы с проводником, подробно описанные в первой части нашей книги, можно применять и при работе с Интернетом. Вы можете копировать, удалять, перемещать и переименовывать файлы и выполнять другие необходимые действия.
Какие действия вы можете выполнять над папками и файлами в Интернете, зависит от тех прав, которыми вас наделяют при подключении к узлу Интернета. Эти права определяет администратор узла.

В заключение отметим, что если вы хотите использовать какое-либо место в Интернете для обмена файлами не постоянно, а лишь изредка, или вообще один раз, то можно просто ввести его адрес в одноименном поле ввода проводника. При этом если требуется ввод имени и пароля, их следует вводить перед адресом, отделяя от остальной части специальными символами “:” и “@”, например, Лр://имя:пароль@Лр.company.ru. После соединения с указанным узлом, его содержимое появится в окне программы, и вы также можете работать с файлами и папками из Интернета, как со своими собственными папками. Windows XP позволяет легко размещать файлы и папки вашего компьютера в Интернете для того, чтобы другие люди могли с ними ознакомиться. Такое размещение называется публикацией. Обычно возможности публикации используют для удобного размещения информации на вашей персональной Web-странице. Для публикации в Интернете можно воспользоваться созданием нового места в вашем сетевом окружении, которое мы только что рассмотрели, однако для удобства на панели задач имеется специальная ссылка для публикации в Интернете.

Чаще всего, при подключении к Интернету, поставщик услуг бесплатно выделяет вам немного места на своем сервере для вашей домашней страницы. В этом случае адрес вашей страницы в Интернете будет состоять из двух частей: адреса вашего поставщика услуг и вашего имени, например, www.provider.ru/~ivanov. Если же при подключении к Интернету такой услуги вам не предоставлено или за нее просят дополнительную оплату, можно воспользоваться одним из бесплатных сервисов в Интернете.

После того, как место размещения страницы определено, можно приступать к ее публикации. Для этого запустите проводник и выделите папку или файл, которые вы хотите опубликовать, перейдя в нужную папку и щелкнув мышью на значке файла или папки. Выберите ссылку с рисунком на панели задач, и на экране появится первый диалог мастера публикации. Данный мастер очень похож на мастер добавления в сетевое окружение, поэтому мы не будем останавливаться на его работе подробно, отметим лишь особенности. Нажмите кнопку Далее (Next), чтобы начать работу мастера, и в дальнейшем самостоятельно переходите к следующему диалогу. Скорее всего, вашего поставщика услуг Интернета не будет в списке служб, поэтому выбирайте элемент Другие места в сети (Other Network Places) в соответствующем диалоге. В поле ввода адреса нужно ввести в точности такой адрес, который вы получили у поставщика услуг для размещения ваших файлов на его узле. При публикации информации в Интернете не используется анонимный вход, так как при этом любой может испортить вашу информацию в сети. Поэтому нужно сбросить флажок анонимного доступа, а в поле для имени пользователя введите ваш идентификатор для подключения к Интернету. Также отметим, что после публикации выбранное вами место, в Интернете появится в списке вашего сетевого окружения.


  • 8. Работа с аудио и видео
    • Работа с папками Мои музыкальные записи и Мои видеозаписи
    • Автоматическое воспроизведение аудио и видео на сменных носителях
    • Запись и прослушивание звуков в Windows
    • Регулятор громкости
    • Звукозапись
    • Звуковое оформление Windows
    • Проигрыватель Windows Media
    • Знакомство с проигрывателем
    • Использование Интернета проигрывателем
    • Поиск и прослушивание радиостанций
    • Воспроизведение компакт-дисков
    • Воспроизведение DVD-дисков
    • Копирование музыки
    • Работа с библиотеками записей
    • Работа с портативными устройствами
    • Запись музыкальных компакт-дисков
    • Настройка внешнего вида проигрывателя
    • Редактирование видеофильмов в Windows
    • Знакомство с редактором видеофильмов
    • Запись и сохранение видео
    • Редактирование записей
    • Запись звукового пояснения
    • Сохранение фильма
    • Передача видео по электронной почте
    • Размещение фильма в Интернете


8. Работа с аудио и видео

Современная работа за компьютером немыслима без средств мультимедиа, поэтому в состав операционной системы Windows ХР включены разнообразные средства для работы со звуком и изображениями. Давайте рассмотрим основные возможности системы по работе с аудио и видео.


8.1. Работа с папками Мои музыкальные записи и Мои видеозаписи

Для работы с видео- и аудиозаписями в Windows ХР предусмотрены специальные папки, которые называются Мои музыкальные записи (My Music) и Мои видеозаписи (My Videos). Это обычные папки на диске вашего компьютера однако при работе с ними Windows предоставляет вам дополнительные возможности. Откройте главное меню и выберите команду Мои музыкальные записи (My Music), чтобы открыть соответствующую папку (Рис. 8.1).

Рис 8.1. Содержимое папки музыкальных записей

Если в этой папке есть музыкальные файлы, то они появятся в правой части окна в виде увеличенных значков. В панели задач появилось несколько новых элементов, связанных с аудиозаписями. Выберите команду Воспроизвести все (Play All) в панели задач. Будет автоматически построен список воспроизведения, после чего запустится программа Проигрыватель Windows Media (Windows Media Player) и начнется воспроизведение музыкальных записей, находящихся в этой папке. Более подробно о работе программы Проигрыватель Windows Media (Windows Media Player) вы узнаете ниже. Вторая команда в панели задач связана с приобретением музыкальных записей в Интернете. Выберите команду Купить в Интернете (Buy music online). Если вы не подключены к Интернету, то появится диалог, говорящий о необходимости подключения. Нажмите кнопку Подключиться (Connect) этого диалога. Будет загружена программа Internet Explorer и открыта страница музыкального магазина.

Переходя по ссылкам, вы можете выбрать интересующий вас альбом и композицию. Не забывайте, что покупка в Интернете осуществляется с помощью кредитных карт. Если вы не хотите больше работать в Интернете, закройте окно программы Internet Explorer и разорвите связь с поставщиком услуг Интернета.

Еще одной возможностью работы с музыкальными композициями в папке Мои музыкальные записи (My Music) является создание музыкальных компакт-дисков. Чтобы записать композиции на компакт-диск, следует выделить их и щелкнуть на выделенных файлах правой кнопкой мыши. Будет открыто вспомогательное меню. В этом меню выберите команду Записать Audio CD (Burn Audio CD). Начнет работу универсальный проигрыватель мультимедийных файлов, позволяющий записать информацию на компакт-диск. Работу с этой программой мы опишем ниже.

Для хранения видеоклипов также предусмотрена специальная папка которая называется Мои видеозаписи (My Videos). Открыть эту папку можно если выбрать в главном меню Windows команду Мои документы (My Documents), после чего перейдите к папке Мои видеозаписи (My Videos), дважды щелкнув мышью на ее значке. В окне проводника появится содержимое папки представленное в виде эскизов, изображающих содержимое клипа. Дважды щелкните на одном из эскизов мышью чтобы запустить программу Проигрыватель Windows Media (Windows Media Player) для просмотра выбранного видеофильма. Также вы можете выполнить некоторые другие действия.


8.2. Автоматическое воспроизведение аудио и видео на сменных носителях

В предыдущих версиях Windows при установке звукового компакт-диска автоматически начиналось его воспроизведение. В Windows XP появилась возможность воспроизведения не только звуковых но и других типов дисков. Кроме того, автоматическое воспроизведение теперь работает и для многих других типов устройств. Функция автоматического воспроизведения значительно повышает удобство работы со сменными устройствами, такими, как компакт-диски, дисководы Zip и другими. Когда вы подключаете сменное устройство или вставляете диск система определяет, какие файлы содержатся на устройстве, и сама запускает нужную программу для работы с этими файлами. Например если это музыкальный диск, то будет запущен проигрыватель. Если диск содержит изображения, то будет запущена программа их просмотра и так далее. Давайте рассмотрим, как настроить эту возможность в Windows XP.

Выберите в главном меню Windows команду Мой компьютер : Му Computer). Будет запущен проводник и текущей станет папка содержащая список устройств, подключенных к вашему компьютеру. Выберите желаемое устройство например дисковод для компакт-дисков и щелкните на соответствующем этому устройству значке правой кнопкой мыши. Выберите в появившемся вспомогательном меню команду Свойства (Properties), чтобы отобразить диалог настройки параметров устройства.

Вкладка Общие (General) содержит различную информацию о характеристиках устройства. Если в дисководе нет диска, то все величины будут равны нулю. Когда вы вставите диск, на этой вкладке будет отображен объем диска, количество свободного места и другая информация. Щелкните мышью на вкладке Автовоспроизведение (AutoPlay), чтобы перейти на эту вкладку и настроить автоматическое воспроизведение. В верхней части диалога выбирается тип информации, для которого вы хотите задать автоматическое воспроизведение. Например вы можете выбрать изображения видео или звуковые файлы. После выбора нужного типа информации во втором списке диалога появится перечень доступных действий, которые можно выполнить при распознавании диска с данным типом информации. Щелкнув мышью на одном из действий в списке вы выберите его. Обратите внимание что конкретные действия устанавливаются для каждого типа информации независимо. Кроме того с помощью переключателя в диалоге вы можете определить/ как будут выполняться действия: автоматически с запросом перед выполнением или вообще не выполняться.

Если вы хотите, чтобы после установки диска с видеоклипами система сама начала их воспроизведение выберите в верхнем списке элемент Видео (Video). В группе элементов управления Действия (Actions) установите переключатель в положение для выбора действий. Во втором списке появится перечень действий. Выберите элемент Воспроизвести (Play) и нажмите кнопку ОК, чтобы закрыть диалог настройки. В дальнейшем при установке в устройстве диска с видеоклипами автоматически начнется их воспроизведение. Аналогично вы можете установить действия и для других типов информации.


8.3. Запись и прослушивание звуков в Windows

Для работы со звуковой информацией в системе Windows есть несколько программ. Кроме того, существует возможность настроить систему для использования звукового сопровождения при работе Windows.


8.3.1. Регулятор громкости

Программа Регулятор громкости (Volume Control) предназначена для управления воспроизведением звука на вашем компьютере. Эта программа позволяет включать и отключать различные источники звука в вашем компьютере а также регулировать громкость каждого источника и стереобаланс когда это возможно. В некоторых случаях возможна регулировка тембра звука. Чтобы запустить программу регулятора громкости, откройте главное меню Windows затем выберите команду Другие программы (Other Programs). В появившемся вспомогательном меню выберите команду Стандартные * Развлечения * Громкость (Accessories * Entertainment * Volume control). После запуска программы откроется окно внешний вид которого зависит от того какая именно звуковая карта используется в вашем компьютере (Рис. 8.2). Данное окно содержит несколько регуляторов громкости и баланса управляющих различными источниками звука. Часто данную программу называют микшером, так как в ней настраивается смешивание звуков от разных источников.

Поскольку число этих источников может быть различным то и количество элементов в окне регулятора громкости также может различаться.

Рис 8.2. Окно регулятора громкости

Каждый элемент управления имеет ползунок регулировки громкости и флажок для полного отключения данного устройства. Дополнительно у каждого устройства имеется также еще один горизонтальный ползунок, регулирующий баланс между левым и правым стереоканалами. Самая левая группа элементов управления меняет громкость одновременно для всех устройств. Вертикальный ползунок позволяет одновременно производить регулировку громкости для всех устройств подключенных к компьютеру. Флажок расположенный ниже, позволяет обеззвучить компьютер, отключив все звуки разом.
Обращаем ваше внимание на то, что отключение звука с помощью установки флажка в окне регулятора громкости не отключает звуковое оборудование компьютера, а лишь отключает акустические системы.

Одновременное отключение звука всех устройств конечно удобно, однако обычно программу регулирования громкости используют не для общей регулировки, а для выборочной настройки отдельных звуковых устройств. Для дополнительной настройки параметров звуковой платы следует выбрать команду меню Параметры * Свойства (Preferences * Options). В появившемся диалоге вы можете самостоятельно выбирать, какими устройствами следует управлять.

Делается это путем сброса и установки флажков. Так, по умолчанию, управление микрофоном в окне микшера не отображается. Вы должны самостоятельно установить флажок напротив микрофона в списке устройств, после чего можете включить вход с микрофона и настроить громкость. После этого компьютер будет работать как громкоговоритель. Лучше не включать вход с микрофона чтобы избежать нежелательных шумов. Однако вам может потребоваться записать что-либо с микрофона. Следует знать, что запись и воспроизведение настраивается совершенно независимо. Для настройки воспроизведения следует с помощью переключателя в диалоге выбрать отображение устройств для записи, а не для воспроизведения, после чего нажать кнопку ОК в диалоге. Вы вернетесь к регулировке но теперь вам будет предложено регулировать уровень записи разных источников звука. Если установить флажок в описании микрофона, вы включите его. Ползунком можно отрегулировать уровень записи. При этом если отключено воспроизведение с микрофона в акустических системах не будет слышно никаких звуков. Однако программы работы со звуком будут получать необходимый сигнал с микрофона.

Для некоторых звуковых карт окно регулятора громкости может содержать дополнительную кнопку, нажатие на которую открывает окно регулировки тембра и других параметров, допускаемых конкретной звуковой картой. Перемещая ползунки установите требуемый тембр звучания и нажмите кнопку Закрыть (Close). После настройки уровней записи и воспроизведения вы можете закрыть окно программы регулировки громкости нажав кнопку в заголовке окна программы.


8.3.2.Звукозапись

Существует большое количество программ для записи звука в файл и последующей обработки звука путем наложения различных эффектов и воспроизведения его через звуковую карту. В состав стандартных программ Windows входит программа Звукозапись (Sound recorder)/ позволяющая решать подобные задачи.

Программа Звукозапись (Sound recorder) вызывается из группы программ Стандартные (Accessories) главного меню Windows и позволяет записать звук подаваемый на линейный вход звуковой карты, с микрофона компакт-диска или любого другого источника. Полученную запись можно прослушать. Если качество звучания вас не удовлетворяет можно изменить параметры записи и перезаписать звуковую информацию. Можно провести некоторые операции редактирования и наложения эффектов а затем сохранить полученную композицию в отдельном файле или вставить в качестве фрагмента в различные документы.

После запуска программы Звукозапись (Sound recorder) на экране появляется ее рабочее окно содержащее шкалу записи и несколько кнопок напоминающих органы управления обычным магнитофоном (Рис. 8.3). Для записи звука необходимо выполнить ряд подготовительных действий. Прежде всего необходимо определить источник звука. Для этого следует открыть окно программы Регулятор громкости (Volume Control), как это рассмотрено выше. В появившемся окне следует установить флажки отключения всех устройств кроме нужного, например, микрофона. Далее следует вернуться к работе с программой звукозаписи и настроить качество записи для фонограммы.

Рис 8.3. Рабочее окно программы

Выберите команду меню Файл * Свойства (File * Options). Появится диалог настройки звуковых параметров новой фонограммы. Среди свойств содержится и информация об атрибутах создаваемой записи, влияющих на ее качество. К таким атрибутам относится частота дискретизации и число каналов. Если качество предполагаемой записи вас не устраивает, нажмите кнопку Преобразовать (Convert). Появится диалог настройки преобразования звука.

Список Формат (Format) позволяет выбрать метод кодирования звуковой информации, а список Атрибуты (Attributes) - качество этого кодирования. Диалог содержит также список Название (Name), содержащий часто используемые форматы и атрибуты записи. Выбрав в этом списке элемент Запись с компакт-диска (Audio CD), мы увидим, что информация на аудиокомпакт-дисках записана в формате РСМ и с качеством 44.1 КГц 16 бит, стерео.

В последнее время популярными становятся форматы использующие сжатие музыки. Для распространения музыки через Интернет широко используется формат МРЗ, полное название которого MPEG Layer-3. Этот формат позволяет уменьшить объем хранимой информации более чем в десять раз по сравнению со стандартным способом хранения звуковой информации. При этом такое уменьшение объема происходит практически без потери качества звука.

Это достигается путем сжатия музыкальной информации и переносе искажений, получающихся из-за сжатия, в неслышимый человеческим ухом спектр сигналов. Также учитывается неспособность большинства людей различать сигналы, по мощности лежащие ниже определенного уровня, разного для разных частотных диапазонов. Подобные техники называются адаптивным кодированием и позволяют экономить на наименее значимых с точки зрения восприятия человеком деталях звучания.

Несмотря на то, что формат МРЗ не единственный из форматов сжатия звука, именно его чаще всего используют на практике. Это объясняется тем, что данный формат имеет целый ряд преимуществ. Формат МРЗ является свободно распространяемым и кодирование информации не требует лицензирования. Кроме того, написано большое количество удобных программ для работы с музыкой в этом формате.

Кроме использования этого большого количества программ, позволяющих создавать файлы в формате МРЗ, можно воспользоваться обычными встроенными средствами Windows. При работе с Windows XP, вам не потребуется никаких дополнительных программ. Используя встроенную программу кодирования и декодирования формата МРЗ, вы получите возможность использовать файлы формата МРЗ в стандартных программах, входящих в состав Windows. Чтобы использовать форматы со сжатием музыки следует в диалоге Выбор звука (Sound Select) выбрать соответствующий формат записи, например, МРЗ или WMA. Как вы уже знаете, список Атрибуты (Attributes) позволяет выбрать качество фонограммы в сохраняемом файле. Обобщенным показателем качества записываемой фонограммы является скорость потока данных, часто называемая битрейтом (bitrate - частота битов). Битрейт изменяется в килобитах в секунду. Качество, соизмеримое с качеством записи на цифровых универсальных дисках DVD, достигается при битрейте, равным 128 Кбит/сек. Качество диктофона можно получить при битрейте равном 8 Кбит/сек.

Искажения при кодировании в формате МРЗ во многом зависят от характера музыкального материала. Симфоническая музыка требует большего битрейта, а танцевальная - меньшего. Наиболее популярным битрейтом при кодировании музыкальных композиций считается 128 Кбит/сек, дающий хорошее качество записи, и позволяющий сжимать исходную запись более чем в десять раз.

Остальные атрибуты кодирования, такие, как частота дискретизации и количество каналов, точно такие же как и при оцифровке звука без сжатия. После того, как вы выберете атрибуты качества кодирования, закройте диалог, нажав кнопку ОК. Теперь выберите папку для сохранения и имя сохраняемого файла.

После выбора формата записи и ее качества нажмите кнопку Сохранить (Save), чтобы открыть диалог задания имени (Рис. 8.4). В поле ввода следует ввести имя сохраняемого вами формата. Затем нажмите кнопку ОК, и выбранное вами имя появится в списке форматов. После выбора формата и качества нажмите кнопку ОК, чтобы закрыть диалог Выбор звука (Sound Select), а затем кнопку ОК диалога Свойства: Звук (Sound Properties).

Рис 8.4. Диалог ввода имени

При записи фонограмма будет преобразована в выбранный формат и сохранена на диске. Если используются форматы сжатия, то при воспроизведении фонограммы данные будут автоматически распаковываться и вы можете даже не заметить что воспроизводится сжатая фонограмма.

Теперь мы готовы начать запись. Чтобы сделать это, следует нажать кнопку в окне программы создания фонограммы, и включить источник звука. Однако перед тем как это сделать лучше запустить программу регулировки уровня звука и убедиться то требуемый источник звука подключен. Если используется микрофон то следует настроить его чувствительность.

После настройки микрофона можно включать запись и начинать говорить. Зеленая линия в средней части окна показывает уровень записываемого звука и ее наличие говорит о том, что запись происходит успешно. Остановить запись можно нажав кнопку. По истечении шестидесяти секунд, запись автоматически останавливается. Чтобы далее продолжить запись, необходимо еще раз нажать кнопку. Общая продолжительность записи указывается правее графика звуковой волны.

Вы также можете использовать данную программу для воспроизведения как только что записанных, так и ранее записанных и находящихся в файлах звуков. Для воспроизведения используется кнопка. Также программа имеет средства для простейшего редактирования звукозаписей, такие как возможность вырезания участка записи, как до так и после текущей позиции ползунка воспроизведения. Дополняет средства редактирования набор простейших звуковых эффектов которые можно наложить на редактируемую запись. Вы можете изменить громкость и скорость а также наложить эхо или обратить звуковую запись. Все эффекты можно вызвать, выбрав соответствующую команду меню.

В заключение работы с фонограммой, ее необходимо сохранить для последующего использования. Выберите команду Файл * Сохранить (File * Save), чтобы открыть соответствующий диалог. В этом диалоге выберите папку для сохранения и имя сохраняемого файла, после чего нажмите кнопку Сохранить (Save). Ваша фонограмма будет сохранена.


8.3.3. Звуковое оформление Windows

Практически все современные компьютеры оборудованы звуковой картой и, соответствующим образом настроив Windows, вы можете значительно повысить удобство работы. Звуковое оформление построено по принципу реакции на события. Во время работы вы выполняете определенный набор действий, как с окнами так и со значками на рабочем столе. Каждому такому действию можно сопоставить какой-либо звуковой эффект. Чтобы настроить звуковое сопровождение Windows следует открыть папку Панель управления (Control Panel) с помощью одноименной команды главного меню. По умолчанию данная папка отображается в виде Web-страницы, в которой имеются ссылки на различные группы элементов управления компьютером. В ином режиме в папке расположены значки всех элементов управления без разбиения на группы.

Выберите группу Звуки, речь и аудиоустройства (Sounds, Speech and Audio Devices), щелкнув мышью на одноименной ссылке. Вы перейдете к папке, в которой сгруппировано управление аудиоустройствами. Выберите значок с названием Звуки и аудиоустройства (Sounds and Audio Devices). Кстати, если у вас панель управления отображается в классическом виде, то нужный значок вы увидите в общем списке и двойным щелчком мыши на данном значке вы выполните аналогичное действие. Появится диалог настройки параметров звукового оборудования, содержащий несколько вкладок. Давайте рассмотрим некоторые из них/ и начнем с вкладки Уровень (Volume) (Рис. 8.15).

Рис 8.5. Настройка свойств мультимедиа

Эта вкладка позволяет установить общий уровень звучания устройства используемого для воспроизведения звуков в системе. Регулировка осуществляется путем перемещения горизонтального ползунка. Перемещение ползунка влево уменьшает громкость а перемещение вправо - увеличивает ее. Ниже ползунка расположены два флажка. Установка первого флажка позволяет обеззвучить компьютер отключив все звуки разом. Сброс этого флажка снова включает звук на компьютере. Если установить второй флажок то на панели задач Windows появится значок регулировки громкости, дважды щелкнув на котором вы запустите программу регулировки уровня звука. Одинарный щелчок мыши откроет окно быстрой регулировки с регулятором общего уровня звука и флажком отключения звука.

При отключенном звуке значок громкоговорителя на панели задач изображается перечеркнутым. Чтобы закрыть окно быстрой регулировки громкости, достаточно щелкнуть где угодно за его пределами. Элементы управления в нижней части вкладки позволяют настроить звучание акустических систем, подключенных к компьютеру. Можно выбрать стереосистемы, встроенные в монитор динамики или систему объемного звучания.

Щелкните мышью на ярлычке Звуки (Sounds), чтобы перейти на соответствующую вкладку диалога настройки (Рис. 8.15). Нижняя часть диалога отображает список событий при работе с Windows, которым можно сопоставить звуковые эффекты. Некоторые программы добавляют свои события в этот список. Если рядом с событием есть значок громкоговорителя, значит этому событию назначен какой-то звук. Можно изменить звук для каждого события, а можно изменить всю звуковую схему целиком. Чтобы назначить событию звук, надо выбрать требуемое событие в списке Озвучивание событий (Sound Events), а в списке Звуки (Sounds) выбрать для него звуковой файл. При необходимости можно воспользоваться кнопкой Обзор (Browse) для поиска нужного звука. Совокупность звуковых эффектов называется звуковой схемой. В открывающемся списке Схема (Scheme) указана текущая звуковая схема.

Кроме готовых звуков, поставляемых в составе Windows, вы можете использовать и собственные сочинения. Например, можно настроить компьютер так, чтобы он играл нравящуюся вам музыку при запуске Windows или говорил приветствие. Для этого вначале следует записать приветствие, используя программу Звукозапись (Sound recorder), и сохранить полученную фонограмму. Для экономии места можно сохранить музыкальную композицию в сжатом виде например, в формате МРЗ. Далее вызовите диалог настройки звукового оформления и в списке Озвучивание событий (Sound Events) выберите элемент Запуск Windows (Start Windows), а правее списка Звуки (Sounds) нажмите кнопку Обзор (Browse). Появится диалог открытия файла. Укажите папку где находится записанная вами фонограмма, и выберите ее, после чего нажмите, кнопку ОК. Звук будет назначен указанному событию, и при следующем запуске Windows будет воспроизведена ваша фонограмма.

Чтобы в дальнейшем облегчить изменение назначенных звуков, лучше сохранить новую звуковую схему. Нажмите кнопку Сохранить как (Save As) около списка Схема (Scheme). Появится диалог Сохранение схемы (Save Scheme) (Рис. 8.6).

Рис 8.6. Диалог сохранения звуковой схемы

Введите в поле ввода имя, которое вы хотите присвоить своей собственной звуковой схеме, и нажмите кнопку ОК чтобы закрыть диалог. В дальнейшем вы можете произвольно менять назначенные звуки. Для возврата к сохраненной схеме следует просто выбрать ее в списке доступных схем.

При работе с Windows приходится записывать звуковую информацию с микрофона, а затем воспроизводить ее. Для настройки этой возможности предусмотрена специальная вкладка в диалоге настройки. Щелкните мышью на вкладке Голос (Voice), чтобы перейти на соответствующую вкладку (Рис. 8.7).

Рис 8.7. Настройка записи и воспроизведения

Вкладка содержит две группы элементов управления: для настройки параметров воспроизведения и записи. В каждой из этих групп есть открывающийся список для выбора используемого устройства. По умолчанию для воспроизведения и записи используется звуковая карта, и мы не рекомендуем ничего менять в этих списках. Кроме списка, группы управления содержат ряд кнопок.

Кнопка Уровень (Volume) открывает окно программы Регулятор громкости (Volume control) (Рис. 8.4) для регулировки большего числа параметров. Параметры зависят от того, в какой группе элементов управления нажата эта кнопка. Кнопка Дополнительно (Advanced) позволяет настроить параметры качества записи и воспроизведения. Кнопка Тест (Voice Test) позволяет проверить работу вашего оборудования по записи и воспроизведению голоса. Нажмите эту кнопку чтобы запустить мастер проверки звукового оборудования и открыть его первый диалог (Рис. 8.8, слева).

Рис 8.8. Диалоги мастера проверки звука

Нажмите кнопку Далее (Next), чтобы начать проверку. Вначале будет проверена возможность записи голоса с микрофона и появится соответствующий диалог (Рис. 8.8, справа). Вам нужно подключить микрофон к вашему компьютеру и прочитать в него текст, который приведен в диалоге. При этом если все нормально, то когда вы говорите, должен меняться индикатор уровня в группе для записи расположенный правее ползунка регулятора. При необходимости настройте уровень записи, перемещая ползунок вниз, чтобы уменьшить уровень и вверх чтобы его увеличить. Нормальным считается уровень когда измеритель во время вашей речи не загорается красным цветом. Допустимыми являются зеленый и желтый цвета. Если при вашей речи измеритель уровня не двигается то следует проверить все соединения и убедиться/ что звуковая карта работает нормально.

Если измеритель меняет размер и цвет и вы настроили уровень то все в порядке. Можно продолжить тестирование, для чего следует нажать кнопку Далее (Next). Появится следующий диалог мастера проверки звукового оборудования (Рис. 8.9). Данный мастер предназначен для проверки возможностей воспроизведения звука. Вам также понадобится подключенный к компьютеру микрофон, убедитесь что акустические системы подключены и включены а затем произнесите в микрофон фразу которая написана в диалоге.

Рис 8.9 Заключительные диалоги мастера

Если все в порядке вы услышите ваш голос из динамиков компьютера. Если ваш голос звучит с искажениями или вы слышите «микрофонный эффект» в виде громкого воя следует уменьшить уровень воспроизведения а если это не поможет то уменьшить уровень записи. Также наблюдайте за индикаторами уровней записи и воспроизведения, расположенными правее ползунков регулировки. После проверки нажмите кнопку Далее (Next) чтобы продолжить работу. Появится заключительный диалог мастера проверки звукового оборудования. Нажмите кнопку Готово (Finish) чтобы закрыть этот диалог и завершить работу мастера. Теперь вы уверены, что ваше оборудование работает нормально, и вы можете использовать различные программы работы со звуком.


8.4. Проигрыватель Windows Media

В состав Windows XP включена программа, которая предназначена для воспроизведения разнообразных мультимедийных файлов. Под мультимедийными файлами понимаются различные звуковые или видеофайлы всевозможных форматов, как использующих сжатие, так и не использующих. Эта программа называется Проигрыватель Windows Media (Windows Media Player) и входит в состав стандартных программ. Проигрыватель автоматически запускается, когда вы выбираете мультимедийный файл в проводнике Windows. Кроме того вы можете запустить проигрыватель с помощью главного меню Windows и выбрать любой файл для воспроизведения. Давайте рассмотрим, как это происходит.

Выберите в главном меню команду Мои музыкальные записи (My Music), чтобы открыть соответствующую папку (Рис. 8.1). Папка Мои музыкальные записи (My Music) предназначена для хранения создаваемых вами, полученных из Интернета или переписанных с компакт-дисков музыкальных файлов. Кроме того, в ней находится нисколько, примеров, поставляемых вместе с Windows. Значки в этой папке имеют различный внешний вид. Разный вид значков показывает, что используются мультимедийные файлы различных стандартов и форматов. Чаще всего из изображения значка понятно, какую информацию содержит файл, обозначаемый данным значком. Давайте послушаем один из них, воспользовавшись для этой цели программой Проигрыватель Windows Media (Windows Media Player).


8.4.1. Знакомство с проигрывателем

Дважды щелкните мышью на значке, обозначающем один из мультимедийных файлов. Будет загружена программа Проигрыватель Windows Media (Windows Media Player) и начнется воспроизведение выбранного музыкального файла (Рис. 8.10). Вы можете выделить несколько файлов и выбрать команду воспроизведения в панели задач или во вспомогательном меню, которое вызывается правым щелчком мыши. При выборе нескольких файлов они будут воспроизводиться последовательно, друг за другом.

Рис 8.10. Воспроизведение фонограммы

Рабочее окно программы, как и все окна Windows, имеет заголовок окна и меню. В правом верхнем углу расположен список воспроизведения. В данном случае он состоит из одного файла, но может содержать и много файлов. Подробнее об этом вы узнаете позже. Ниже меню выводится название композиции, которая в настоящий момент воспроизводится. В левой части окна имеется панель режимов с несколькими кнопками, нажатие которых позволяет выбирать режим работы программы. Далее мы рассмотрим каждый из имеющихся в проигрывателе режимов, а пока лишь отметим, что в данное время проигрыватель находится в режиме воспроизведения, который является основным режимом работы.

В нижней части окна проигрывателя располагается панель управления воспроизведением, которая содержит обычные для такого рода программ элементы: кнопку паузы или воспроизведения кнопку полной остановки, регулятор громкости, кнопки перемотки вперед и назад а также ползунок, показывающий текущее положение воспроизведения в файле. Большая кнопка, расположенная в левой части панели, может выглядеть как или . Во время Воспроизведения кнопка имеет вид ). Нажатие данной кнопки приостановит воспроизведение, а кнопка изменит свой вид на. Нажав кнопку, вы продолжите воспроизведение с прерванного места. Кнопка, расположенная правее предназначена для прекращения воспроизведения. Если позже вы нажмете кнопку, композиция будет снова воспроизведена с самого начала. С помощью ползунка регулируется громкость звука.

Если вы работаете с несколькими звукозаписями или фильмами с помощью кнопок и можно переходить к предыдущему или следующему файлу. Если в списке воспроизведения имеется только один файл данные кнопки недоступны. Для ускоренной перемотки вперед и назад используются кнопки и соответственно. Следует отметить что ускоренная перемотка не работает для некоторых типов файлов. Вы можете перейти к любой части воспроизводимого произведения перетащив мышью ползунок расположенный над кнопками. Если вы просматриваете видеофильм можно остановить воспроизведение и перетащить ползунок в произвольное место чтобы отобразить выбранный кадр.

Центральная часть окна предназначена для воспроизведения видеоинформации. При прослушивании аудиозаписей это место обычно используется для отображения различных

визуальных эффектов. У вас есть возможность выбрать эффекты с помощью кнопок, расположенных над панелью управления. Далее мы покажем, что внешний вид проигрывателя можно настроить по своему вкусу, поэтому вид окна программы на вашем компьютере может отличаться от вида приведенного в рисунке. Но все равно он будет работать точно так же как и описанный нами. Воспроизведение видео- и аудиофайлов в проигрывателе выполняется так легко что практически не требует особых знаний. Все действия просты и понятны, органы управления похожи на аналогичные органы бытового музыкального центра. Познакомившись с основными элементами окна проигрывателя мультимедийных файлов, рассмотрим некоторые другие, кроме воспроизведения звуковых и видеофайлов, возможности проигрывателя.


8.4.2. Использование Интернета проигрывателем

Кроме воспроизведения мультимедийных файлов расположенных на вашем компьютере проигрыватель Windows Media может воспроизводить звуковые и видеопотоки из различных источников. К числу основных источников мультимедиа информации вне вашего компьютера относится прежде всего Интернет. Давайте рассмотрим основные возможности проигрывателя по работе с такой информацией. При этом обращаем ваше внимание что программа активно работает с Интернетом и чтобы ознакомиться с ее возможностями в полной мере необходимо быть подключенным к сети. Если вы еще не подключились к Интернету и не настроили свой компьютер для работы в этой сети вам необходимо сделать это прежде чем продолжать изучение возможностей проигрывателя. Если же у вас нет возможностей выхода в Интернет, вы можете пропустить описание работы данной программы в Интернете.

Установите соединение с Интернетом, а затем перейдите в режим путеводителя, нажав одноименную кнопку на панели режимов, которая расположена второй сверху. Кнопка останется в нажатом состоянии, а в центре окна программы появится начальная страница путеводителя (Рис. 8.11).

Рис 8.11. Работа в режиме путеводителя в Интернете

В этом режиме проигрыватель получает информацию из Интернета. Вашему вниманию предлагается информация о музыкальных и видеоновинках, новостях политики, бизнеса и так далее. Подробно ознакомиться с различной информацией можно, щелкнув мышью на соответствующих ссылках. Ссылки могут выглядеть по-разному. Чаще всего создатели стремятся сделать так, чтобы ссылки были заметными на фоне остального содержимого страницы. Определить ссылку на изображении достаточно легко. Обычно ссылки выделяются в документе цветом или подчеркиванием. Указатель мыши, проходя над ссылкой, меняет свою форму на стилизованное изображение руки.

Центральная часть окна проигрывателя в этом режиме очень похожа на содержимое окна программы обозревателя Интернета при путешествии по всемирной паутине. Просто в нашем случае адреса Web-страниц программа вводит за вас самостоятельно. Внешний вид загружаемой в этом режиме из Интернета

страницы может быть самым разным, однако в нем обязательно будут присутствовать ссылки на разнообразную информацию. Также можно искать интересующую вас композицию или клип введя их названия в поля поиска. Кроме того, можно заказать в Интернет-магазинах интересующие вас произведения и переписать их на Свой компьютер. Конечно, для покупок в сетевых магазинах требуется наличие кредитной карты. Такие карты предлагают многие российские банки.

Для того чтобы разобраться, как происходит работа с путеводителем выберем одну из ссылок щелкнув на ней мышью. В окно программы Проигрыватель Windows Media (Windows Media Player) будет загружена новая страница. В нашем случае мы попали на страницу обзора видеоновинок. Щелкнув мышью на интересующем вас фильме можно узнать информацию о нем, посмотреть презентационный ролик, и купить понравившийся вам фильм. Такие ролики называют трейлерами (Trailer), так, что если вы увидите это слово на странице, имейте в виду что оно обозначает.

Кроме ссылки на первую страницу путеводителя обозначенной как Домашняя страница (Ноmе) проигрыватель имеет вертикальный ряд ссылок, обеспечивающий быстрый доступ к различной информации в Интернете. Эти ссылки расположены в левой части окна с изображением Web-страницы. Щелкните мышью на ярлычке Музыка (Music). В рабочем окне программы появится новая страница . Данная страница также является своеобразным путеводителем в мире музыки. Ее внешний вид постоянно меняется, однако вы без труда можете разобраться в ссылках, которые есть на ней. Например, вы можете искать нужную вам музыкальную композицию или исполнителя, который вам нравится. Для этого следует выбрать ссылку поиска, выбрать категорию например блюзы (Blues). Появится список музыкантов. Выберите в списке понравившегося вам исполнителя. Обычно информация об исполнителе содержит его биографию и список выпущенных альбомов. Вы можете выбрать альбом из списка, просмотреть его содержимое и даже прослушать фрагменты композиций этого альбома.

Щелкните мышью на ссылке Радио (Radio), чтобы перейти на соответствующую страницу. Появится окно путеводителя. Эта страница содержит ссылки на различные радиостанции в Интернете, которые вещают на разных языках и транслируют разную музыку (Рис. 8.19, слева).

Рис 8.12. Web-страница радиостанции

Выбор интересующей вас радиостанции осуществляется переходом по соответствующей ссылке. Щелкните мышью на названии радиостанции, и на экране вашего компьютера появится окно программы обозревателя Интернета (Рис. 8.12). В этом окне вы можете выбрать интересующую вас тему или композицию и прослушать ее вместе с комментариями о ней. При этом окно проигрывателя не будет закрыто и вы продолжите работу с двумя программами одновременно.

Для детального знакомства и работы в мире видеофильмов предназначена соответствующая ссылка путеводителя. Щелкните мышью на ярлычке Видео (Video). В рабочем окне опять появится новая страница. Она мало отличается от рассмотренных ранее страниц. Обычно эта страница содержит ссылки на самые популярные новые фильмы, Описание каждого фильма имеет ссылки на трейлеры, так что, перейдя по ней, вы сможете посмотреть на экране вашего компьютера рекламный ролик. В зависимости от качества вашего соединения с Интернетом вы можете выбрать различный размер просматриваемого фильма. Поддержка в Интернете сведений для проигрывателя постоянно расширяется и обновляется. Вы можете найти самую последнюю информацию о ваших любимых исполнителях, увидеть их фотографии, послушать песни и даже познакомиться с их биографией. К сожалению, информация об отечественных исполнителях отсутствует, и вам придется довольствоваться только звездами мировой музыки и кино.

Ссылка Развлечения (Entertainment) загружает страницу, содержащую другие ссылки на занимательную и интересную информацию в сети Интернет. Ссылка Стиль жизни (Lifestyles) загружает страницу со ссылками на информацию о различных увлечениях. Ссылка Бизнес (Business) используется, если вы интересуетесь финансовой и деловой информацией. Если вы интересуетесь спортом, то вам будет полезна одноименная ссылка. Для получения самой свежей информации в разных областях используйте ссылку Новости (News), а для того, чтобы увидеть различные интересные моменты жизни в реальном времени вам пригодится ссылка Web-камеры (Webcams).


8.4.3. Поиск и прослушивание радиостанций

Рассмотренная ссылка Радио (Radio) путеводителя по медиа в Интернете предлагает вам список радиостанций, который заложили в программу разработчики этого путеводителя. Может случиться что нужной вам станции вы в путеводителе не найдете. Для более удобной работы с радиостанциями в Интернете используется кнопка Настройка радио (Radio Tuner) на панели режимов проигрывателя. Сразу отметим что слушать радио при подключении к Интернету через модем - дорогое и не очень удобное занятие. Если же у вас имеется выделенная линия для работы с Интернетом или вы оплатили не ограниченное по времени подключение а радиоприемник у вас не может принимать интересные станции то рассматриваемая возможность проигрывателя вам может прийтись по вкусу. Кроме того с помощью Интернета можно принимать радиостанции не вещающие в вашем регионе. Щелкните мышью на кнопке Настройка радио (Radio Tuner) на панели режимов чтобы загрузить в программу новую страницу состоящую из двух частей.

В левой части находится список известных программе радиостанций которые вещают в Интернете. Вы можете добавлять и удалять их в свой собственный список расположенный в правой части окна если знаете адреса радиостанций вещающих в Интернете. Для этого используются кнопки Добавить (Add) и Удалить (Delete).

Если вы не знаете какой адрес у радиостанции можно попытаться найти ее в Интернете. В верхней части правой половины окна находится система поиска радиостанций. Нажмите кнопку Поиск (Search) чтобы запустить поиск. Появится диалог Расширенный поиск станций (Advanced station search). Давайте попробуем найти русскоязычную музыкальную радиостанцию. Для этого в открывающихся списках диалога расширенного поиска следует уточнить некоторые параметры. В списке Диапазон (Band) выберите элемент FM. В списке Скорость (Speed) укажите скорость вашего модема. Обычно она равна 28 килобит в секунду если вы используете телефонную линию среднего качества для работы с Интернетом. Далее в списке Язык (Language) выберите русский язык а в списке Страна (Country) - выберите Россия. Дополнительно вы можете указать жанр интересующей вас радиостанции. Можно указать также ключевые слова для поиска но и без них мы указали достаточно информации для поиска радиостанции. После настройки параметров нажмите кнопку Поиск (Search) чтобы начать процедуру поиска в Интернете нужной радиостанции. Поиск может занять некоторое время. По его окончании если поиск окажется успешным появится список найденных станций (Рис. 8.13).

Рис 8.13. Найденная радиостанция и ее Web-страница

Как мы видим, программа нашла интересующую нас радиостанцию, передающую музыку в Интернете и вещающую на русском языке. Давайте послушаем, что передает эта радиостанция. Дважды щелкните на названии найденной станции чтобы начать загрузку ее параметров. По окончании загрузки начнется воспроизведение трансляции. Одновременно будет открыто окно обозревателя Интернета, в котором будет отображена Web-страница выбранной радиостанции (Рис. 8.14). Не прерывая воспроизведения вы можете перейти в это окно и ознакомиться с информацией о радиостанции.


8.4.4. Воспроизведение компакт-дисков

Проигрыватель может также воспроизводить музыкальные компакт-диски. Вставьте такой компакт-диск в дисковод и нажмите кнопку Компакт-диск (CD Audio) на панели режима. Скорее всего автоматически начнется воспроизведение диска. Если воспроизведение началось, нажмите кнопку остановки на панели управления проигрывателя. Появится содержимое компакт-диска представленное в виде дорожек (Рис. 8.15).

Рис 8.15. Содержимое компакт-диска

Содержимое диска отображается в виде таблицы каждая строка которой представляет звуковую дорожку. Если флажок расположенный слева от дорожки установлен данная дорожка выбрана если он сброшен дорожка исключается из списка. Чтобы прослушать дорожку необходимо дважды щелкнуть на ней мышью.

Вначале программа ничего не знает о диске который вы вставили. Однако с помощью Интернета можно попытаться получить названия песен и другую информацию о диске. Для этих целей в правом верхнем углу окна расположено несколько кнопок. Обращаем ваше внимание что кнопки Сведения о диске (Album Details) и Присвоить имена (Get Names) работают только если вы подключены к Интернету и в дисковод вставлен лицензионный компакт-диск. Попробуем воспользоваться этой возможностью программы. Нажмите кнопку Сведения о диске (Details). Начнется передача информации из Интернета/ которая будет отображена в проигрывателе после получения .

Чтобы узнать дополнительную информацию о диске нажмите кнопку Присвоить имена (Get Names). Опять начнется передача информации из Интернета, по окончании которой в окне будет отображен список композиций вашего диска).

Вы можете изменить этот список, но если информация верна, лучше оставить ее как есть. Если информация отображается правильно просто нажмите кнопку Подтвердить (Apply). Конечно для того, чтобы получить эти сведения, информация о диске должна быть размещена в Интернете, однако сведения о большинстве современных зарубежных альбомах в Интернете имеются.

Давайте рассмотрим что можно попытаться сделать, если информации об этом альбоме нет в Интернете. Если ваш диск не найден, можно попробовать найти его, нажав кнопку Найти альбом (Find Album). В этом случае будет запущен мастер поиска и появится первое окно этого мастера. Нажмите кнопку Далее (Next) в появившемся окне приветствия. Появится следующее окно мастера. В поле ввода этого окна нужно ввести имя исполнителя и нажать кнопку Далее (Next).

Можно вводить не целое имя, а его фрагмент. Будет осуществлен поиск в Интернете, и в окне проигрывателя появится список всех исполнителей, которые подходят под фразу, заданную в качестве критерия поиска.

В появившемся списке выберите нужного вам исполнителя и нажмите кнопку Далее (Next), чтобы продолжить работу. Будет открыт список альбомов выбранного исполнителя. В данном списке попробуйте найти нужный альбом. Если он есть, нажмите кнопку Далее (Next), чтобы отобразить список композиций. В заключение, нажмите кнопку Готово (Finish).

Если попытка поиска окончилась неудачей, остается ввести названия композиций и название альбома вручную. Остальные возможности программы можно рассмотреть и без подключения к Интернету. Разорвите связь с поставщиком услуг Интернета. Чтобы сделать это, щелкните мышью на значке, расположенном на панели задач Windows и в появившемся диалоге нажмите кнопку Отключиться (Disconnect).


8.4.5. Воспроизведение DVD-дисков

Проигрыватель Windows Media, входящий в состав Windows ХР, может воспроизводить диски DVD, однако для того, чтобы у вас появилась такая возможность, необходимо установить дополнительное программное обеспечение. Если программное обеспечение, декодирующее формат DVD на вашем компьютере установлено, то в диалоге настройки параметров, открываемого командой меню Сервис * Параметры (Tools * Options), появится вкладка для работы с DVD. Щелкните мышью на нужном ярлычке, чтобы перейти на соответствующую вкладку.

Данная вкладка содержит элементы управления позволяющие ограничить просмотр нежелательных фильмов некоторыми людьми, например, малолетними детьми. Каждый фильм на DVD имеет рейтинг. Установив флажок Родительский контроль (Parental Control), вы можете выбрать в списке рейтинг фильма который можно просматривать всем. Если фильм имеет более жесткий рейтинг то для его просмотра будет нужен пароль который вы можете сами задать. Многие фильмы на DVD имеют несколько вариантов дубляжа на разных языках. Вторая группа элементов управления позволяет выбрать языковые настройки такие как язык субтитры и так далее. Если фильм содержит информацию на выбранном вами языке то этот язык будет использоваться по умолчанию.

Щелкните мышью на ярлычке Форматы (Formats) чтобы перейти на соответствующую вкладку диалога настройки. Чтобы при вставке DVD-диска автоматически начиналось его воспроизведение следует установить флажок у соответствующего элемента списка. Также в этом диалоге вы можете выбрать другие форматы которые проигрыватель начнет автоматически воспроизводить. После настройки параметров нажмите кнопку ОК чтобы закрыть диалог. Теперь вставьте диск в дисковод. После того как диск будет опознан начнется его воспроизведение.

Кнопка расположенная в нижней части рабочего окна позволяет растянуть изображение на весь экран. Левее этой кнопки расположена кнопка, которая прерывает воспроизведение и отображает на экране меню фильма. В этом меню вы можете выбрать различные варианты просмотра, такие как смена языка выбор произвольной сцены фильма и так далее. Набор этих вариантов зависит от конкретного фильма. Во время воспроизведения вы также можете пользоваться обычными элементами управления для остановки, временной остановки быстрого воспроизведения и так далее.


8.4.6. Копирование музыки

Для копирования музыки на ваш компьютер предназначена одноименная- кнопка, расположенная в верхней части окна проигрывателя. Вы можете создавать на своем компьютере различные сборники переписывая композиции с компакт-дисков. Давайте рассмотрим эту операцию более подробно. Вначале необходимо выбрать какие дорожки мы будем сохранять на диске путем установки и сброса флажков около названий дорожек. После этого нажмите кнопку Копировать музыку (Copy Music) расположенную в верхней части рабочего окна. Начнется процесс копирования музыкальной информации сопровождающийся изменением текста в окне,

Чтобы уменьшить объем музыкальной информации на диске программа при копировании производит ее сжатие. Одним из популярных способов сжатия является МРЗ который рассмотрен выше. В описываемом проигрывателе используется другой но похожий метод. Как и при использовании МРЗ здесь также происходит некоторая потеря качества музыки. Величину потерь и следовательно степень качества можно регулировать. Выберите команду меню Сервис * Параметры (Tools * Options) чтобы открыть одноименный диалог. В этом диалоге выберите вкладку Копирование музыки (Copy Music). Для настройки копирования музыки используется одноименная группа элементов управления данной вкладки. Качество копируемой музыки можно изменить с помощью перемещения ползунка. Двигая ползунок влево мы уменьшаем качество записи однако объем музыкальной информации хранящейся на диске также уменьшается. Если перемещать ползунок вправо то качество записи увеличится а также увеличится и занимаемый композицией объем на диске.

Ниже ползунка отображается прогнозируемый объем всего диска при выбранных параметрах качества. Считается/ что качество упакованной музыки становится сравнимым с качеством записей на компакт-диске при упаковке со скоростью воспроизведения/ равной 128 Кбит в секунду. По умолчанию программа предлагает сохранять записи с несколько худшим качеством (96 Кбит в секунду). Переместите ползунок в положение 128 Кбит и нажмите кнопку ОК/ чтобы закрыть диалог Параметры (Options).

Попробуйте снова скопировать несколько дорожек и затем прослушайте их. Попытайтесь оценить качество сделанной записи и если оно вас не удовлетворяет снова измените качество записи. Цель этих манипуляций - выбрать наиболее приемлемое для вас качество записи композиций так как слух у разных людей также отличается. В этом же диалоге вы можете выбрать папку в которую будет осуществляться копирование музыки. Для этого нажмите кнопку Изменить (Change) в группе элементов управления для выбора папки. Появится диалог выбора папки. В этом диалоге можно выбрать существующую папку для записи музыки или создать новую папку. После выбора папки нажмите кнопку ОК чтобы закрыть диалог. Теперь нажмите кнопку ОК чтобы закрыть диалог настройки параметров.

Процесс кодирования звуковых дорожек может занять довольно большое время так как требует больших вычислительных затрат. При копировании выполняются сложные процедуры сжатия информации почти без потери качества звучания. По окончании копирования выбранные файлы будут перенесены в вашу музыкальную библиотеку, расположенную в папке Мои музыкальные записи (My Music), которая в свою очередь находится в папке Мои Документы (My Documents). Теперь вы уже знаете, что при необходимости вы можете изменить расположение папки для копирования.

В дальнейшем вам не потребуется компакт-диск чтобы прослушивать ваши любимые мелодии. Вы можете слушать их из своей музыкальной библиотеки. Конечно, для хранения большого количества музыки вам потребуется жесткий диск большого объема но для современных компьютеров это не является проблемой.


8.4.7. Работа с библиотеками записей

Для работы с библиотекой используется все тот же проигрыватель. Прежде всего, отметим что создавать библиотеку можно в различных папках на дисках вашего компьютера. Поэтому при первом обращении к библиотеке программа просит вас указать ее расположение. Кроме того вы можете изменить его уже во время работы. Чтобы изменить расположение папки с библиотекой выберите команду меню Сервис * Параметры (Tools * Options) чтобы открыть одноименный диалог а затем выберите вкладку Копирование музыки (Copy Music). В этом диалоге можно выбрать расположение вашей библиотеки мультимедиа. Сейчас мы ничего менять не будем поэтому нажмите кнопку Отмена (Cancel). Теперь нажмите кнопку ОК чтобы закрыть диалог Параметры (Options).

Нажмите кнопку Библиотека мультимедиа (Media Library) на панели режимов. Рабочее окно программы в очередной раз изменится (Рис. 8.15).

Рис 8.15. Содержимое мультимедийной библиотеки

Центральная область рабочего окна разбита на две части. В левой части в виде дерева отображается структура вашей библиотеки а в правой части отображается содержимое выбранных папок из левой части. Такая структура напоминает содержимое окна проводника Windows. Библиотека мультимедиа на вашем компьютере содержит четыре основных папки. Это папки Аудио (Audio), Видео (Video), Настройки радиотюнера (Radio tuner presets) и папка Списки воспроизведения (Playlists). Назначение этих папок понятно из названий. Кроме того, есть специальная папка/ содержащая удаленные вами произведения.

Для работы с библиотекой используется панель инструментов, расположенная в верхней части рабочего окна. Эта панель содержит несколько кнопок. Давайте рассмотрим их применение. Нажмите кнопку Поиск (Search). Появится соответствующий диалог (Рис. 8.16).

Рис 8.16. Диалог настройки поиска

Данное средство предназначено для поиска в библиотеке записей по определенным критериям. Список позволяет выбрать, как должны сочетаться слова во фразе. Набор флажков позволяет осуществить расширенный поиск включая для просмотра имя исполнителя, название альбома, жанр композиции и другие признаки. Установив соответствующий флажок вы включаете соответствующий элемент в поиск. Сбросив флажок вы исключаете элемент из поиска. После того, как параметры поиска установлены, нажмите кнопку Искать (Search). На экране будут отображены результаты поиска (Рис. 8.17). Чтобы оформить результаты поиска в виде списка воспроизведения, нажмите кнопку Результаты (Search result). Поисковый диалог будет закрыт и в левой части окна программы появится список с таким же названием. Вы можете работать с этим списком, как с любым другим, в том числе прослушивать, копировать его на компакт-диски и так далее.

Рис 8.17. Результаты поиска

Кроме воспроизведения отдельных композиций, программа позволяет создавать так называемые Списки воспроизведения (Playlists). Списки воспроизведения представляют собой удобное средство для группировки записей библиотеки по определенным признакам. Список объединяет несколько мультимедийных композиций, не только звуковых но и видео, а также их комбинации. В списке указывается последовательность воспроизведения композиций. Эти списки могут создаваться автоматически как например при копировании с компакт -диска или при поиске. Также вы можете создавать списки воспроизведения вручную. Нажмите кнопку Создать список воспроизведения (Create Playlist). Появится одноименный диалог (Рис. 8.18). Введите в поле ввода имя для создаваемого списка например Моя любимая музыка и нажмите кнопку ОК чтобы создать список. В левой части окна среди списков воспроизведения появится новый список.

Вначале созданный список является пустым. Вы можете добавить в него композиции из других папок библиотеки. Для этого необходимо открыть соответствующую папку и выбрать запись. Станут доступными кнопки для добавления в список и для удаления из списка воспроизведения. Нажмите кнопку чтобы открыть вспомогательное меню. Данное меню содержит перечень доступных списков воспроизведения и записей.

Выберите среди них нужный список или запись. Запись будет добавлена в список.

Рис 8.18. Ввод имени нового списка

В заключение отметим, что начать воспроизведение списка можно, дважды щелкнув на имени списка в левой части окна программы


8.4.8. Работа с портативными устройствами

Проигрыватель может работать с переносными устройствами воспроизведения музыки. В настоящее время наиболее распространенными устройствами такого типа являются так называемые МРЗ-плееры. Они представляют собой портативные приборы, способные воспроизводить музыку без использования движущихся частей, таких как магнитная лента минидиск или компакт-диск.

Плеер представляет собой маленький, но мощный компьютер, который воспроизводит закодированную музыку хранящуюся в его памяти. Он имеет ряд кнопок управления, позволяющих выбирать композиции для воспроизведения, а также осуществлять регулировки громкости, баланса и так далее. Запись информации в память плеера осуществляется путем его подключения к обычному компьютеру и запуска соответствующей программы. Если портативное воспроизводящее устройство подключено к компьютеру и опознано системой Windows, вы можете копировать на него музыкальные композиции, а также удалять их из устройства с помощью проигрывателя Windows Media.

Давайте рассмотрим эту возможность, убедитесь, что портативный проигрыватель подключен к компьютеру. При необходимости подключите его. Затем нажмите кнопку Переносные устройства (Portable Devices) на панели режимов, чтобы перейти в соответствующий режим работы (Рис. 8.19).

Рис 8.19. Работа с портативными устройствами

Рабочее окно поделено на две области. Слева располагается выбранная папка из библиотеки мультимедиа, откуда вы будете переписывать музыкальные композиции. Справа показано содержимое портативного музыкального устройства. Внизу наглядно отображается количество свободного места на устройстве а также предполагаемый объем занимаемый файлами которые мы хотим скопировать. Этот объем может измеряться как в мегабайтах так и в минутах воспроизведения. Вверху расположена панель инструментов позволяющая выполнять все действия с устройством.

Вы можете удалять файлы на устройстве копировать их как с компьютера на устройство так и наоборот. Чтобы скопировать файлы на устройство необходимо вначале их выбрать с помощью установки флажков слева от названия дорожек.

Возможность выполнения тех или иных операций зависит от возможностей вашего конкретного портативного устройства, Обратите внимание, что качество записываемой на устройство музыки можно сделать отличным от принятого при сохранении композиции на диск. Это бывает полезным, так как объем памяти портативных устройств обычно не очень большой, и небольшое снижение качества может позволить записать на устройство больше композиций. Выберите команду меню Сервис * Параметры (Tools * Options), чтобы открыть одноименный диалог. В этом диалоге выберите вкладку Устройства (Devices) (Рис. 8.21, слева).

Рис 8.20. Диалоги параметров переносных устройств

В данном диалоге в виде списка отображены все обнаруженные программой устройства со сменными носителями информации. Выберите в этом списке переносное устройство и нажмите кнопку Параметры (Properties), чтобы открыть диалог настройки (Рис. 8.20). Этот диалог позволяет выбрать, с каким качеством будет записываться информация. С помощью переключателя выбирается, будет ли использоваться качество, задаваемое при настройке программы, или следует для переносных устройств использовать отдельную настройку. Настройка осуществляется с помощью ползунка, точно так же, как в уже рассмотренном выше случае. После выбора качества копирования, нажмите кнопку ОК, чтобы закрыть диалог.

Если вы подключены к Интернету, то нажатие кнопки Добавить (Add) позволит вам отобразить список портативных устройств которые напрямую, без специальных дополнительных программ, поддерживаются проигрывателем, и при необходимости переписать из Интернета необходимую информацию для работы нового устройства. Чтобы закрыть диалог, нажмите кнопку ОК. Теперь после того, как качество записи настроено, нажмите кнопку Копировать музыку (Copy Music). Начнется процесс передачи музыкальной информации на переносное устройство. Передача музыки сопровождается обновлением информации в рабочем окне.

После того как вы скопировали выбранные музыкальные файлы в портативное устройство вы можете отключить его от вашего компьютера и прослушивать музыку в любом месте.


8.4.9. Запись музыкальных компакт-дисков

В проигрывателе Windows Media поставляемом в составе Windows XP, появилась возможность записывать музыкальные компакт-диски из композиций, хранящихся в вашей музыкальной библиотеке. Если у вас есть устройство для записи компакт-дисков то оно интерпретируется программой как переносное устройство при записи музыки на которое происходит не сжатие информации а наоборот ее распаковка в стандарт Audio-CD.

Нажмите кнопку Переносные устройства (Portable Devices) на панели режимов чтобы перейти в соответствующий режим работы. Теперь в правой верхней части рабочего окна в списке портативных устройств следует выбрать устройство для записи компакт-дисков. Теперь настроим параметры записи. Выберите команду меню Сервис* Параметры (Tools * Options), чтобы открыть одноименный диалог. В этом диалоге выберите вкладку Устройства (Devices). Обратите внимание что в списке устройств уже выбрано необходимое устройство. Нажмите кнопку Параметры (Properties) чтобы открыть диалог настройки. Чтобы использовать это устройство для записи следует установить флажок, разрешающий использование. Кроме того при записи на диск система формирует временные файлы поэтому на диске вашего компьютера должно быть не менее 700 мегабайт свободного места. В соответствующем списке укажите диск, на котором есть столько свободного места. Далее следует выбрать скорость записи. Это делается путем выбора элемента в соответствующем открывающемся списке. В этом списке перечислены все скорости, с которыми ваше устройство может записывать информацию. Современные устройства для записи компакт-дисков могут записывать информацию с разными скоростями. Чем выше скорость записи, тем быстрее происходит процесс. Также следует учитывать, что различные заготовки рассчитаны на разную скорость записи. Обычно это указывается на обложке конверта с заготовкой. По умолчанию предлагается максимальная скорость, которую поддерживает ваше устройство записи. Лучше использовать этот выбор, и только если во время записи или последующего воспроизведения дисков будут ошибки, следует выбрать меньшую скорость записи дисков. Если вы установите флажок, расположенный в нижней части диалога настройки то по окончании записи диск будет автоматически извлечен из устройства. После настройки параметров записи нажмите кнопку ОК, чтобы закрыть диалог. Теперь мы готовы к записи. Далее нужно выбрать композиции для записи. Это можно сделать, выбрав в открывающемся списке, расположенном в правом верхнем углу рабочего окна, список композиций. Перечень композиций появится в левой части рабочего окна. Нажмите кнопку Копировать музыку (Copy Music), расположенную в верхней части рабочего окна. Начнется процесс записи музыкального компакт-диска который может занять довольно продолжительное время. Это время зависит от длительности композиций и скорости записи. Обращаем ваше внимание, что отменить процесс создания диска нельзя.


8.4.10. Настройка внешнего вида проигрывателя

Проигрыватель Windows Media позволяет чрезвычайно легко менять свой внешний вид. Это можно сделать, нажав кнопку Выбор обложки (Skin Chooser) на панели режима. В рабочем окне появится список обложек, в котором представлен перечень доступных обложек. Выбрать обложку можно, щелкнув мышью на нужном элементе этого списка. При этом в правой части будет показан вид выбираемой обложки (Рис. 8.21, слева).

Рис 8.21. Выбор обложки программы

После того, как обложка выбрана, нажмите кнопку Применить (Apply Skin), или дважды щелкните на требуемом элементе списка, чтобы изменения вступили в силу. При этом внешний вид рабочего окна изменится в соответствии с выбранной вами обложкой.

Если вы подключены к Интернету вы можете выбрать дополнительные обложки, которых нет в списке. Нажмите кнопку Другие Обложки (Other Skins). Будет запущен обозреватель Интернета. В этом окне появятся различные варианты обложек для программы Проигрыватель Windows Media (Windows Media Player). Для выбора какого-либо варианта обложки дважды щелкните на нем мышью. Появится диалог загрузки файла из Интернета (Рис. 8.22), не отличающийся от аналогичных диалогов при использовании других программ.

Рис 8.22. Загрузка информации и новая обложка

Прогресс-индикатор данного диалога позволяет наглядно увидеть процесс загрузки файла. Установите флажок в нижней части этого диалога, и по окончании загрузки диалог автоматически будет закрыт. После того, как файл переписан из Интернета на ваш компьютер, в списке обложек появится новый элемент. Как вы уже знаете, чтобы его выбрать, следует дважды щелкнуть на нем мышью. Сделайте это, и вид проигрывателя изменится.

Чтобы вернуться к обычному виду программы, необходимо нажать большую кнопку, расположенную в правом нижнем углу рабочего стола Windows. В появившемся вспомогательном меню необходимо выбрать команду Вернуться к полному режиму (Return to Full Mode). Внешний вид проигрывателя будет восстановлен. Нажмите кнопку в правом верхнем углу окна программы, чтобы завершить ее работу. В заключение отметим что программа позволяет не прерывать воспроизведение аудио- и видеофайлов даже во время работы в различных режимах. Так, можно слушать музыку во время копирования информации на портативные устройства или во время настройки внешнего вида программы.


8.5. Редактирование видеофильмов в Windows

В составе Windows XP имеется встроенная в систему программа редактирования видеофильмов. Эта программа называется Windows Movie Maker, и команда меню для ее запуска находится в списке стандартных программ. Следует отметить, что основное назначение данной программы - это создание домашних видеоархивов и подготовка видеоматериалов для их размещения в Интернете.

Чтобы записывать фильмы с различных источников, таких как видеокамера, видеомагнитофон или телевизор, ваш компьютер должен быть оборудован специальным устройством видеозаписи. Если такого устройства нет, то вы сможете только редактировать уже готовые видеоклипы. Программа Windows Movie Maker сама распознает наличие устройства видеозаписи на вашем компьютере и начнет его использовать в работе. Обратите также внимание на то, что программа требует для своей работы свободного места объемом не менее двухсот мегабайт на диске компьютера.


8.5.1. Знакомство с редактором видеофильмов

Чтобы запустить программу создания и редактирования фильмов, выберите команду главного меню Windows Другие nporpaммы * Стандартные * Windows Movie Maker (More Programs * Accessories * Windows Movie Maker). После того, как программа будет запущена, на экране появится ее рабочее окно (Рис. 8.23). Рассмотрим основные элементы окна редактора видеофильмов.

Рис 8.23. Рабочее окно программы

Заголовок окна отображает название программы и имя создаваемого или редактируемого клипа. Меню предназначено для выбора разнообразных команд программы. Эти элементы присутствуют во всех окнах Windows и не требуют особых пояснений. Ниже меню расположены панели инструментов, группирующие кнопки по функциональному назначению.

Существуют четыре панели инструментов, каждая из которых может отображаться и удаляться независимо. Первая панель инструментов служит для создания открытия и сохранения файлов. Вторая панель предназначена для редактирования видеоклипов и содержит кнопки для копирования, вырезания и вставки. Третья панель инструментов предназначена для указания расположения вашей коллекции клипов на диске компьютера а четвертая панель позволяет модифицировать структуру этой коллекции.

Центральная область окна разбита на три части. В левой части расположена панель навигации которая отображает хранящиеся на диске вашего компьютера видеоклипы в виде иерархической структуры. Центральная часть предназначена для отображения в виде значков различных клипов, с которыми вы в настоящий момент работаете. В правой части расположена область для просмотра выбранного в центральной области клипа. Она содержит окно просмотра а также панель управления просмотром. Вы можете останавливать воспроизведение осуществлять перемотку в обе стороны и так далее.

Внизу рабочего окна программы расположена область для редактирования. Она содержит панель инструментов расположенную вертикально, а также линию раскадровки. Редактирование осуществляется путем перетаскивания значков изображающих клипы, из рабочей области на линию раскадровки в нужном вам порядке. Если вы поместили хотя бы один клип на эту линию появляется возможность редактирования клипов с точностью до тысячных долей секунды. Поскольку клип может продолжаться много времени строка раскадровки получается очень длинной. Чтобы перемещаться вдоль строки используется полоса прокрутки расположенная в нижней части окна программы Windows Movie Maker.

Перед тем как начать работать с программой давайте рассмотрим ее основные настройки. Выберите команду меню Вид * Параметры (View * Options). Появится диалог задания параметров программы позволяющий настроить основные параметры программы которые будут использоваться в дальнейшей работе (Рис. 8.24). Поле ввода Автор по умолчанию (Default Author) предназначено для определения имени которое будет помещаться в каждый созданный видеофильм и определять его авторство. Программа Windows Movie Maker позволяет комбинировать фрагменты видеоизображения и простые картинки. Картинки преобразуются в статические видеофрагменты. Поле ввода Величина выдержки фотографии (Default Imported Photo Duration) в группе элементов управления Общие (General) позволяет задать длительность видеофрагмента, полученного из картинки.

Рис 8.24. Диалог настройки параметров

Одной из особенностей программы является возможность автоматически разбивать записываемый фильм на клипы. Далее мы подробно рассмотрим эту возможность а пока отметим что установка флажка Автоматически создавать клипы (Automatically create Clips) в группе элементов управления Общие (General) включает эту возможность программы.

Нажатие кнопки Сброс предупреждений (Reset Warning Dialogs) запретит программе показывать различные диалоги предупреждающие вас о каких-либо событиях. Это бывает полезно например чтобы запретить отображение диалогов драйвера платы ввода видеоизображения и сразу начать запись. Редактор видеофильмов может пересылать созданные фильмы по электронной почте. Кнопка Параметры почты (E-mail Options) предназначена для выбора программы работы с элфктронной почтой. Нажмите эту кнопку чтобы отобразить диалог настройки электронной почты (Рис. 8.25).

Рис 8.25. Диалог настройки электронной почты

Вам предлагается выбрать из списка одну из программ которая будет использоваться для отправки фильмов. Обычно по умолчанию используется программа Outlook Express входящая в состав Windows XP/ поэтому лучше выбрать именно эту программу. Нажмите кнопку ОК чтобы закрыть этот диалог.

Группа элементов управления Расположение (File Locations) диалога Параметры (Options) предназначена для выбора места на диске/ где будут располагаться временные файлы создаваемые программой а также откуда программа будет брать фотографии для вставки их в результирующий фильм. Выбор расположения осуществляется с помощью полей ввода и кнопок Обзор (Browse). При этом появляется стандартный одноименный диалог Windows в котором вы можете выбрать место на диске.

Группа элементов управления Запись файла (Record File) определяет где будут храниться созданные вами фильмы. В поле ввода можно указать расположение создаваемых фильмов. Также для выбора можно воспользоваться кнопкой Обзор (Browse). Если установить флажок Автоматически создавать файл (Auto Generate File) то программа Windows Movie Maker будет автоматически присваивать имена создаваемым клипам.

Нажмите кнопку OK диалога Настройки (Options), чтобы закрыть его. Теперь давайте приступим к изучению возможностей программы и начнем с записи видеоклипов.


8.5.2. Запись и сохранение видео

Еще раз напоминаем, что для проведения записи фильмов необходимо, чтобы ваш компьютер был оснащен устройством ввода видеоизображения. Это может быть отдельная плата или может быть, ваша видеокарта оснащена подобным разъемом. Кроме того вы можете использовать . простую Web-камеру, подключенную к шине USB.

Нажмите кнопку Запись (Record) на панели инструментов программы Windows Movie Maker. Появится диалог (Рис. 8.26), предназначенный для выбора устройства записи а также качества записываемого фильма. Давайте рассмотрим какие возможности для записи предоставляет этот диалог.

Рис 8.26. Диалог настройки записи

Открывающийся список Запись (Record) позволяет выбрать тип записываемого сигнала: Только видео (Video only) Только аудио (Audio Only), Видео и Аудио (Video & Audio). Если программа обнаружила на вашем компьютере устройство для записи видео то в этом списке автоматически будет установлен элемент Видео и Аудио (Video & Audio). Если устройство не обнаружено, то выбранным будет элемент Только аудио (Audio Only). Если и звуковой платы на вашем компьютере не обнаружено то в этом случае программа Windows Movie Maker просто не будет работать.

Кнопка Сменить устройство (Change Device) предназначена для выбора другого устройства записи если оно имеется на вашем компьютере. Например изображение вы можете записывать с устройства ввода видео а звук записывать с микрофона или линейного входа звуковой карты. Также вы можете изменить настройки выбранного устройства. Нажмите кнопку Сменить устройство (Change Device) чтобы открыть диалог для выбора устройств (Рис. 8.27).

Рис 8.27. Смена устройства и его параметры

С помощью открывающихся списков в этом диалоге можно выбрать нужное нам устройство для записи аудио- и видеосигналов. Если устройство для записи видео еще не настроено то сделать это можно нажав кнопку Настройка (Configure). Появится диалог настройки параметров который позволяет настроить устройство ввода видео. В зависимости от используемого устройства диалог может сильно различаться. Когда вы нажимаете кнопки этого диалога появляются соответствующие диалоги настройки внешний вид которых зависит от вашего оборудования видеозаписи и может быть самым различным. Если вы используете плату видеозахвата, то обычно появляются диалоги для выбора телевизионного стандарта, размера получаемого изображения и количества используемых цветов , а также параметров яркости и контрастности изображения. Мы не будем подробно останавливаться на настройке, вы можете прочитать об этом в документации к вашему оборудованию видеозахвата.

Если вы используете цифровую видеокамеру или Web-камеру, то внешний вид диалога настройки может быть иным и учитывать особенности конкретной видеокамеры.

В данном диалоге обычно выбирается режим работы, а также параметры яркости контрастности, цветности и другие характеристики изображения. Установив соответствующий флажок, вы включите автоматическую регулировку, а убрав флажок, вы можете самостоятельно настроить нужный параметр с помощью соответствующего ползунка. После настройки нажмите кнопку ОК, чтобы закрыть диалог. В заключение нажмите кнопку ОК, чтобы закрыть диалог смены устройства.

Следующая группа элементов управления с помощью флажков определяет длительность производимой записи и возможность создания клипов. Если установлен флажок Ограничить время записи (Record Time Limit), то становится доступным поле ввода, в котором можно указать интервал времени, в течение которого будет вестись запись. Для установки времени можно воспользоваться кнопками, расположенными в правой части поля ввода. Если установлен флажок Создавать клипы (Create Clips), то после завершения записи фильм автоматически будет разбит на фрагменты. Мы подробно рассмотрим создание видеоклипов ниже поэтому сейчас сбросьте флажок Создавать клипы (Create Clips).

Открывающийся список Настройка (Settings) позволяет выбрать формат и качество записываемого фильма. Чтобы облегчить вам выбор качества записываемого фильма, программа Windows Movie Maker предлагает вам выбор из уже готовых настроек: низкое среднее и высокое качество. Для более точного указания характеристик следует выбрать элемент Другое (Other). При этом в диалоге появится еще один открывающийся список. Для каждого элемента этого списка в скобках указывается скорость, которую должен обеспечивать канал связи с Интернетом чтобы передавать этот фильм без рывков и задержек. Этот список в основном используется при создании фильмов которые затем будут размещены на Web-страницах в Интернете. Чем выше качество тем большая скорость требуется для воспроизведения фильма и тем больше объем видеофайла на диске. Если вы хотите размещать фильм в Интернете то следует выбирать среднее или низкое качество. Для домашнего использования можно использовать среднее или высокое качество.

После того как параметры выбраны можно начинать запись. Программа может записывать как последовательность видеокадров которые потом образуют фильм, так и отдельные произвольные кадры. Для записи отдельных кадров используется кнопка.

Включите источник видеосигнала который вы используете, например, видеомагнитофон. В окне просмотра появится изображение. Теперь нажмите кнопку Запись (Record), чтобы начать процесс записи. В диалоге появится сообщение, извещающее, что идет запись. Одновременно начнется отсчет времени записи. Остановка записи происходит при истечении времени, отведенного на запись или при окончании свободного места на диске, а также при нажатии кнопки Стоп (Stop), в которую превращается кнопка для записи. Через некоторое время нажмите кнопку Стоп (Stop), чтобы остановить запись. Появится диалог сохранения файла, похожий на все диалоги сохранения в программах Windows. Введите имя сохраняемого клипа и нажмите кнопку Сохранить (Save), чтобы закрыть диалог.

По окончании сохранения система опять готова к работе, и вы можете записывать новый видеофильм. Теперь в рабочей области окна программы Windows Movie Maker появится значок, обозначающий записанный нами клип.

Далее с записанным клипом можно выполнять различные действия. В окне для просмотра появится первый кадр этого клипа. Вы можете воспроизвести его, нажав кнопку на панели управления воспроизведением. Кроме того, вы можете начать редактирование клипа. Ниже мы рассмотрим основные приемы редактирования.


8.5.3. Редактирование записей

При работе над фильмом всегда возникает необходимость редактирования, то есть добавления частей из другого фильма, склеивания кусков, удаления ненужных фрагментов и так далее. Большинство из этих операций доступно и в программе Windows Movie Maker. Из множества клипов вы в результате получите готовый фильм. Для компоновки фильма из различных клипов предназначена строка редактирования, называемая также линией раскадровки, расположенная в нижней части окна программы. Эта строка представляет собой изображение кинопленки, каждый кадр которой является отдельным клипом (Рис. 8.28). Пустые кадры закрашены серым цветом. С помощью линии раскадровки формируется последовательность клипов в создаваемом фильме. Перетаскивая с помощью мыши на линию раскадровки нужные вам клипы, вы компонуете фильм. При этом клипы могут быть получены с устройства ввода видео, подключенного к компьютеру, или импортированы из файлов с видеофильмами.

Рис 8.28. Линия раскадровки

Чтобы приступить к созданию фильма, подведите указатель мыши к значку, обозначающему записанный вами клип. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте указатель мыши на линию раскадровки. Как только указатель попадет на первый слева кадр линии раскадровки, отпустите кнопку мыши. Таким образом, вы поместили клип в строку редактирования. Аналогично вы можете разместить несколько клипов.

В строке редактирования можно задать только последовательность клипов, а их длительность задается с помощью временной диаграммы. Если нажать кнопку на панели инструментов редактирования, линия редактирования превратится во временную диаграмму.

В верхней части этой диаграммы отображается временная шкала, позволяющая вам узнать длительность всего фильма и каждого клипа в отдельности. Длина области отображения клипа соответствует его длительности воспроизведений. Вертикальная черта с треугольным маркером на шкале указывает текущее положение в фильме. Каждый клип в диаграмме представлен первым кадром и названием. Значок громкоговорителя в левом нижнем углу кадра указывает что кроме видеопоследовательности в клипе имеется звуковое сопровождение. С помощью кнопок и на панели инструментов вы можете менять масштаб отображения клипов вплоть до покадрового отображения. Обратите внимание что кнопка превратилась в и ее повторное нажатие восстановит Исходный вид линии раскадровки.

Теперь поместим в создаваемый фильм какое-нибудь статическое изображение. Нажмите кнопку на панели инструментов редактирования чтобы снова отобразить линию раскадровки. Выберите команду меню Файл * Импорт (File * Import). Появится диалог выбора импортируемого файла (Рис. 8.29) похожий на стандартный диалог открытия файла.

Рис 8.29. Диалог выбора файла

Прейдите в папку Мои рисунки (Му Pictures) выберите какой-либо рисунок, и нажмите кнопку Открыть (Open). Начнется процесс формирования клипа из выбранного изображения. По окончании процесса формирования клипа в рабочей области программы Windows Movie Maker появится эскиз, изображающий созданный клип. Отметим, что аналогично можно импортировать любой файл с изображением или с фрагментом видео.

Теперь можно приступать к редактированию фильма. Основной задачей программы Windows Movie Maker является создание фильма из различного видео- и фотоматериала. Вы можете создавать фильм из нескольких клипов комбинируя их последовательность. Также вы можете проводить обрезку клипов тем самым удаляя из них ненужные фрагменты. Все клипы, из которых будет состоять фильм вначале нужно перенести на линию раскадровки. Вы можете менять последовательность воспроизведения клипов перетаскивая их с помощью мыши ближе к началу или концу линии раскадровки. Клипы в окончательном варианте фильма будут располагаться друг за другом. Можно изменять начало и окончание воспроизведения клипов чтобы они частично перекрывали друг друга на временной диаграмме. Обратите внимание, что когда клипы перекрывают друг друга, в фильме происходит плавный переход от одного фрагмента к другому.

Для редактирования перенесем новый клип на линию раскадровки. Подведите указатель мыши к эскизу клипа, нажмите левую кнопку, мыши и, не отпуская ее, перемещайте указатель мыши к линии раскадровки. Как только указатель попадет на первый слева свободный кадр, отпустите кнопку. Чтобы выбрать клип для редактирования нужно просто щелкнуть на его изображении расположенном на линии раскадровки.

Отредактируем клип, полученный нами из картинки. Как вы помните в настройках программы по умолчанию длительность клипа получаемого из картинки, равна пяти секундам. Иногда такая длительность слишком велика. Давайте уменьшим эту длительность путем удаления части клипа. Нажмите кнопку на панели инструментов окна редактирования, чтобы отобразить временную диаграмму. Щелкните мышью на изображении вставленного клипа, чтобы выделить его. С помощью кнопок и на панели инструментов добейтесь того, чтобы интервал времени между соседними рисками временной шкалы соответствовал одной десятой секунды. Так будет удобнее работать.

Выделение фрагментов видеофильма в программе Windows Movie Maker осуществляется путем расстановки точек монтажа. Имеются начальная и конечная точки монтажа. Простановка первой из этих точек отбрасывает все, что находится до нее, а простановка второй - все, что после этой точки. Когда мы выделяем клип на линии раскадровки, в его начале и конце автоматически проставляются точки монтажа, представляющие собой изображение треугольника на шкале времени. Рисунок изображает начало клипа, а его конец. Когда указатель мыши попадает на эти точки, он принимает форму стрелки с двумя концами. Буксируя значок начала клипа вправо, а значок конца клипа - влево, мы можем уменьшать длительность клипа, отрезая его части. При этом исходный клип останется неизменным, просто его начало и конец не будут использоваться в редактируемом фильме. Вы также можете перетаскивать весь клип, меняя начало его воспроизведения. Для этого следует выделить клип и перетащить его левее, установив указатель мыши в центре клипа. При этом начало клипа совпадет с окончанием предыдущего клипа, и в фильме будет создан плавный переход од одного клипа к другому. Длительность перехода определяется размером области перекрытия.

То же самое можно сделать, если проставить точки монтажа вручную. Подведите указатель мыши к отметке на шкале времени, соответствующей второй секунде записи. Указатель мыши изменит свою форму на изображение стрелки. Теперь щелкните мышью. В месте щелчка на временной диаграмме появится вертикальная черта. Выберите команду меню Клип * Установить конечную точку монтажа (Clip * Set End Trim Point). Изображение после указанной нами точки исчезнет. Аналогично можно установить и начальную точку монтажа.

Путем расстановки начальной и конечной точек можно выделить любой фрагмент клипа.

Кроме клипов, полученных путем записи или импорта, программа может автоматически разбивать фильм на клипы. Разбиение происходит в тот момент, когда изображение в фильме кардинально меняется. Это происходит чаще всего при смене плана. Если это разрешено, автоматическое разбиение на клипы происходит по окончании записи фрагмента или при его импорте. Вы также можете в любой момент самостоятельно разбить клип на несколько отдельных клипов. Чтобы автоматически разбивать фильм на клипы после записи или импорта, следует установить флажок Создавать клипы (Create Clips) в соответствующем диалоге. Для разбития на несколько частей выберите клип во временной диаграмме, щелкнув на нем мышью. Задайте место разбиения щелкнув мышью в нужном месте на шкале времени. В месте щелчка появится вертикальная черта. Нажмите кнопку, расположенную под полем предварительного просмотра, и клип будет разбит на два самостоятельных клипа. Вы можете перетащить их с помощью мыши в различные места редактируемого фильма.

Если вы щелкнете мышью на свободном месте временной диаграммы, то выделите весь редактируемый фильм. Нажав после этого кнопку расположенную под полем предварительного просмотра вы сможете просмотреть создаваемый фильм. Если щелкнуть мышью на клипе во временной диаграмме, после чего нажать кнопку, то будет воспроизводиться только выделенный клип. Вы можете выделить клип в рабочей области программы и воспроизвести его. Обратите внимание, что исходный клип, представленный эскизом в рабочей области, и клип во временной диаграмме или в линии раскадровки, могут существенно различаться, если вы меняли начальные и конечные точки монтажа или разбивали клип на части. Кстати, другие кнопки, расположенные рядом с, позволяют выполнить ускоренную перемотку, приостановить и прекратить воспроизведение, а также перейти к началу или концу выделенного фрагмента. Так как данные кнопки не отличаются от аналогичных кнопок обычного видеомагнитофона или любого, компьютерного проигрывателя, например, проигрывателя Windows Media рассмотренного выше, то мы не будем на них останавливаться.

Набрав нужный набор клипов, и разместив их в заданной последовательности, вы создадите заготовку фильма. Далее следует убрать ненужные части, удаляя начало и конец некоторых клипов. Возможно, при этом вам потребуется разбить ряд клипов на части. Вы можете перемещать клипы, меняя их порядок в фильме. В результате вы получите почти готовый фильм. Осталось выполнить некоторые дополнительные действия, о которых речь пойдет ниже.

По умолчанию программа Windows Movie Maker сама присваивает клипам имена. Однако вы можете изменить их по своему вкусу. Чтобы сделать это, сначала нужно выделить требуемый клип в центральной части рабочего окна программы, щелкнув на нем мышью. Немного подождав, еще раз щелкните на названии клипа. Пауза должна быть достаточной, чтобы программа не восприняла ваши действия как двойной щелчок мышью. После второго щелчка станет доступным поле ввода на месте названия клипа в котором вы можете ввести новое название.


8.5.4. Запись звукового пояснения

Часто возникает необходимость в сопровождении видеозаписей своими комментариями. Программа Windows Movie Maker позволяет накладывать на записанный видеоклип звуковые комментарии. Дорожка комментариев может как заменять звук в оригинальном клипе, так и накладываться поверх оригинального звука. Можно использовать эту дорожку для наложения, например, перевода к фильму. Перейдите в режим работы с временной диаграммой и нажмите кнопку на панели инструментов. Появится диалог записи комментария. Данный диалог предназначен для настройки параметров записи пояснительной дорожки. С помощью установки флажка Выключить звук (Mute video soundtrack) вы можете выключить оригинальный звук фонограммы во время запись пояснений. Если флажок сброшен, то происходит наложение пояснений на оригинальный звук. Ползунок позволяет регулировать уровень записи при пояснениях. Перемещая ползунок вверх и вниз, следует установить такой уровень записи, при котором индикатор, расположенный правее ползунка, еще не загорается красным цветом.

У вас есть возможность выбрать устройство записи звука, отличающееся от того, которое предлагается по умолчанию. Чтобы сделать это, нажмите кнопку Изменить (Change). На экране появится диалог для выбора устройства (Рис. 8.30).

Рис 8.30. Диалог выбора устройства

Данный диалог содержит два открывающихся списка: Устройство (Device) и Входной канал (Input Line). Первый список позволяет выбрать устройство для записи звука. Этих устройств может быть несколько. Одним из них является ваша звуковая карта, а вторым, например, может служить плата для ввода видео. Второй список предназначен для указания того какой вход устройства записи будет использован. Типичная звуковая карта имеет несколько таких входов. В разных случаях следует использовать различные источники звука. Если вы хотите делать пояснения лично, то лучше воспользоваться микрофоном. Наложение перевода, скорее всего, потребует использование линейного входа.

В списке Входной канал (Input Line) выберите элемент Микрофон (Microphone) и нажмите кнопку ОК, чтобы закрыть диалог Настройка аудио (Configure Audio). Теперь все готово для записи пояснений. Нажмите кнопку Запись (Record) диалога Запись комментария (Record Narration Track). После того как начнется воспроизведение клипа в поле предварительного просмотра и движение ползунка по временной диаграмме, можете начинать говорить в микрофон.

После окончания ввода пояснений или после окончания воспроизведения клипа нажмите кнопку Стоп (Stop), в которую превратилась кнопка для записи. Запись будет прекращена и появится диалог для сохранения записанного звука. Этот диалог не отличается от любого диалога сохранения документа в Windows. В поле ввода Имя файла (File Name) введите имя сохраняемого звука, например Пояснения к фильму, и нажмите кнопку Сохранить (Save), чтобы закрыть диалог. Теперь в рабочей области появился еще один значок, а в области редактирования появилась линия звуковой дорожки с пояснениями. Нажав кнопку на панели инструментов, вы откроете диалог настройки баланса.

С помощью ползунка в данном диалоге вы можете менять баланс между уровнями записи оригинальной звуковой дорожки фильма и записываемой дорожки пояснений.

Следует отметить, что работа со звуковым сопровождением не отличается от работы с видеоклипами. Вы можете записать несколько звуковых клипов можете изменить их имена а также можете импортировать звуковой клип из файла. С помощью мыши звуковые клипы перетаскиваются из рабочей области на звуковую дорожку после чего вы можете менять их расположение устанавливать начало и конец, как и при работе с видеоклипами.

В результате вы подготовите проект, состоящий из множества видеоклипов и звуковых клипов, расположенных в нужных частях временной диаграммы. После этого следует создать фильм и сохранить его на диске.


8.5.5. Сохранение фильма

После того, как редактирование фильма завершено, его необходимо сохранить на диске для дальнейшего использования. Чтобы сохранить созданный фильм, нажмите кнопку на панели инструментов программы Windows Movie Maker. Появится диалог сохранения фильма. В данном диалоге расположены две группы элементов управления. Группа Качество воспроизведения (Playback Quality), как ясно из ее названия, определяет качественные характеристики создаваемого видео. Если вы помните, при записи видео мы уже устанавливали аналогичные характеристики. При сохранении фильма на диск мы можем изменить их. Открывающийся список Настройка (Settings) позволяет выбрать готовые установки качества фильма: низкое среднее и высокое качество. Если вам требуется уточнить эти настройки, то следует выбрать элемент Другое (Other). При этом в диалоге появится еще один открывающийся список, выбирая элементы которого, вы сможете указать, какое качество вам требуется. Помните, что, чем выше качество, тем больший объем будет занимать сохраняемый фильм на диске компьютера.

Вторая группа элементов управления задает некоторые дополнительные сведения о фильме. Поле Название (Title) предназначено для ввода .названия фильма, которое будет отображаться при воспроизведении этого фильма в других программах. Поле Автор (Author) определяет имя человека или организации, который создал этот фильм. Это имя также будет отображаться при воспроизведении в других программах, например. Проигрыватель Windows Media (Windows; Media Player). Назначение поля Дата (Date) очевидно, поэтому на нем мы останавливаться не будем. Поле Оценка (Rating) позволяет описать жанр созданного фильма, например, игровое, любительское, драма, комедия и так далее. Поле ввода Описание (Description) предназначено для ввода вашего комментария к созданному фильму. Это бывает полезно, если вы хотите описать срой впечатления о фильме, сделать пометки, которые вы боитесь забыть.

После того, как характеристики сохраняемого фильма уточнены, нажмите кнопку ОК диалога Сохранить фильм (Save Movie), чтобы закрыть его и продолжить работу. Появится диалог Сохранить как (Save As), не отличающийся от любого диалога сохранения в программе, работающей под управлением Windows. Выберите папку для сохранения, в поле ввода Имя файла (File Name) введите название вашего фильма, после чего нажмите кнопку Сохранить (Save) этого диалога, чтобы закрыть его и начать сохранение. Появится диалог с прогресс-индикатором, иллюстрирующим процесс создания фильма.

Процесс создания фильма может занять несколько минут в течение которых прогресс-индикатор будет меняться. После завершения создания фильма появится диалог, который спросит вас о том, хотите ли просмотреть полученный фильм прямо сейчас.

Чтобы посмотреть, что у нас получилось, нажмите кнопку Да (Yes) этого диалога. Будет запущена программа Проигрыватель Windows Media (Windows Media Player), и начнется воспроизведение нашего фильма. Во время этого воспроизведения вы можете оценить качество получившегося фильма, а также его сюжет и звуковую дорожку.


8.5.6. Передача видео по электронной почте

Кроме сохранения фильма на диске, программа Windows Movie Maker позволяет сохранять его в Интернете или передавать по электронной почте. Рассмотрим последнюю возможность программы подробно. Для начала процедуры отправки фильма по электронной почте надо нажать кнопку Отправить (Send) на панели инструментов программы. Появится открывающийся список, в котором следует выбрать элемент Электронная почта (E-Mail). Появится диалог Отправка фильма по электронной почте (Sent Movie via E-Mail). Этот диалог в точности повторяет рассмотренный ранее диалог Сохранить фильм (Save Movie). Выберите желаемое качество фильма в списке Настройка (Settings) и заполните другие поля в диалоге, после чего нажмите кнопку ОК, чтобы закрыть диалог. Появится диалог, запрашивающий имя фильма для отправки.

Данное имя требуется программе, чтобы временно хранить файл с фильмом до его отправки. Введите в поле любое имя, которое будет характеризовать отправляемый фильм. При этом обратите внимание, что по соображениям совместимости программа требует ввода имени фильма латинскими буквами. Введите имя и после ввода нажмите кнопку ОК этого диалога. Появится диалог с прогресс-индикатором, иллюстрирующим процесс создания фильма. После завершения создания фильма появится диалог выбора почтовой программы. Этот диалог мы уже рассматривали, поэтому выберите в списке элемент Программа электронной почты по умолчанию (Default E-mail Program) и нажмите кнопку ОК, чтобы закрыть диалог. Будет запущена почтовая программа. Обычно в качестве почтовой программы используется Outlook Express, входящая в состав Windows. Давайте рассмотрим ее использование. Итак, будет запущена программа Outlook Express и на экране появится окно создания сообщения. Обратите внимание, что текст письма уже заполнен, а также автоматически вложен файл с фильмом. Вам остается только ввести адрес получателя.

В поле Кому (То) введите адрес электронной почты, на который вы хотите отправить фильм. Теперь нажмите кнопку на панели инструментов окна Создать сообщение (New message). Письмо с фильмом будет помещено в папку Исходящие (Outbox). Вы можете установить связь с поставщиком услуг Интернета сейчас или в любое удобное для вас время. При этом подготовленное сообщение будет отправлено адресату при вашем ближайшем сеансе работы с Интернетом.


8.5.7. Размещение фильма в Интернете

В программе предусмотрена возможность быстрого размещения созданного фильма в Интернете на вашей персональной Web-странице. Для начала процедуры размещения фильма в Интернете надо нажать кнопку Отправить (Send) на панели инструментов программы и выбрать в появившемся списке элемент Отправить на Веб-сервер (Sent to Web-server). Появится диалог аналогичный рассмотренному диалогу Сохранить фильм (Save Movie) . Укажите параметры качества фильма, а также укажите название, жанр и другую информацию о фильме. После того, как параметры фильма указаны, нажмите кнопку ОК, чтобы закрыть диалог. Появится диалог для ввода имени фильма. Введите произвольное имя и нажмите кнопку ОК, чтобы закрыть диалог. Появится диалог для указания параметров размещения в Интернете.

Если у вас нет персональной Web-страницы в Интернете, вы можете получить ее на узле фирмы Microsoft. Для этого установите соединение с Интернетом и нажмите кнопку Зарегистрироваться (Register), после чего следуйте инструкциям. Если у вас есть домашняя Web-страница, установите переключатель в верхней части диалога в положение В эту папку моего узла (In this folder) и введите полный адрес вашей страницы. Если вы создаете новый сайт для размещения видео нажмите кнопку Создать (New). Появится диалог ввода параметров нового узла. Введите в верхнем поле ввода имя узла. В поле ввода, расположенном ниже, введите Интернет-адрес вашего узла. Еще ниже расположено поле ввода адреса, по которому другие могут, смотреть ваш фильм. Также заполните это поле.

В списке, расположенном ниже, укажите имя домашней страницы на вашем узле Интернета. Обычно это файл с именем index.htm. флажки дополнительной настройки лучше не менять. После ввода всех необходимых параметров нажмите кнопку ОК, чтобы закрыть диалог И вернуться к предыдущему диалогу.

Обратите внимание, что некоторые поля настройки заполнились автоматически. Введите в соответствующих полях имя и пароль для доступа на Web-узел. Теперь нажмите кнопку ОК, чтобы закрыть диалог настройки. Появится диалог, информирующий о необходимости соединения с Интернетом. Нажмите кнопку Подключиться (Connect) этого диалога, чтобы начать соединение. После того, как соединение установлено, начнется процесс передачи созданного видеофильма в Интернет, сопровождающийся появлением диалога с прогресс-индикатором. После того, как передача файла будет завершена. Диалог закроется. Запустите обозреватель Интернета и посетите вашу домашнюю страницу. Попробуйте просмотреть размещенный в Интернете видеофильм. После просмотра можете разорвать соединение с Интернетом.

В заключение завершим работу Windows Movie Maker. Нажмите кнопку в правом верхнем углу программы. Появится диалог о необходимости сохранения проекта. Если вы планируете продолжать работу над фильмом, то нажмите кнопку Да (Yes) этого диалога, а затем выберите место для сохранения и имя проекта. Если работа над проектом далее не планируется, нажмите кнопку Нет (No). Работа программы будет завершена.


  • 9. Вспомогательные программы
    • Проверка диска
    • Очистка диска
    • Дефрагментация диска
    • Назначение заданий
    • Резервное копирование
    • Прочие полезные программы
    • Работа с командной строкой
    • Отправка и прием факсимильных сообщений


9. Вспомогательные программы

В состав стандартных программ Windows XP входит ряд программ, которые помогают решать возникающие при работе проблемы. Такие программы принято называть служебными программами или утилитами. Кроме служебных программ в этой главе будут рассмотрены некоторые другие вспомогательные программы.


9.1. Проверка диска

Есть ряд служебных программ для работы с дисками. Они выполняют проверку на наличие ошибок, дефрагментацию, архивацию, а также очистку диска. Все эти программы можно запустить из главного меню Windows, однако удобнее это делать из папки Мой компьютер (My Computer).

Выберите команду Мой компьютер (My Computer) в главном меню Windows. Далее щелкните правой кнопкой мыши на значке, обозначающем диск, с которым будут работать служебные программы, чтобы открыть вспомогательное меню. Выберите команду Свойства (Options). Появится диалог изменения свойств диска. Щелкните мышью на ярлычке Сервис (Tools), чтобы выбрать одноименную вкладку (Рис. 9.1).

Рис 9.1. Вкладка запуска сервисных программ

Одной из служебных программ является Проверка диска

(Scandisk), позволяющая обнаруживать и исправлять различные ошибки на носителях информации. Эти ошибки могут возникнуть по разным причинам, например, из-за повреждений фрагментов магнитной поверхности жесткого диска. Еще одной причиной ошибок может служить внезапный сбой компьютера при записи информации на носитель. Часто заметить ошибки сразу бывает трудно и дальнейшая работа с таким носителем может только усугубить ситуацию.

Программа проверки дисков запускается автоматически при старте Windows, если вы неправильно завершили ее работу в предыдущий раз. В предыдущих версиях Windows при этом запускалась версия для ДОС, которая работала не очень надежно. Особенностью Windows XP является то, что всегда запускается Windows-версия программы проверки, которую мы и рассматриваем. Вы также можете в любое время провести проверку диска самостоятельно.

Нажмите кнопку Выполнить проверку (Check Now) в диалоге для запуска программы проверки. Будет запущена программа проверки дисков и появится ее рабочее окно (Рис. 9.2). Флажки в этом окне позволяют выбрать параметры проверки диска. Если установлен флажок Автоматически исправлять ошибки (Automatically Fix Errors), то программа будет сама принимать решение по исправлению найденных ошибок.

Рис 9.2. Проверка диска

Если установить флажок Проверять и восстанавливать поврежденные сектора (Scan for and attempt recovery of bad sectors), то кроме проверки диска на наличие логических ошибок в файловой системе, также будет проведена проверка на наличие физических ошибок поверхности жесткого диска. Обычно этот флажок не устанавливают, так как такая проверка занимает много времени. Но иногда полную проверку все же следует проводить.

Установив нужные параметры, следует нажать кнопку Запуск (Start) для начала проверки. Проверка будет сопровождаться изменением прогресс-индикатора, расположенного в нижней части рабочего окна. По окончании проверки появится диалог с сообщением, что проверка завершена (Рис. 9.2). Если во время проверки были обнаружены ошибки, то вам будет предложено просмотреть отчет о проверке. Нажмите кнопку ОК, чтобы закрыть этот диалог.

Отметим, что при запуске программы проверки диска с помощью главного меню, из группы стандартных служебных программ вам будет предложено вначале выбрать диск для проверки. При запуске же из папки Мой компьютер (My Computer) такого предложения не будет, так как диск уже выбран, когда вы открываете диалог настройки свойств диска.


9.2. Очистка диска

При работе с компьютером постепенно на дисках накапливается некоторое количество ненужных файлов. Многие программы создают временные файлы, но не все удаляют их по окончании работы. Конечно, о большинстве файлов сказать, нужны ли они или нет, можете только вы, однако при своей работе, система Windows сама создает множество файлов, которые занимают место на диске впустую. Программа Очистка диска (Disk Cleanup), также относящаяся к группе служебных программ, используется для удаления с диска ненужных файлов. Запуск программы очистки диска может производиться как автоматически, так и вручную. Автоматический запуск происходит, когда на диске остается свободного места меньше, чем установленный в системе предел. При этом появляется диалог, предупреждающий об этом (Рис. 9.3). Обратите внимание, то чем меньше остается на диске свободного места, тем чаще будет появляться этот диалог.

Рис 9.3. Диалог, предупреждающий о малом свободном месте

Чтобы запустить очистку диска, где осталось мало места, нажмите кнопку Очистка диска (Disk Cleanup) этого диалога. Если вы хотите запустить программу очистки самостоятельно, то откройте папку Мой компьютер (My Computer) в главном меню Windows. Щелкните правой кнопкой мыши на значке, обозначающем диск, который вы хотите очистить, и во вспомогательном меню выберите команду Свойства (Options). В появившемся диалоге щелкните мышью на ярлычке Общие (General), чтобы выбрать нужную вкладку. На этой вкладке нажмите кнопку Очистка диска (Disk Cleanup), чтобы запустить соответствующую программу. Программа очистки выполняет на указанном диске поиск файлов, которые могут быть удалены автоматически. По окончании просмотра диска на экране появляется диалог, показывающий результаты этой проверки (Рис. 9.4). В списке в центре диалога указаны группы файлов, которые можно удалить, и занимаемое ими место на диске.

Рис 9.4. Диалог настройки очистки диска

Во время работы Windows на диске образуется много файлов, которые создаются для временных целей. Когда на диске много места, количество этих файлов не имеет большого значения. Когда место на диске заканчивается, удаление лишних файлов может помочь в решении проблемы. При просмотре диска подлежащими удалению рассматриваются несколько групп файлов. Прежде всего, это содержимое папки Корзина (Recycle Bin), в которую попадают удаляемые вами файлы, поскольку большинство файлов, попадающих в нее, предназначено для окончательного уничтожения. Далее идет папка Temporary Internet Files (Временные файлы Интернета), содержащая файлы, которые появились на компьютере при работе с Интернетом. Эти файлы нужны для быстрого повторйого просмотра Web-страниц, на которых вы уже побывали, и при их удалении ничего страшного не произойдет.

Многие программы при своей работе создают временные файлы для хранения каких-то частей обрабатываемой информации. В Windows предусмотрена специальная папка для таких файлов. Иногда эти файлы не уничтожаются по окончании работы тех программ, которые их использовали. Чтобы удалять такие файлы, предусмотрена специальная группа. Также для очистки предлагается несколько других групп файлов. Чтобы задать удаление групп файлов, следует установить соответствующие флажки диалога. Когда вы нажмете кнопку ОК диалога, начнется процесс очистки. На вопрос о том, действительно ли вы хотите удалить файлы, следует ответить утвердительно, нажав кнопку Да (Yes) открывшегося диалога. Появится диалог с прогресс-индикатором, который иллюстрирует процесс очистки (Рис. 9.5).

Рис 9.5. Процесс очистки диска

Иногда удаление ненужных файлов не решает проблему нехватки места на диске. В этом случае система может 1 предложить вам удалить часть компонент Windows или установленных программ. То же самое вы можете сделать и самостоятельно, если выберете вкладку Дополнительно (More Options) диалога Очистка диска (Disk Cleanup) (Рис. 9.6).

Рис 9.6. Дополнительные возможности очистки

На этой вкладке вам предлагаются три варианта увеличения свободного места на диске за счет удаления части файлов, используемых системой Windows. Первая группа элементов управления позволяет удалить некоторые компоненты Windows, которые вы сейчас не используете. Чтобы удалить часть компонент Windows, нажмите кнопку Очистить (Clean up). Появится первый диалог мастера компонент Windows. В этом диалоге в качестве списка представлены компоненты системы, которые вы можете удалить. Выбор элемента списка отображает в нижней части диалога комментарий о том, что представляет собой выбранный компонент, также отображается занимаемый этим компонентом объем на диске. Чтобы пометить компонент для удаления, следует установить флажок напротив соответствующего элемента списка. Вторая группа дает возможность удалить ранее установленные программы. Нажатие кнопки Очистить (Clean up) в этой группе элементов управления приведет к появлению диалога Установка/удаление программ (Add/Remove Programs. В данном диалоге также в виде списка представлены установленные в настоящий момент программы. Выбрав программу для удаления, вы увидите занимаемый ею объем на диске. Чтобы удалить программу, нажмите кнопку Удалить (Delete). Будет запущен мастер удаления программ. Подробно об установке и удалении компонент Windows, а также об удалении установленных программ, вы можете прочитать в соответствующей главе этой книги.

Третья группа элементов управления позволяет увеличить свободное место на диске путем уменьшения места, занимаемого под свои нужды программой восстановления системы. Более подробно работа программы восстановления системы также будет описана ниже.


9.3. Дефрагментация диска

Система хранения данных на жестком диске в системе Windows построена так, что постепенно работа с диском может насколько замедляться. Все дело в принципах работы файловых систем FAT, FAT32 и NTFS, которые используются Windows XP. В этих файловых системах весь диск делится на мелкие части одинакового размера, называемые кластерами. При создании нового файла система Windows помещает в специальной области в начале диска запись, где содержится имя файла и номер первого кластера, куда будет записываться файл. Если файл большой, и одного кластера не хватило, то система ищет первый попавшийся свободный кластер и пишет в него остаток файла. Так продолжается до тех пор, пока весь файл не будет записан на диск. Последний кластер файла помечается особо. Все кластеры, использованные в записи файла, помечаются как занятые. При удалении файла все кластеры помечаются как свободные.

Такая; система хорошо работает в самом начале, когда свободные кластеры расположены по порядку. Однако в процессе работы, во время создания и удаления файлов свободные кластеры могут появляться в произвольном месте диска, и в скором времени файлы на Диске становятся фрагментированными. В таком файле часть информации может находиться в начале диска, а часть в конце. Чтение и запись такого файла существенно замедляется, так как диску приходится постоянно перемещать головки из одного места в другое, а это занимает время. Особенно заметно уменьшение скорости работы при фрагментации дисков с файловыми системами FAT и FAT32. Благодаря особенностям построения файловой системы NTFS, уменьшение скорости из-за эффекта фрагментации незначительно, хотя и система NTFS подвержена фрагментации. Чтобы принудительно ликвидировать фрагментацию, то есть выполнить дефрагментацию диска, в Windows XP предусмотрена специальная программа, входящая в состав стандартных служебных программ.

Обращаем ваше внимание, что перед запуском программы дефрагментации необходимо завершить работу всех остальных программ. Это связано с тем, что любое изменение информации на обрабатываемом диске, а это может случиться, если другие программы работают, приводит к повторному запуску дефрагментации.

Откройте папку Мой компьютер (My Computer) и выберите диск, на котором вы хотите выполнить дефрагментацию, щелкнув на нем правой кнопкой мыши. В появившемся вспомогательном меню выберите команду Свойства (Options), чтобы открыть диалог настройки параметров диска. Щелкните мышью на ярлычке Сервис (Tools), чтобы выбрать одноименную вкладку, на которой расположены кнопки запуска служебных программ (Рис. 9.1). На этой вкладке нажмите кнопку Выполнить дефрагиентацию (Defrag Now). Также можно запустить программу дефрагментации, выбрав соответствующую команду в списке стандартных служебных программ главного меню. В этом случае вам придется выбрать диск для дефрагментации в появившемся диалоге. При любом способе запуска на экране появится рабочее окно программы дефрагментации (Рис. 9.7).

Рис 9.7. Дефрагментация диска

В верхней част окна расположен список дисков вашего компьютера. В центре окна имеются две полосы, демонстрирующие степень дефрагментации выбранного диска. Перед дефрагментацией программа проводит анализ диска, и его результаты отображаются в верхней полосе. Нижняя полоса показывает диск после дефрагментации. Различная информация отображается разным цветом. Пояснения условных обозначений, также часто называемые легендой, отображаются в нижней части рабочего окна.

Перед дефрагментацией следует выбрать диск из списка. Вы можете запустить процедуру анализа, если нажмете соответствующую кнопку диалога. Результат анализа будет отображен в дополнительном диалоге (Рис. 9.7). По результатам анализа программа делает рекомендацию -. нуждается ли диск в дефрагментации или нет. При необходимости вы можете запустить дефрагментацию прямо из диалога с результатами анализа, нажав кнопку Дефрагментировать (Defrag).

Дефрагментация может занять довольно продолжительное время, до нескольких часов. По окончании процесса появится диалог с результатами. Нажмите кнопку ОК, чтобы закрыть его. Чтобы завершить работу программы дефрагментации, закройте ее рабочее окно.

По окончании работы программы все файлы на жестком диске будут дефрагментированы, а свободное место будет сосредоточено в конце диска. Рекомендуется регулярно, приблизительно один раз в месяц, проводить полную дефрагментацию вашего диска, особенно если вы используете файловые системы FAT или FAT32.


9.4. Назначение заданий

Система Windows XP позволяет вам запускать различные задачи в заданное время, превращая компьютер в своеобразный будильник. Вы можете это сделать с помощью папки Назначенные задания (Scheduled Task). Выберите команду главного меню Другие программы * Стандартные * Служебные * Назначенные задания (More Programs * Accessories * System Tools * Scheduled Tasks), чтобы запустить проводник и перейти в папку с назначенными заданиями. В этой папке расположены все задания, которые ожидают своего выполнения, а также мастер настройки задания (Рис. 9.8).

Рис 9.8. Список назначенных заданий

Дважды щелкните мышью на значке Новое задание (Add Scheduled Task), чтобы запустить мастер планирования заданий, с помощью которого вы создадите новое задание. Нажмите кнопку Далее (Next) в появившемся первом диалоге мастера, чтобы продолжить работу. Вы перейдете ко второму диалогу мастера (Рис. 9.9)/в котбром вам предлагается выбрать из списка доступных задач ту, которую вы хотите запускать.

Рис 9.9. Выбор задачи и периодичности запуска

Если задачи нет в списке, нажмите кнопку Обзор (Browse), чтобы найти ее в появившемся диалоге. Например, может оказаться полезным регулярный запуск программы Outlook Express для проверки вашего почтового ящика в Интернете. Нажмите кнопку Далее (Next), чтобы продолжить настройку. Появится следующий диалог мастера (Рис. 9.9). Данный диалог используется для указания имени создаваемого задания и периодичности выполнения этого задания. В поле ввода вы можете указать любое имя для задания, однако лучше оставить то,; которое предлагает система. С помощью переключателей выбирается периодичность запуска. Установите переключатель в желаемое положение, чтобы выбрать периодичность запуска прбграммы, и нажмите кнопку Далее (Next), чтобы продолжить работу. Вы перейдете к очередному диалогу мастера (Рис. 9.10).

Рис 9.10. Настройка времени и идентификации

Этот Диалог устанавливает точное время и дни, по которым будет производиться запуск программы. В поле ввода Время начала (Start time) установите требуемое время. Далее установите переключатель, чтобы выбрать дни запуска. Пусть в нашем случае это будет Ежедневно (Daily). Наконец, следует в открывающемся списке Дата начала (Start Time) выбрать, начиная с какого числа, следует запускать программу. После установки параметров нажмите кнопку Далее (Next) для продолжения. Появится следующий диалог (Рис. 9.10).

Поскольку с системой Windows XP могут работать несколько человек, необходимо определить, какой пользователь будет запускать нашу задачу. В появившемся диалоге введите нужный идентификатор пользователя и затем дважды введите пароль. Помните, что если вы ошиблись в написании идентификатора или пароля, задача в назначенное время запущена не будет. После ввода имени и пароля нажмите кнопку Далее (Next), чтобы продолжить работу. Появится заключительный диалог мастера планирования заданий (Рис. 9.11).

Рис 9.11. Заключительный диалог мастера

Данный диалог информирует, как мы настроили запуск программы. Установка флажка в этом диалоге позволяет настроить дополнительные параметры запуска программы, однако сейчас мы не будем этого делать. Нажмите кнопку Готово (Finish), чтобы завершить работу мастера. В результате описанных действий в списке заданий появится еще один элемент, соответствующий выполненным настройкам. В нужное время выбранная программа будет автоматически запущена. Дважды щелкнув мышью на значке задания, вы можете изменить настройки в появившемся диалоге. Удалить задание можно точно так же, как и любой файл в проводнике.


9.5. Резервное копирование

Чрезвычайно полезно хранить резервные копии важной информации. Можно просто копировать информацию на дискету или другой диск. Однако Windows XP предлагает вам удобное средство для создания резервных копий важной информации. Существуют специальные устройства для резервного копирования, которые могут хранить большие объемы информации. В домашних условиях для резервного копирования удобно использовать устройство записи на компакт-диски. Значительно реже используются стримеры, хранящие информацию на магнитной ленте.

Выберите команду главного меню Другие программы * Стандартные * Служебные * Архивация данных (More Programs * Accessories * System Tools * Backup), чтобы запустить мастер архивации данных и открыть его первый диалог (Рис. 9.12).

Рис 9.12. Выбор режима и операции

Данный диалог позволяет выбрать режим работы: простой или расширенный. Ничего не меняйте в этом диалоге и просто нажмите кнопку Далее (Next), чтобы продолжить работу в простом режиме. Появится следующий диалог мастера архивации, который с помощью переключателя устанавливает, какую операцию вы хотите выполнить (Рис. 9.12). Можно создать архив, восстановить файлы из архива и создать диск аварийного восстановления Windows. Установите переключатель в положение Выполнить архивацию (Perform Backup) и нажмите кнопку Далее (Next), чтобы продолжить работу и отобразить следующий диалог мастера архивации (Рис. 9.13).

Рис 9.13. Выбор режима и элементов

В этом диалоге с помощью переключателя определяется, какие данные вы хотите сохранить. Вы можете сделать полный архив всех данных на всех дисках компьютера, можете сами выбрать файлы для сохранения, а можете сохранить только системные файлы. Какой вариант выбрать, зависит от того, какую информацию вы хотите продублировать для надежного хранения.

Давайте рассмотрим вариант выборочного сохранения файлов, как наиболее удобный. Установите переключатель в среднее положение и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится очередной диалог мастера, предназначенный для выбора папок, которые следует сохранить (Рис. 9.13). В левой части диалога можно выбрать папки для сохранения, при этом в правой части появится содержимое выбранной папки. Установив флажок напротив файла или папки, вы помечаете его для сохранения. Для удобства флажки появляются как в левой, так и в правой части диалога, После выбора файлов и папок нажмите кнопку Далее (Next), чтобы продолжить работу и отобразить следующий диалог мастера, который определяет расположение создаваемого архива, а также имя архивного файла (Рис. 9.14).

Рис 9.14. Выбор носителя и завершение мастера

Если система обнаружит на вашем компьютере устройства для резервного копирования, то в списке Тип носителя (Backup media type) появится соответствующий элемент. Достаточно часто в качестве носителя для резервного копирования выступает стример - устройство для хранения информации на магнитной ленте. В домашних условиях чаще используются устройства для работы с магнито-оптическими дисками или устройства записи на компакт-диски. Если таких устройств не обнаружено, то первый список диалога будет недоступен, и архив можно будет создать на дискете или на другом жестком диске компьютера, информация на котором не требует архивации.

По умолчанию вам предлагается имя архива, и лучше не менять его. Нажав кнопку Обзор (Browse), вы откроете диалог, в котором можете указать диск и папку, где располагается архив. После выбора места расположения архива и его имени нажмите кнопку Далее (Next), чтобы закрыть диалоги и продолжить работу. На экране появится заключительный диалог мастера, отображающий в одном месте всю собранную информацию о предстоящем создании архива (Рис. 9.14). Нажмите кнопку Готово (Finish), чтобы закрыть этот диалог и продолжить работу. Начнется процесс архивации выбранных файлов и папок на указанный носитель, сопровождающийся появлением диалога с подробной информацией о ходе выполнения этой процедуры (Рис. 9.15).

Рис 9.15. Диалог с информацией о ходе архивации

Если вы используете для резервного копирования носители информации, которые имеют недостаточный объем для хранения всей нужной информации, то в процессе записи вам будет предложено вставить новый носитель, когда предыдущий будет полностью заполнен. Например, записав один компакт-диск, вы установите следующий, когда потребуется. Помните, что современные жесткие диски имеют очень большие размеры, и для полной архивации вам может понадобиться достаточно много носителей. Архивация может занять достаточно много времени. По окончании процесса архивации появится диалог с результатами. Нажмите кнопку Закрыть (Close), чтобы закрыть этот диалог.

Теперь в любое время вы можете восстановить копии тех файлов, которые вы поместили в архив. Давайте рассмотрим, как это сделать. Снова запустите мастер архивации данных. Появится его первый диалог (Рис. 9.12). Нажмите кнопку Далее (Next), чтобы продолжить работу. В появившемся диалоге установите переключатель в положение Восстановить файлы (Restore Files from Backup), чтобы выбрать соответствующий режим работы, и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится диалог мастера, отображающий список созданных архивов (Рис. 9.16).

Рис 9.16. Выбор архива и файлов

В левой части диалога нужно выбрать один из созданных архивов для восстановления. Дважды щелкнув на элементе списка, вы откроете его содержимое. Возможно, при этом появится диалог, информирующий о необходимости вставки носителя. В правой части с помощью установки флажков можно выбрать файлы и папки для восстановления. После выбора файлов и папок нажмите кнопку Далее (Next), чтобы продолжить работу. Появится заключительный диалог мастера. Нажмите кнопку Готово (Finish), чтобы закрыть диалог и начать восстановление. Процесс восстановления также сопровождается диалогом, иллюстрирующим ход выполнения операции. По окончании восстановления, нажмите кнопку Закрыть (Close), чтобы закрыть диалог. Теперь файлы заменены на те, которые хранились в архиве.


9.6. Прочие полезные программы

Для выполнения различных математических расчетов в состав системы Windows включена программа Калькулятор (Calculator), запуск которой осуществляется с помощью команды главного меню Другие программы * Стандартные * Калькулятор (More Programs * Accessories * Calculator), и рабочее окно которой в точности повторяет внешний вид обычного настольного или карманного калькулятора (Рис. 9.17).

Рис 9.17. Варианты работы с калькулятором

Вводить числа и задавать операции можно мышью, нажимая с ее помощью соответствующие кнопки в рабочем окне, или с помощью нажатия одноименных клавиш на клавиатуре. Результат отображается в поле, расположенном в верхней части окна. Работа с калькулятором очень проста и напоминает работу с обычным калькулятором. В зависимости от ваших потребностей программа имеет два режима работы: обычный (Рис. 9.17) и инженерный (Рис. 9.17). Переключение между режимами осуществляется с помощью команд меню Вид * Обычный (View * Stahdard) или Вид * Инженерный (View * Scientific). Инженерный вариант калькулятора может вести расчеты в различных системах счисления, а также вычислять сложные функции. В обычном режиме калькулятор выполняет простые арифметические операции. Если вы работали с обычным калькулятором, то без труда освоите и компьютерный.

Второй стандартной программой, с которой вы уже знакомы, является программа Блокнот (Notepad), которая может быть запущена с помощью команды главного меню Другие программы * Стандартные * Блокнот (More Programs * Accessories * Notepad) (Рис. 9.18). Данная программа представляет собой простой текстовый редактор, который позволяет просматривать и изменять текстовые документы.

Кроме того, ; из программы Блокнот (Notepad) вы можете печатать просматриваемые или редактируемые документы.

Рис 9.18. Рабочее окно программы Блокнот (Notepad)

Поскольку данная программа используется в основном для просмотра текстов, ее возможности по редактированию сильно ограничены. Вы можете одновременно работать только с одним документом и поэтому при открытии нового документа, старый автоматически закрывается. Если вы хотите создавать или редактировать текстовые документы, лучше воспользоваться программой WordPad, подробно описанной выше. Работа в блокноте очень похожа на работу \ в редакторе WordPad, за исключением возможностей форматирования текста.

Блокнот чаще всего используют для создания простейших неформатированных файлов, например, файла автоматического запуска, размещаемого на компакт-диске, о котором рассказывалось в части нашей книги, посвященной записи на компакт-диски. Также с помощью блокнота редактируются многие служебные файлы Windows XP. К достоинствам программы Блокнот (Notepad) можно отнести простоту работы, поэтому данная программа достаточно часто используется.

Еще одной стандартной программой в Windows является Таблица символов (Character Map). Данная программа относится к служебным программам, поэтому команда для ее запуска находится именно в этой группе. Запустите программу Таблица символов (Character Map), и на экране появится ее рабочее окно (Рис. 9.19).

Рис 9.19. Таблица символов

В списке расположенном в центре окна программы, отображаются все символы шрифта, которые можно выбрать в открывающемся списке, расположенном в верхней части рабочего окна. Щелкнув мышью на изображении символа, вы выбираете его. Если при этом нажать кнопку Выбрать (Select), то символ помещается в поле ввода, расположенном в нижней части рабочего окна. Таким способом вы можете выбрать несколько символов, а затем скопировать их изображения в буфер обмена Windows, нажав кнопку Копировать (Сору). В любой другой программе, например, в текстовом редакторе, вставьте содержимое буфера обмена в редактируемый документ, и в нем появятся выбранные символы.

Таблица символов используется для вставки необычных символов, которые имеются в шрифте, но отсутствуют на клавиатуре. Особенно полезно использовать эту программу при работе с необычными шрифтами, в качестве символов которых используются не буквы, а рисунки, например, рисунок в шрифте Wingdings.

В некоторых случаях может оказаться полезной стандартная программа Экранная клавиатура (On-Screen Keyboard). Команда

для запуска этой программы расположена в группе Специальные возможности (Accessibility). Запустите эту программу, и на экране появится изображение обычной клавиатуры (Рис. 9.20).

Рис 9.20. Экранная клавиатура

Щелчки мышью на рисунках клавиш полностью идентичны нажатию соответствующей клавиши на клавиатуре. Экранная клавиатура предназначена в первую очередь для людей с ограниченной подвижностью, которые не могут использовать обычную клавиатуру. Однако иногда данная программа используется и в других целях, хотя значительно реже.


9.7. Работа с командной строкой

До настоящего времени некоторые люди используют устаревшие программы, написанные для операционной системы ДОС. Чтобы эти люди могли работать и с Windows, в состав системы включена специальная программа для запуска устаревших программ, которая называется командная строка. Чтобы запустить этот режим работы, следует выбрать команду главного меню Другие программы * Стандартные * Командная строка (More Programs * Accessories * Command prompt). На экране появится окно, напоминающее экран компьютера, на котором работает операционная система ДОС. Мигающий горизонтальный курсор указывает место ввода команд. Вы можете ввести с помощью клавиатуры любую команду системы ДОС. Вы можете редактировать набранную команду, передвигая курсор влево и вправо с помощью клавиш и Нажимая клавиши и вы вызовете в строку ввода ранее введенные команды. Для переключения языка используется та же комбинация клавиш, что и при обычной работе в Windows. Для завершения ввода команды и ее выполнения следует нажать клавишу на клавиатуре. Результат выполнения команды будет отображен в окне (Рис. 9.21).

Рис 9.21. Работа с командной строкой

Все, что выводится на экран, запоминается. Вы можете прокрутить назад список с помощью линии прокрутки, чтобы увидеть результат выполнения предыдущих команд. Отметим, что в режиме командной строки, в отличие от работы в операционной системе ДОС, поддерживаются длинные имена файлов и папок.

Следует отметить, что не все программы для операционной системы ДОС будут работать с командной строкой Windows XP. Командная строка представляет собой программу, которая эмулирует работу ДОС, а не заменяет ее. Если программа для ДОС использует нестандартные возможности аппаратуры компьютера или работает с устройствами не через драйверы, а напрямую, то такая программа не будет работать в командной строке Windows XP.


9.8. Отправка и прием факсимильных сообщений

При работе с Windows XP у вас имеется возможность отправки и приема факсимильных сообщений без использования

дополнительных программ. Единственным 'условием является наличие модема, умеющего работать и с факсами. Кроме того, вы можете указать, что факс-модем является совместно используемым ресурсом. В этом случае отправлять и принимать факсимильные сообщения сможете не только вы, но и другие пользователи сети.

После установки Windows XP среди принтеров должен появиться еще один, с именем Факс (Fax). Работа с принтерами подробно рассмотрена выше, поэтому сейчас мы не будем ее рассматривать. Если факс не установлен, то следует на панели управления выбрать ссылку Установка и удаление программ (Add/ Remove Programs), а в появившемся диалоге выбрать установку и удаление компонент Windows, после Чего выбрать службу факса. Подробно про установку и удаление компонент Windows вы узнаете ниже.

Откройте панель управления и выберите элемент Принтеры и другое оборудование (Printers and other hardware), и перейдите по ссылке Принтеры и факсы (Printers and Faxes). На экране появится список установленных принтеров. Дважды щелкните на значке, обозначающем факс, чтобы открыть диалог настройки. Если факс не настроен, то будет запущен соответствующий мастер и появится его первый диалог. Нажмите кнопку Далее (Next), чтобы перейти к диалогу настройки параметров титульной страницы (Рис. 9.22).

Рис 9.22. Настройка титульной страницы и выбор устройства

Информация, вводимая в полях этого диалога, используется при подготовке титульной страницы факса. При отправке факса, к нему будет добавлена титульная страница, содержащая информацию о вас. Введите нужную информацию и нажмите кнопку Далее (Next), чтобы продолжить работу.

Появится диалог мастера, предназначенный для выбора устройства, которое будет использовано для отправки факса (Рис. 9.22). Обычно в качестве такого устройства используется факс-модем. Выберите в списке устройств желаемое устройство для отправки факсов и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится диалог для задания строки идентификации данного устройства. Эта строка будет передаваться приемной стороне и будет характеризовать передающее устройство. Введите в поле ввода любую информацию, которую вы пожелаете, и затем нажмите кнопку Далее (Next). Появится диалог для выбора устройства, используемого для приема факсов. В общем случае устройства для передачи и приема могут не совпадать, хотя часто это одно и то же устройство. Выберите в списке нужное устройство, укажите число звонков, после которых модем должен снять трубку, и нажмите кнопку Далее (Next), чтобы продолжить работу. Появится диалог для ввода строки идентификации устройства при ответе. Эта строка будет передаваться вашим факсом удаленному факсу при приеме документа. Введите любую строку или используйте предлагаемую по умолчанию, а затем нажмите кнопку Далее (Next), чтобы продолжить работу. Появится следующий диалог мастера. Данный диалог предназначен для выбора дальнейших действий с принятым факсом. Вы можете с помощью установки флажков отправлять принятые факсы автоматически на печать или сохранять их в выбранной папке. Возможно также одновременное выполнение этих действий. Если вы выберете вариант печати, то в списке нужно будет выбрать принтер. Для второго варианта следует указать папку, куда будут сохраняться принятые факсы. После настройки переадресации факсов нажмите кнопку Далее (Next), чтобы открыть заключительный диалог мастера. Нажмите кнопку Готово (Finish), чтобы закрыть диалог и закончить работу мастера настройки. Чтобы подготовить факс, вы можете использовать любой текстовый редактор. Далее вы печатаете подготовленный документ, а в качестве принтера выбираете факс. Поскольку отправка факса требует дополнительной информации о месте доставки факса, будет запущен мастер отправки факсов. Нажмите кнопку Далее (Next), чтобы начать работу мастера. Второй диалог мастера предназначен для указания координат отправляемого факса (Рис. 9.23).

Рис 9.23. Настройка параметров отправки факса

Заполнение предлагаемых полей является обязательным. Вы должны указать имя получателя и его телефон. Есть возможность отправки факса нескольким получателям. Для этого после ввода параметров отправки нажмите кнопку Добавить (Add). Получатель будет добавлен в список. После окончания подготовки списка отправки нажмите кнопку Далее (Next), чтобы продолжить работу. Следующий диалог мастера предлагает вам выбрать один из вариантов оформления титульной страницы. Сейчас мы не будем этого делать.

Нажмите кнопку Далее (Next), чтобы отобразить диалог настройки расписания отправки (Рис. 9.24). С помощью установки переключателя вы можете выбрать немедленную отправку, отправку по расписанию и так далее. Выберите вариант отправки, при необходимости установите время отправки и нажмите кнопку Далее (Next). Появится диалог для выбора, информировать ли вас о том, что факс доставлен или нет. С помощью переключателя выберите желаемый вариант и нажмите кнопку Далее (Next), чтобы отобразить заключительный диалог мастера. Нажмите кнопку Готово (Finish), чтобы закрыть диалог. Если вы указали, что факс должен быть отправлен немедленно, начнется процесс отправки факса.

Прием факсов осуществляется автоматически. После прохождения выбранного ранее числа звонков, факс-модем снимет трубку и начнется прием документа. По окончании приема, если он прошел успешно, документ будет или распечатан, или помещен в особую папку. Все зависит от того, как вы настроили соответствующий параметр в мастере. Вы можете просмотреть принятые факсы, при необходимости удалить их или снова распечатать. Чтобы сделать это, дважды щелкните на значке факса в списке принтеров в панели управления. Откроется окно управления факсами (Рис. 9.25).

Рис 9.24. Окно управления факсами

В левой части окна расположен список папок, где в отсортированном виде хранятся принятые и отправленные факсы. Выбрав папку, вы отобразите ее содержимое в правой части окна. Выбрав конкретный факс, с помощью кнопок на панели инструментов вы можете посмотреть его, распечатать, переслать по электронной почте и так далее. По окончании работы с факсами не забудьте закрыть рабочее окно.